Editing Sequences Using the Keyboard

Top  Previous  Next

The keyboard can be used in several ways to help build sequences in the Sequencer:

 

Selecting a Cell

Selecting Multiple Cells

Modifying Cells

Copying, Cutting and Pasting

Copying and Pasting Timings

Undoing and Redoing

Zooming

Creating and Opening Sequences

Saving Changes

Refreshing the Display

Help

Freeform Play Mode

Opening a Tooltip

Other Keyboard Usage

 

Please also see Editing Sequences Using the Mouse.

 

 

Selecting a Cell

 

Sequences are displayed in the Sequencer as a grid.  Rows represent channels or RGB channels, and columns represent timings.  Cells in the grid therefore represent the lighting effects that will happen on channels at various points in time while the sequence is being played.

 

A cell, or a range of cells, can be selected, allowing you to apply various tools to it (such as specifying what lighting effects should take place in that cell).  You can recognize the currently selected cell (or cells) by a thick black and white border.  For example, in the following sequence, the cell of the third channel between 1 second and 1.5 seconds is selected:

 

SelectedCell

The time between 1 and 1.5 seconds of the third channel is selected

 

You can change which cell is selected by using the arrow keys - Up, Down, Left and Right.  Page Up and Page Down can also be used, to go up and down in the sequence by a page at a time. Ctrl-Left and Ctrl-Right can be used to page left and right.

 

If the currently selected cell is not the first cell in the currently selected channel (i.e. the cell starting at time zero), hitting the Home key brings you to the first cell in the currently selected channel.  If, however, the first cell is already selected, then hitting the Home key will bring you to the first channel in the sequence.  So, hitting the Home key twice in a row will bring you to the first cell in the first channel.

 

The End key works similarly, but for the last event and the last channel.

 

Selecting Multiple Cells

 

A range of cells can be selected by holding down the shift key while using the arrow keys (or Page Up, Page Down, Home, or End).  For example, the following picture has four cells selected, two each from second and third channels:

 

SelectedCells

Four cells are currently selected, two each in Channel 2 and Channel 3

 

Modifying Cells

 

Once you have selected a cell, or a range of cells, you can modify the cell or cells by pressing keys:

 

 

Ctrl+N: create new musical sequence

Alt+N: create new animation sequence

Ctrl+O: open existing sequence

Ctrl+W: close the current sequence

Ctrl+S: save the current sequence

Ctrl+Shift+S: save as (current sequence takes on the new name)

Ctrl+Alt+S: save a copy (make a backup)

F1: help

 

Arrow keys/PgUp/PgDown: move selection

Home: move to first column

End: move to last column

Shift+arrow/PgUp/PgDown/home/end keys: expand selection

C: select column

R: select row

E: select effect

Ctrl+A: select all

 

A: set selected cells to toolbar effect at MAX toolbar intensity

I: set selected cells to toolbar effect at MIN toolbar intensity

U: set selected cells to FADE UP using toolbar intensity range

D: set selected cells to FADE DOWN using toolbar intensity range

F: fill selected cells

G: toggle selected cells

H: create chase in selected cells

DEL: clear selected cells

M: apply current settings to selected effects

Shift+A/I/U/D/M: choose effect then fill selection

O: open the color fade selector

N: set selected cells to ON effect at max toolbar intensity

T: set selected cells to TWINKLE effect at max toolbar intensity

  during playback inserts a timing mark

S: set selected cells to SHIMMER effect at max toolbar intensity

L or Shift-L: activate Select Tool

 

Spacebar: start and stop playback

Shift+Spacebar: clear timeline range, then start playback

 

Ctrl +  zoom in on time scale

Ctrl -  zoom out on time scale

Ctrl+Z: undo last operation

Ctrl+Y: redo

Ctrl+X: cut

Ctrl+C: copy

Ctrl+V: paste

Ctrl+Alt+V: paste special

 

 

SelectedTwinkle

The selected cells have been changed to twinkles

 

Copying, Cutting and Pasting

 

The lighting effects in cells can be copied, cut, and pasted using the standard Windows copy, cut and paste keys, Ctrl-C, Ctrl-X, and Ctrl-V.

 

Note that the Light-O-Rama Sequencer supports several different pasting modes and pasting options (paste from/to foreground/background).  You can choose these settings using the Paste Options subpanel of the left-hand Tools Panel.

 

Copying and Pasting Timings

 

Timings can be copied using Ctrl-Insert, and inserted using Shift-Insert.

 

Undoing and Redoing

 

Changes to a sequence can be undone and redone using the standard Windows undo and redo keys, Ctrl-Z and Ctrl-Y.  Note that this includes any changes to the sequence, not merely changes made using the keyboard.

 

Zooming

 

The view of a sequence's grid can be zoomed in and out using the keyboard.  Both rows (channels) and columns (timings) can be zoomed.

 

To zoom in on channels - i.e. to make them bigger - use Alt-Down, and to zoom out, use Alt-Up.  Alt-Page Down and Alt-Page Up also work, to zoom in and out as much as possible.

 

To zoom in on timings, use Alt-Right; to zoom out, use Alt-Left.  Alt-End and Alt-Home zoom in and out as much as possible.

 

Creating and Opening Sequences

 

The New and Open Dialog can be opened using either Ctrl-N, Ctrl-O, or Ctrl-R.  Ctrl-N will open it to its New Sequence tab, Ctrl-O will open it to its Existing Sequence tab, and Ctrl-R will open it to its Recent Sequence tab.

 

Saving Changes

 

Changes to a sequence can be saved using Ctrl-S.  If this is a new sequence that has never before been saved, this will first prompt you for a filename to save the sequence to.

 

Refreshing the Display

 

Occasionally during play, the display of a sequence's grid may seem to blank out.  This is typically caused when your computer happens to do something unrelated to Light-O-Rama, and temporarily takes the focus away from the Sequencer.  The sequence itself is not affected, nor are the actual lights - only the Sequencer's display of the sequence is - and the display is typically returned to normal when play reaches the next screen (or stops).  However, if you do not wish to wait for that, you can hit the F5 key to manually refresh the display.

 

Help

 

The Light-O-Rama help file can be opened by hitting the F1 key.

 

Freeform Play Mode

 

The space bar can be used to start and stop the current sequence either in "from selection" mode or, if a freeform play range has been selected, in freeform play mode.  While playing, the up and down arrows can be used to define a freeform play range.  If play is started with "Shift-Space" instead of just "Space", the freeform play range will be removed, and play will then start in "from selection" mode.

 

Opening a Tooltip

 

If your mouse is over the current sequence's grid, you can open a tooltip describing the cell it is pointing to by hitting the "P" key.  This can be done regardless of whether you have set your display preferences to disable tooltips.

 

Other Keyboard Usage

 

The various menus on the menu bar can be accessed by holding down the Alt key while pressing a particular key for the menu in question:

 

Key

Effect

<Alt>-E

The Edit menu

<Alt>-F

The File menu

<Alt>-H

The Help menu

<Alt>-P

The Play menu

<Alt>-T

The Tools menu

<Alt>-V

The View menu

<Alt>-W

The Window menu

 

After opening a menu, menu items can be selected using their hotkeys (indicated by an underlined letter).  For example, pressing Alt-E followed by K will select "Duplicate Track" from the Edit menu.  Keys such as Up, Down, Left, Right, Enter and Space can also be used to navigate these menus.

 

Many functions in the Light-O-Rama Sequencer cause dialog windows to open up.  Those which have "OK" and "Cancel" buttons can typically have "OK" invoked by hitting the Enter key, and "Cancel" by hitting the Escape key.

 

Standard Windows keyboard navigation should work on these dialogs - for example, using the Tab key to tab between controls, or the arrow keys to choose which radio button in a group is selected.

 

Hotkeys exist on many of these dialogs, which allow you to select a specific control on the dialog by holding the Alt key and pressing the key of the underlined letter.  For example, in the Channel Settings dialog (picture follows), the "Name" control can be selected by Alt-N, the "Color" control by Alt-C, and so forth:

 

ChannelSettings

The Channel Settings dialog