What's New?

<< Click to Display Table of Contents >>

Navigation:  »No topics above this level«

What's New?

What's New in the Latest Version

 

What's New in Version 6.1.6

What's New in Version 6.1.4

What's New in Version 6.1.2

What's New in Version 6.1.0

 

 

What's New in Version 6.1.6

 

Control Panel

 

Limited log files to a total of 3 files of 5 MB each (15 MB total)

Added a "Refresh" button to the screen where you select your SD card. Normally this screen should automatically update the list of available cards, but in case it doesn't, you now have a way to update the list.

If a media file cannot be found while playing a show, the log will now list the name of the sequence and the full path to the media file, instead of a generic message. https://forums.lightorama.com/topic/56155-minor-nitfeature-request/

While playing a show, sequences that fail to play 5 times in a row will be removed from the show. Shows that have no more sequences to play due to errors will be shut down. These events will be noted in the player log. Note that the sequences are not permanently removed from a show, only from the current running of the show.

Fixed creation of show files and SD cards for DMX networks when using an Advanced license.

 

Sequencer

 

Bug fix: when using the mouse to select cells in the beat channel section of the sequence grid, the selection would jump between rows. This only happened when the waveform was displayed. Also, when using the mouse to select cells in the main section of the sequence grid, the grid would not auto-scroll upwards if you dragged into the beat channel section.

Increased maximum number of spokes in the Spoke shape from 50 to 100.

Fixed potential crash when importing online props into a preview.

Fixed possible crash in File > Save A Copy.

 

SuperStar

 

If the name of a Text Action or Image Action had a character that wasn't from the standard US keyboard (e.g. a degree symbol or accented letter), it prevented the Sequencer from saving the sequence.

 

 

What's New in Version 6.1.4

 

Control Panel

 

Bug fix: in Create Shows, saving a show that has a schedule entry that ends exactly at midnight no longer generates an error.

Bug fix: in the Show Player, a show could briefly start back up after it is finished playing.

Bug fix: in the Settings section: clicking the "Change Light-O-Rama Folder Location" button would cause an error.

Bug fix: when editing an SD card show, some fields on the screen were not populated correctly. Fields with incorrect data included play type and schedule type.

Bug fix: the media player will be recreated any time there is a media error. This should allow the show to keep playing after a transient error.

Bug fix: fixed text* motion effects so that they always render at 96 dpi. The Control Panel was creating playback files using the dpi of the primary display, which only created correct files when Windows scaling for the primary display was set to 100%.

In Live Player, the "+" button now inserts cues after the selected row, making it easier to add cues anywhere in your list.

Bug fix: In Live Player, if there is a cue that is currently playing, clicking the Play Next button will play the cue after the one that is currently playing, regardless of selection. Otherwise it will play the cue after the one that is selected.

Bug fix: In Live Player, it is no longer possible to edit the cue list while a cue is playing.

Bug fix: shows that only contain a background section or an interactive section can now be played.

Bug fix: in Create Shows, opening a show and then clicking the Cancel button after not making any changes, would result in a "Unsaved changes" message.

Bug fix: the list of upcoming shows now displays correctly when there is an on-demand show with start and/or end times.

An on-demand show is now identified with a "!" in the upcoming shows list.

 

Sequencer

 

Bug fix: When adding or editing a motion effect in the Motion Effect Generator, the music played to the end of the song instead of to the end of the selection.

Bug fix: Fixed incorrect rendering of Curtain effect when Movement set to chase, Repeat mode set to Once fit to duration, and Speed set to 0.

Bug fix: Spaces were sometimes removed when editing Text motion effects.

Bug fix: In the playback window, channel effects would sometimes turn on 50 milliseconds before motion effects, even though programmed to come on at the same time.

Increased the maximum number of motion effect rows from 100 to 600 to accommodate high density props like the GE Rosa Grande.

Added support for keyboard shortcuts to switch tabs in the Sequencer. Ctrl+Tab forward, Ctrl+Shift+Tab backward. Same shortcuts used in most web browsers.

Added "Motion effect start (0=back, 1=left)" parameter to Sphere and Cylinder shapes.

Added support for tilting mouse wheel to scroll left/right in: sequence grid, preview design, wiring view, and playback windows.

 

SuperStar

 

Fixed a bug. The progress dialog box was counting image mask actions as text actions

Optimized image masks and text masks to only compile if they are within the time range we are compiling. Before it was compiling all of them regardless.

Fixed a bug where 16 channel AC controllers using DMX were not working. The bug was caused by rgbOrderOffset not getting initialized properly.

Fixed a bug where if you select an image on one row, then right click on a different image row and select "insert current image into imageAction effect" then it inserts the image on the row you first clicked on.

Added "Unselect All Left, Unselect All Right, and Unselect All" to the "Edit" menu

 

Mobile App

 

Added support for starting on demand shows and override sequences. This requires your computer to be running version 6.1.4 or later.

 

 

What's New in Version 6.1.2

 

Hardware Utility

 

Fix device file not found error.

 

Control Panel

 

Bug fix: in Create Shows, unable to reorder sequences in a playlist when the playlist contained more than one instance of the same sequence.

Bug fix: in the Show Player, shows sometimes briefly started back up after they finished.

Bug fix: when creating SD cards for regular LOR networks (not enhanced), fade effects on the card changed intensity much more slowly than specified by the effect.

Bug fix: when creating SD cards for regular LOR networks (not enhanced), the last effect in the sequence was not getting written to the card.

Bug fix: when creating SD cards, turn lights off at end was not working.

Bug fix: when creating SD cards, animation sequences resulted in a write error when used as starter or filler sequences.

 

Sequencer

 

Bug fix: when pasting into the text box for Text, TextPE, and TextXY motion effects, only plain text (no formatting) will be included. In earlier versions of S6, pasting from MS Word included font size information that overrode the font size slider.

Bug fix: Text, TextPE, and TextXY motion effects with multiple spaces in a row would only show a single space on the prop.

Bug fix: in Preview Design's Channel Conflicts tab, the Start Channel column was showing "LOR Regular, Unit 01, Circuit 1" for every conflict.

Bug fix: in the Prop Definition dialog, the simulated prop drawing in the lower half of the Shape section didn't refresh appropriately when resizing the window.

Spinner motion effect enhancement:

oadded new style "pinwheel_3"

oadded new color modes "fade_inner" and "fade_outer".

ocolor mode "Fade_3d" was renamed "fade_both". One difference: where "Fade_3d" always displayed a single color, "fade_both" maintains the colors displayed in "color_per_arm" mode. If only 1 color is selected, the old "Fade_3d" and the new "fade_both" will display the same thing. If more than 1 color is selected, the new "fade_both" will give you a look that was not achievable in prior versions.

 

 

What's New in Version 6.1.0

 

Initial production release of the S6 Light-O-Rama Software Suite.

 

Big Changes

 

Many functions that used to be separate programs are now part of the Control Panel. This includes:

 

oDefining your lighting networks (previously done in Network Preferences)

oMonitoring the status of those networks (previously done in the Comm Listener)

oCreating shows (previously done in the Show Editor)

oChecking if there are any issues with the show (previously done in the Verifier)

oScheduling shows (previously done in the Schedule Editor)

oPlaying shows (previously done in the Show Player)

oCreating SD cards for Light-O-Rama Director units (previously done in the Hub)

 

There is a new phone app, available for Android, iPhone, and iPad, that allows your phone to communicate with the Control Panel

 

Licensing

 

Registering your software is done from the new Control Panel.

The Startup and Shutdown sections of shows are now available at all license levels.

Show On Demand is now available at all license levels.

Using calendar dates when creating a show schedule is now available at all license levels.

Your license is also used when logging into the phone app.

 

Control Panel

 

Access the Hardware and ServoDog Utilities.

Access the PixCon16 configuration tool.

Find PixieLink controllers on the network.

Network Preferences and network status are combined onto a single page. The network log can be displayed in a separate window if desired (similar to the Comm Listener window, but nicer)

Test lights - test a preview, a group of channels, or a group of pixels

Access the Sequencer - with a view similar to the Sequencer's Start Page.

Edit, verify and schedule shows. Length of each sequence and total duration of the show are displayed.

When playback is disabled, you can pick 1 of 2 playback modes: Show Player (traditional playback), Live Player (jukebox playback).

The new Show Player allows the queue of upcoming sequences to be manipulated by the user.

The new Show Player allows a set of "Override Sequences" to be defined and inserted into the queue at any time (for example "Clear out please" announcements).

The new "Live Player" mode puts you in control of playing your show. It works like a jukebox and makes using Light-O-Rama sequences in live performances much easier.

Create SD cards for your mini- or MP3 Director.

Click the cloud icon in the title bar to enable or disable your cloud connection, which is used by the phone app. A cloud icon with a "!" in it means the computer is connected to the cloud, but the phone app is not connected to the cloud. When the phone app connects, the icon will show a check mark inside.

Album art is displayed beside a musical sequence if the media file contains such an image.

The new Control Panel behaves like a regular Windows program. It does NOT minimize to the system tray.

Sequence playback uses a new file format. This should allow sequences to start playing more quickly and use less memory. S4/5 compressed sequences (LCS) and intensity data (LID) files are no longer used.

 

Hardware Utility

 

The tabs for "Digital IO Boards" and "X10 CM11A" have been removed.

The SD card creator remains, but can only use LMS and LAS files. The ability to use LOREDIT files here has been removed.

The Light Console and Pixel Console remain, even though these functions have been recreated in the new Control Panel.

 

Sequencer

 

The right-click menu for the waveform has been removed, although this menu is still available by right-clicking on the yellow timeline. Also, the ability to drag across the waveform to zoom in has been removed. Double-clicking on the waveform now opens the Audio Settings panel.

Empty grid view groups are now automatically deleted.

Added new item to the timeline's right-click menu: Zoom To Play Range.

Added new shortcuts: Ctrl-A to set max intensity and Ctrl-I to set min intensity. These are the counterparts to Ctrl-U and Ctrl-D. Ctrl-A will no longer select all, but you can use R followed by C to accomplish that.

The "T" shortcut key will now add a timing mark wherever the pointer is located if there is no selection in the sequence grid and playback is stopped. You can clear the selection by clicking in the waveform area.

On the right-click menu, "Add/Modify Motion Effect Rows" is now "Manage Motion Effect Rows"

Motion rows are now only displayed in the order in which they are rendered. You can no longer drag a motion row anywhere in the sequence grid. Row order is modified using the "Manage Motion Effect Rows" menu item.

The first column in the Manage Motion Effect Rows dialog now identifies the foreground and background rows.

On the Sequencer Preferences "Startup" tab there is a new option: Use default window arrangement at startup. A few users with multiple monitors had problems with the way the Sequencer remembered the position of its windows - sometimes causing a crash the next time the Sequencer started. This gives those users a reliable way to start the Sequencer every time.

The playback marker style can now be set by right-clicking on the timeline, as well as in Sequencer Preferences. For users that change the playback marker style fairly often, and this allows them to do that more quickly.

Converted the "Carryover" column to "End Unit / End Circuit" in Prop Definition.

Previously, setting a dimming curve in Prop Definition only applied to ELOR and DMX networks. They now also work on regular LOR networks (not enhanced).

Added option to Preview Design's Layout View to save it as a PNG image file. You can then open the PNG image in MS Paint or similar programs and print to multiple pages. This is helpful for layouts that are wider than 1 page.

Typing the right-arrow key after a paste will now keep you on the first row of the selection. So you can do multiple pastes with Ctrl-V, Arrow-right, Ctrl-V, Arrow-right, Ctrl-V, Arrow-right, etc.

Updated the Statistics tab in Preview Design to include the number of channels in each LOR network. This can help you diagnose when a network is overloaded.

On Preview Design's Design tab, added "Create Group" to the item list's right-click menu.

Added a Snowflake shape in Prop Definition. This shape can be used to efficiently model pixel snowflakes and other props with radial symmetry. Motion effects that move left or right will spin around the snowflake.

Added Teal and Pink to the list of traditional colors in the Prop Definition screen.

When editing a prop with a custom shape, you can now shrink the size. This works well for coro props -- and the smaller size greatly improves performance.

Added FSEQ export to the File menu - only available with a PRO license.

There is now full support for dumb RGBW fixtures (4 channels). RGBW is sequenced as a regular RGB channel; but when output to lights, the white channel is set to the minimum of the red, green, and blue values, and then the red, green, and blue channels are reduced by the calculated white value. In Prop Definition, the RGB order setting affects the order of the first 3 channels; white is assumed to be the last channel.

 

SuperStar

 

Added enhanced singing face features. Eyes will now blink every 2-4 seconds. Bow/Star will illuminate when mouth is moving. Motion row defaults for Boscoyo type faces will automatically be added into the image list.

Added twinkle and shimmer to the smooth effects

Added Windows Font support in Text Setup dialog box. This allows text using any of the Windows system fonts. Bold, Italic, underline, and smoothing can be done for any of the fonts at any size.

 Added "Don't Use Music" feature in the Auto Sequence dialog box.

Added feature for image mode, double click in the green grid, or the preview and in addition to setting the current color for the pixel you clicked on, it sets all non-black to the current color.  This is to make it easy to change the color of all the pixels for a face element for the Boscoyo type faces.

Added the feature "Silhouette Mask Adjacent Effects Only." This enables you to have multiple image masks at the same place in the time ruler and have background and foreground effects that apply to the mask they are adjacent to.

Added support for image masks with smooth effects

Added ability to multi select images and delete them with the Image list "Delete" button

Added feature so Ctrl + double click will select all 4 colors in the color controls

Added support for the new 14 element LOR singing faces

Increased the maximum dimensions from 360x360 to 400x400

Fixed a bug in the Singing Faces Dialog box that pops up informing them about what image options the user should pick. The text for one of the cases was being truncated.

Fixed a bug where SSEdit.exe can crash if in the Image Setup dialog box you go to Large grid and then back to Standard grid.

Fixed a bug where if you import an image in a path that has an '&' character then when you go back to the sequencer and attempt to save the .loredit file the sequencer gets an error.

Fixed a bug in "Change Orientation" in the "Move or Scale Selected Effects" dialog box. The source width and height were interchanged when the preview was Horizontal. They now work as expected.

Fixed a bug where Instant Sequence would not create any effects if you double click to edit a sequence.

Fixed a bug where if launched from the Sequencer and you do "export to sequence editor" the .lms file can have missing channels if there are props in the Preview that have duplicate channel assignments.

Fixed a bug where if you are in horizontal orientation and you copy a portion of an image in Image mode, when you try to move the orange rectangle it doesn't move around properly.

Fixed a bug where if you copy a portion of an image in Image mode and do not press Esc key, then select an effect that is not and image action and do paste, the paste appears to do nothing because what it did was paste the portion of the image that was copied while in image mode. Fixed it by exiting "copy a portion of an image" mode if the graphic mode changes, or if the "copy" button is pressed.

Fixed a bug where if you have a group selected and load a .sup file then the code thinks there is still a group selected.

Fixed a bug where you can select a smooth effect and then select a smooth effect before the currently selected effect and the selection region in the time ruler becomes .05 seconds long

Fix some bugs in the "stop at edge" feature in the Text Setup dialog box. Large superstar fonts were going 3 pixels off the left edge.

If a Preview is horizontal and has more than 50 pixels per row then the Sequencing Grid was being displayed too large and you could not see the Preview.

 

New PixieLink Firmware Version 1.04

 

Firmware 1.04 has been released for the PixieLink to support a support module upgrade. It also fixes the 141 fatal error (TCPIP stack initialization failure) and fixes the 17 Mbps speed option.