Visualization Sequences

Top  Previous  Next

The Light-O-Rama SuperStar Sequencer can import visualizations created using the Light-O-Rama Visualizer.

 

Import Visualization
Special notes on Import Visualization
Instant Sequences using a visualization
Instant Sequences using a quick visualization
Is the SuperStar program now a Visualizer program?
Selecting a light fixture
Adding an effect
Play the effect
Add a morph
Play it
The concept
Instant Sequence
Future enhancements

 

Import Visualization

 

To use this feature, click on the SuperStar Sequencer's File menu and select "Import Visualization...".  The Import Visualization dialog box will appear:

 

Scrunch the Sequencing Grid: "Scrunch the Sequencing Grid" and it will scrunch everything into as few rows as possible.  Using "Scrunch the Sequencing Grid" makes it so if you have 100 light fixtures or less, you will be able to fit all of them onto two sequencing rows.  Note: Instant Sequence will work best if you do not "Scrunch the Sequencing Grid".
 
Sorted by Rows: This setting will produce the best Instant Sequences, and is the recommended setting for importing a visualization.  Your lights will be sorted by rows, and each light fixture will be represented by a box on the green sequencing rows.  The program does its best to sort your lights along the rows that it sees.  Many light displays have two or three rows of lights; for instance, there could be lights at the roof line, the window line, and the ground line.  In that case, the program will create three rows of green sequencing squares above your visualization.  The first row will contain the light fixtures that the program found at the roof line, the next row will contain the light fixtures that the program found at the window line, and the third row will contain the light fixtures the program found at the ground line.  Note that this is just an example; the program may find a different number of rows in your visualization.
 
A sequencing row can only have 50 boxes, so if you have more than 50 light fixtures in a row on your visualization, then the light fixtures will be split into more than one sequencing row.  If you have a prop with many light fixtures in it, the program does its best to not split the prop between lines.  Props are assigned to a row as a group.  The center of the prop is used to decide which row the prop will be placed in.
 
Important note: The fixtures in a prop will be placed onto the row in the same order that they were added in the Visualizer.  To change the order of the fixtures, do the following:
 
1. Launch the Visualizer program.
2. Bring up the Properties dialog box for that prop.
3. In the "General" tab, click on the "Change Order of Fixtures" button at the bottom.
4. Save the visualization file.
5. Import the visualization file into SuperStar.
6. Click on the fixtures in the prop, and you should see that they are ordered differently in the green sequencing row.
 
CCRs are always placed first.  The sorting applies only to props and light fixtures.
 
In short, the program sorts things in a way that makes it easiest to sequence, and will produce the best instant sequences.
 
Sequencing Grid:
 
Max Length: This sets the maximum length of a sequencing row.  The max length can be set from 25 to 200.  The default is 50, and this works best for most visualizations.  If you have a row of lights in your visualization that will not fit into one sequencing row, then you can increase the length of a row so that the row of lights will all fit into one sequencing row.  Do not make this value any larger than necessary, because it can make the size of the squares in the sequencing grid small and harder to click on.
 
Horizontal: Most light displays are wider than they are tall.  For most displays, it is suggested that you use a horizontal display.  This will place a horizontal sequencing grid above your visualization, and leaves the most room for your visualization.
 
Vertical: Vertical orientation is designed for displays that are taller than they are wide.  For example, if you are sequencing a visualization of an RGB megatree then you would want vertical orientation.  A vertical orientation will place a vertical sequencing grid to the right of your visualization.
 
Normal: Normal mode creates one green sequencing square for each fixture or CCR pixel on your visualization.
 
Wrap Around: Wrap Around mode creates a duplicate set of sequencing squares to the right of the normal set of sequencing squares so that you end up with two green sequencing squares for each fixture or CCR pixel on your visualization.  This mode is designed for use with 360 degree trees.  It allows easier creation of effects so you can start them at any point on the tree and wrap around to any other point on the tree.  For example, you can start a morph in the middle of the tree and end it on the middle of the wrap around part of the sequencing grid.  The resulting morph will start in the middle of the tree, cross the last string onto the first string, and end in the middle of the tree.

 

Maximum Detection Lines (green lines on the visualization): This setting defaults to 4, and with a setting of 4 means that your lights will be assigned to four rows or less.  The detection lines are drawn in green across the visualization.  A setting of 4 works well for most displays.  however, if your display is large or just has a lot of different rows, then try increasing the number.  For example, if you have a row of mini-trees, you would want them all in the same sequencing row and to be consecutive in the row.  If other fixtures are being placed in between some of the mini-trees, then you could increase the Maximum Detection Lines setting to 5 or 6 or higher until all the mini-trees get put consecutively into their own rows.
 
In some cases, you will need to move the fixtures and props a bit in your visualization to isolate them into their own areas so that they get placed into rows in the desired manner.

 

Special notes on Import Visualization

 

The SuperStar Sequencer allows fixtures with identical channel assignments.  For example, you may have a snowman fixture and a bell fixture that are both plugged into the same channel, so that they have the same channel assignment.  In this example, the snowman and the bell will be treated as if they were one fixture, and will be assigned to the same square on the sequencing grid.

 

When importing your visualization, you may get the following warnings:

 

"Warning: Found one or more fixtures with unassigned channels.  Fixture [Bush 01] has no channels assigned.  This and any other fixtures with no channels assigned will be dark gray and will be inactive." This warning means that the fixture mentioned (in this example, "Bush 01") has no channels assigned to it.  A fixture with no channels assigned cannot be exported because the program has no channel information for that fixture.  Therefore, the fixture is drawn in dark gray and cannot be selected, nor can any effects be assigned to it.  Note that the fixture mentioned in the warning is the first fixture found with no channels assigned; there could also be other fixtures with no channels assigned.  Also realize that you can still sequence all the other fixtures and export the sequence, and all other fixtures will work.
 
"Warning: Found some fixtures that share a channel yet don't share all channels.  Channel [White] in Fixture [Mega Tree bundle 01] and Channel [Red] in Fixture [Mega Tree bundle 04] are both assigned to 0A.02.  This usually happens when a wrong channel is entered by mistake.  Please use the Visualizer program to check the two fixtures mentioned to see if a channel was entered by mistake.  The SuperStar Sequencer allows fixtures that have identical channels but does not allow fixtures where some channels are the same and some are not.  When this happens, the first occurrence of a channel will be active, the duplicate occurrences of a channel thereafter will be inactive." This very long warning attempts to explain that the program allows fixtures to have identical channel assignments, but if two fixtures share some channels but have some channels that are different, it is difficult for the program to decide how you would want those fixtures assigned to the sequencing grid, and so it disables the duplicate channel assignments.  As mentioned in the warning, this may have happened because you entered incorrect channel information by mistake.  However, if you intentionally assigned the channels in this manner, the program doesn't know how to handle it.  You are encouraged to use a different channel assignment scheme, but if you can't, it just means that manual sequencing for those fixtures could be difficult.  You can still use Instant Sequence, and the sequence should look OK, and will export and play fine.
 
"Warning: A Cosmic Color Device such as a CCR, CCB, or CCP shares a channel with another fixture.  Fixture [CCR 02] and Fixture [Bush 03] both use channel 02.03.  This usually happens when a wrong channel is entered by mistake.  Please use the Visualizer program to check the two fixtures mentioned to see if a channel was entered by mistake.  The SuperStar Sequencer does not allow a Cosmic Color Device to share channels with other fixtures.  Fixture [Bush 03] will be dark gray and will be inactive." This warning is self-explanatory.  Using the same channel assignment for a fixture that is in a CCR is invalid.  The fixture will be drawn in dark gray, and you will not be able to select it.  As with the other warnings, realize that all other fixtures will sequence and export just fine.

 

Instant Sequences using a visualization

 

The Instant Sequence also feature works for visualizations, using the following steps:

 

Click on the File menu and select "Import Visualization"
Select a visualization file that you created using the Light-O-Rama Visualizer
Press Ctrl+I to launch the Instant Sequence dialog box, and use the three buttons in the lower left of the dialog box
Click on the "Open Audio File" button to open your audio file
Click on the "Sequence All" button
Click on the "Play/Stop All" button

 

Instant Sequences using a quick visualization

 

Want to use Instant Sequence but don't have a visualization of your lights? The SuperStar Sequencer can create a quick visualization file for you:

 

Click on the Tools menu and select "Create Quick Visualization".
Place a checkmark by each controller that you have.  If necessary, change the settings for each controller.  For example, if you have four 16 channel controllers and they have unit IDs 01, 02, 03, and 04, simply place a checkmark by the first four controllers listed in the dialog box.
Click on "Create QuickVis", and it will create a visualization file named "QuickVis.lee".  The visualization will be a grid of lights where each light represents a channel.  With this grid of lights, you can now use Instant Sequence to create a sequence for your lights.
After creating the sequence, click on the File menu and select "Export", and you will then be able to play the sequence to your lights using the Light-O-Rama Sequence Editor.

 

Is the SuperStar program now a Visualizer program?

 

No.  The SuperStar Sequencer imports the visualization file and displays it in the SuperStar work area.  The SuperStar Sequencer can only display the visualization file; the Light-O-Rama Visualizer is used to create or modify visualizations.

 

Selecting a light fixture

 

After importing a visualization file, you can click on any of the light string fixtures to select them.  A single click selects one item, while Ctrl+click can be used to select additional items.  A click and drag will select any item within the drag rectangle.  Each light string fixture is also mapped to a box in the green sequencing grid.  When clicking on a light fixture, you will see it become selected, and will also see a green square get selected.  You can also select fixtures by clicking on the green squares.  Left click selects, and right click deselects.

 

Adding an effect

 

Select one or more light fixtures.
Click on the Tools menu and select Scenes.  The Scene dialog box will appear.
Click on the Add button in the Scene dialog box.  A white bar will appear in the time layer area.  This bar represents the effect you just added.

 

Play the effect

 

In the toolbar is a group of buttons that look like the controls on a tape recorder.  Press the Play button (the button with a right-facing triangle); this will play eight seconds of the sequence.  After pressing Play, you should see your selected light fixtures turn on when the play cursor runs across the white bar which represents the effect that you just added.

 

Add a morph

 

Click on the Tools menu and select Morphs.  The Morph dialog box appears, and the first and last boxes in the green sequencing grid should have "1" and "2" on them.
In the yellow time scale, select from 3.00 seconds to 4.00 seconds.
Click on the Add button in the Morph dialog box.

 

A white bar with a tail should appear in the time layer area.

 

Play it

 

Click on the Play button again.  When the play cursor runs across the white bar with a tail, the morph will turn on every fixture, one at a time.  In other words, the effect starts at the "1" on the green sequencing grid, and travels to the "2" on the green sequencing grid.  This ends up doing a sweep or a chase across all the fixtures.

 

The concept

 

Every light in your visualization has a location and a color.  When selecting a fixture, you have selected a location.  You select the color by using the red, green, blue and white color controls on the left side of the SuperStar Sequencer.  The default is to have all four color controls "on".  However, if you want to turn on all the red lights in your display, turn on only the red color controls and select all your fixtures.  Add a scene, and you will see only the red lights in your display turn on when you hit the Play button.

 

Note: Click on the word "Main" above the color controls, and it will cycle through the basic rainbow colors.

 

Instant Sequence

 

You can use the Instant Sequence feature on your visualization:

 

Click on the Tools menu and select "Instant Sequence".
If you don't already have an audio file loaded, click on the "Open Audio File" button in the Instant Sequence dialog box.
Click on the "Sequence All" button.
After all the processing is done, click on the "Play/Stop All" button.

 

If you want to change the number of effects that are being created, click on the Timing Map button in the upper left of the Timing Map dialog box, and change the Sensitivity setting.

 

To create a different instant sequence, click on the "Roll Dice" button in the Instant Sequence dialog box.  Then click on Sequence All, then Play/Stop All.

 

Future enhancements

 

While a wide range of visualizations have been tested with the SuperStar Sequencer, there is an even wider range of possible visualizations, and so it is difficult to test every scenario.  So, as you work with your particular visualization, feedback is welcomed on ways that support can be improved for your particular needs.  Please send such feedback to wishlist@lightorama.com.