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Congratulations on purchasing a Light-O-Rama Pixel Tree! This document will show you how to display 
patterns of light on your tree that are sure to delight everyone who sees it. 

 

Additional Items Needed 

In addition to the tree you purchased, you will need a few more items to make the lights blink. 

1) You will need a way to connect the Pixel Tree's controller to your computer. We recommend the 

Light-O-Rama "High Speed USB to RS485 Adapter" (red color). If you already have an older LOR USB 

Adapter (black color), that can work too. 

 

http://store.lightorama.com/usbrs485hs.html 

 

2) You will need a "Cat5", "Cat5e", or "Cat6" cable to connect the USB Adapter to the controller. These 
are commonly used for Ethernet connections so you may already have one. If not, you can purchase one 
from the Light-O-Rama online store in any of several lengths. 

http://store.lightorama.com/usbrs485hs.html
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http://store.lightorama.com/accessories.html 

 

3) You will need the 4.3.16 version (or later) of the Light-O-Rama Software Suite. In order to use the 
Pixel Editor module within the suite, you will need a PRO license level. If you already own the 
Light-O-Rama Software Suite, but have a lower license level, you will only need to purchase the upgrade 
to the PRO level. 

 

Purchase the license here: http://store.lightorama.com/sopr.html 

The latest version is always announced and available for download from here: 
http://forums.lightorama.com/index.php?/forum/15-important-announcements/ 

 

4) OPTIONAL: this document assumes you will run your light show from a Windows computer. However, 
if you do not want to dedicate a computer to that task, you can save your show to an SD card and run it 
from one of our standalone controllers. Light-O-Rama offers 2 such controllers: the Gen3 Mini Director 
with 1 port, and the G3 MP3 Director with 2 ports. 

 

http://store.lightorama.com/midiwimp3pl.html 

http://store.lightorama.com/accessories.html
http://store.lightorama.com/sopr.html
http://forums.lightorama.com/index.php?/forum/15-important-announcements/
http://store.lightorama.com/midiwimp3pl.html


Light-O-Rama Pixel Editor with the Pixel Tree Kit (16 x 25) 

Light-O-Rama                       www.lightorama.com                    Page 3 of 16 

 

 

http://store.lightorama.com/g3mp3director.html 

 

Initial Setup 

Install the LOR Software Suite if you haven't already done so. It must be version 4.3.16 or later. 

Register the software if you haven't already done so. Instructions are here: 

http://www.lightorama.com/help/registering_light-o-rama.htm 

Connect your Pixel Tree to your computer as shown below. Do not connect any other controllers. 

http://store.lightorama.com/g3mp3director.html
http://www.lightorama.com/help/registering_light-o-rama.htm
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Apply power to the controller. 

Which Network? 

The LOR software supports up to 16 LOR networks attached to a single computer. These are labelled 

"Regular", "Aux A", "Aux B", "Aux C" and so on, up to "Aux O".  For every LOR network attached to your 

computer, you need a separate LOR USB Adapter. So if you are using 2 networks, you would need 2 LOR 

USB Adapters. 

 If the Pixel Tree is the only element in your display, it should be placed on the "regular" network. 

 If you already own other LOR controllers, putting the Pixel Tree on its own LOR network might 

be desirable for reducing network load, and in other cases it might be required. When would it 
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be required? It is required if you have older controllers that are not compatible with the 

"enhanced LOR" protocol (ELOR for short). In this case, the older controllers must be placed on 

a separate network from the Pixie controller. To see a list of which controllers are ELOR 

compatible, see this page: 

http://www1.lightorama.com/network-speeds/ 

Which Unit ID? 

Every LOR controller is assigned a "Unit Id". The LOR Hardware Utility is used to assign unit ids to many 

types of LOR controllers, including the Pixie controllers. The Pixie 8D controller actually uses 8 

consecutive unit ids. The following table shows the unit ids assigned to each string for a sampling of 

possible unit ids assigned to the controller in the Hardware Utility. 

 

If the Pixel Tree is the only element in your display, the you can just assign unit id 1 to the controller. 

However, if you have additional LOR controllers, you will want to assign the Pixie 8D controller to a unit 

id that is unique and does not overlap any of your other LOR controllers. 

Once you decide on the unit id for the controller, write it down! One or more of the following is 

recommended: 

 Write it on a sticker and place the sticker on the controller board. 

 Write it on the controller's case. 

 Keep a spreadsheet with all of your controller unit ids. 

Detailed instructions for setting the unit id for the Pixie controller can be found in the Pixie manual: 

http://www1.lightorama.com/PDF/Pixie_Man_Web.pdf 

Additional information about setting unit ids can be found in the help file for the Hardware Utility: 

http://www.lightorama.com/help/setting_unit_ids.htm 

Here is what the Hardware Utility looks like when connected to the Pixie controller: 

http://www1.lightorama.com/network-speeds/
http://www1.lightorama.com/PDF/Pixie_Man_Web.pdf
http://www.lightorama.com/help/setting_unit_ids.htm
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Network Configuration 

Now that you have decided which network the controller will be placed on and which unit id it will have, 

you need to tell the LOR software about your network configuration. To do this, open the LOR Network 

Configuration program: 
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LOR Network Configuration has 2 modes: simple and advanced. If the program opens in simple mode 

(like the screen below), then you will need to go into Advanced Mode by clicking the "Advanced" button. 
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Now you should see something like this: 

 

To enter the settings for a network, click on the desired row in the Port or Speed column. Then a 

window will open where you will be able to enter the settings for that network: 
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 Set the Port field to the comm port that Windows has assigned to your USB Adapter. If you are unsure 

which comm port Windows has assigned, you can go back to the Hardware Utility and click the "Auto 

Configure" button in the upper left corner. 

If you have a single LOR network, the configuration should look very similar to the picture below 

 Port should be specific to your computer 

 Speed should be 500K (or perhaps 1000K if supported by your hardware) 

 Enhanced LOR Network must be checked 

 

If you are putting pixel controllers (like the Pixie) on one network and other controllers on a different 
network, then the following configuration is often used (the ports shown in the first column should be 
specific to your computer). 16 and 24 channel controllers would be attached to the "regular" network, 
and pixel controllers would be attached to "Aux A". 
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Click OK to save the configuration and close the program. 

 

Creating a Pixel Editor Preview 

Start the Pixel Editor. 

 

You will be using the Pixel Editor to create the light patterns (sequence) for the Pixel Tree. However, 
before you can do that, you first need to create a "preview". A preview is a diagram of your light display 
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- it describes where each display element is placed and which unit ids and channels it uses. 

Select Tools > Manage Previews from the Pixel Editor's main menu. 

 

If you are new to the Pixel Editor, you will see a single preview called "Default" already exists - click on 
"Default" to select it. If you have already used the Pixel Editor, select your current preview. Click the 
Modify button to make changes to the selected preview. 

 

Select Prop > New to a create a new display element (prop). 
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The Prop Definition window should be set as follows: 

 

 Set the name to something meaningful for you 

 The left section defines the type of lights used by the prop. The Pixel Tree is composed of RGB 
Pixels. You might try setting the Dimming Curve to "PixelCurve" for more linear dimming. The 
pixels should be in RGB order. However, if you start playing effects on your tree and selecting 
blue in the software makes the actual lights turn red or green, then you should probably revisit 
the Channel Order setting. 

 The center section defines the prop's shape. In this case, the Pixel Tree is a 360 degree tree. 
String 1 will be behind the tree, away from the audience.  

 Specifying a starting location of "Bottom Left", tells the program that the string numbers will 
go around the tree counter-clockwise. This must match the way you have physically wired 
the tree. 
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 If the starting location is set to "Bottom Right", then the string numbers proceed in a 
clockwise direction. 

 

 The right section specifies the network, unit id, and starting circuit for the controller.  

 Ensure "Individual Start Channels" is unchecked. 

 Ensure "Separate Unit # for each RGB string" is checked. 

 Ensure "Max Circuit" is set to 150. 

 Enter settings on the first row of the table. All of the subsequent rows will be calculated 
automatically.  

 Set the network in the first column (Regular, Aux A, etc.). The value you set must match 
the enhanced network that you set up in LOR Network Configuration.  

 Enter the unit id in the first row of the table. The unit id you enter here must match the 
value you set in the Hardware Utility.  

 Leave the "Start Circuit" value as 1.  

Once all values for the prop have been entered, click the Save button. You can now move the prop by 
clicking anywhere inside the prop and dragging the mouse. You can resize the prop by clicking on any of 
the 4 red corners and dragging with the mouse. You may want to increase the bulb size to make the 
pixels on the tree easier to see on your computer screen.  

If you have other props in your display, you can add them now. 

After you are finished, click the Save button to save your preview. 
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Then click OK to close the Preview List window. 

 

Opening a Sequence 

 To add the Pixel Tree to an existing sequence, simply select File > Open from the Pixel Editor's 
main menu; then select the LOR sequence file (files with an LMS or LAS extension). Do NOT add 
the Pixel Tree channels to your existing sequence using the Sequence Editor. The Pixel Tree 
channels will only exist in the Pixel Editor sequence. 

 To create a new sequence, use the Sequence Editor to start a new sequence, add timing marks 
etc. Once the new sequence has been saved, you can close the Sequence Editor and open the 
sequence in the Pixel Editor. 

 You should NOT have a sequence open in the Sequence Editor and Pixel Editor at the same time. 
If you want to see a sequence open in both editors at the same time, make a copy of the 
sequence file; then open the copy in the Sequence Editor and the original file in the Pixel Editor. 

 

Populating a Sequence 



Light-O-Rama Pixel Editor with the Pixel Tree Kit (16 x 25) 

Light-O-Rama                       www.lightorama.com                    Page 15 of 16 

 

Learn how to create a Pixel Editor sequence by watching this video (you can skip the part about creating 

a preview since you have already done that step): 

http://youtu.be/5unIkAJjauU 

If you would prefer learning from a written presentation, read this PDF document: 

http://www1.lightorama.com/PDF/LOR-PixelEditorIntroduction-RevA.pdf 

You can control the Pixel Tree lights as you sequence by running the LOR Control Panel program (you 

will see a red light bulb in the system tray while it is running) and then select Tools > Control Lights from 

the Pixel Editor main menu. 

 If the lights are the wrong color, for example you select blue but the lights on the tree display 

red or green, then go back to the Prop Definition and change the Channel Order. 

 If the lights do not come on at all, one cause could be that the Unit ID you entered in the Prop 

Definition does not match the Unit ID you set the controller to using the Hardware Utility. Other 

causes are listed here: 

http://www.lightorama.com/help/control_lights.htm 

After you have finished your sequence, select File > Save Intensity Data from the main menu. This 

creates a file that is required for playback of the sequence from the Sequence Editor or the Show 

http://youtu.be/5unIkAJjauU
http://www1.lightorama.com/PDF/LOR-PixelEditorIntroduction-RevA.pdf
http://www.lightorama.com/help/control_lights.htm
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Player, or when creating an SD card for the Mini- or MP3-Director. If you have other items in your 

display that you have sequenced with the Sequence Editor (SE), then the SE sequence and the 

intensity data file will be played back together. 

Need more help?   

Checkout the Light-O-Rama helpdesk at http://helpdesk.lightorama.com 

 


