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What is the “Pixel Editor”

 Newest member of Light-O-Rama’s Software Suite

* Makes it easy to display complex effects on RGB lights
* CCR trees
e Other Light-O-Rama Cosmic Color devices
* Elements connected to DMX/E1.31 pixel controllers
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Workflow Step 1: Create a Preview

* Creating a preview only has to be done once. A Pixel
Editor preview can be shared across all of your sequences
— no additional importing or copying is required.

Sequence Editor Sequences Pixel Editor Sequences
Sequence 1 Sequence 1
Channels
Sequence 2
Sequence 2
SEETTaE Sequence 3

/

Sequence 3 Preview
Channels Channels



Workflow Step 1: Create a Preview

* When you first start the Pixel Editor, there is
already an empty preview created for you
named “Default”. Feel free to use the “Default”
preview or create your own (“2015 Christmas
Display” perhaps).

* You must add props to the preview for every
display element you wish to sequence with the
Pixel Editor.

* Optionally, you can also add props that you will
be sequencing with the Sequence Editor. Adding
Sequence Editor props allows you to see how
your entire display will look when played back —
Pixel Editor and Sequence Editor props together.

Preview List

You should create one preview for each seasonal display.
For example, you could name one "2014 Christmas".

You would then associate each of your 2014 Pixel Editor
sequences ta the "2014 Christmas" preview. You will also
associate props with a preview. I you associate 10 props
with the "20714 Christmas" preview, then those 10 props
will be available for sequencing in the Pixel Editor in
every sequence that uses that preview.
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Workflow Step 2: Create a Sequence

You can create a new sequence using the Sequence Editor or
the Pixel Editor (starting with version 4.3).

Sequence Editor

The sequence should only contain
the channels you will sequence with
the Sequence Editor — leave out
channels that will be sequenced
with the Pixel Editor.

Make sure timing grids are set up
the way you want. Use the Beat
Wizard or Tapper Wizard if desired
to create beat channels. Beat
channels can be viewed in the Pixel
Editor to aid your sequencing.

Save and close the sequence when
you are done.

Pixel Editor v4.3 or later

* Select File > New from the
menu

* Select the preview associated
with this sequence

* Make sure timing grids are
set up the way you want.




Workflow Step 3: Create RGB Effects

* If the sequence was created in the Sequence Editor, select
File > Open from the Pixel Editor menu to open it.

* Add effects to your RGB props as desired.

e Save the sequence (this saves the effects for subsequent
editing).

e Save the sequence as an Intensity Data file. The intensity
data file is required so that the Sequence Editor and Show
Player can play back the Pixel Editor sequence.



Sequence Editor with Intensity File
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How Effects Work

r Shape

Predefined | Custom

Tree 180 -

Actual # of Strings 5

Bxact # of RGE MNodes per 74

String

#of Folds in each String 1

Starting Location Bottom Left -

am
EEEEEEER
EEEEEEEEEN
123 4567383 EEEEEEEENN
EEEEEEN
ErEEEEN

You define a prop EE:"'.:

37

“Line” shapes are for roof

15
. . Buffer created to
lines and wire frames!

Effect scaled to buffer Result
match prop definition



Hands-on Tutorial

Creating your first Pixel Editor sequence



Tutorial: Creating a Sequence

* In the following step-by-step tutorial, we will create
a Pixel Editor sequence that runs through all* of
the effects

* Create a simple preview

* Create a new animation sequence
* Add effects to the sequence

* Play it back

* This tutorial assumes you are using version 4.3 or
later

* We will skip the “none” effect because it doesn’t do anything, and also the “movie” effect
because it will have its own tutorial.
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Create a Pixel Editor Preview

Open the Pixel Editor...

Tools | Help

| Manage Previews

Effect Generator
Control Lights

Preview Playback  »

Select Tools >
Manage Previews
from the menu to
open the Preview List
window.

Preview List

You should create one preview for each seasonal display.
For example, you could name one "2014 Christmas”.

You would then associate each of your 2014 Picel Editor
sequences to the "2014 Christmas” preview. You will also
associate props with a preview. f you associate 10 props
with the 2014 Christmas" preview, then those 10 props
will be available for sequencing in the Pixel Editor in
every sequence that uses that preview.

Defaut |
Irifix

Copyright (C) 2015 Light-O-Rama, Inc.

Double-click on the “Default”
preview to modify it...

or click on “Default” to select
it, then click the “Modify”
button.

If you don’t want to use the
Default preview, create a new
one by clicking the “New”
button.

12



Add a Prop to the Preview

* Select Prop > New from e
the preview window Copy
menu. This will open a E:tht
Prop Definition window. — P

|DnﬁrIat . LISt .

r Bulb
Shape | Square -
Size |‘J

1
Transparency |_J
0%

r Background

Set | | Clear |

Brightness




Define the Prop

Set the name to “Hmatrix”

Click the RGB tab and make
sure the “RGB Pixels”
button is selected

In the Shape section, select
“Matrix-Horizontal” from
the drop-down. We will use
the default values for this
shape — 16 strings of 50
pixels each.

In the Channel section,
select “Undetermined”
from the drop-down. This
means there is no physical
prop, but we can still create
effects for it.

Prog Definition

Mame  HMatrix I a‘z’ﬁsﬁce | Phesl Editor = |
r Lights r Shape

Dimming Curve | None -

Tlad'rtional RGE I

Predefined | Custom

| Iatrbe-Horizontal

@ RGB Pixels

Actual # of Strings
Exact # of RGE Modes per

16

HaRED

50

Comment

Channel

{

Individual Start Channels

V| Separate Unit #for each RGE string

Max Circuit | 150

Dumb RGE (3 channel) String Metwork  Unit # é‘i“m (E;nmduﬂ 832’
- | # of Folds in each String 0 =
annel e

Order RGB order b Starting Location Bottom Left M
i
:

Save | Canedl |
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Save Preview

Click “Save” once the
prop has been sized to
your satisfaction.

New prop is
listed on the left

r Bulb

o Preview Design - Default

| Save |

Preview Default
Name

Prop ~ Format » List » &

Shape | Square
Size [
8 )

Transparency |_J

r Background

Set | |

Brightness

Stretch prop to yield roughly equal
horizontal and vertical spacing between
pixels. Drag any of the 4 red “handles” in

the corners to resize.

—




Create a New Animation Sequence

ﬁ Light-0-Rarna Pixel Editor v4.3.2 Pro

File | Sequence Tools Help

New r Musical Sequence
Open Animation Sequence
Recent Files *

Save

Save As

Save Intensity Data
Close

Exit

Select File > New >
Animation Sequence
from the menu to open
the New Sequence
window.

Mew Sequence

Length of animation: | 1:00.00

Leave at the 1 minute
default length

Create a fiwed timing grid

() Tenth second intervals
i) Half second intervals
E} One second intervals I

i) Custom interval

0.10

Preview: Default .

The preview you
Author: Your Name jUSt created
— Fixed Timing

Create a timing grid of
fixed 1 second intervals

— Fresform Timing
[] Create an empty freefom timing grid

Create

Cancel

File > New was added in version 4.3. In prior versions, a new sequence

must be created using the Sequence Editor.



The Sequence Window

. Light-O-Rama Pixel Editor v4,0.39 Pro =N = ==
File  Sequence Tools Help

You can have multiple sequences
open at a time. Each sequence

The preview associated
will have its own tab

with this sequence

Open the Effect
Generator

_PE Tutorial las
. O au - ro 1w * <manua select> - ec enerator
Change the list of props . Rab Iyselect> -~ [ 00 B 0 2 00 {Dﬁ —
X B = I B 00 @ Timing Grid ~ Fixed Grid: 1.00 - b EBRE- Mo effect
that are displayed —_— D - D = o 2 0;14
List of props --' “ ---
to sequence ll Undo & Redo ”Current Effect” ]l
(! ! | | ————_

Next, we will look at the Effect Generator window, so click the “Effect Generator” button



Open the Effect Generator

Open the Effect
Generator by
clicking the “Effect
Generator” button
above the
sequence grid; or
use the “E”
shortcut key

o Effect Generator

Mixed Effect

Left Effect Right Effect

QK || Cancel | g;"ej |_J | Restart |Defau|t v||HMatrix -
r Left r Mixer r Right
|n0ne v| Palette: 7.7~ Mode - |Mix_Avevage v| |E| |n0ne v| Palette: 77~ Mode -
L U R
Left Effect Sparkle : nght Effect
selection oo [ - selection
. r Favorite Effects
Mlxer Save Delete New Folder Rename FaVOrIte
----- Favorites
Controls Effects




Select the “bars” Effect

° Se|eCt ”barS” o Effect Generator
from the left
drop-down box
A bunch of
controls will -| Cocel_] 22 ) et S 0 =
appear that r Mixer  Right
a”OW you to |bars v| Palette: - Mode ~ |Mb"-_A“'EEIQE "| | <3 | |none v| Palette: 7~ Mode -
control the bar ‘JI ! H IH H H " LY R
Direction = - i arde
effect. You can o o spaide
alette Repe: ; -
leave them at 1 : ; ol ¥ -
their default e
.. Slow Fast |=
pOSItIO n S . C[n:anter : r Favorite Effects
° I- k “ h D,, Save Delete Mew Folder Renamne
Click “Show 3 Mahigt = Fovortes
. Click “OK”. This  ||[2==2] .

will close the
window.



Add the Effect to the Sequence

[=][E /=]

o Light-O-Rama Pixel Editor vw4.0.39 Pro

Click the “On” tool. This will

cause the current effect to be
placed in every cell you
subsequently select.
“bars” is now

PE Tutorial las * Effe Ct
@ Default - Prop View = <manually select> ~ A0 @ 58 2 ok Jb  Effect Generator
= = I B 00 @ Timing Grid + Fixed Grid: 1.00 - b BB N (7] bars/none/Mix_Average/0.00s on HMatrix
|Tps| 0:02 0:04 0:06 0:.08 0:10 012 0:14
HMatrix -

| S e N R

After clicking the “On” tool,
select the first 4 cells.

m

1




Select the “butterfly” Effect

Reopen the
Effect Generator

Select
“butterfly” from
the left drop-
down box

Leave the
bufferfly
controls at their
default
positions.

Click “OK” to
close the
window.

o Effect Generator

Bulb

[ ok [ Ccancel Size [J | Festat | pussssss | Defaut | |Hiatrix -
| eft r Mixer r Right
|bu[-[e|ﬂy v| Palette: 7~ Mode + |Mix_Avemge v| | 3 | |ngne vl Palette: .~ Mode -
S 1ED T|ET S0 EET | L U ;
Style | linear A | E Sparkde :
Colors | rainbow - | Brightness
— Mode |fU" i
Chunks :
1 10 |=
Skip
2 10 r Favorite Effects
Directi ——— Save Delete Mew Folder Rename
irection |non1'|a| - |5
— - Favorites
Hue Shift :
o 360° L

(=[O =)




Add the Effect to the Sequence

On a given
sequence row, the
grid colors will
alternate white and
gray to indicate
where one effect
stops and the next
one starts.

SN
N

o Light-0-Rama Pixel Editor v4.0.39 Pro

File  Sequence

Tools  Help

“butterfly” is
now the
Current Effect

ﬂ'ﬁl @ Bk 0N gb  Effect Generato
rhERB A @

Prop View = <manually select> ~

Grid = Fixed Grid: 1.00 butterfly/none/Mix_Average/0.00s on HMatrix

[]10 []12 []14

Iy "--

| 4 ‘____
Select the next 4 cells. Illl
. ! I [ [ [ |

»

1




Select the “colorwash” Effect

Select
“colorwash”
from the left
drop-down box

Set Horizontal
Fade to “center

”

on-.

Set Mixer
Brightness
Mode to “fade
in and out”.

Move Fade
Speed to about
mid-position.

Click “OK”

o Effect Generator

I| Cancel
|

Bulb
| Size IJ

Restart

 FRestt | NS |Defaut

~ | | HMatrbc

|c:olorwash

i |

Palette: 5.7~ Mode -

ELEL]

Horizontal Fade

Vertical Fade

|u:enter_on -

[l

r |

r Mixer

| Mix_Average - | | <
L U R
Sparkle :

Birightt —
MI'Ingeness | fade_in_and_out -

Fade { J
Speed

-
>

r Faverite Effects
Save Delete Mew Folder Rename

----- Favorites

r Right

| none g |

Palette:

r+ Mode -




Add the Effect to the Sequence

Double-click on
the prop name
to play back the
visible portion

of the sequence

o Light-0-Rama Pixel Editor v4.0.39 Pro

File  Sequence Tools Help

- A EI & bE DN §b  Effect Generato

“colorwash” is
now the
Current Effect

- b BB N (7] colonwash/none/Mix_Average/0.00s on HMatrix

DDE []10 0:12

E) T

PE Tutorial las *

@ Default - Prop View = <manually select>

b= = [ B 00 @ Timing Grid ~ Fixed Grid: 1.00
|Tps| 0292 0: []4 0: 05
HMatrix

-

Select the next 4 cells

0:14




Select the “countdown” Effect

Select
“countdown”
from the left
drop-down box

Set Seconds To
Count to “3”.

Reset Mixer
Brightness
Mode to “full”.

Click “OK”

o Effect Generator

Save Delete Mew Folder Rename

----- Favortes

[ ok I canca | 2 [)  Restat | O | Defaut ~ | [HMatrx
| eft r Mixer r Right
|Cgumdgwn v| Palette: 77~ Mode ~ |Mix_A\remge v| |:_>| |none v| Palette: 5.7~ Mode -
ELIET | E1 | EjEmiE | L O i
Seconds To Count I 3 = I Sparkle :
Font Name |Ana| v| Brightnessf—
Madz |f”" hd
ant Size
' Small : Large
Position Offset
] Top Bottom r Favorite Effects




Add the Effect to the Sequence

Effects that you
have used in
the sequence

appear here as

thumbnails

that you can
click on to

make it the

Current Effect,

ordragonto a
grid cell.

o Light-O-Rama Pixel Editor v4.0.39 Pro

File  Sequence

Tools  Help

PE Tutorial las =

@ Default ~

|  Props |
HMatrix

Prop View - <manually select>

= = I B 00 @ Timing Grid ~ Fixed Grid: 1.00
0:02 0:04 0:06 0:.08 E
L] L] L] L] L] L]

A ﬂ Iﬁl ﬁ w I}}] @ Effect Generator

== o =<5

“countdown” is

now the
Current Effect

- BB e [7] countdown,/none/Mix_Average/0.00s on HMatrix

0:10 0:12

Select the next 4 cells. The grid will
automatically scroll as your cursor

approaches the grid’s edge.

m




Select the “curtain” Effect

Select “curtain”
from the left
drop-down box

' Effect Generator EI@

Set Movement
to “open then

close” T ok | _coes | 22 Resat | | (Ocfat 7| [Hvatex M
Left r Mixer Right

Set Repeat curtain - Palette: 7.7~ Mode ~ ‘;_;I Palette: .r~ Mode -

Mode to EL|ET ST NEH)EmEL LU ET NET NET EN|EmiE |

“ B
re p ed t d t Curtain Edge certer - Sparkle F Style linear - o~

” S — N

S peed Movemert I|Dpen_1hen_close vI Brightniess full—v Colors rainbaw -

Mad
Swag Width . oce Chunks .
Select 0 e — i i - |
" ” )
b Utterﬂy fro m Fepeat Hoce r Favorite Effects ———— Slz(lp :
10
H Speed
the r|ght drOp' 12 — : = Save Delete Mew Folder Rename Direction ——
----- Favorites \—I
down box Hue Shif ]
0 w 360" 7

Set Mixer to

“Mix Overlay”.
Click “OK”



Add the Effect to the Sequence

ﬂ

Light-0-Rama Pixel Editor v4.0.39 Pro

Help

“curtain/butterfly” i

File Tools

Sequence

PE Tutorial las =

ﬂ Iﬁl ﬁ ﬂ I}}] @ Effect Generator

@ Default ~ Prop View -~ <manually select> -
b= = I I 00 B Timing Grid = Fixed Grid: 1.00 - BB e @ curtain/butterfly/Mix_Overlay/0.00s on HMatrix
0:08 0:10 012 0:14 016 0:18 022[] U 22
Props | ’ ) ) y I L R
HMatrix it

AN N R I M A

[ I N

Select the next 4 ceIIs
-------

m

i

i

now the Current Effect



Select the “fire” Effect

Select “fire”
from the left
drop-down box

Select “none”
from the right
drop-down box

Click “OK”

Back in the grid,
select the next
4 cells. Then
Ctrl-S to save
the sequence.

o Effect Generator

fo o]

[ ok [ Ccancsl gé"; [J | Festat | NS | Defaut | [ HMatre -
Left r Mixer r Right
Palette: 7~ Mode - |Mix_0verla~,r v| | “ |none +J Palette: 5~ Mode -
Hse[i:gl'rt L |_J R
Low High
Hue: Shift : Sparkle :
0 " S
360 Brightness ——————————————
Mode |fU" T
r Favorite Effects

Save Delete MNew Folder Rename

----- Favorites




Select the “fireworks” Effect

Select ' Effect Generator

“fireworks”
from the left
drop-down box

Select red, ITIIIW o U Em I + | [t
green, blue, ~Mixer —— st
yellow, and Ll AR L M Overay v [<>] || [none v] Paletie o Mode -
white color B L U R
checkboxes g I R-J =T
Brightness ———————————————
Increase the Rate Change [continuous -] e [fal -
Explosion Rate g e SN : — .
Click “OK™ PS”‘C'B - Slﬂl Fast ':::rit;ie:ismm Folder Renarne
Back in the grid, Paticle Fade — : — |- Favortes
select the next - - <

4 cells.



Select the “garland” Effect

Select “garland”
from the left
drop-down box

o Effect Generator

Select blue &
white colors

[ ok |i| Cancel | g;ls [J | | Defauit + | | HMatric -
Change Garland [T Mixer ~Right
Fill to “left to lgarand <]} Palette 57~ Mode - Mocovetay v [<][[none  v| Paletter ir- Mode -
right” | 71 v | L U R

Garand Type Sparkle .

Change Repeat 0 Lt P : With Repeat Mode set to

“« - Brightness ————————
arland Fi . - ade full A o .
Mode to “once Gartand Fil (1ft_to_sicht Mode | “once fit to duration”, the

H H ” Spacing .
fit to duration 0 :ight — effect will only play once.
Click “OK” Fepeat Voo |lonce.fito_duaion ~ | P — Click the Restart button to
Sneed Save Delete MNew Folder Rename . .
Back in the grid, 12 Son : = |- Favortes see it play again.

select the next

4 cells.



Select the “meteor” Effect

Select “meteor” from the left ' Effect Generator
drop-down box

Colors don’t matter when Color
Scheme is “rainbow”

Double-click the Meteor Count — =
) | oK | Ccancel | E;E U B Dot ~ | | Hitatric
slider to unlock start & end - - - .
r Mixer r Right
handles. Move start handle m Palette: v+ Mode - (Mocovemy =] [<o]||fene <] Paletes -
(green) all the way to the left. ELEELER|EmED s .
Move the end handle (red) all I
) Colar Scheme [rainbow | - Sparkle %
the way to the right.
Meteor Court . Brightniess |[||—|
. 1to 100 ul -
Click Restart to see how the Feu Mar] fooe B
Tail Length
number of meteors changes 25 o i m—| e
over tlme Meteors Effect |down ,| r Favorite Effects
) i Save Delete Mew Folder Rename
. Swirl Intensity .
Click “OK” 0 o m— Favortes
Back in the grid, select the next <1EEL | -

4 cells.



Select the “picture” Effect

Select “picture” from the left
drop-down box

Use Google to find an
animated gif file that is close to
the size of our prop (16x50).
Save the file to your Pictures
directory.

Click the Choose Picture File
button and from the open file
dialog select the picture file
you just downloaded. It should
immediately start playing.

Click “OK”

Back in the grid, select the
next 4 cells.

o Effect Generator

e &
Left

J

7= Mode -

| Choose Picture File |

C:AUserstMatt'Pictures \new.gif

| Scale Image

Mowement | —

Speed

12 Slow i

Position Offset

Fast

1]

PeekABoo Hold Time
10 =h

Leng

m

[ Resiat | e |Dsfaut v | [ HMatrie
r Mixer - Right
| Mie_Overay - | |T |none - | Palette:
L U R
Sparkle F
Brightress ————————————————
Mode |f”” r |
r Favorite Effects

Save Delete MNew Folder Rename

----- Fawvorites




Select the

Select “pinwheel” from the
left drop-down box

Select the red, green, and
blue colors from the palette

Increase Arm Width
Decrease Arm Length
Increase Arm Bend

In the Mixer section, set
Sparkle to the max value

Click “OK”

Back in the grid, select the
next 4 cells.

Numeric values allow you to
match the setting exactly

‘pinwheel” Effect

. Effect Generator

Bulb |

| 0K | | Cancel | Sine Restart | | J | | Defaut ~ | | Hitatrix
Left r Mixer - Right
[ pinwhesl ~ [l Paletie: 7~ Mode ~ [ Mie_Oweray | |T| [none v| Palette
0 |= 7l | | . R
MNumber of Amms - ISparkIe _ﬂ
b 1 10 Bricht
b Vi : Rl —
5 Thin Fat
A Length |
“ Short | L
o ang r Favorite Effects
’&".-,m B k Save Delete MNew Folder Rename
! Cw/ Cin -
- Favorites
Color Mode |co|orjer_arrn - |




Select the “snowflakes” Effect

Select “snowflakes” from P Effect Generator
the left drop-down box
Deselect all colors from the
palette. Notice how it
defaU|tS to Whlte' -l Cancel EILEIE Restart | | I | |Defauh v| |HI"!'Ia1rix
Change Snowflake Type to [ Mixer Right
”1” |snowﬂeﬂces—7| Palette: 7= Mode - |m| |i| |u| Palette:
. . 0 0 | L U R
In the Mixer sect.lon, reset Spriarecon : ST S—
Sparkle to the min value Few Many — .
' Y . S;uoh\flakeType : Mode | ful
Click “OK sm Big | Random There is no “snowstorm”
Direction q g .
. . . ffi n the Pixel E r
Back in the grid, select the : o : R = effect in the Pixel Edito
Speed e Doie N because similar results can
next 4 cells. Then Ctrl-S to 12 Slow : Fast — be achieved by adjusting
save the sequence. the direction and speed in
the “snowflakes” effect. ~ _




Select the “spirals” Effect

* Select “spirals” from the left | { tect Generstor
drop-down box
* Select red and white colors
from the palette.
“u~n
* Set Palette Repeat to “2 ) B (2 < [
* Increase Rotation [ —— R —
Mix_Overay - \:_>| norie | Palette:
* Increase Thickness L 0 -
d C“Ck the ”ShOW 3D” SDEII'HB %
checkbox (you will need to — Brightness
Direction left_to_right - Mode ful h
scroll to the bottom of the e =
. 41 :
parameter settings) Left Right
Tthkness r Favarite Effects
° C"Ck ”OK” & ;I'hin h Save Delete Mew Folder Rename
Tgickness Change [ - Favorites
* Back in the grid, select the ore Max
next 4 cells.
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Select the “text”

Left Side

* Select “text” from the [

drop-down box

* Enter “Merry” in the
text box. Select the
text and change the
color to red. Change
the font to “Calibri”
or “Lucida Sans” if
you have it.

* Set Font Size to about
86

* Set Movement to
“left”

* Set Speed to about 5

* Adjust Position so
that text is against
the top edge

o Effect Ganerator

Effect

ot - Faletre » Mode ~

Click “OK” when you are
satisfied with the result

Right Side
* Select “text” from

the drop-down box

* Enter “Christmas” in
the text box. Select
the text and change
the color to white.
Change the font to
“Calibri” or “Lucida
Sans” if you have it.

* Set Font Size to
about 86

* Set Movement to
“right”

* Set Speed to about 5

* Adjust Position so

that text is against
the bottom edge



Add the Effect to the Sequence

_ Light-O-Rama Pixel Editor v4.0.39 Pro

File  Sequence Tools Help

(o8 =)

“text/text” is now the
Current Effect

PE Tutorial las =
@ Default ~ Prop View ~ <manually select> ~
B = [ B 00 W Timing Grid + Fixed Grid: 1.00

 Prom 050

- kBB e @

ﬁ Iﬁl ﬁ ﬂ H}] @ Effect Geners
teat/text/Mi_Overlay/4.00s on HMatrix
0:56 0:58

H Matrix

----"'“w ‘.

Select the next 4 cells.
I N N S A N

m

L)




Complete the Sequence

o Light-0-Rama Pixel Editor v4.0.39 Pro

[E=N(ECR =™

File  Sequence Tools Help

When you
are done,
type
Ctrl-S

“xn

after the file name
means the file is not saved

Change the mode to
Ramp Down

PE Tutoral las *

@ Default ~ Prop View = <manually select> ~ ? D ﬁ E‘I [}m @ Effect Generator
tO Save b= B I B 00 B  Timing Grid - Fixed Grid: 1.00 - b BB N @  test/text/Mix_Overlay/4.00s on HMatrix
the Tps ..046. .048.. . ”052| U54| 055 058.
HMatrix

sequence -----"
Select the last 4 cells.
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Play Back the Sequence

. Light-0-Rama Pixel Editor v4.0.39 Pro ===

Play from the beginning
of the sequence to the

Play the visible portion

Play from the current location of the sequence
current location to T o
the end of the %
sequence '
q | PE Tin, a3
H 9 Defe t - Prop View ~ <manually select> ~ AD DM w B 4B  Effect Generator
Play the fuu = .E h .E O0 B Timing Grid + | Fixed Grid: 1.00 NI REENE AR ©  text/text/Mix_Owverlay/4.00s on HMatrix
Sequence ([ Prps_| 0:46 0:48 0:50 0:52 0:54 0:56 0:58
HMatrix ' ! ! ' ' & """""'""H“ .
[ A AN NN N By
‘--------------

You can also play back a specific prop - preview will play in the left window and the effects for the selected prop will
play in the right window. To do this, right-click on a prop name and select one of the choices from the pop-up menu.
As a shortcut, you can double-click on a prop name to play the visible portion of the sequence.



2 Sequence Rows Per Prop

FPE Tutorial las The top row contains Effect
. Generator results that are a
& Default - Prop View =
A fop ¥ieW = <mar mix of 1 or 2 effects E [:m @
[ E E h B Timing Grid = |Fixed Gnid I BEERE Bl L7
| Prl:lps | IIIIIIII []I:E]IE IIIIIII [:" { I‘ 1 1 1 1 1 1 I[I]:E]IEI 1 1 1 1 1 I[:I]:E]IE IIIII
HMatrix

The bottom row can also contain
Effect Generator results that are
a mix of 1 or 2 effects

The 2 rows are mixed together to
produce the final effect for the prop



Smooth Transitions

* In the sequence we have created so far, effects
transition abruptly one to the next.

* Now we are going to modify the sequence so each
transition is smooth (crossfade).



Move Effects to the Bottom Row

* Move every other effect from _ Light-0-Rama Pixel Editor v4.039 Pro

File  Sequence Tools Help

the top row to the bottom
row

* Click the Arrow icon to go into
selection mode.

e Select all the cells of an effect
using the mouse. Then click

PE Tutorial las ~

the SCIssors icon to CUtI or use @ Default - Prop View = <manually select> - I!?A O @ @ BE 0} P Effect Generator
the CtrI'X Shortcut key. = = I I 00 B Timing Grid = Fixed Gric: 1.00 Lo @  bars/none/Mi_Average/4.00s on HMatrix

Props | 0:05 0:10 0:15 0:20 0:25 0:30

* Select the destination grid L Frp
cells using the mouse. Then
click the clipboard paste icon,
or use the Ctrl-V shortcut key.

* Repeat until you reach the

end of the sequence.

* The result is shown on the
right.



Add Fade Out Transitions

o Light-0-Rama Pixel Editor v4.0.39 Pro

Add a fade out to every effect,
both top and bottom rows.

File  Sequence Tools Help

Click the last cell in an effect.
This causes that effect to be
the Current Effect.

Now click the empty cell to :
the right. Then type the “D” PE Tutorallas -

ShOFtCUt key (fade down). & Default ~ Prop View = <manually select> - WIE‘ @ i b2 0 4db  Effect Generator

B B b B 00 B Timing Grid + Fixed Gridk100 v &% 23 (B - 9 ¢ @  bars/none/Mix Average/5.00s on HMatrix
Repeat for every effect. — o - o ° i a
The result is shown on the HMatrix

right.




Add Fade In Transitions

Change the first Ce” |n every o Light-O-Rama Pixel Editor v4.0.39 Pro
File  Sequence Tools Help

effect to a fade in/up, both
top and bottom rows.

Click the first cell in an effect.
This causes that effect to be
the Current Effect. Then type
the “U” shortcut key (fade up).

PE Tutorial las =
Repeat for every effect. @ Default - Prop View = <manually select> -
b= = I B 00 @ Timing Grid = Fixed Gric:1.00 =

The result is shown on the

. | Props |
rlght' HMatrix
Type Ctrl-S to save!

0:05 0:10

WIE‘ @ ﬁ ﬁ H}] @ Effect Generator

UREENE RAR @
015 0:20

bars/none/Mix_Average/5.00s on HMatrix

0:25 0:30




Success!

* The sequence looks much better now with smooth
transitions.

* You have successfully created a Pixel Editor
sequence and used every effect (except movie).

e Congratulations and enjoy using the Pixel Editor!

Participate in the Pixel Editor forum on the
Light-O-Rama web site to ask questions and find the
latest information.
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