Design Tab

Top  Previous  Next

The Design tab of the Preview Design window is where you create props (display elements) and arrange them so that they match your display.

 

This is the first of 5 tabs on the Preview Design window. The others are:

 

Channel Conflicts & Bulk Changes

Other Warnings

String Summary

Statistics

 

The Design Tab

The Design Tab

 

The Design Tab is divided into 2 main sections:

 

The left side contains controls that allow you to create and modify props and groups:

 

Add Item button

Zoom control

Toolbar

Prop and Group List

Bulb tab

Scale tab

Background tab

 

The right side is the visual design canvas - a representation of your display that will be used to simulate your lights during sequence playback.

 

 

Selecting Items

 

Items in the Prop and Group List can be selected by clicking on them. The prop or group that is selected will then be displayed in yellow on the design canvas to the right. You can also do the reverse: you can click on a prop on the design canvas and its name will be highlighted in the Prop and Group List.

 

You can also select more than one item at a time. This is often useful for moving several props at the same time or for creating groups. In the Prop and Group List, Ctrl-click on an item to select it in addition to items already selected. Use Shift-click to select a range of items in the list. When selecting items using the mouse on the design canvas, hold the Shift button down on the keyboard while clicking the mouse and that prop will be added to the ones already selected.

 

In the picture below, the “Gutter” prop has been selected – it is highlighted in the Prop and Group List and displayed in yellow on the design canvas.

 

PreviewDesignGutters

 

 

Keyboard Shortcuts

 

The following keyboard shortcuts can be used on the design tab:

 

Shortcut

Action

key-dark32-Del

deletes the selected prop or group

key-dark32-Ctrl key-dark32-A

selects all props and groups

 

key-dark32-ArrowUp

 

key-dark32-ArrowLeft

key-dark32-ArrowDown

key-dark32-ArrowRight

moves the selected props by a small amount

key-dark32-Ctrl key-dark32-ArrowUp

Makes the selected items larger. Hold the keys down longer to engage the keyboard auto-repeat if needed.

key-dark32-Ctrl key-dark32-ArrowDown

Makes the selected items smaller. Hold the keys down longer to engage the keyboard auto-repeat if needed.

key-dark32-Ctrl key-dark32-ArrowLeft

rotates the selected props counterclockwise

key-dark32-Ctrl key-dark32-ArrowRight

rotates the selected props clockwise

key-dark32-Ctrl key-dark32-number0

Control-zero resets prop rotation to its default value (fixed prop shapes only)

key-dark32-Ctrl key-dark32-Z

undo last operation

key-dark32-Ctrl key-dark32-Y

redo last operation

 

 

Add Item

 

Click the Add Item button to add Props and Groups to your preview. After saving the new prop or group, it will be added to the Prop and Group List and displayed on the design canvas on the right.

 

PreviewDesignAddItem

 

Create a new prop using one of the built-in shapes, or define a custom shape

 

This option opens the Prop Definition window, allowing you to create a prop from scratch. The wide variety of built-in shapes makes it easy to create many common display elements.

 

Some of the shapes that can be selected in the Prop Definition window

Some of the shapes that can be selected in the Prop Definition window

 

Create a new group from existing props and groups

 

This option opens the Group Definition window, allowing to create a new group. Any props and groups that are currently selected on the Design tab will be preselected on the Group Definition window as members of new group. Of course you can change the selections once you are in the Group Definition window.

 

Add a Light-O-Rama device (AC controller, Cosmic, Pixie, Pixcon, Flood, etc)

 

This option will create props according to the Light-O-Rama controller and unit id you specify. It is a good way to quickly create props that have accurate channel assignments. Flood lights created with this option will look realistic, but you may need to change the shape for props created for other controllers if you are going for realism in your preview.

 

Add a DMX device

 

This option can be used to create a generic DMX device that uses regular (single) or RGB channels. It is a quick way to create props that have accurate channel assignments; but if you are going for realism, use "Create a new prop" or one of the "online" options instead.

 

Add an RGB device (generic)

 

This option can be used to create RGB floods and "dumb RGB" props attached to Light-O-Rama controllers. Each prop will be created as single RGB bulb with a star shape. It is a good way to quickly create RGB props that have accurate channel assignments; but if you are going for realism, use "Create a new prop" or one of the "online" options instead.

 

Import an S5 prop file

 

This option loads props and groups into your preview from a file that had previously been exported. These files have an “.lpeprop” extension. You should review the channel assignments on any imported props to make sure they match your controllers – this can be done by double-clicking on the name of an imported prop to open the Prop Definition window. By default, an imported prop will be assigned the name that it had when it was exported. However, if that name is already being used in the preview, then a numeric suffix will be added to the name in order to make it unique.

 

Import a Visualizer file (fixture, prop, or complete visualization)

 

This option imports a file created with the S4 Visualizer. You will be prompted to select a Visualizer fixture file (.LFF extension), prop file (.LPF extension), or complete visualization file (.LEE extension). All of the fixtures and props defined in the selected file will then be loaded into the preview. Visualizer fixtures will become S5 props. Visualizer props will become S5 groups. You should review the channel assignments on any imported props to make sure they match your controllers.

 

Draw a new string

 

When you select this option, the cursor will change to the edit cursor when moved over the design canvas. Click on the design canvas to start drawing your string. A single click of the left mouse button will insert a vertex into the line and allow you to continue drawing the next segment. To stop drawing, double-click the left mouse button or use the ESC key. When you stop drawing, the Prop Definition window will open so you can adjust the number of bulbs in the string and also assign a channel.

 

This option is also available from the Design Canvas's right-click menu.

 

Light-O-Rama props (online)

 

This option will open the Online Prop Import screen, allowing you to import props for items sold in the Light-O-Rama store, such as pixel trees and singing faces. It is recommended that you have internet access when using this option so that you see the latest available content (content will likely change over time). You should review the channel assignments on any imported props to make sure they match your controllers.

 

SuperStar (online)

 

This option will open the Online Prop Import screen, allowing you to import props that match sequences sold by SuperStar Lights. It is recommended that you have internet access when using this option so that you see the latest available content (content will likely change over time). You should review the channel assignments on any imported props to make sure they match your controllers.

 

Boscoyo Studio (online)

 

This option will open the Online Prop Import screen, allowing you to import props for items sold by Boscoyo Studio. You will need internet access when using this option so that you can retrieve the content. You should review the channel assignments on any imported props to make sure they match your controllers.

 

Prop definitions imported from this link were created by Boscoyo Studio. Light-O-Rama provides a connection to the data in order to make our software easier to use, but is not responsible for the content.

 

Generic Props (online)

 

This option will open the Online Prop Import screen, allowing you to import props for some commonly used lights. It is recommended that you have internet access when using this option so that you see the latest available content (content will likely change over time). You should review the channel assignments on any imported props to make sure they match your controllers.

 

 

Zoom

 

PreviewDesignZoom

 

You can zoom in on your props to make fine adjustments. The buttons on the left and right will zoom in or out one step at a time. Or you can use the slider to quickly move to the desired zoom level. If you are zoomed in, clicking on a prop in the Prop and Group List will cause the canvas to scroll so the selected prop becomes visible.

 

 

Toolbar

 

PreviewDesignToolbar

 

The toolbar consists of:

 

Item menu

Format menu

Options menu: gear3 icon

Undo and Redo buttons

 

Item Menu

 

PreviewDesignItemMenu

 

Most of the choices on the Item menu are also available when you right-click on the Prop and Group List and also when you right-click on the design canvas.

 

Modify - you can double-click on an item’s name, or you can single-click on it and select “Modify” from the Item Menu. Either method will open the Prop Definition window if a prop is selected, or the Group Definition window if a group is selected.

Copy - this command opens the Copy Prop Dialog, which is very helpful in creating a collection of props that all look the same, such as a series of arches or mini-trees.

Delete - use this command to delete the selected props and groups. You will be asked to confirm before the delete actually takes place.

Layout - use this command to view a printable layout of the selected prop or group with channel information for every string or pixel. This can be quite large depending on the number of channels/pixels involved.

Copy prop to advanced shape - this command is used to copy a pixel-based prop to a new prop with the same channel assignments and pixel locations but with the Advanced shape so it can be further customized.

Export selected items - this command exports the selected props and groups to a file. You might do this so they can be imported into another preview or so they can be shared with other users.  You will be prompted for a location to save the export file.  Export files have the extension ".lpeprop". To import props, see the Add Item button.

 

Format Menu

 

Format menu with Align submenu open

Format menu with Align submenu open

 

All items on the Format menu are also available on the Design Canvas's right-click menu.

 

Align - if multiple props are selected, the items on this sub-menu allow you to align those props in various ways.

Make same size - if multiple props are selected, the items on this sub-menu allow you to resize the selected items such that they all have the same width, height, or both.

Horizontal spacing - if multiple props are selected, the items on this sub-menu allow you to make the horizontal spacing between them equal, or to remove any space between them (so they abut one another).

Vertical spacing - if multiple props are selected, the items on this sub-menu allow you to make the vertical spacing between them equal, or to remove any space between them (so they abut one another).

Rotation - after selecting 1 or more props, the actions listed under the “Rotation” menu allow you to rotate the selected items back to their default orientation (0 degrees), to 90 degrees right, or 90 degrees left. Selected props and/or groups can be rotated to any angle by dragging the rotation handle that is displayed when they are selected or using the keyboard shortcuts Ctrl-LeftArrow and Ctrl-RightArrow. Ctrl-0 (control key + zero key) is a shortcut for resetting rotation back to the default orientation (0 degrees). Note that freeform prop shapes do not have a default orientation, so the Rotation > 0 command has no effect on them.

Reset - after selecting 1 or more props, the actions listed under the “Reset” sub-menu allow you to reset the selected items back to their default position (centered), or default size (half of the canvas size), or both. Resetting the position is particularly useful because it is possible to drag items off the edge of the design canvas. When this happens, select the prop from the Prop and Group List, then choose Format > Reset > Position from the menu to make it visible again.

 

Options Menu

 

PreviewDesignOptionsMenu

 

Show pixel numbers on selected props - this option displays a number next to each pixel in the selected pixel-based prop. The number indicates the order in which the pixels should be wired; however, it does not indicate which string the pixel is on. You will need to zoom in to read the numbers. A check mark will be displayed to the left of the menu item when enabled. This option is also available on the Design Canvas's right-click menu.

 

Numbered Pixels

Numbered Pixels

 

Set color for pixel number labels - this option allows you to change the color used to display pixel numbers when "Show pixel numbers" is enabled.

New prop defaults - this option allows you to set some defaults when the Prop Definition screen is used to create new props.

 

Preview Design Preferences

Preview Design Preferences

 

Undo/Redo

 

Prop adds, deletes, movement, scaling, and rotation can be undone and redone. Undo/redo does not apply to modifying props or groups.

 

16_undo clicking this button undoes the last operation, and has the keyboard shortcut Ctrl-Z.

 

16_redo clicking this button reapplies an operation that was previously undone, and has the keyboard shortcut Ctrl-Y.

 

 

Prop and Group List

 

The Prop and Group List is displayed immediately below the toolbar. Every prop and group in your preview will be listed here in alphabetical order. To help distinguish groups from props, groups will be listed with blue text. In the picture below, "Arch 2-3", "Arch 4-5", "Arch 6-7", "Arch 1-7" and "Arches with subgroups" are groups, and the others are props. Props "arch1" through "arch7" are selected.

 

To select an item in the list, just click on it with the left mouse button. You can use shift-click to extend the selection, and ctrl-click to select additional items. More information is available in the Selecting Items section.

 

The Prop and Group List

The Prop and Group List

 

After selecting 1 or more items in the list, you can use the toolbar to select actions to perform, or you can right-click on them to view a menu that has many of the same options as the Item menu.

 

The Prop and Group List with right-click menu displayed

The Prop and Group List with right-click menu displayed

 

 

Bulb Tab

 

PreviewDesignBulbSettings

 

After selecting 1 or more props, you can change the bulb settings for the selected props. The default bulb shape is square, which uses the least amount of computer resources; however there are a variety of shapes available.

 

There are some specialized bulb shapes:

Strobe 1 - a strobe that flashes about once per second

Strobe 3 - a strobe that flashes about 3 times per second

Snowfall Tube - simulates single color snowfall tubes (also known has drip tubes and meteor tubes).

Flood - use for flood lights, single color or RGB.

 

Making the bulb size larger can make the prop easier to see on the computer screen. For strobes and floods you will almost always want to make the bulb size larger than the default in order to make them look realistic.

 

For most props, you will want to leave the bulb transparency setting at 0%. For floods, you may want something more transparent (> 0%). Adjust the transparency slider until you achieve the desired appearance.

 

An example of strobes on a megatree along with the associated prop definition:

StrobeTree PropDefinitionMegaStrobes

 

 

Scale Tab

 

PreviewDesignScaleTab

 

After selecting one or more props or groups, you can use the buttons on this tab to increase or decrease the size of the selected items. This can be useful for fine-tuning the size of an item. It also the best way to resize freeform prop shapes, as they do not display resize handles on the design canvas.

 

Click a button once to perform a small change, or hold the button down to continuously scale the selected items.

 

The "Change height and width" buttons have the following keyboard shortcuts:

 

Shortcut

Action

key-dark32-Ctrl key-dark32-ArrowUp

Makes the selected items larger. Hold the keys down longer to engage the keyboard auto-repeat if needed.

key-dark32-Ctrl key-dark32-ArrowDown

Makes the selected items smaller. Hold the keys down longer to engage the keyboard auto-repeat if needed.

 

 

Background Tab

 

PreviewDesignBrightness

 

Using a background image (such as a picture of your house) can be a great help in creating a realistic preview. Click the “Set Image” button to choose the image file. Clicking the “Clear Image” button will remove the image from the preview. Move the Brightness slider to the left to dim the background image, simulating the view of your display during nighttime. Image brightness can also be changed from other areas of the program.

 

 

Note that there are other settings that control whether the background image is shown at all and whether it maintains its aspect ratio.

 

 

Save Image with Preview

 

If this box is unchecked, then the image file will remain separate from your preview, and the sequences that use the preview.

 

If this box is checked, then the image file is stored with the preview. If you export such a preview and send the export file (LORPREV extension) to someone else, the background image will be included. The background image will also be included if you send a sequence to another user and the sequence uses such a preview.

 

 

Design Canvas

 

UsingYourMouseToArrangeThePreview

 

In the picture above, there is 1 blue string, 2 red strings, and 5 RGB arches. The second arch is selected.

 

In the preview design window, traditional strings (incandescents, LEDs, strobes) are displayed with the color of the string (e.g. a string of red LEDs will show as red). RGB pixels and dumb RGB strings are displayed in white. Any string that has been selected, traditional or RGB, is shown in yellow.

 

The selected item is always shown in yellow and has 4 red scaling “handles” at the corners (lines just have 2 handles) and a rotation handle to the right. You can select multiple props using Shift-click on the design canvas, or Ctrl-click or Shift-click in the Prop and Group List. The selected prop(s) can be dragged around the preview window using the mouse. They can be resized by dragging any one of the 4 red handles in the corners, or by using the Ctrl-UpArrow and Ctrl-DownArrow keyboard shortcuts. You can rotate them by dragging the handle on the right side, by using the Format > Rotation menu, or by using the Ctrl-LeftArrow and Ctrl-RightArrow keyboard shortcuts. If you have multiple props selected, you can align them in many ways using the Format menu.

 

You can double-click on a prop to open its Prop Definition.

 

Any movement, scaling, or rotation action can be undone by clicking the undo button or using the Ctrl-Z keyboard shortcut.

 

Right-Click Menu

 

PreviewDesignCanvasMenu

 

After right-clicking on the design canvas you can:

 

Add an item - this has the same effect as clicking the Add Item button.

Draw a new string - this allows you to interactively draw a new light string directly on the design canvas.

Modify the selected prop

Copy the selected prop

Delete the selected props

Perform any of the operations available on the Format menu

Enable or disable the display of pixel numbers on pixel-based props when they are selected

 

Right-Click on Lines-Connected Vertex

 

PreviewDesignVertexMenu

 

With these menu options, you can add and remove line segments without opening the Prop Definition window.