Sequence Menu

Top  Previous  Next

The Light-O-Rama Sequencer's Sequence Menu gives you access to a set of functions that operate on the currently selected sequence (the highlighted tab).  If there is not any file open, then the Sequence Menu is disabled.

 

Sequence Information

File References

View Sequence Folder

Media File

Convert Media to WAV file

Convert to Animation

Change Sequence Length

Skew All

Windows Command

Preview Design

Assign Different Preview

Manage Archived Props

Manage RGB Aggregates

Manage Picture Effects

Delete Grid Rows

Add New

Waveform Area

Smooth To Fades Level

Grid Configuration

 

 

The Sequence Menu

The Sequence Menu

 

 

Sequence Information

 

This menu item opens the Sequence Information dialog, giving you visibility to key information about the current sequence, This includes who created the sequence and when, as well as information about the music (artist, title, and album).

 

File References

 

This menu item opens the File References dialog, giving you visibility to all files referenced by the current sequence.

 

View Sequence Folder

 

This menu item will open a Windows Explorer window with the current folder set to the folder containing the current sequence.

 

This might be of use if you want to see the file size of the current sequence, or to make a copy the sequence file. If you are going to make a copy, make sure and save it first!

 

Media File

 

This menu item allows you to specify the audio or video file that should be used with the current sequence.  This may be useful, for example, if you have changed the directory that you store your media files in.

 

When used on an animation sequence, it will convert the animation sequence to a musical sequence.

 

Convert Media to WAV file

 

This menu item converts the media file associated with the sequence to the wave format (which has a WAV file extension).

 

Some media file formats do not position accurately when play back is started in the middle of the file. This can cause inaccuracies in sequencing - your lights would turn on at slightly different times depending on whether play back was started from the beginning of the sequence or the middle. MPG video files and variable bit rate MP3 files are most susceptible to this issue. Converting to a wave file can eliminate this problem.

 

Convert to Animation

 

This menu item will convert the current sequence from a musical sequence to an animation sequence.

 

Perhaps someone has sent you a sequence, but you don't have the media file to go with it. By converting the sequence to an animation, you can still play it back and watch the preview.

 

To convert an animation sequence to a musical sequence, use the Media File menu item.

 

Change Sequence Length

 

This menu item allows you to change the duration of the current sequence.

 

For information on the format used to specify an amount of time, please see the Time Format topic.

 

The Change Sequence Length dialog

The Change Sequence Length dialog

 

Skew All

 

Skewing a sequence will move all of its events, timings, and loops by some specified amount of time.  A sequence can be skewed either to the left - i.e. shifting its events (and such) earlier in time - or to the right - i.e. shifting them later in time.

 

After selecting "Skew All" from the Sequence menu, a window will open up, allowing you to choose the size and direction of the skewing:

 

The Skew All dialog

The Skew All dialog

 

In most cases, you should leave the "Action" section with the default choices. However, if you have a special situation, you can turn off skewing of effects or timing marks as needed.

 

After completing this dialog, the sequence will be skewed by the amount, and in the direction, that you chose.

 

Here is an example of a simple sequence, before and after skewing to the right by one-quarter second:

 

A simple sequence, before skewing

A simple sequence, before skewing

 

 

The same sequence, after skewing to the right by 1/4 second

The same sequence, after skewing to the right by 1/4 second

 

 

Windows Command

 

This menu item will open the Windows Shell Command dialog which allows a command to be executed whenever the current sequence is run (whether by the Sequencer or by the Show Player).

 

Preview Design

 

This menu item opens the Preview Design window for the current sequence.

 

Assign Different Preview

 

This menu item allows you to associate a different preview to the current sequence. This function works best if the new preview started out as a copy of the original preview. However, the function will also look for matching prop names between the old preview and the new preview. Effects will be preserved for props and groups that match. Where there is no match, those items and their effects will be archived.

 

Manage Archived Props

 

This menu item will open the Manage Archived Props dialog which allows you to change archived props in the current sequence: delete them, turn them into preview props, or turn them into beat channels.

 

Manage RGB Aggregates

 

This menu item will open the Manage RGB Aggregates dialog which allows you to add, modify, and delete RGB aggregate channels. RGB aggregates allow you to combine any 3 existing channels (the colors don't need to be red, green, and blue necessarily), and the combination of the 3 is treated as an RGB channel for sequencing purposes.

 

Manage Picture Effects

 

This menu item will open the Manage Picture Effects dialog, which allows you to control where the image files used in the sequence's Picture motion effects are stored. The images can be stored inside the sequence file (making it easier to move your sequence from one computer to another), or they can be stored separately from the sequence.

 

Delete Grid Rows

 

This menu item will open the Delete Grid Rows dialog which allows you to permanently remove certain types of unused grid rows from the sequence. This menu item is only available to users with a Pro license.

 

The Delete Grid Rows dialog

The Delete Grid Rows dialog

 

Add New

 

This menu item opens a sub-menu, allowing you to add a new loop level, beat channel, subsequence, or RGB aggregate. "Add New" is also available on the Grid View menu.

 

Waveform Area

 

The "Waveform" sub-menu allows you to set the audio waveform area’s height. Choose “Large” to see the maximum amount of detail in the waveform. Choose “Small” to see the waveform, but have more room to display the sequence. Animation sequences are automatically set to hide the waveform. The height can also be set by right-clicking in the waveform area.

 

S5WaveformAreaSubmenu

 

Smooth To Fades Level

 

The "Smooth To Fades Level" sub-menu allows you to control whether adjacent effects are merged with one another. Being more aggressive may reduce the number of commands sent to your controllers. On the other hand, if you are sequencing DMX fixtures that require specific DMX values to control their functions, then you should probably set this to "None". Changing this setting only applies to new effects, it does not change effects already in the sequence. So you can change the setting back and forth as needed over the course of creating a sequence.

 

ToolsMenuSmoothToFadesLevel

 

Grid Configuration

 

This item opens a sub-menu allowing you import or export the user-defined grid views in the sequence. The system-generated "Show All Items" grid view is not included in the export.

 

Grid Views in a sample sequence

Grid Views in a sample sequence

 

So in the example shown above, "View 1", "View 2", "View 3", and "View 4" would be included in the export file.

 

For Pro users, the export file will also include the properties of each motion effect row. This is useful if you have created motion rows for subsections of a prop or group.

 

The "Grid Configuration" sub-menu is also accessible from on the Grid View menu.