Move or Scale Selected Effects

Top  Previous  Next

This feature is used to move or scale the selected effects according to the settings in the dialog box.  Note that you cannot undo the changes done by this dialog box so it is recommended that you save the sequence to a new name prior to using this dialog box.  For example if you are moving all the effects two pixels to the right you would do the following:

 

1.Click on the File menu and select “Save As” and save the sequence to something like “MySequence_movedRight2Pixels.sup”

2.Click on the Edit menu and select “Select All”

3.Leave “Move Origin” selected and set “Left/Right” = 2

4.Click on the OK button

5.Click on any effect and you should see that it has been moved to the right by 2 pixels

 

This feature is also useful for converting a sequence to different dimensions. For example, if you want to stretch a 12 CCR sequence to be a 16 CCR sequence you would do the following:

 

1.Click on the File menu and select “Save As” and save the sequence to something like “MySequence_16CCR.sup”

2.Click on the Edit menu and select “Select All”

3.Click on “Scale”

4.Set:

Source Width = 12

Dest Width = 16

Source Height = 50

Dest Height = 50

           

5.Click on the Ok button

6.Click on any effect and you should see that it has been stretched to fit onto a 16 CCR layout

 

Selected Effects to Modify

 

This defaults to all effect types being selected. But if, for example, you only want to modify the selected “Scenes” then you would uncheck all the effect types and leave “Scenes” selected

 

Move Origin

 

Select this if you want to move the effects left, right, up, or down, the number of pixels set in the Left/Right control and the Up/Down control

 

Scale

 

Select this if you want to scale the effects. Scale means to stretch or squish.  The “Source Width” and “Source Height” is the original width and height of the sequence.  The “Dest Width” and “Dest Height” is the destination width and height, or in other words, the width and height that you want the sequence to become.

 

Do Scene Thinning

 

This setting is used when “Scale” is selected.  It is easiest to explain this setting by using the example of  a scene that is random pixels that look like stars in the sky.  If you shrink the stars and have “Do Scene Thinning” selected then some of the stars will get removed or “thinned” out so that the density of stars in the shrunken sky stays the same.   If you shrink the stars and have “Do Scene Thinning” unselected then all of the stars will be kept, and in the shrunken sky the density of stars will be greater.  In the extreme case, if you shrunk the sky a lot then there would be no space between the stars anymore.

 

Change Intensity

 

Select this if you want to increase or decrease the intensity of the color of all selected effects. Note this change is always relative to the current intensities.

 

For example, if you set 50% then all color intensities will be reduced by 50%.  If you then select the same effects and reduce the intensity by 50% again, then the intensities will be 25% of what they were before you did any changes.

 

As another example, if you set 200% then color intensities of 50 and lower will get doubled. All values 50 and greater will become 100. This means that increasing the color intensities by 200% and then decreasing them by 50% will not necessarily get you back to the original intensities.

 

Change Orientation

 

If the orientation of your visualization is different than the orientation of your sequence then you can change the orientation of the effects in the sequence by using “Change Orientation.”

 

For example, let us say you have a horizontal sequence designed for a 50 wide by 16 tall horizontal display where the strings of lights run horizontally. But you have a display that is 50 wide by 16 tall and the strings of lights run vertically.

 

The default is for SuperStar to see the display as a vertical display because the strings run vertically. And when the sequence is played, the sequence will look rotated by 90 degrees. So to get it to look right on the display you can change the orientation by doing the following:

 

1.Click on the “File” menu and select “Open” and open the sequence

2.Click on the “File” menu and select “Save As” and save the sequence to a name such as “MySequence_horizontal.sup”

3.Click on the “Edit” menu and select “Select All”

4.Click on the Tools menu and select “Move or Scale Selected Effects”

5.Select “Change Orientation”

6.Select “Rotate 90° Left (Vert to Horz)

7.Click on “OK”

 

The effects in the sequence should now all be rotated to the right and should play properly to your display.

 

Note: Another way to address the problem of orientation of the grid being different than the orientation of the sequence is to change the orientation of the grid. To do this click on “Tools” menu and select “Preferences” and then change the orientation of the grid.