What's New?

Top  Previous  Next

What's New in the Latest Version

 

What's New in Version 5.2.4

What's New in Version 5.2.2

What's New in Version 5.2.0

What's New in Version 5.1.4

What's New in Version 5.1.2

What's New in Version 5.1.0

 

 

What's New in Version 5.2.4

 

LOR Hub now supports all SD card options

LOR Hub can now turn off SD card schedule days if desired

Improvements in LOR Hub for creating SD cards with PC configuration

Simple Show Builder is being removed with the next release

Superstar Improvements

Sequencer Improvements

Sequencer Bug Fixes

Bug Fixes

 

LOR Hub now supports all SD card options

The LOR Hub program can now create SD cards with a full range of options, including triggers, filler sequences, starter sequences, etc.  In a future release, SD card building will be removed from the Hardware Utility and the Simple Show Builder will be removed from the suite.

 

LOR Hub can now turn off SD card schedule days if desired

Previously there was no way to stop an SD card show from running on a particular day, except by using a workaround of setting the start and end times for a particular day the same.  LOR Hub can now properly turn OFF a schedule for a particular day.

 

Improvements in LOR Hub for creating SD cards with PC configuration

When creating an SD card in Advanced mode in Hub, a new option has been added to configure the MP3 Director's ports the same way as those ports are defined on the computer.  This can help with ease of setup of MP3 directors.

 

Simple Show Builder is being removed with the next release

LOR Hub has taken over all functions of the old Simple Show Builder program.  In the next release this program will be removed from the suite.  Instead, use LOR Hub to create your shows.

 

Superstar Improvements

 

Added support for group modify of "average time length of effects" and "skip inactive grid squares"

Added the "Do Scene Thinning" option in the "Move or Scale Selected Effects" dialog box

Added "Orientation" setting in the Preferences dialog box

Added support to convert 6 channel star effects to white effects on RGB stars from other vendors (previously it only worked for the standard 200 pixel RGB star)

 

Sequencer Improvements

 

All 3 windows on the Motion Effect Generator now update simultaneously, which is also a performance improvement. Previously they could update slightly out of sync for very large props. Requested by Light-O-Rama.

 

If the user selects Create Playback Files from the menu and the sequence hasn't been saved, the user is now offered a chance to save it (without having to cancel, save the sequence, then try and create playback files again).  Requested by user ndutton.

http://forums.lightorama.com/topic/48065-reduce-the-clicks/

 

Enhancement: when opening a sequence, archived props will automatically be un-archived if a prop with the same name has been added back to the sequence's preview since the sequence was last opened. Same logic will also apply when you change the preview assigned to a sequence. Requested by Light-O-Rama.

 

Enhancement: more accurate conversion when assigning a different preview to an existing sequence. Requested by Light-O-Rama.

 

Performance improvements to the Picture motion effect. Requested by user jamills706.

http://forums.lightorama.com/topic/48263-spinning-orange-circle-forever/

 

In the New Animation Sequence dialog, show the sequence length as words, and give a warning when OK is clicked and the length is more than an hour. Requested by user Rabeiler.

http://forums.lightorama.com/topic/48288-animation-sequence-will-not-preview/

 

In the sequence grid, the drop-down list of grid views would previously display views in the order they were created. Now, the system grid view (Show All Items) is listed first, and then user-created grid views are listed in alphabetical order. Requested by user Jade Rymkos.

http://forums.lightorama.com/topic/48687-is-there-a-way-to-reorder-grid-views/

 

Increased the maximum number of bulbs in a bulb shape to 999. Requested by users dibblejr and gsmith37064.

http://forums.lightorama.com/topic/48682-moving-s4-to-s5/

 

In the Paste Special dialog, you can now specify the spacing between horizontal copies. A negative value yields an overlap, a positive value leaves a blank space between each copy. 0 is always the default value (it is not remembered between uses). Requested by user spascall.

 

Added new "hold" effect, which freezes the state of the prior effect. For example, you can freeze and unfreeze a spiral effect to the beat of the music by alternating spiral and hold effects on the same motion effect row. The hold effect must be touching the prior effect to work. Requested by Light-O-Rama.

 

In Prop Definition, added "Arm Thickness" parameter to the Star shape. A value of 1.0 is the normal thickness. Smaller values make the arms thinner. Requested by Light-O-Rama.

 

New tab on Sequencer Preferences that allows the user to choose among 3 edit cursors. Previously, only the yellow pencil was available. Requested by user bdwillie.

http://forums.lightorama.com/topic/48787-sequencer-pencil-pointer/

 

"Custom Chase" options are now available on the toolbar via a new drop-down arrow next to the chase button. The chase options will also get saved with the sequence, and recalled the next time the sequence is opened. Requested by Jack Richter via help desk.

 

Add the "+" shortcut key for the Repeat function (to match SE).  Requested by Light-O-Rama.

 

Added the Enter shortcut key to place an effect in the grid (to match SE). Requested by Light-O-Rama.

 

Added option in preferences (Channel Effects tab) to view fades as ramps. Requested by multiple users.

 

Added option in preferences (Channel Effects tab) to adjust background color of channel rows in the grid. Requested at Christmas Expo.

 

In Prop Defintion's layout tool for custom and advanced shapes, there is a new "Crop" function that removes extra rows and columns. Requested by Light-O-Rama.

 

Added Help buttons ("?" icon) to Preview Design, Prop Definition, Group Definition, and Custom Grid screens. Requested by Light-O-Rama.

 

Increased the max width and height on the SimpleShape effect to 1000% in order to allow shapes to expand beyond the prop boundaries. Requested by user Mike Baldwin.

 

Sequencer Bug Fixes

 

Bug fix: in the sequence grid, right-clicking on a "member props" or "member groups" node and selecting "Hide Group Members" from the pop-up menu disabled further highlighting of prop names as the mouse pointer was moved. Reported by John Johnson Jr via help desk.

 

Bug fix: in rare cases the Sequencer could crash if 1) the LOR Control Panel was running when the Sequencer started, and 2) a Schedule was enabled or Show on Demand was running, and 3) the option to Control Lights when the Sequencer started was enabled. Reported by Jim Wright via help desk.

 

Bug fix: S5 Verifier checked for application files that don't exist in S5, which resulted in "Message Number 7" errors that were not really errors. Reported by stevehoyt, TitusCarnathan, richmuller and others.

http://forums.lightorama.com/topic/47959-tc-72-verifier-losing-its-mind/

http://forums.lightorama.com/topic/47777-52-verifier-errors/

 

Bug fix: when using music to control a slider in the Motion Effect Generator, the audio data was being pulled from the wrong part of the sequence. The effect used the correct audio data when placed in the sequence grid -- the error was only when the effect was displayed in the Motion Effect Generator. Reported by Light-O-Rama.

 

Bug fix: when you imported an S5 prop file in Preview Design, clicked the "Set Channels" button, then changed the name of the prop while setting channels, the resulting list of props and groups to lthe left of the design canvas would no longer be in alphabetical order. Reported by user ndutton.

http://forums.lightorama.com/topic/48041-preview-design-bugs-and-suggestions/

 

Bug fix: if a sequence gets moved to another folder or to another computer and the media file is in the same folder as the sequence, then playback files created from the new location could point to the wrong folder for the media file.  Reported by user ndutton.

http://forums.lightorama.com/topic/48059-missing-files-bugs-and-suggestions/

 

Bug fix: when the sequence length was changed, the sequence was not marked as containing unsaved changes. Reported by Light-O-Rama.

 

Bug fix: in rare cases, effects could exist in sequences past the end of the sequence. When using playback files for such sequences, the Show Player would refuse to play the song with the message "ERROR STARTING SEQUENCE (Invalid end centisecond for last replacement event: 78195; channel is 55210 centiseconds)". Reported by NJ Malenke and stevehoyt.

 

Bug fix: if Holiday Lights Designer was enabled in S4 and then the user upgraded to S5, the Show Player would display errors in the log like "ERROR PLAYING SEQUENCE (Address in use Trace: UDP SetIntensity Trace: HandleIO)". Reported by Derek Flint via help desk.

 

Bug fix: certain combinations of removing and renaming props in a preview could leave a sequence unable to be opened (error message "An entry with the same key already exists"). Reported by Michelle Lovering via help desk.

 

Fix crash when Windows policy "System cryptography: Use FIPS compliant algorithms for encryption, hashing, and signing" is enabled. Reported by Dave Webb via help desk

https://support.microsoft.com/en-us/help/811833/system-cryptography-use-fips-compliant-algorithms-for-encryption-hashi

 

The LOR SC485 serial port adapter (not USB) now works with the S5 Sequencer. Reported by several users via the help desk.

 

Fixed the online import of "Boscoyo ChromaStar 36 3 ring".  Reported by Mike Baldwin via help desk.

 

Bug fix: in the Motion Effect Generator, double-clicking on a slider did not fully unlock it. Reported by Light-O-Rama.

 

Bug fix: in the Motion Effect Generator, effects with alpha transparency were not displayed correctly in the left and right windows. The combined window was correct. Reported by Light-O-Rama.

 

Bug fix: if the user right-clicked on a cell in the sequence grid, and then right-clicked on another cell in a different row, several cells in the clicked column would be selected. Reported by Light-O-Rama.

 

Bug fix: when doing Repeat, then Undo, then Redo, the Redo was done in the wrong place. Reported by Light-O-Rama.

 

Fixed a bug with clipboard files, where files created as part of the "Papagayo to LOR" process could not be pasted. Reported by Dennis Holliday via the help desk.

 

Bug fix: in the Control Lights window, unchecking a box for an enhanced LOR network or for DMX, did not actually stop output from going to those networks. Reported by Light-O-Rama.

 

Other Bug Fixes

 

In LOR Hub and Hardware Utility, sequences with DMX Fades when written to the SD card could cause the MP3 director to go out of sync.

LOR Hub was not able to properly create an SD Card schedule.  The schedule would always revert back to the defaults instead of what the user specified.

LOR Hub would crash if the user attempted to create an SD card show with no sequences in the create list.

During installation, the Post Install process was not creating 3 new superstar visualization samples.

In Superstar, text masks were not working in visualizations where some of the mask is outside of the matrix.

In Superstar, fixed a bug where the white color control was not appearing if the only white that existed was in images.

In Superstar, changed it so you can do "merge intensity data files" even in the demo version

In Superstar, fixed a bug where scene pixels were getting clipped out if the clip region was on the right half of the wrap around screen

 

 

What's New in Version 5.2.2

 

Updates to the Sequencer

Superstar 'Add +' button

Bug Fixes

 

Updates to the Sequencer

 

A "Where Used" function has been added to the File References dialog, so you can find the effect that uses a missing reference. Requested by Michael Lenbom via help desk.

 

In the Prop Definition screen, when defining a "Tree 360 Up & Over" shape using pixels, the shape diagram will now indicate the location of the first pixel on each string. Requested by Light-O-Rama.

 

The user now has control over how "smooth to fades" is applied with a new sub-menu: Sequence > Smooth To Fade Level. This setting controls whether adjacent effects are merged together or not. Previously, the level was fixed at the "mild" setting; however, with the mild setting it is impossible to create DMX intensities that are 2 steps apart (for example: 65, 63, 61). Requested by Drew Hickman.

 

Updated the pencil icon to be more visible, and moved the tip to the upper left. Requested by Ernie McAnally via help desk.

 

If the user had a Pro license, when they created Playback Files an intensity data file (.LID extension) was always created. Now an intensity data file is only created if the sequence has props that use DMX or Enhanced LOR networks. Requested by Light-O-Rama.

 

Added a "How Do I Get Started?" link at the top of the "Start Page". Requested by Light-O-Rama.

 

Superstar 'Add +' button

 

In the "Image Setup" dialog box, a new button was added called "Add +".  The "Add+" button adds the current image to the image action, selects the next image, and bumps the time ruler selection forward. This makes it easy to add a series of images for an animation.

 

Bug Fixes

 

In certain circumstances, LOR Hub could create a computer show with incorrect sequence entries.  When enabling the show, LOR Show Player would not be able to find the correct sequence.

In certain circumstances, LOR Hub could create an SD card with sequences that in the future could not be edited.  The SD card would however work.

If a MotionPak in LOR Hub did not have the same upper/lowercase as the base sequence, LOR Hub would not be able to find it.

 

 

What's New in Version 5.2.0

 

New Program:  LOR Hub

Updates to the Sequencer

Bug Fixes

 

New Program LOR Hub

 

A new program for the Showtime Suite has been added called 'Hub'.  Hub currently has 2 main functions.  

1.It enables our new MotionPak technology which allows you to modify LOR Sequence Store sequences for use with props the LOR Hardware Store will sell.  The first props will be 'Singing Faces'

2.It is the replacement for Simple Show Builder. Simple Show Builder is still available in this release, however it will be removed in a future release.  If you previously used Simple Show Builder you should move to Hub.
Hub can create both simple computer shows, as well as SD card shows for MP3 directors.

 

In future releases, Hub will continue to grow and will be taking over all 'show' type functionality including things like the Show Editor, Show Scheduler, and Building advanced SD cards for MP3 Directors from the Hardware Utility.

 

Updates to the Sequencer

 

If the content of the Start Page extends beyond the bottom of the window, the vertical scrollbar that is displayed now spans the entire right edge of the window - making it easier to scroll. Reported by Light-O-Rama.

 

Bug fix: if the user made the Start Page a floating window, then selecting Window > Reset Window Layout would close the Start Page. Reported by Light-O-Rama.

 

The first 4 items on the Windows menu have been renamed: "View Playback Window", "Viiew Motion Effects Window", "View Previews Window", and "View Control Lights Window". Also these items will only be shown if the respective window is currently hidden ("X" in the upper right corner of the window has been clicked). This should make it clearer what these menu items do, particularly the Control Lights item. Reported by Light-O-Rama.

 

If the content of the Control Lights window extends beyond the bottom of the window, a vertical scrollbar is now displayed. Reported by Light-O-Rama.

 

The Start Page can now be hidden, unhidden, and floated just like the Previews and Control Lights windows. Reported by Light-O-Rama.

 

Bug fix: the TextPE effect did not display the text specified by the user. Reported by user Dave Trollope via help desk.

 

Bug fix: if a sequence used video media and Loop At End was enabled for playback and video playback was set for full screen, the video window would often get resized instead of remaining full screen. Reported by user Bry.

http://forums.lightorama.com/topic/47295-video-playback-issue-in-shows/

 

When you right click on the sequence grid, there is a new sub-menu under Timing Marks > Insert Timing at Selection, with options for Left, Right, and Both. This will insert timing marks at the left and/or right edge of the grid selection. Reported by user Luke Kamp via help desk.

 

Bug fix: on Preview Design's Channel Conflict tab, clicking a column heading in the conflict list would crash the program. Now clicking a column heading sorts the table according to the values in that column. Reported by Light-O-Rama.

 

On Preview Design's Channel Conflict tab, there are now fields for the user to enter text to filter the list by name or by channel. A "Select All" checkbox was also added. Reported by Light-O-Rama.

 

When dragging a favorite or subfolder in the Motion Effect Generator, the favorites tree will now auto-scroll when the cursor nears the top or bottom edge. Reported by user NJ Malenke via help desk.

 

Bug fix: when moving a timing mark with "Drag events with timings" enabled, the Sequencer could crash in some cases. Reported by user Peter Dusaitis via help desk.

 

Bug fix: the "Create an empty freeform timing grid" check box on the New Animation Sequence dialog did not actually create a freeform timing grid. Reported by Light-O-Rama.

 

You can now right-click on the Playback Window and change the brightness of the background image (if there is one). Reported by Light-O-Rama.

 

RGB aggregates with one or more sub-channels (red, green, or blue) left undefined, could cause the Sequencer to crash when modifying effects. Reported by user Keith Henrickson via help desk.

 

Added new dimming curves to the Prop Definition screen: Linear_30pct, Linear_40pct, PixelCurve_30pct, PixelCurve_40pct. Reported by user jamills706.

http://forums.lightorama.com/topic/47355-dimming-curves-question/

 

Windows Shell Commands get shared between sequences if you use File > Save As to create a new sequence. Specifying a new command from the revised screen will only affect the sequence that is open. Reported by user k6ccc.

http://forums.lightorama.com/topic/47372-windows-command-changes-affects-multiple-sequences/

 

In rare cases where 2 props in a preview have the same name, the entire preview file would not load at startup. Now the preview is loaded and a warning about duplicate names is shown on the "Other Warnings" tab of Preview Design. Reported by Light-O-Rama.

 

Fixed playback issues when sequences are arranged side-by-side. Reported by user NJ Malenke via help desk.

 

A "Copy to Clipboard" function has been added to the File References dialog. For sequences with many motion effect file references, this can allow you to paste the list of files into a spreadsheet or word processor for further analysis. Reported by user Stephen Chapman via help desk.

 

Bug fix: title bar of Playback Window was not showing the name of the current motion effect when one was clicked on in the sequence grid. Reported by Light-O-Rama.

 

During sequence playback, the Color Fade tool is now grayed out like the rest of the toolbar. Reported by Light-O-Rama.

 

If a comm port is unable to be opened, added a tip to the error message: "Make sure shows are disabled and the Hardware Utility is closed". Reported by user stevehoyt.

http://forums.lightorama.com/topic/47470-problem-enabling-comm-port/

 

Added new menu items when right-clicking on the Preview Design canvas: Add, Modify, Copy, and Delete. Reported by Light-O-Rama.

 

Improvements when upgrading Pixel Editor previews and sequences to S5 for non-US customers -- problem occurred on PC's configured to use a comma as the decimal separator in numbers. Reported by user Niklas Adolfsson via help desk.

 

Bug fix: When using the space bar in the Tapper Wizard --  if you go one tap past when the music ends, the space bar defaults to the “exit” button and closes the wizard (thus erasing all of your “beats”). Reported by user Steve Warner.

 

Bug fix: the Sequencer could crash when the toolbar channel effect was set to DMX Intensity and you tried to add a motion effect. Reported by user Steve Warner.

 

Bug fix: clicking the Refresh button on the online prop import screen did not display the updated data correctly. Reported by Light-O-Rama.

 

In Archived Prop Management, added button to select all props with no effects. Reported by Light-O-Rama.

 

Bug Fixes

The Post Install process failed to copy 3 new examples for Superstar.

The configuration for PixCon16 MKII devices was incorrectly showing 32 ports.

In Superstar, if the preview uses horizontal orientation and you go into "floating windows" mode, the program could crash.

In Superstar, the first time beat marks are created they are created without issue.  Creating beat marks a second time incorrectly deleted them.

In Superstar, if you changed timings the program may not prompt you to save your work.

In Superstar, when using Text Masks along with scenes or morphs, it was possible that the mask was not applied.

In Superstar, when using a Text Mask or an Image Mask, if Layer Priority was disabled, foreground effects would be incorrect and background effects would not be rendered.

In Superstar, if the program was launched from S5 changes would not be saved if "Save" or "Save As" was used to save the sequence as a .sup file.

In Superstar, when using Autosequence effects, the displayed timings may be incorrectly changed to the most recently used Autosequence settings.

In Superstar, when using Autosequence if "average the time length of effects" was selected then the last few seconds of an autosequence effect may not generate triggers.

In Superstar, when using Autosequence if "Burst and Return" was used, there could be a compile issue. This happens most frequently with low sensitivity settings such as 1 or 2.

In Superstar, when using Autosequence morphs with transparency set to transparent were not being saved properly.

In Superstar, when shrinking using the pixel extender and smooth effects, the shrink did not occur properly.

In Superstar, the "Center X,Y" control in the Smooth Effects dialog box  the buttons were not oriented properly when creating a horizontal sequencing grid.

In Superstar, if the pixel extender is enabled and a visualization with a sequencing grid was imported with a "max length" , a crash could occur.

In Superstar, if the pixel extender is enabled and a sequence was being shunk, only half of the effects would get applied.

 

 

What's New in Version 5.1.4

 

Registry Wipe can now clean Program Files folder

Updates to the Sequencer

Updates to SuperStar

 

Registry Wipe can now clean Program Files folder

 

Some versions of the LOR S4/S5 uninstaller can leave behind unwanted programs in the user's Program Files(x86)\Light-O-Rama folder.  This can lead to installation problems the next time the user tries to install the software. Registry Wipe can now clean those entries up.

 

Updates to the Sequencer

 

Performance improvements:

1.The Sequencer starts about 20% faster. Reported by Light-O-Rama.

2.Improved the calculation time of Text and Picture effects. Reported by Light-O-Rama.

 

Countdown effect changes:

1.Added a "MM:SS" display option and allow a max of at least 1 hour. Reported by Light-O-Rama.

2.Text can now be positioned in both the X and Y directions. Forum request.

 

Changes to Preview Design:

1.you can now double-click on a prop in the design area to open its Prop Defintion. Reported by Light-O-Rama.

2.The "Tree 360 Spirals" shape could display an erroneous message regarding the number of folds when the number of revolutions was set to a large number. This message has been removed and the revolution limit restored to 25. Reported by Drew Hickman and user ukoberon. http://forums.lightorama.com/topic/46953-spiral-360-prop-tree-issue-512/

3.Created new "Cylinder Spiral" shape for spiral-wrapped tree trunks and columns. Reported by user jamills706. http://forums.lightorama.com/topic/46949-wrapped-tree-trunk-propmodel/

4.On the Prop Definition screen, if the diagram area was taller than it was wide, many of the shape diagrams would overflow. Now they are properly scaled. Reported by Light-O-Rama.

5.Bug fix: a prop made of pixels that uses the "Tree 360 Spiral" shape could crash the Sequencer. Reported by Light-O-Rama.

6.Bug fix: the Prop Definition window was expecting the "Arial Narrow" font to be installed, but that font is not on all computers. On some computers this could cause the program to show a continual stream of error messages. The program will now check if the font is installed before using it. Reported by user Norm Bowman (via help desk).

7.The "Tree 360 Up & Over" shape now supports folds in the string. When used with pixels, the layout has been redone to represent pixel strings that go up and over the top of the tree. Reported by Drew Hickman and Jesse Tryon.

8.If there are any unsaved changes in the Preview Design screen and you click the Cancel button or click the Windows "X" button to close it, then you will get a message confirming that you want to continue without saving the changes. Reported by user Gordon Varney (via help desk).

9.You can now delete props from the Channel Conflicts tab in Preview Design. Select Change Seleced Props > Delete Props. All of the actions on the Change Selected Props menu are also now available by right-clicking on the selected props in the Channel Conflict list. Reported by Light-O-Rama.

10.When copying a prop in Preview Design (Item > Copy), channels will no longer be renumbered if the "Uses the same channels as" field is set on the source prop. Reported by Light-O-Rama.

 

Changes to freeform play ranges:

1.Bug fix: when you were defining a freeform range for playback and you moved the cursor to the left - past the left edge of the grid - it cleared the selection. This made it difficult to select 0:00.00 as the starting point. Reported by Drew Hickman.

2.The following menu items have been added when you right-click on the timeline or the waveform (reported by user spascall): 

a.Set Play Range Start - if no freeform play range exists, it creates a range from the selected point to the end of the sequence; otherwise it moves the start point of the existing range. 

b.Set Play Range End - if no freeform play range exists, it creates a range from the beginning of the sequence to the selected point; otherwise it moves the end point of the existing range. 

c.Clear Freeform Play Range - clears an existing freeform play range.

 

Do not allow channels to be copied in the "Show All Items" grid view. This grid view is system generated - items can be moved, but not hidden or copied. Reported by user daughjs.

http://forums.lightorama.com/topic/47021-cant-delete-duplicate-channel-button/

 

In the sequence grid, when you right click on a channel name for a prop that has multiple strings, a new "Set Channel Name" option will appear. This capability will primarily help custom props with multiple strings which get channel names like "Horatio Hornblower: r64 c31". The channel name will be stored with the preview, so it will apply to all sequences that use that preview. Reported by Robert Brescia.

 

In the Skew All and Skew Selection commands, the maximum offset has been increased from 10 seconds to 600 seconds. Also, the user will now have the option of skewing the current timing grid or all freeform timing grids. Reported by user NJ Malenke.

 

Bug fix: changes made to the sequence while calculations are occurring (icon in the upper left is spinning), might not be reflected during preview playback. Reported by user k6ccc.

http://forums.lightorama.com/topic/46930-modifying-motion-effects-sometimes-not-taking-the-change-until-after-opening-and-saving-the-effect/

 

After clicking on a slider in the Motion Effects Generator, you can now fine-tune the value using the left or right arrow keys. If the slider is unlocked, shift-left-arrow and shift-right-arrow can be used to change the ending value. Reported by Drew Hickman.

 

When you right-click on the timeline or the waveform and select "Zoom In" from the menu, the zoomed sequence grid is now centered on where the right-click took place. Reported by Light-O-Rama.

 

In rare cases, a preview could get saved that had a prop with an invalid circuit number (like 0). In prior versions, this would result in a popup error message as the Sequencer opened; and if the preview were subsequently opened in Preview Design could result in a crash. Going forward there is no popup message when the program is opened. The preview can then be opened in Preview Design and the error will be reported on the "Channel Conflicts" tab - where it can be corrected. Reported by Light-O-Rama.

 

Bug fix: you are no longer allowed to drag beat channels into the list of preview props and vice versa. Reported by Light-O-Rama.

 

The 3 versions of the chase tool (intelligent, by prop, and by row) have been condensed into 2: regular chase and custom chase. Regular chase is the same as intelligent chase (chase by prop when the first row is a motion row, and chase by row for anything else) with the addition that the selected area for the chase is now cleared. For a custom chase, the user is prompted whether they want to chase by row or prop, and whether the selected area should be cleared. A new keyboard shortcut shift-H initiates a custom chase. Custom chase is also accessible from the right-click menu. Reported by user spascall.

 

When exporting the grid configuration and "Show All Items" is the current grid view, the user will now get a warning stating that "Show All Items" is a system-generated view and will not be included in the export file. Reported by Drew Hickman.

 

In the Paste Special window, the "All the way to the end of" drop-down box now includes the last item in the selection and the last row in the grid view. The last row in the grid view is now the default. Reported by user spascall.

 

Bug fix: motion effects on props should override effects on groups that they are a member of. However, that was not happening in all cases. Reported by user John Trp (via help desk).

 

Bug fix: the Fill tool would display the message "Trying to fill between effects, but the row is empty!" when the sequence row was not empty. Reported by user lkcubsrule.

http://forums.lightorama.com/topic/47070-s5-fill-error/

 

Bug fix: Ampersands (&) in prop names would not display correctly in the sequence grid. Reported by Light-O-Rama.

 

When playing back a sequence to real lights and when saving playback files, the Sequencer now checks if motion effects have been placed on props connected to an LOR network that is not enhanced. If so, then the action is cancelled until the condition is fixed. Reported by Light-O-Rama.

 

The music is only supposed to play one time when you click the play button in the Motion Effect Generator. However, due to a bug, if the loop button on the toolbar for the sequence was enabled, it would cause the music to repeat in the Motion Effect Generator as well. Reported by Light-O-Rama.

 

The Motion Effect Generator now has a mute button so users can turn off the music while creating their motion effect. Reported by NJ Malenke.

 

When using the Max Intensity, Min Intensity, Fade Up, or Fade Down tools, the message "'Motion effect' is selected on the toolbar, but no motion effect is currently displayed in the playback window. Would you like to create an effect using the Motion Effect Generator?" will now only get displayed when motion effect rows are part of the selection. If the effect shown on the toolbar is "motion effect" but only channel rows are selected, then the toolbar effect is changed to the ON effect. Reported by Drew Hickman.

 

The checkbox to enable or disable looping of effects in the Motion Effect Generator has been replaced by a toggle botton (press on, press off). Also, the loop icon shown there and on the sequence toolbar will now show a red slash through it when disabled. Reported by Light-O-Rama.

 

Bug fix: when attempting to open a playback file (.play.lms), the program would display an error message, then go ahead and open the file anyway. Now no attempt is made to open the playback file after the error is displayed. Reported by Light-O-Rama.

 

Fixed the File References dialog so that long sequence names, media file names, and preview background file names wrap if they extend beyond the width of the window. Reported by Light-O-Rama.

 

 

Updates to SuperStar

 

FEATURES:

 

Several new options and effects have been added to Superstar's Auto Sequence tool including effects 'Folding Ricochet', 'Snake Up/Down', along with options to 'Skip Inactive Grid Squares' as well as 'Average the Time Length of Effects'.

The Sequencer now sends the current timing grid to SuperStar when inserting a SuperStar effect. This allows SuperStar to display the same timings as the Sequencer.

 

BUG FIXES:

 

Exporting as intensity data could cause the program to crash

Text masks and image silhouette masks were not keyed on their clip rectangle. Any effects that fall entirely with in the mask's clip rectangle get applied to the mask.

In the Auto Sequence dialog box if the user did not select one of the 8 custom colors, a message is now displayed.

When saving in the Demo version, the file added to the recent files dialog was incorrectly specified as ',supe.sup'.

When saving in the Demo Version, the suggested filename was incorrectly defaulted to '.supe.sup'.

In some cases, opening a valid .supe file would cause an error stating the file was not created on this computer.

Improved export speed of sequences that use large Visualizations

Increased the number of images allowed from 1500 to 3000.

When automatic modification of Star Scenes occurred, it was incorrectly changing the archive status of the file.

Increased the width of every 5th long tick mark on the edge of the sequence grid

In sequences with effect groups, after a 'select all' effect groups could no longer be expanded.

Increased available memory for both 32 and 64 bit systems.

The number of channel elements has increased from 8 million to 50 million.

When using Single Step, if the stop button was pressed the first selected effect was not made active.  This could lead to a warning or error.

Writing large images could cause the program to crash.

The number of fonts has been increased to 30 to allow for user created fonts to be used.

While using the Pixel Extender, if the Layer Priority feature was active pixels were extended too far.

When using the Move or Scale effects tools after selecting effects that have a group in the selection, the effects would not be applied.

When using the Move or Scale effects tools while in wrap around mode, some effects were not wrapped properly.
 

 

What's New in Version 5.1.2

 

Updates to the Sequencer

Updates to SuperStar

 

Updates to the Sequencer

Sequence grid row height:

1.Bug fix: if the user repeatedly shrunk the row height in the sequence grid, they would reach certain sizes where some prop/channel names did not get displayed. Now names are always displayed, regardless of the row height. Reported by user ndutton.

2.Enhancement: depending on the row height, the Sequencer would choose one of 3 font sizes to display prop/channel names with. Now it will choose among 4 font sizes - a new one was added when the row height is extra tall. Reported by Light-O-Rama.

In Preview Design, renamed "Channel Conflicts" tab to "Channel Conflicts (and bulk change tool)" to better reflect its functionality. Reported by Light-O-Rama.

Audio wizard changes:

1.Bug fix: when the VU Wizard was set to analyze only part of the song, it would still insert timing marks and/or channel effects for the entire song. Reported by Light-O-Rama.

2.The default timing grid shown in the Beat, VU, and Tapper wizards is now the one currently selected in the sequence grid. Reported by Light-O-Rama.

3.Improved performance when the Apply button is clicked in the Beat, VU, and Tapper wizards. Reported by Light-O-Rama.

4.Bug fix: when clicking the "Start" button on the Tapper wizard, typing the space bar did not produce taps. Reported by Drew Hickman and NJ Malenke.

Moved menu item Sequence > Audio Wizards > Add Beat Channel to Sequence > Add New > Beat Channel. On the sequence grid's right-click menu, the Audio Wizards > Add Beat Channel item was removed. Added item to the Grid View menu: Add New > Beat Channel. Reported by user Drew Hickman.

Fixed multiple issues with the Renumber Strings dialog (accessed by going to Preview Design, Channel Conflicts tab, Change Selected Props > Renumber Strings). Also added a "Reverse Order" button to this dialog. Reported by user k6ccc. http://forums.lightorama.com/topic/46721-editing-channel-assignments-information/

The "Other Warnings" tab in Preview Design will now display a warning when the channel assignments for a master prop and sub-prop are out of sync. A sub-prop has the "Uses the same channels as" field populated in the Prop Definition screen. Reported by user k6ccc. http://forums.lightorama.com/topic/46721-editing-channel-assignments-information/

Renamed the opening "Sequences" tab page to "Start Page" to better reflect its purpose. Reported by Light-O-Rama.

Enhancements to the Prop Definition window:

1.All shape parameters are now displayed in a single column list and a scroll bar will be displayed if the list does not fit in the available space.

2.There are no longer separate tabs for the "Custom" and "Advanced" shapes. The grid to edit those shapes is now accessed from a button which opens a separate window -- giving the user much more screen space to edit custom props.

3.A thumbnail view is now displayed for Custom and Advanced props in the lower portion of the Shape section.

4.The delete key can now be used to clear cells on the grid when editing a Custom or Advanced shape.

5.The last shape you used to create a new prop is now remembered and set as the default the next time you create a prop.

6.The Save and Cancel buttons were moved to the upper left corner to be consistent with the Preview Design window.

New shapes in Prop Definition:

1.Tree 360 panels. This can model large commercial trees that are assembled by tiers, and those tiers are broken into panels/branches. The shape assumes each panel has its own set of channels and that every panel is lit the same way. Requested by user Drew Hickman.

2.Tree 360 tiers. Also known as "Z trees". This shape does not support RGB pixels. Requested by user spascall.

3.Sphere and Cylinder shapes. These can be configured to display 1, 2, 3, or all 4 quadrants (vertical sections). The Tree 360 Wedges shape was also updated with a parameter to choose the number of quadrants it displays. Requested by user stevehoyt and others. http://forums.lightorama.com/topic/46771-how-to-define-prop-for-tree-shaped-like-a-globe/

If there are no existing previews, the Upgrade Sequence screen now disables the choose existing preview option. Reported by Light-O-Rama.

The sequence upgrade process now does a better job of handling inconsistent settings on RGB channels. Previously, some situations could cause the Sequencer to crash. Reported by user Val Bennett.

http://forums.lightorama.com/topic/46800-upgrading-sequence-error-from-s4-in-s5/

During the sequence upgrade process, warnings about subsequence channels now include the channel name. Reported by Light-O-Rama.

Adjusted the size and layout of the New Animation Sequence and New Musical Sequence dialogs so they display correctly when the "Visual Effects" tab of Window's Performance Options dialog is set to "Adjust for best performance". Reported by user John Hall.

Adjusted the wording of items in Preview Design's "Add New Item" dialog. Reported by Light-O-Rama.

Changes to motion effects:

1.Removed the align left, center, and right buttons for the Text effect -- as they did not have any effect on actual lights. Reported by user k6ccc. http://forums.lightorama.com/topic/46834-feature-request-horizontal-position-offset-in-motion-effects/

2.Added TextPE effect that exactly replicates the S4 Pixel Editor's text effect to improve sequence upgrades. Adjustments to text effects in upgraded sequences are no longer required. Note there are now 2 text effects in S5: "Text" and "TextPE". Reported by Light-O-Rama.

3.Renamed the "Full Length" option in the Movie effect to "Movie Length Matches Sequence Length". Reported by Light-O-Rama.

4.Bug fix: when inserting a new motion effect, the Motion Effect Generator window could be calculating the effect "None" (blank screen) even though the selection in the drop-down box showed a different effect. This only occurred when Sequencer Preferences > Motion Effects > "When opening, initialize from the current toolbar effect and color" was unchecked. Reported by Light-O-Rama.

5.Bug fix: in some cases the bulb size slider control on the Motion Effects Generator could disappear. Reported by Light-O-Rama.

6.Bug fix: the scanner effect could cause an error during effect calculations and result in the play buttons not being enabled. Reported by Chris Reynolds and Eric Brown.

7.There is no longer a delay when you first open the Motion Effects panel until thumbnail images appear. Reported by Light-O-Rama.

On the grid's toolbar, the Motion Effects and SuperStar tools are now only visible when the user has a PRO level license. Reported by Light-O-Rama.

Added a warning when trying to use the Fill tool on an empty row. Reported by Light-O-Rama.

If the current toolbar effect is set to "Motion Effect" when the Color Fade tool is selected, the toolbar effect is now automatically changed to "On". Reported by Light-O-Rama.

 

Updates to SuperStar

 

FEATURES:

 

Added "Snake Up" and "Snake Down" as movement options in the Auto Sequence dialog box

Added "skip inactive grid squares" option in Auto Sequence dialog box

Added "Average the Time Length of Effects" option in Auto Sequence dialog box

 

BUG FIXES:

 

Fixed a bug where an encrypted file from previous versions would not read in if it has groups or timings in it.

Added a check for "Full Range" color mode if launched from a SuperStarRequest. If in "Full Range" mode, SuperStar forces "Balanced" mode and adjusts all the color values to be 100 or less.

Made it so every 5th long tick mark on the edges of the sequencing grid is thicker.

Fixed a bug where if you had effect groups in a sequence and you did "select all" then you could no longer expand the effects in the effect groups

Doubled the amount of memory SuperStar can use This prevents memory errors when compiling large sequences.

Fixed a bug where writing out a large image could cause the program to crash.

Fixed it so the Auto Sequence movement options work properly with pixel speeds other than 1.00

 

What's New in Version 5.1.0

 

Initial production release of S5 ShowTime Designer Pixels.