What's New?

Top  Previous  Next

Updates Made to Older Versions

 

What's New in Version 4.x.x

What's New in Version 3.x.x

What's New in Version 2.x.x

What's New in Version 1.x.x

 

 

What's New in the Latest Version

 

What's New in Version 5.1.4

What's New in Version 5.1.2

What's New in Version 5.1.0

 

 

What's New in Version 5.1.4

 

Registry Wipe can now clean Program Files folder

Updates to the Sequencer

Updates to SuperStar

 

Registry Wipe can now clean Program Files folder

 

Some versions of the LOR S4/S5 uninstaller can leave behind unwanted programs in the user's Program Files(x86)\Light-O-Rama folder.  This can lead to installation problems the next time the user tries to install the software. Registry Wipe can now clean those entries up.

 

Updates to the Sequencer

 

Performance improvements:

1.The Sequencer starts about 20% faster. Reported by Light-O-Rama.

2.Improved the calculation time of Text and Picture effects. Reported by Light-O-Rama.

 

Countdown effect changes:

1.Added a "MM:SS" display option and allow a max of at least 1 hour. Reported by Light-O-Rama.

2.Text can now be positioned in both the X and Y directions. Forum request.

 

Changes to Preview Design:

1.you can now double-click on a prop in the design area to open its Prop Defintion. Reported by Light-O-Rama.

2.The "Tree 360 Spirals" shape could display an erroneous message regarding the number of folds when the number of revolutions was set to a large number. This message has been removed and the revolution limit restored to 25. Reported by Drew Hickman and user ukoberon. http://forums.lightorama.com/topic/46953-spiral-360-prop-tree-issue-512/

3.Created new "Cylinder Spiral" shape for spiral-wrapped tree trunks and columns. Reported by user jamills706. http://forums.lightorama.com/topic/46949-wrapped-tree-trunk-propmodel/

4.On the Prop Definition screen, if the diagram area was taller than it was wide, many of the shape diagrams would overflow. Now they are properly scaled. Reported by Light-O-Rama.

5.Bug fix: a prop made of pixels that uses the "Tree 360 Spiral" shape could crash the Sequencer. Reported by Light-O-Rama.

6.Bug fix: the Prop Definition window was expecting the "Arial Narrow" font to be installed, but that font is not on all computers. On some computers this could cause the program to show a continual stream of error messages. The program will now check if the font is installed before using it. Reported by user Norm Bowman (via help desk).

7.The "Tree 360 Up & Over" shape now supports folds in the string. When used with pixels, the layout has been redone to represent pixel strings that go up and over the top of the tree. Reported by Drew Hickman and Jesse Tryon.

8.If there are any unsaved changes in the Preview Design screen and you click the Cancel button or click the Windows "X" button to close it, then you will get a message confirming that you want to continue without saving the changes. Reported by user Gordon Varney (via help desk).

9.You can now delete props from the Channel Conflicts tab in Preview Design. Select Change Seleced Props > Delete Props. All of the actions on the Change Selected Props menu are also now available by right-clicking on the selected props in the Channel Conflict list. Reported by Light-O-Rama.

10.When copying a prop in Preview Design (Item > Copy), channels will no longer be renumbered if the "Uses the same channels as" field is set on the source prop. Reported by Light-O-Rama.

 

Changes to freeform play ranges:

1.Bug fix: when you were defining a freeform range for playback and you moved the cursor to the left - past the left edge of the grid - it cleared the selection. This made it difficult to select 0:00.00 as the starting point. Reported by Drew Hickman.

2.The following menu items have been added when you right-click on the timeline or the waveform (reported by user spascall): 

a.Set Play Range Start - if no freeform play range exists, it creates a range from the selected point to the end of the sequence; otherwise it moves the start point of the existing range. 

b.Set Play Range End - if no freeform play range exists, it creates a range from the beginning of the sequence to the selected point; otherwise it moves the end point of the existing range. 

c.Clear Freeform Play Range - clears an existing freeform play range.

 

Do not allow channels to be copied in the "Show All Items" grid view. This grid view is system generated - items can be moved, but not hidden or copied. Reported by user daughjs.

http://forums.lightorama.com/topic/47021-cant-delete-duplicate-channel-button/

 

In the sequence grid, when you right click on a channel name for a prop that has multiple strings, a new "Set Channel Name" option will appear. This capability will primarily help custom props with multiple strings which get channel names like "Horatio Hornblower: r64 c31". The channel name will be stored with the preview, so it will apply to all sequences that use that preview. Reported by Robert Brescia.

 

In the Skew All and Skew Selection commands, the maximum offset has been increased from 10 seconds to 600 seconds. Also, the user will now have the option of skewing the current timing grid or all freeform timing grids. Reported by user NJ Malenke.

 

Bug fix: changes made to the sequence while calculations are occurring (icon in the upper left is spinning), might not be reflected during preview playback. Reported by user k6ccc.

http://forums.lightorama.com/topic/46930-modifying-motion-effects-sometimes-not-taking-the-change-until-after-opening-and-saving-the-effect/

 

After clicking on a slider in the Motion Effects Generator, you can now fine-tune the value using the left or right arrow keys. If the slider is unlocked, shift-left-arrow and shift-right-arrow can be used to change the ending value. Reported by Drew Hickman.

 

When you right-click on the timeline or the waveform and select "Zoom In" from the menu, the zoomed sequence grid is now centered on where the right-click took place. Reported by Light-O-Rama.

 

In rare cases, a preview could get saved that had a prop with an invalid circuit number (like 0). In prior versions, this would result in a popup error message as the Sequencer opened; and if the preview were subsequently opened in Preview Design could result in a crash. Going forward there is no popup message when the program is opened. The preview can then be opened in Preview Design and the error will be reported on the "Channel Conflicts" tab - where it can be corrected. Reported by Light-O-Rama.

 

Bug fix: you are no longer allowed to drag beat channels into the list of preview props and vice versa. Reported by Light-O-Rama.

 

The 3 versions of the chase tool (intelligent, by prop, and by row) have been condensed into 2: regular chase and custom chase. Regular chase is the same as intelligent chase (chase by prop when the first row is a motion row, and chase by row for anything else) with the addition that the selected area for the chase is now cleared. For a custom chase, the user is prompted whether they want to chase by row or prop, and whether the selected area should be cleared. A new keyboard shortcut shift-H initiates a custom chase. Custom chase is also accessible from the right-click menu. Reported by user spascall.

 

When exporting the grid configuration and "Show All Items" is the current grid view, the user will now get a warning stating that "Show All Items" is a system-generated view and will not be included in the export file. Reported by Drew Hickman.

 

In the Paste Special window, the "All the way to the end of" drop-down box now includes the last item in the selection and the last row in the grid view. The last row in the grid view is now the default. Reported by user spascall.

 

Bug fix: motion effects on props should override effects on groups that they are a member of. However, that was not happening in all cases. Reported by user John Trp (via help desk).

 

Bug fix: the Fill tool would display the message "Trying to fill between effects, but the row is empty!" when the sequence row was not empty. Reported by user lkcubsrule.

http://forums.lightorama.com/topic/47070-s5-fill-error/

 

Bug fix: Ampersands (&) in prop names would not display correctly in the sequence grid. Reported by Light-O-Rama.

 

When playing back a sequence to real lights and when saving playback files, the Sequencer now checks if motion effects have been placed on props connected to an LOR network that is not enhanced. If so, then the action is cancelled until the condition is fixed. Reported by Light-O-Rama.

 

The music is only supposed to play one time when you click the play button in the Motion Effect Generator. However, due to a bug, if the loop button on the toolbar for the sequence was enabled, it would cause the music to repeat in the Motion Effect Generator as well. Reported by Light-O-Rama.

 

The Motion Effect Generator now has a mute button so users can turn off the music while creating their motion effect. Reported by NJ Malenke.

 

When using the Max Intensity, Min Intensity, Fade Up, or Fade Down tools, the message "'Motion effect' is selected on the toolbar, but no motion effect is currently displayed in the playback window. Would you like to create an effect using the Motion Effect Generator?" will now only get displayed when motion effect rows are part of the selection. If the effect shown on the toolbar is "motion effect" but only channel rows are selected, then the toolbar effect is changed to the ON effect. Reported by Drew Hickman.

 

The checkbox to enable or disable looping of effects in the Motion Effect Generator has been replaced by a toggle botton (press on, press off). Also, the loop icon shown there and on the sequence toolbar will now show a red slash through it when disabled. Reported by Light-O-Rama.

 

Bug fix: when attempting to open a playback file (.play.lms), the program would display an error message, then go ahead and open the file anyway. Now no attempt is made to open the playback file after the error is displayed. Reported by Light-O-Rama.

 

Fixed the File References dialog so that long sequence names, media file names, and preview background file names wrap if they extend beyond the width of the window. Reported by Light-O-Rama.

 

 

Updates to SuperStar

 

FEATURES:

 

Several new options and effects have been added to Superstar's Auto Sequence tool including effects 'Folding Ricochet', 'Snake Up/Down', along with options to 'Skip Inactive Grid Squares' as well as 'Average the Time Length of Effects'.

The Sequencer now sends the current timing grid to SuperStar when inserting a SuperStar effect. This allows SuperStar to display the same timings as the Sequencer.

 

BUG FIXES:

 

Exporting as intensity data could cause the program to crash

Text masks and image silhouette masks were not keyed on their clip rectangle. Any effects that fall entirely with in the mask's clip rectangle get applied to the mask.

In the Auto Sequence dialog box if the user did not select one of the 8 custom colors, a message is now displayed.

When saving in the Demo version, the file added to the recent files dialog was incorrectly specified as ',supe.sup'.

When saving in the Demo Version, the suggested filename was incorrectly defaulted to '.supe.sup'.

In some cases, opening a valid .supe file would cause an error stating the file was not created on this computer.

Improved export speed of sequences that use large Visualizations

Increased the number of images allowed from 1500 to 3000.

When automatic modification of Star Scenes occurred, it was incorrectly changing the archive status of the file.

Increased the width of every 5th long tick mark on the edge of the sequence grid

In sequences with effect groups, after a 'select all' effect groups could no longer be expanded.

Increased available memory for both 32 and 64 bit systems.

The number of channel elements has increased from 8 million to 50 million.

When using Single Step, if the stop button was pressed the first selected effect was not made active.  This could lead to a warning or error.

Writing large images could cause the program to crash.

The number of fonts has been increased to 30 to allow for user created fonts to be used.

While using the Pixel Extender, if the Layer Priority feature was active pixels were extended too far.

When using the Move or Scale effects tools after selecting effects that have a group in the selection, the effects would not be applied.

When using the Move or Scale effects tools while in wrap around mode, some effects were not wrapped properly.
 

 

What's New in Version 5.1.2

 

Updates to the Sequencer

Updates to SuperStar

 

Updates to the Sequencer

Sequence grid row height:

1.Bug fix: if the user repeatedly shrunk the row height in the sequence grid, they would reach certain sizes where some prop/channel names did not get displayed. Now names are always displayed, regardless of the row height. Reported by user ndutton.

2.Enhancement: depending on the row height, the Sequencer would choose one of 3 font sizes to display prop/channel names with. Now it will choose among 4 font sizes - a new one was added when the row height is extra tall. Reported by Light-O-Rama.

In Preview Design, renamed "Channel Conflicts" tab to "Channel Conflicts (and bulk change tool)" to better reflect its functionality. Reported by Light-O-Rama.

Audio wizard changes:

1.Bug fix: when the VU Wizard was set to analyze only part of the song, it would still insert timing marks and/or channel effects for the entire song. Reported by Light-O-Rama.

2.The default timing grid shown in the Beat, VU, and Tapper wizards is now the one currently selected in the sequence grid. Reported by Light-O-Rama.

3.Improved performance when the Apply button is clicked in the Beat, VU, and Tapper wizards. Reported by Light-O-Rama.

4.Bug fix: when clicking the "Start" button on the Tapper wizard, typing the space bar did not produce taps. Reported by Drew Hickman and NJ Malenke.

Moved menu item Sequence > Audio Wizards > Add Beat Channel to Sequence > Add New > Beat Channel. On the sequence grid's right-click menu, the Audio Wizards > Add Beat Channel item was removed. Added item to the Grid View menu: Add New > Beat Channel. Reported by user Drew Hickman.

Fixed multiple issues with the Renumber Strings dialog (accessed by going to Preview Design, Channel Conflicts tab, Change Selected Props > Renumber Strings). Also added a "Reverse Order" button to this dialog. Reported by user k6ccc. http://forums.lightorama.com/topic/46721-editing-channel-assignments-information/

The "Other Warnings" tab in Preview Design will now display a warning when the channel assignments for a master prop and sub-prop are out of sync. A sub-prop has the "Uses the same channels as" field populated in the Prop Definition screen. Reported by user k6ccc. http://forums.lightorama.com/topic/46721-editing-channel-assignments-information/

Renamed the opening "Sequences" tab page to "Start Page" to better reflect its purpose. Reported by Light-O-Rama.

Enhancements to the Prop Definition window:

1.All shape parameters are now displayed in a single column list and a scroll bar will be displayed if the list does not fit in the available space.

2.There are no longer separate tabs for the "Custom" and "Advanced" shapes. The grid to edit those shapes is now accessed from a button which opens a separate window -- giving the user much more screen space to edit custom props.

3.A thumbnail view is now displayed for Custom and Advanced props in the lower portion of the Shape section.

4.The delete key can now be used to clear cells on the grid when editing a Custom or Advanced shape.

5.The last shape you used to create a new prop is now remembered and set as the default the next time you create a prop.

6.The Save and Cancel buttons were moved to the upper left corner to be consistent with the Preview Design window.

New shapes in Prop Definition:

1.Tree 360 panels. This can model large commercial trees that are assembled by tiers, and those tiers are broken into panels/branches. The shape assumes each panel has its own set of channels and that every panel is lit the same way. Requested by user Drew Hickman.

2.Tree 360 tiers. Also known as "Z trees". This shape does not support RGB pixels. Requested by user spascall.

3.Sphere and Cylinder shapes. These can be configured to display 1, 2, 3, or all 4 quadrants (vertical sections). The Tree 360 Wedges shape was also updated with a parameter to choose the number of quadrants it displays. Requested by user stevehoyt and others. http://forums.lightorama.com/topic/46771-how-to-define-prop-for-tree-shaped-like-a-globe/

If there are no existing previews, the Upgrade Sequence screen now disables the choose existing preview option. Reported by Light-O-Rama.

The sequence upgrade process now does a better job of handling inconsistent settings on RGB channels. Previously, some situations could cause the Sequencer to crash. Reported by user Val Bennett.

http://forums.lightorama.com/topic/46800-upgrading-sequence-error-from-s4-in-s5/

During the sequence upgrade process, warnings about subsequence channels now include the channel name. Reported by Light-O-Rama.

Adjusted the size and layout of the New Animation Sequence and New Musical Sequence dialogs so they display correctly when the "Visual Effects" tab of Window's Performance Options dialog is set to "Adjust for best performance". Reported by user John Hall.

Adjusted the wording of items in Preview Design's "Add New Item" dialog. Reported by Light-O-Rama.

Changes to motion effects:

1.Removed the align left, center, and right buttons for the Text effect -- as they did not have any effect on actual lights. Reported by user k6ccc. http://forums.lightorama.com/topic/46834-feature-request-horizontal-position-offset-in-motion-effects/

2.Added TextPE effect that exactly replicates the S4 Pixel Editor's text effect to improve sequence upgrades. Adjustments to text effects in upgraded sequences are no longer required. Note there are now 2 text effects in S5: "Text" and "TextPE". Reported by Light-O-Rama.

3.Renamed the "Full Length" option in the Movie effect to "Movie Length Matches Sequence Length". Reported by Light-O-Rama.

4.Bug fix: when inserting a new motion effect, the Motion Effect Generator window could be calculating the effect "None" (blank screen) even though the selection in the drop-down box showed a different effect. This only occurred when Sequencer Preferences > Motion Effects > "When opening, initialize from the current toolbar effect and color" was unchecked. Reported by Light-O-Rama.

5.Bug fix: in some cases the bulb size slider control on the Motion Effects Generator could disappear. Reported by Light-O-Rama.

6.Bug fix: the scanner effect could cause an error during effect calculations and result in the play buttons not being enabled. Reported by Chris Reynolds and Eric Brown.

7.There is no longer a delay when you first open the Motion Effects panel until thumbnail images appear. Reported by Light-O-Rama.

On the grid's toolbar, the Motion Effects and SuperStar tools are now only visible when the user has a PRO level license. Reported by Light-O-Rama.

Added a warning when trying to use the Fill tool on an empty row. Reported by Light-O-Rama.

If the current toolbar effect is set to "Motion Effect" when the Color Fade tool is selected, the toolbar effect is now automatically changed to "On". Reported by Light-O-Rama.

 

Updates to SuperStar

 

FEATURES:

 

Added "Snake Up" and "Snake Down" as movement options in the Auto Sequence dialog box

Added "skip inactive grid squares" option in Auto Sequence dialog box

Added "Average the Time Length of Effects" option in Auto Sequence dialog box

 

BUG FIXES:

 

Fixed a bug where an encrypted file from previous versions would not read in if it has groups or timings in it.

Added a check for "Full Range" color mode if launched from a SuperStarRequest. If in "Full Range" mode, SuperStar forces "Balanced" mode and adjusts all the color values to be 100 or less.

Made it so every 5th long tick mark on the edges of the sequencing grid is thicker.

Fixed a bug where if you had effect groups in a sequence and you did "select all" then you could no longer expand the effects in the effect groups

Doubled the amount of memory SuperStar can use This prevents memory errors when compiling large sequences.

Fixed a bug where writing out a large image could cause the program to crash.

Fixed it so the Auto Sequence movement options work properly with pixel speeds other than 1.00

 

What's New in Version 5.1.0

 

Initial production release of S5 ShowTime Designer Pixels.