# Table of Contents

## Part I  Getting Started with Light-O-Rama

## Part II  What's New?

## Part III  Feature Comparison

## Part IV  Light-O-Rama Concepts

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Sequences</td>
<td>67</td>
</tr>
<tr>
<td>Animation Sequences</td>
<td>72</td>
</tr>
<tr>
<td>Musical Sequences</td>
<td>73</td>
</tr>
<tr>
<td>Channels</td>
<td>74</td>
</tr>
<tr>
<td>RGB Channels</td>
<td>77</td>
</tr>
<tr>
<td>Timings</td>
<td>80</td>
</tr>
<tr>
<td>Effects</td>
<td>83</td>
</tr>
<tr>
<td>Loops</td>
<td>92</td>
</tr>
<tr>
<td>Tracks</td>
<td>95</td>
</tr>
<tr>
<td>Animations</td>
<td>97</td>
</tr>
<tr>
<td>Subsequences</td>
<td>98</td>
</tr>
<tr>
<td>Windows Shell Commands</td>
<td>99</td>
</tr>
<tr>
<td>2 Shows</td>
<td>100</td>
</tr>
<tr>
<td>Interactive Groups</td>
<td>109</td>
</tr>
<tr>
<td>3 Schedules</td>
<td>114</td>
</tr>
<tr>
<td>The Weekly Schedule</td>
<td>115</td>
</tr>
<tr>
<td>The Calendar Schedule</td>
<td>116</td>
</tr>
<tr>
<td>4 Hardware</td>
<td>118</td>
</tr>
<tr>
<td>Light-O-Rama Controllers</td>
<td>119</td>
</tr>
<tr>
<td>Dasher Controllers</td>
<td>123</td>
</tr>
<tr>
<td>Digital IO Cards</td>
<td>126</td>
</tr>
<tr>
<td>BSOFT Digital IO Cards</td>
<td>127</td>
</tr>
<tr>
<td>X10 Controllers</td>
<td>128</td>
</tr>
</tbody>
</table>

## Part V  The Light-O-Rama Software Package

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Registering Light-O-Rama</td>
<td>132</td>
</tr>
<tr>
<td>Registering Offline</td>
<td>133</td>
</tr>
<tr>
<td>2 Control Panel</td>
<td>134</td>
</tr>
<tr>
<td>3 Sequence Editor</td>
<td>143</td>
</tr>
<tr>
<td>Editing Sequences Using the Keyboard</td>
<td>145</td>
</tr>
<tr>
<td>Editing Sequences Using the Mouse</td>
<td>151</td>
</tr>
<tr>
<td>Time Format</td>
<td>152</td>
</tr>
<tr>
<td>The Menu Bar</td>
<td>153</td>
</tr>
<tr>
<td>The File Menu</td>
<td>153</td>
</tr>
<tr>
<td>The New and Open Dialog</td>
<td>155</td>
</tr>
<tr>
<td>The New Animation Dialog</td>
<td>159</td>
</tr>
<tr>
<td>The New Musical Sequence Dialog</td>
<td>162</td>
</tr>
</tbody>
</table>

© 2010 Light-O-Rama, Inc.
Contents

The Edit Menu ................................................................................................................................................. 165
The New Track Dialog ................................................................................................................................. 177
Preference Dialogs ........................................................................................................................................ 179
Display Preferences ........................................................................................................................................ 180
Advanced OpenGL Settings ......................................................................................................................... 185
DMX Preferences .......................................................................................................................................... 187
Holiday Lights Designer Preferences ........................................................................................................... 187
Network Preferences ..................................................................................................................................... 188
New Animation Preferences ......................................................................................................................... 191
New Musical Sequence Preferences ............................................................................................................ 192
Play Preferences ........................................................................................................................................... 192
Video Preferences ......................................................................................................................................... 194
Zoom Preferences .......................................................................................................................................... 196
The View Menu ............................................................................................................................................. 196
The Tools Menu ............................................................................................................................................ 205
The Play Menu ............................................................................................................................................... 221
The Window Menu ....................................................................................................................................... 226
The Help Menu .............................................................................................................................................. 227
Toolbars ......................................................................................................................................................... 228
The Standard Toolbar ................................................................................................................................... 229
The Tools Toolbar ....................................................................................................................................... 233
The Track and Timings Toolbar .................................................................................................................... 237
The Tools Panel .......................................................................................................................................... 239
Saved Tools .................................................................................................................................................. 242
Recent Tools .................................................................................................................................................. 242
Clipboards ..................................................................................................................................................... 243
The Right-Click Context Menu .................................................................................................................... 248
Channel and RGB Channel Buttons ........................................................................................................... 253
Channel Settings .......................................................................................................................................... 254
RGB Channel Settings ............................................................................................................................... 255
Channel and RGB Channel Buttons' Popup Menus ....................................................................................... 256
Insert Device .................................................................................................................................................. 260
Convert to RGB Channel ............................................................................................................................. 266
Track Bars ....................................................................................................................................................... 268
Track Bars' Popup Menus .............................................................................................................................. 268
Loop Menus .................................................................................................................................................... 271
The Loop Context Menu ............................................................................................................................. 271
Loop Level Buttons ...................................................................................................................................... 274
The Waveform .............................................................................................................................................. 275
The Animator ............................................................................................................................................... 278
The Beat Wizard .......................................................................................................................................... 280
The Channel Property Grid .......................................................................................................................... 283
The MIDI Wizard ......................................................................................................................................... 286
The Effects Summary Tab ............................................................................................................................ 287
The Various Effects Tab ............................................................................................................................... 288
The Individual Notes Tab .............................................................................................................................. 291
The Tapper Wizard ...................................................................................................................................... 293
The VU Wizard ............................................................................................................................................ 296
Freeform Play Mode .................................................................................................................................... 299
4 Show Editor ............................................................................................................................................... 300
5 Schedule Editor .......................................................................................................................................... 301
6 Simple Show Builder .................................................................................................................................. 307
7 Show Player .............................................................................................................................................. 313

© 2010 Light-O-Rama, Inc.
8 Hardware Utility .......................................................... 314

Light-O-Rama Controllers .................................................. 315
  Selecting a Comm Port .................................................. 316
  Setting Unit IDs .......................................................... 317
  Configuring Units ....................................................... 319
  Testing Units .............................................................. 324
  Downloading Sequences .............................................. 327
  Firmware Updates ....................................................... 331

Light-O-Rama Wireless Devices ................................. 333

Light-O-Rama MP3 Directors ............................................ 337

Digital IO Boards .......................................................... 339

X10 Controllers ............................................................ 340

Test Console ................................................................. 341

9 ServoDog Utility .......................................................... 343

10 Verifier ................................................................. 344

List of Verifier Messages ................................................ 346

Verifier Messages 1-10 ..................................................... 347

1: No errors or warnings found .................................. 347
2: Verification cancelled .............................................. 347
3: Light-O-Rama is not installed .................................. 348
4: No registry entry for application path ..................... 348
5: Application directory does not exist ....................... 349
6: Verifier not running from LOR application path ....... 349
7: Application file does not exist ................................ 349
8: Unlicensed LOR demo version used ....................... 350
9: Unsupported version of Windows Media Player ......... 350
10: No registry entry for user data path ....................... 350

Verifier Messages 11-20 .................................................. 351

11: User data directory does not exist ......................... 351
12: No registry entry for non-media data path ............... 352
13: Non-media data directory does not exist ............... 352
14: No registry entry for media data path ................... 353
15: Media data directory does not exist ....................... 353
16: Application file has unexpected version number .... 354
17: Weekly schedule file does not exist ....................... 354
18: Yearly schedule file does not exist ....................... 355
19: Calendar scheduling not supported ....................... 355
20: No shows are scheduled ....................................... 356

Verifier Messages 21-30 .................................................. 356

21: Show file does not exist ....................................... 356
22: Error reading show file ........................................ 357
23: Sequence file does not exist ................................. 357
24: Sequence file cannot be loaded ......................... 358
25: Show has no sequences ....................................... 358
26: Media file does not exist ...................................... 358
27: Conflicting channel settings in sequence ............... 359
28: Channel is completely off .................................... 360
29: Sequence is completely off .................................. 360
30: Channel is missing settings ................................. 360

Verifier Messages 31-40 .................................................. 361

31: Channel uses undefined comm network ................ 361
32: Channel in tracks of conflicting length ................ 361
33: Musical file used in non-audio section of show ....... 362

© 2010 Light-O-Rama, Inc.
1 Getting Started with Light-O-Rama

Welcome to Light-O-Rama

Light-O-Rama is a computerized lighting system designed to control elaborate or simple lighting displays. The Light-O-Rama system can be applied to almost any lighting situation, from stand-alone controllers to synchronizing hundreds of controllers.

This page gives a high-level overview of how to start controlling your lights using Light-O-Rama:

- Getting Help about Light-O-Rama
- Important Terms and Information
- Connecting the Lights Using Light-O-Rama Controllers
- Creating a Show

For more detailed information, please see Light-O-Rama Concepts and the Light-O-Rama Software Package.

Experienced users may wish to see what's new in the latest version of Light-O-Rama.

Getting Help about Light-O-Rama

Other than this help file, there are several ways to get help about Light-O-Rama:

- Frequently Asked Questions, quick start guides, training presentations, tutorials, demos, and user guides can be found on the Support page of the Light-O-Rama website, along with phone, mail, and email contact information.
- Light-O-Rama users’ forums can be found at the LOR Users Support Center.
- The LOR Wiki is a user-created and edited repository of Light-O-Rama information. Please note that the information contained in the LOR Wiki is not published by Light-O-Rama, and cannot be considered official.

Important Terms and Information

**Companion Unit**

A companion unit is a Light-O-Rama controller that receives lighting commands from another source - either a PC running Light-O-Rama software, or from another controller known as a director unit.

**Control Panel**

The Light-O-Rama Control Panel is a program that can be used to manage the Light-O-Rama system on your PC. The Control Panel runs in the system tray (where the PC's clock is displayed). Light-O-Rama is made up of a number of different programs, and the Control Panel is a convenient way of accessing them. The Control Panel must be running in order to control shows from your PC.

**Daisy Chain**
This is the term generally used to describe the manner in which Light-O-Rama light controllers are connected. A **wire** goes from the source (a PC running Light-O-Rama software or a **director unit**) to a **companion unit**. Another wire goes from that companion unit to another companion unit, and so on, until all companion units are “chained” together.

Do not put "Y"s or forks in the data cable. Only connect the units in this daisy chain configuration.

**Data Cable**

Light-O-Rama controllers can be **connected** using both data cables and **phone cables**, but you **must** know which type of cable it is (for the purposes of Light-O-Rama, a cable is considered a **data cable** if its wires are connected straight through).

How do you know if it is a data cable? Well, most likely the only cable that you will see that is **not** a data cable is a wire that is intended specifically for phones. If you go to your local hardware store and purchase a phone extension cable, then that wire is **not** a data cable. The distinction between data cables and phone cables is important, because the wires are swapped around. There are selectors or jumpers on most Light-O-Rama controllers that allow you to specify which wire type you are using.

Only the wire coming into a controller (from the previous controller or from a PC running Light-O-Rama software) should be used to determine which selector setting to use. The wire leaving a controller (if there is one) can be of any type, and has no bearing on which selector setting should be used. For example, if a controller has a phone cable coming in from the previous controller, and a data cable leaving to the next controller, the selector should be set for "phone cable".

**Director Unit**

A **director unit** is a Light-O-Rama controller that sends lighting commands to other controllers (known as **companion units**). Controllers can run individually in **standalone mode**, but to synchronize multiple controllers together, they must be directed either by a PC running Light-O-Rama software, or by a director unit.

Standalone **sequences** may contain lighting commands for a number of different units. A director unit is a unit that is running standalone - i.e. not connected to a PC - that contains lighting commands for other units cabled to it (the companion units). The director unit can also control its own lights, simultaneously.

There is no difference in the hardware of a director unit and a companion unit - the only difference is the mode that they are in.

A PC running Light-O-Rama software can also be thought of as a director unit, in that it can send lighting commands to Light-O-Rama controllers. There must be one **and only one** director unit (or PC running Light-O-Rama software) on a **daisy chained** group of controllers.

**Hardware Utility**

The **Light-O-Rama Hardware Utility** is a program that can be used to set up and test the hardware used to control lights, as well as download **sequences** to **standalone controllers** or **director units**.

**Phone Cable**
Light-O-Rama controllers can be connected using either data cables or phone cables, but you must know which type of cable you are using. See data cables for details.

**Schedule**

A schedule is a list of shows and the times at which those shows are to be played.

If the Light-O-Rama Control Panel is running on a PC, and its "Enable Schedule" option is turned on, then the schedule will be monitored, and its shows will be started and stopped at the appropriate times.

The Schedule Editor program is used to create and modify schedules.

**Sequence**

A sequence is a file that contains a set of lighting commands to be sent to Light-O-Rama controllers. There are two types of sequences: musical sequences, which have an associated music or video file that is to be played at the same time, and animation sequences, which do not.

Sequences can be grouped together into shows.

The Sequence Editor program is used to create and modify sequences.

**Show**

A show is a file that contains a number of sequences, and the order in which they should be played.

A schedule can be created to specify the times at which various shows should be played.

The Show Editor program is used to create and modify shows.

**Standalone**

A Light-O-Rama controller can be controlled by another controller (or a PC running Light-O-Rama software), or it can control itself and/or other controllers, in standalone mode. A sequence, created using the Sequence Editor, can be downloaded to a standalone controller using the Hardware Utility. The controller can then be set up to run this sequence whenever it has power, or, if the unit is a model with an internal clock, it can be instructed to run the sequence during a particular time.

A standalone controller whose sequence contains lighting commands for other controllers will transmit those commands to the other controllers. In this case, the controller is known as a director unit.

**Unit**

A unit is another term for a Light-O-Rama controller. Each unit has a number of circuits, each of which can be used to control lights independently of each other. Each unit is identified by a unit ID.

**Unit ID**
Each unit has an identifier assigned to it, known as a unit ID. When a lighting command is sent to a unit, all of the units that are daisy chained together can see that command. However, the command contains a unit ID; only the units having that unit ID will act upon that command.

For Light-O-Rama controllers, the unit ID is a two characters, each of which can have any of the values 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, and F. For example, "01", "25", "37", "5C", "BD", or "E2". However, not all possible combinations are allowed: "00" and "F1" through "FF" are disallowed.

Controllers other than Light-O-Rama controllers use different formats for their unit IDs.

Connecting the Lights Using Light-O-Rama Controllers

To connect lights using Light-O-Rama controllers, take the following three steps:

1. Determine the serial port and hook up a controller.
2. Select a unit ID.
3. Test the lights.

**Step 1. Determine the Serial Port and Hook Up a Controller**

Insert an SC485 converter into your PC's DB9 serial connector which you plan on using for the Light-O-Rama network. If you are using a USB/RS-232 converter, then make sure that it is properly installed, and that the SC485 converter is connected. If you're not sure what all this is about, simply try to find a connector on the back of your PC that has nine pins and which will accept the SC485 adaptor.

Using a cable, connect a Light-O-Rama controller to the SC485 adaptor. Make sure that the LOR controller is powered on. The LED in the controller should be blinking.

Using the Light-O-Rama Control Panel, start the Hardware Utility program. In the Hardware Utility’s Setup Comm Port section, use the Auto Configure button. This will cause the Hardware Utility to look for the attached controller and determine which comm port is being used.

**Step 2. Select a Unit ID**

If your controller has unit ID selection switches, you can select its ID by adjusting the selectors to the desired ID. If your controller does not have these unit ID selection switches, then you will need to set its unit ID by using the Hardware Utility:

To set the unit ID using the Hardware Utility, connect one and only one unit to the PC using the SC485 adaptor and a cable. In the Set Unit IDs section, go to Set New Unit ID, select the ID that you wish to use for the controller, and click the Set Unit ID button. This button will only work on new units that have never been assigned a unit ID (to change the unit ID of a unit that already has one assigned, use the Change Existing ID section instead).

**TIP:** Assign unit IDs sequentially, starting at 01. This will make maintenance of the units faster.

**Step 3. Test the Lights**

With the unit connected to the PC, attach lights and power the unit on. In the Hardware Utility, click the Refresh button in the top center of the screen. After a short time, your unit should appear in the
dropdown list to the right of the Refresh button. Select the unit, and you can then test the lights using the various controls in the Test Unit’s Operation section of the Hardware Utility.

**TIP:** Before clicking Refresh, set the Hardware Utility’s Max Unit ID to as low a value as possible. This is the maximum unit ID of controllers that you plan on using (you can always change it to a higher value if you add more controllers later). Setting it to a low value makes the Hardware Utility run faster (though it will not find any connected units with higher unit IDs).

Creating a Scheduled Lights Display

To create a lights display and have it run at certain times, take the following steps:

1. **Make your sequences.**
2. **Make a show.**
3. **Make a schedule.**
4. **Turn on the Control Panel’s “Enable Schedule”**.

**Step 1. Make Your Sequences**

Using the Sequence Editor, create the sequences that will be used in your show.

You can test how the lights will look for a sequence while in the Sequence Editor: Make sure Control Lights is turned on in the Play Menu, and that you have assigned the channels in the sequence to a controller that is hooked up to your PC. Then, click the play button (which is the green arrow in the toolbar).

**Step 2. Make a Show**

A show is a collection of sequences. A show can be created using the Show Editor program.

Shows have several sections, each of which can have sequences:

- **Background:** Sequences listed in the “background” section will be played for the entire duration of the show.
- **Startup:** Sequences listed in the “startup” section will be played when the show first begins.
- **Animation** and **Musical:** After the “startup” sequences have completed, sequences in both of these sections will run, until it is time for the show to stop.
- **Shutdown:** When it is time for the show to stop, the “animation” and “musical” sequences will stop running, and the sequences in the “shutdown” section will start. Only after the “shutdown” sequences are finished will the show truly end.

In the Show Editor, you can add sequences to any of these sections by selecting the appropriate section’s tab, and hitting the big PLUS button.

After you have created your show, you should save it using the “Save” or “Save As” button. Assign the show a meaningful name - this is the file name that you will be using in the next step.

**Step 3. Make a Schedule**

Unlike sequences, you cannot run a show interactively. Instead, to test a show, put that show into a schedule, using the Schedule Editor program:
In the Schedule Editor, click the **Add** button, and select the show file with the name that you created in the previous step. Select a start and end time that will allow the show to start at a convenient time for you to view it. Then click **Save** to save your schedule.

**Step 4. Turn On the Control Panel's "Enable Schedule"**

To view the scheduled show, turn on the **"Enable Schedule"** option in the Light-O-Rama **Control Panel**. Doing this will cause the Control Panel to monitor your schedule, and start and stop your show at the appropriate times.

2 What's New?

What's New in Light-O-Rama

- [What's New in Version 2.8.12](#)
- [What's New in Version 2.8.10](#)
- [What's New in Version 2.8.8](#)
- [What's New in Version 2.8.6](#)
- [What's New in Version 2.7.6](#)
- [What's New in Version 2.7.4](#)
- [What's New in Version 2.6.2](#)
- [What's New in Version 2.6.0](#)
- [What's New in Version 2.5.6](#)
- [What's New in Version 2.5.4](#)
- [What's New in Version 2.5.2](#)
- [What's New in Version 2.4.10](#)
- [What's New in Version 2.4.8](#)
- [What's New in Version 2.3.8](#)
- [What's New in Version 2.3.6](#)
- [What's New in Version 2.3.4](#)
- [What's New in Version 2.1.6](#)
- [What's New in Version 2.1.4](#)
- [What's New in Version 2.1.2](#)
- [What's New in Version 2.0.16](#)
- [What's New in Version 2.0.14](#)
- [What's New in Version 2.0.12](#)
- [What's New in Version 2.0.8](#)
- [What's New in Version 2.0.4](#)
- [What's New in Version 2.0.0](#)
- [What's New in Version 1.5.0](#)
- [What's New in Version 1.4.0](#)


- Sequence Editor Can Keep Lights On at End of Play, and Turn Them Off Manually
- Bug Fixes

**Sequence Editor Can Keep Lights On at End Of Play, and Turn Them Off Manually**
In previous versions of Light-O-Rama, the Sequence Editor would automatically turn off all lights in a sequence when that sequence finished playing. It can now optionally keep them turned on, via the new "Lights Off at End" menu item in the Play menu. The lights can subsequently be turned off manually via "Lights Off Now".

**Bug Fixes**

- If, while importing a channel configuration file, you double-clicked the channel configuration's filename in the file browsing dialog, and if your mouse was over a sequence grid at the time, then after the file was imported, depending upon where your mouse was, this could have caused the grid to behave as if you clicked your mouse on it. For example, if you were over a channel button, the Channel Settings dialog for that channel could have opened.
- If DMX effects were used in a sequence, and the Sequence Editor's Vary Color of Channel Buttons setting was turned on, then during play, for certain DMX effects, the sequence grid could temporarily go blank as displayed in the Sequence Editor (though the behaviour of your actual lights would not be adversely affected).
- In certain situations, such as after an undo, the selected channel from the channel dropdown list in the Animator would spontaneously change to being the first channel in the list.
- If you manually edited certain registry settings related to disk file paths (note: doing this is not recommended) which Light-O-Rama normally sets itself, leaving off a backslash at their ends would lead to unexpected results.
- If an RGB channel (as opposed to one of its constituent channels) was used to draw in the Animator, and that RGB channel was deleted from the sequence, the cells of the Animator using that RGB channel would not be blanked out.
- If a constituent channel of an RGB channel (as opposed to the RGB channel itself) was used to draw in the Animator, then in certain situations, the cells of the Animator using that constituent channel could have been blanked out inadvertently.
- In certain situations, very small fades (for example 0% to 1%) over relatively long spans of time would cause other effects to spontaneously appear on the channel.
- The Color Fade tool would give an option to insert DMX effects even if DMX editing was disabled.
- If a the Color Fade tool was used to make DMX effects, and those DMX effects were themselves fades, they would not be sent to the controllers. They now are sent, but (as of the time of this writing) LOR hardware does not support fading DMX effects, and so they are converted to regular fades.

What's New in Version 2.8.10

- The Advanced OpenGL Settings Dialog
- Bug Fixes

**The Advanced OpenGL Settings Dialog**

The new Advanced OpenGL Settings dialog can be used, experimentally, to try to investigate or work around strange graphics issues. However, this is not recommended; such problems can typically be better resolved in other ways, such as updating your computer's graphics card's drivers.

**Bug Fixes**

- The Set Paste Mode submenu in the Sequence Editor's Edit menu did not have a shortcut key associated with its Paste from Foreground option.
- On some computers, selecting a sequence from the Sequence Editor's Windows menu would cause a portion of the display to remain showing the previous sequence, until something like a
What's New? 13

refresh was done.

- When the Chase tool was used with Paste from Foreground turned off, and the chase was done either from the bottom left to the top right or vice versa, in some cases it would not properly overwrite existing effects outside of the actual things being chased with off effects.
- The "+" key is supposed to invoke the Repeat tool, but only the "+" key on the standard part of the keyboard was doing so, while the "+" key on the numeric keypad did nothing.
- When more than one sequence was open in the Sequence Editor, and they were maximized, clicking on the "X" to the right of the menu bar would close the active sequence (as it should), but that sequence's tab would remain open in the row of sequence tabs. Subsequently clicking on that tab, for the closed sequence, would cause the Sequence Editor to crash.
- Stopping play of a sequence in the Sequence Editor would sometimes cause the column of cells that happened to be at the time of the start of play to become selected.

What's New in Version 2.8.8

- Bug Fixes

Bug Fixes

- Various things in the Animator, such as drawing and erasing, were much slower than normal.
- When a sequence was loaded, the Animator would not remember whether its controls were hidden for that sequence or not.
- Attempting to write a musical sequence to an SD card (for a standalone controller) would result in a "subscript out of range" error message.

What's New in Version 2.8.6

- RGB Channels
- Color Fade Tool
- Repeat Tool
- Intelligent Fade Tool
- Fill Tool
- Chase Tool
- Paste from Foreground
- Insert Device
- Tools Panel
- Recent Tools
- Saved Tools
- Clipboards
- Sequences Created with Equally Spaced Timings in Freeform Grids
- Select Multiple Files in the Hardware Utility's MP3 Tab
- Tabbed Sequences Display
- Tools Menu Hotkeys Changed
- Keyboard Editing Keys Changed
- Off Effect via Delete Key
- Keyboard's Background/Foreground Selectors' Behavior Changed
- Shimmer and Twinkle Display Update
- Text of Channel Buttons Changes Color During Play
- Offline Registration Utility
- Bug Fixes

RGB Channels
An **RGB channel** represents a light or string of lights that can change colors - for example, a pixel on a Cosmic Color Ribbon. It consists of three "normal" **channels**, representing the three component colors - red, green and blue. Previously, to sequence such a device, you would have to sequence those three channels for the three component colors individually - that is, you would set up the **sequence** to have those three channels, and you would (for example) set the red channel to fade up, the green channel to hold steady, and the blue channel to fade down.

Now, you still can sequence the three component channels individually, but instead you could simply add an "RGB channel" to the sequence, and use it to deal more directly with the resulting colors. For example, instead of telling the red channel to fade up, the green channel to hold steady, and the blue channel to fade down, you would simply tell the RGB channel to fade from cyan to yellow.

**Color Fade Tool**

The **Color Fade** tool is a new tool that can be used to tell **RGB channels** how to behave. For example, to specify that the RGB channel should fade from cyan to yellow over a certain time range in a sequence, you would select the Color Fade tool, with its colors set to cyan and yellow, and apply the tool to that time range of the sequence.

The Color Fade tool can also be used to do **fills**, by clicking the selected area instead of clicking and dragging.

**Repeat Tool**

The **Repeat** tool takes whatever is contained in the selected area of the **sequence** and makes a new copy of it immediately following the selected area. Using the tool again (without changing what area of the sequence has been selected) will make another new copy immediately following the first, and using it again will make a third new copy immediately following the second. This can be repeated as many times as you like, making as many back-to-back copies of the selected area as you want.

**Intelligent Fade Tool**

The **Intelligent Fade** tool is similar to the **Fade Up** and **Fade Down** tools. However, using it makes **either** a fade up or a fade down, depending upon whether you click and drag left to right or right to left.

It can also be used to do **fills**, by clicking the selected area instead of clicking and dragging.

**Fill Tool**

If you apply the **Fill tool** to an area that has no **effects** (i.e. the lights are off in that **channel** at that time), it will automatically make a **fade** from the intensity that precedes the empty area to the intensity that follows the empty area. For example, if there is a fade up from 0 to 75, followed by the lights being off, followed by a fade down from 50 to 25, and you apply the **Fill tool** to the area where the lights are off, it will change that area so that it becomes a fade down from 75 to 50.

The **Fill tool** can also be used in a similar way on **RGB channels**, where it will change an empty area so that it fades from the color preceding the empty area to the color following the empty area.

The Fill tool behaves a little differently than most other tools. With most tools, if you click and drag
an area, that area will be selected, and when you let up on the mouse button, that tool will be
applied to the selected area. The Fill tool, however, does not select an area, and it is applied as
soon as you click, and as soon as you drag to a new area, too. This, combined with the fact that
the Fill tool does nothing if it's used on an area that already has an effect, hopefully makes it quick
and easy to fill a large and complicated area of the sequence just by clicking once and dragging
around to the appropriate spots without letting go of the mouse button.

**Chase Tool**

The Chase tool takes a pattern and "chases" it through the selected area. That is, when you click
on a spot in the sequence, and then drag through other channels and through time, then when you
let go of the mouse button, it will take the pattern in the selected area's corner where you initially
clicked and copy it through the remaining channels in the selection, offsetting it a little bit in time
with each subsequent channel.

**Paste from Foreground**

"Paste from Foreground" is a new pasting option. When it is turned on, any portions of the
clipboard's copy buffer that have "off" effects won't actually be pasted when you select "Paste". That
is, copied "off" effects won't overwrite what you already have in your sequence.

**Insert Device**

The channel button popup menu now gives a new way to add channels to a sequence: "Add Device".
When this is selected, a dialog will open asking the type of device to add (such as an LOR/CTB 16
or a Cosmic Color Ribbon) and some settings for that device (such as its unit ID). The appropriate
number of channels will then be added to the sequence, and they will automatically be populated
with the appropriate unit IDs, circuit IDs, and so forth.

**Tools Panel**

The left-hand side of the Sequence Editor now has a new Tools Panel, with a few subpanels ("Saved
Tools", "Recent Tools" and "Clipboards"). The panel can be pinned to the display so that it is
always open, or it can be hidden so that it appears only as a small tab on the left of the Sequence
Editor, with the full panel sliding out when the mouse goes over that tab. The individual subpanels
can also be collapsed or expanded.

**Recent Tools**

The Recent Tools subpanel of the Tools Panel on the left-hand side of the Sequence Editor shows
buttons representing the tools that were used recently (such as "Fade Up 25-75", "Shimmer Down
100-0", or a color fade). Clicking on one of the buttons will make that tool the currently active tool.

Not all tools are put on the Recent Tools subpanel's list; only those that would take more than one
mouse click to activate are put there. For example, "Toggle" and "Shimmer" do not get put on the
list, since you could activate those in a single mouseclick (from the Tools toolbar).

Right-clicking on a tool's button enables you to put the tool on the Saved Tools list.

**Saved Tools**

The Saved Tools subpanel of the Tools Panel on the left-hand side of the Sequence Editor is similar
to the Recent Tools subpanel, except that it shows only those tools that you have decided to save. Once you put a tool on the Saved Tools list, it will remain there (until you explicitly remove it), even after the Sequence Editor has been stopped and restarted.

**Clipboards**

In previous versions of the Sequence Editor, there was only a single clipboard for copying and pasting. Now, the Sequence Editor starts with a single clipboard, but you can easily add more of them, and quickly switch between which one is in use at the moment, using the new Clipboards subpanel of the Tools Panel on the left-hand side of the Sequence Editor. That is, you now can have several different things copied at the same time, all of which can be pasted into your sequence.

The Clipboards subpanel also allows you to save a clipboard, so that its contents will be available to be pasted even after you stop and restart the Sequence Editor, and to lock a clipboard, so that it cannot be copied to (but still can be pasted from), to prevent accidental overwriting of a clipboard that you want to keep.

It also allows quick access to pasting options such as Paste by Cell, Paste by Time, and Paste from Foreground.

**Sequences Created with Equally Spaced Timings in Freeform Grids**

Previously, if you chose to create a sequence with equally spaced timings (such as “a timing every tenth of a second”), the sequence's first timing grid would be a fixed timing grid. You can now optionally make it either a fixed timing grid or a freeform timing grid.

**Select Multiple Files in the Hardware Utility’s MP3 Tab**

You can now select multiple files simultaneously in the Hardware Utility's MP3 tab (by using standard Windows methods, such as Shift-click).

**Tabbed Sequences Display**

When more than one sequence is open, the Sequence Editor now shows a single one of them, maximized, with tabs across the top having the names of the open sequences. Selecting any particular tab will cause the Sequence Editor to switch to display that sequence.

If you want to see multiple sequences at once, you can unmaximize the currently displayed sequence.

**Tools Menu Hotkeys Changed**

Several hotkeys for various menu items on the Tools menu have been changed, to try to minimize overlap and to give unique hotkeys to as many “high profile” tools as possible.

**Keyboard Editing Keys Changed**

The keys assigned to several keyboard editing shortcuts have been changed, to make room for new functions (such as the Chase tool and Fill tool).

**Off Effect via Delete Key**
One changed keyboard editing shortcut which it is worth explicitly pointing out (because it has been requested by several people) is that the Delete key will now apply the "Off" tool to the selected area.

**Keyboard's Background/Foreground Selectors' Behavior Changed**

Previously, background and foreground effects mode could be enabled by certain keystrokes. To turn them off, there was a different keystroke for enabling "regular" effects. Now, instead of keystrokes to enable those modes, there are keystrokes to toggle them between being enabled and disabled.

**Shimmer and Twinkle Display Update**

In the sequence grid, shimmer and twinkle effects are now displayed as a little heavier than they used to be, to hopefully make them more easily recognized.

Note that this change is only from the point of view of how they look displayed on your screen in the Sequence Editor; their behavior on your actual lights is unchanged from what it was before.

**Text of Channel Buttons Changes Color During Play**

During play, the Sequence Editor can be set up to change the colors of channel buttons to represent the current intensity of the associated channel. The text of the channel name on that channel button, however, was always black. Depending upon the color of the channel and its current intensity, this could sometimes make the button difficult or even impossible to read. Now, the color of the text of a button will be either black or white, depending upon which would be easier to read at that moment for that channel.

**Offline Registration Utility**

Previously, if a user had a computer that was not connected to the internet, they could only register that computer by calling in to Light-O-Rama Customer Support. LOR Customer Support had a program called the "Offline Registration Utility" which they then used to get the user's computer activated.

This program is now distributed by the LOR installer, along with all the other programs (such as the Sequence Editor). So, if a customer has two machines, one of which is connected to the internet but the other of which is not, they can register their offline computer by using the Offline Registration Utility on the online computer, without calling in to LOR Customer Support.

Offline registration via LOR Customer Support is still available, in case (for example) the customer has only one computer, and it is not connected to the internet.

**Bug Fixes**

- In the Sequence Editor, when "Paste by Cell" was set, and a copy and paste was done including an event that was not completely coincident with a cell, in some situations the events pasted wouldn't appropriately match the events copied completely.
- In the Sequence Editor, dragging a channel button in order to move that channel would not work properly if the visible channel range was scrolled up or down while dragging.
- Various issues were fixed when converting a sequence from being a musical sequence to an animation sequence, and vice versa.
- When the DMX Tool, Fade Tool or Intensity Tool windows were closed by clicking on their "X"
buttons, the next time that they were displayed, they would be displayed in an entirely new location instead of in the spot where they had been when they were closed.

- The "Paste" button on the Sequence Editor's toolbar would not be enabled until after a copy (as opposed to a cut) had been done. That is, if you started up the Sequence Editor and immediately did a cut, the Paste button would still be greyed out even though you had cut something.
- If you double-clicked somewhere on the New and Open dialog, for example to open a sequence by double-clicking its filename, then depending upon where your mouse was, when the dialog closed and the sequence opened, it could have caused something to happen such as a channel's settings dialog being opened, or the current tool being applied to a cell in the sequence.

What's New in Version 2.7.6

This version fixes the following bugs:

- The Schedule Editor only displayed a thin portion of its vertical scroll bar.
- In certain situations, the Sequence Editor could possibly crash after having undone the adding of timings.

What's New in Version 2.7.4

- Show on demand
- Show Player can preload sequences
- Shows can be shut down gracefully
- LOR Control Panel improvements
- Shuffle mode options
- Maximum Light-O-Rama circuit number is now 512
- New iDMX1000 firmware: version 1.41
- New DIO32 firmware: version 1.30
- New DC-MP3 firmware: version 4.10
- Bug fixes

Show On Demand

You can now cause a show to be played without having scheduled it. This is done via the "Show On Demand" menu item of the Light-O-Rama Control Panel's popup menu.

Please note that this feature is available only for license levels Basic Plus and higher.

Show Player Can Preload Sequences

In previous versions of Light-O-Rama, when the Show Player played a show, a sequence in that show would not be loaded until the first time it was used in the show. Depending upon the size of the sequence and the power of the computer, it could take a human-noticeable amount of time to load a sequence, so this could lead to undesired delays between sequences (the first time they are played during a given run of a show).

This is still the default behavior, but you can now optionally set the show to preload sequences, so that they will all be loaded as the first step in the show, before any of them are played.

Shows Can Be Shut Down Gracefully

In previous versions of Light-O-Rama, selecting "Disable Shows" from the Light-O-Rama Control
Panel's menu would cause the currently running show to stop immediately, abruptly stopping any sequences that happened to be playing. This can still be done (by selecting "Disable Shows Immediately"), but you can now shut down a show gracefully instead (by selecting "Disable Shows Gracefully").

This will cause the show that happens to be playing (if any) to be put into shutdown mode; any song that happens to be playing will be allowed to finish, after which the show's Shutdown section will run. When the Shutdown section finishes, the show will stop, and shows will be disabled.

**LOR Control Panel Improvements**

Several improvements were made to the Light-O-Rama Control Panel:

- The "Current" and "Scheduled" sections of its status window were often mostly redundant (if the currently playing show was the show that was scheduled to be playing at the current time). The "Scheduled" section has now been replaced by a "Next" section, which shows what will happen after the current show.
- Those sections would update only after a noticeable delay of several seconds. They now update in a much more real-time fashion.
- Similarly, the first log messages that were displayed would be delayed; they are now real-time.
- The Control Panel's light bulb icon in the system tray now is different colors depending upon the state of the system: If scheduled shows are enabled, it is blue; if they are disabled, but shows on demand are enabled, it is orange; if shows are disabled entirely, it is red.
- Several new log messages were added, hopefully giving a more informative view into what the Show Player is doing.

**Shuffle Mode Options**

In previous versions of Light-O-Rama, when the Musical Section of a show was set to shuffle the sequences instead of playing them in order, any sequence could be randomly chosen to play at any time. This meant that, for example, the same sequence could play twice (or more) in a row, or some particular sequence could be played a second time before some other particular sequence was played even once.

The Show Editor now allows you to control the way that sequences are shuffled: You can choose whether or not a single sequence is allowed to be played twice in a row, and you can choose whether or not all sequences must be played once before some sequence is played a second time.

Existing show files will continue to behave in the same manner as they did before (unless and until you change their settings): a sequence can be repeated back-to-back, and can be played a second time before all other sequences have been played once.

The default for new shows is exactly the opposite: no sequence will be played twice in a row, and no sequence will be played a second time before all sequences have been played once.

**Maximum Light-O-Rama Circuit Number Is Now 512**

In previous versions of Light-O-Rama, the maximum allowable circuit number for a Light-O-Rama controller was 256. It is now 512. At the present time, this is primarily useful for controlling DMX devices.

**New iDMX1000 Firmware: Version 1.41**
A new version of the firmware for the iDMX1000 has been released (version 1.41). It contains the following enhancements:

- It now has native address support (i.e. there is no longer a need for multiple unit IDs for a single iDMX1000). The old method of having a single iDMX1000 use multiple unit IDs is still supported, as "legacy mode". An iDMX1000 will be in native mode or legacy mode depending upon the unit ID it is set to: If its unit ID ends in a "0" (such as "10", "20", or "30"), it will be in legacy mode, where it actually uses sixteen unit IDs of sixteen channels each (e.g. setting the unit ID to 10 will cause it to use unit IDs 10 through 19 and 1A through 1F). If its unit ID ends in anything other than a zero, it will use only that single unit ID, but it will support all its channels on that single unit ID.
- Previously, only DMX addresses up to 256 were supported. Now, addresses up to 512 are supported (but only in native mode).
- Previously, only 64 "intelligent channels" were supported at a time - i.e. only 64 channels could simultaneously be doing shimmers, twinkles, and/or fades. Now, 128 intelligent channels are supported at a time.

**New DIO32 Firmware: Version 1.30**

A new version of the firmware for the DIO32 motherboard has been released (version 1.30). This version adds native address support - that is, there is no longer a need to use multiple unit IDs for a single DIO32; it can now support all channels on a single unit ID.

Please note that in order to take advantage of this new functionality, you will not only have to use the new firmware, but you will also have to change a jumper on the board which tells it whether to operate in native mode or legacy mode. Please refer to your DIO32 documentation for details.

**New DC-MP3 Firmware: Version 4.10**

A new version of the firmware for the DC-MP3 has been released (version 4.10). It contains the following enhancements and fixes:

- Previously, an individual sequence could only last for up to ten minutes. It can now last up to 44 hours.
- Previously, only certain manufacturer's SD cards were supported. A much larger variety is now supported (list to be compiled - although it will more likely be a list of unsupported cards rather than a list of supported cards).
- Support for SD cards with the FAT32 file system was added.
- Support for SDHC (high capacity) SD cards was added.
- Previously, shows could be set to play every hour or every half hour; they now can also be set to play every 15 minutes or every 10 minutes.
- Digital output (DO) pins 1 through 6 now operate. They react to commands for unit ID F0, channels 1 through 6. They only react on the DC-MP3 that is controlling the show; for example, they will not react on a DC-MP3 controlled via the PC network.
- Under some circumstances, shows would start at midnight, without having been scheduled to do so. This has been fixed.

**Bug Fixes**

- Protection against several possible crashes was added to the Light-O-Rama Control Panel. Although it is not known if any of these actually caused any crashes, it is known that some
customers have had the Light-O-Rama Control Panel crash.

- When disabling shows, or when unloading Light-O-Rama, the LOR Control Panel would hang frozen for a noticeable amount of time before becoming responsive again (in the case of disabling shows) or closing (in the case of unloading).
- The Light-O-Rama Control Panel's status window would sometimes incorrectly state that the next show would start at 12:00 AM on Sunday.
- Sometimes, lighting commands were quickly repeated back-to-back. This would not cause any noticeable problems with how the sequence looked, but it did cause a minor increase in network traffic, or standalone/SD sequence file size.

What's New in Version 2.6.2

- Light-O-Rama Diagnostic distributed by installer
- Bug fixes

Light-O-Rama Diagnostic Distributed by Installer

The Light-O-Rama Diagnostic is a troubleshooting tool that displays various information about your Light-O-Rama configuration. It used to be available only as a separate download from lightorama.com, but now is installed as a standard part of the Light-O-Rama Software Package.

Bug Fixes

- On Windows 98 SE machines, running a show of sufficient length would eventually cause an error message to pop up, saying that an error occurred in "Formhook_aftermessage". Clicking "OK" would close the error message, but it would soon pop up again, and again and again. If it was left without clicking "OK" to close it, eventually the show would stop abnormally.
- In the Sequence Editor, "Sequence Info", from the "View" menu, would sometimes display the incorrect directory of the media file associated with a musical sequence.
- If a channel was set up to be a subsequence, and the sequence file assigned to it did not exist or otherwise could not be loaded, then loading of the main sequence would fail when the loading of the subsequence failed. The result of this was that the main sequence could not be opened, and so the problem could not be fixed by modifying the subsequence filename associated with the channel. Now, the main sequence will successfully load, and the missing subsequence will simply not do anything during play. Note that the Light-O-Rama Verifier will still show this error.
- If you set the name of a channel to include an ampersand, then in the Sequence Editor, the name would be displayed on the channel's button improperly. The ampersand would be missing, and the character after it would be underlined (indicating that it could be used as a hotkey for that button).
- If the Sequence Editor was used on a computer with multiple monitors, and the cursor was hovered over a spot on a sequence grid that was on a monitor to the right of the primary monitor, the tool tip would pop up in the wrong place (on the far right side of the primary monitor).
- Hitting the escape key closes most dialogs, but it did not close the Beat Wizard, VU Wizard, or Tapper Wizard.

What's New in Version 2.6.0

- Undo/redo recording can be disabled
- All license levels now use unencrypted save files
- Hardware Utility shows version of connected MP3 Director's firmware
- New DC-MP3 firmware: Version 3.3
- New Servo Dog firmware: Version 1.02

© 2010 Light-O-Rama, Inc.
• **Bug fixes**

**Undo/Redo Recording Can Be Disabled**

Certain very large operations in the Sequence Editor could take a very long time to do. For example, skewing a track involves changing all of the timings, effects, and loops in the track; in a large sequence with many channels, this could take a prohibitively long time. Much of the time spent is actually due to recording the changes so as to later be able to undo and redo them.

For situations like this, undo and redo recording can now be disabled, via the Edit menu. You will not be able to undo any changes that were made while undo recording was disabled, but the changes that you make will be made more quickly.

**All License Levels Now Use Unencrypted Save Files**

In previous versions of Light-O-Rama, when a sequence was saved using either a Basic license or else the unlicensed Demo version of the software, the sequence file would be encrypted instead of being saved in plain XML. Now, this encryption is done only for the unlicensed Demo version; a Basic level license (or any other level license) will cause files to be saved unencrypted.

**Hardware Utility Shows Version of Connected MP3 Director's Firmware**

Previously, the Hardware Utility's LOR MP3 tab would show whether an MP3 Director was connected or not. Now, if one is, it additionally shows the MP3 Director's firmware version.

**New DC-MP3 Firmware: Version 3.3**

Version 3.2 of the DC-MP3 firmware (DC_MP3_V3-3.lhx) adds one new feature and fixes two bugs:

- Output number 8, which was previously unused, will now be high (+5 volts) when a show is active, and zero when no show is active.
- When a sequence started playing, in some rare cases the music and the lights would start off significantly out of sync with each other.
- A bug was causing trigger number 6 to interact with trigger number 3 in some cases.

**New Servo Dog Firmware: Version 1.02**

Version 1.02 of the Servo Dog firmware (ServoDog_V1-02.lhx) fixes a bug where if channels 1 and 8 were in digital output mode, there would be crosstalk causing random results.

**Bug Fixes**

- Certain ways of scrolling through the channel list in the Animator window were not working.
- Skewing a track would not work if the timing grid currently in use by the track was a fixed timing grid.
- In the Servo Dog Utility, when a channel button was clicked, if another channel button had previously been selected, there was a chance that the configuration of the channel that was clicked would be set to the same values as the configuration of the channel that had previously been selected.
- In the Hardware Utility, controllers that were connected via Easy Light Linkers were not showing up in all cases.
What's New in Version 2.5.6

- **Bug fixes**

**Bug Fixes**

- If a show was scheduled starting on Saturday and ending on Sunday, instead of playing through, it would continuously shut down and restart. A common symptom of this is that the first sequence in the show's musical section would play over and over.

What's New in Version 2.5.4

- **Bug fixes**

**Bug Fixes**

- X10 controllers were not successfully being controlled in some situations.
- When a sequence was loaded, the zoom level of its waveform display was being set to a default value, rather than to the zoom level the sequence had been saved with.

What's New in Version 2.5.2

The following changes were made in this version:

- LOR Control Panel's status window now displays a log
- Support for configuring Cosmic Color Ribbons
- Circuit IDs greater than 16 supported
- The Light-O-Rama ServoDog Utility
- Bug fixes

**LOR Control Panel's Status Window Now Displays a Log**

The LOR Control Panel's status window now displays a log of what is occurring with shows. For example, it displays messages indicating that a show or a sequence is stopping or starting, that an error occurred playing a sequence, and that an interactive trigger was detected.

**Support for Configuring Cosmic Color Ribbons**

The Hardware Utility's Configuration screen now supports configuring Cosmic Color Ribbons.

**Circuit IDs Greater than 16 Supported**

In previous versions, the circuit IDs of Light-O-Rama controllers could range from 1 to 16. They now can range from 1 to 256 instead.

Note that not all Light-O-Rama controllers have more than sixteen circuits, and of those that do, not all support this new feature yet (instead, they use more than one unit ID, each with sixteen possible circuit IDs). Currently, the only Light-O-Rama controller that can be set to use more than sixteen circuit IDs for a single unit ID is the Cosmic Color Ribbon. Support for this feature in some other controllers is planned for the future, at which time firmware upgrades may be necessary to take advantage of it.
The Light-O-Rama ServoDog Utility

The Light-O-Rama ServoDog Utility is a new program which can be used to configure Light-O-Rama ServoDog controllers.

Bug Fixes

- If an error opening a comm port occurred when the Hardware Utility was being started, this could lead to strange errors later, such as the Hardware Utility unexpectedly closing in certain situations.
- If the musical section of a show contained sequences that could not be played due to errors, then in some situations the first sequence of the musical section of the show might repeat several times in a row.
- On some computers, when a Light-O-Rama program (such as the Sequence Editor) was started, it would open in Demo mode very frequently, despite having previously been activated (and without having upgraded to a new version).
- In the Sequence Editor, if you clicked the space bar to start play while the mouse button was down, then when play ended, you would be in “mouse dragging” mode, no matter whether you subsequently released the mouse button or not.
- If you used a countdown in the Tapper Wizard, sometimes the song would not start after the conclusion of the countdown.
- Various problems would occur if you set the default Sequences and Audio directories to be top level directories of a drive (for example, "C:\Sequences" and "C:\Audio" rather than "C:\LOR\Sequences" and "C:\LOR\Audio").
- In some situations, deleting a track from a sequence would cause the track dropdown list and the timing grid dropdown list to misbehave.

What’s New in Version 2.4.10

The following changes were made in this version:

- Exporting/importing channel configuration with tracks improved
- Commands sent to Holiday Lights Designer regardless of licensing level
- Hardware Utility supports DIO32 servo configuration
- Refresh command made quicker
- Bug fixes

Exporting/Importing Channel Configuration with Tracks Improved

In previous versions of Light-O-Rama, exporting and importing channel configuration from and to sequences that have more than one track could lead to strange, and probably undesired, results. This was due to the interaction between channels that were in more than one track of the sequence and channels that were in more than one track of the configuration file. If the positions of such channels did not match up between the sequence and the configuration file, then the resulting settings of those channels would be changed in a predictable, but probably undesired, way.

In this version, the method of importing has been altered, so as to give (hopefully) better results:

Unlike in previous versions, the first step to importing channel configuration, before any channels are actually imported from the configuration file, is now to check the sequence for channels that are in more than one track. If any such channels are found, then all copies of each channel, except for the
first of each channel, are removed from the sequence.

Next, channels are imported from the configuration file. But unlike in previous versions, if a channel is in more than one track of the configuration file, instead of overwriting the settings of an existing channel in the sequence every time the channel is encountered in the configuration file, that is only done on the first encounter of the channel. Instead, on subsequent encounters of the same channel, a copy of the appropriate channel from the sequence is inserted into the track at the appropriate position.

This has two potential side effects to watch out for (although both of these seem minor compared to the side effects caused in previous versions):

First, if a track in the sequence is composed entirely of channels from previous tracks, and the channel configuration file has no track in the same position, then all channels will be removed from that track. Since the track has no channels, it will then be removed from the sequence. However, note that these channels have not been removed from the sequence - they have only been removed from the track. They are still in the earlier tracks.

Second, a channel from the sequence with no corresponding channel in the configuration file could get "pushed down" towards the bottom of the sequence's track, if the channel configuration file contains channels in that track which are copies of channels from earlier tracks.

**Commands Sent to Holiday Lights Designer Regardless of Licensing Level**

Different licensing levels can control different numbers of controllers; for example, the Basic level can control two controllers, while the Advanced level can control an unlimited number of controllers. If a sequence contains a lighting effect for a controller that the license level cannot control, the effect is simply not sent to the controller.

In previous versions, this also applied to sending commands to Holiday Lights Designer: lighting effects could be sent to Holiday Lights Designer only if they could be sent to an actual controller, based on the license level. Now, lighting effects can always be sent to Holiday Lights Designer, regardless of the licensing level.

**Hardware Utility Supports DIO32 Servo Configuration**

The Hardware Utility can now be used to configure the DIO32 for servos.

**Refresh Command Made Quicker**

The Hardware Utility's Refresh command, used to scan a Light-O-Rama network for controllers, now works more quickly than it did before.

**Bug Fixes**

- If a show contains some sequences in a "Magic Toy" interactive group, and a trigger in that group is triggered, any playing sequences that happen to be from that same interactive group should be, but were not, stopped, before the newly triggered sequences start.
- The Channel Property Grid would allow you to remove the last channel from a track, which would lead to undesired behavior. It now no longer allows the last channel to be removed from a track.
- There must be a channel in every track; Light-O-Rama should prevent you from removing the last channel from a track. Due to bugs, though, it's possible that the last channel could be removed.
from a track; in such a case, if the sequence were saved, it could not thereafter be reloaded. In this version, the sequence can now be loaded, but any tracks without channels will automatically be removed from the sequence during the load.

- **Input triggers** would work correctly only for the first eight circuits of a controller. They now work on the full sixteen.

### What's New in Version 2.4.8

The following changes were made in this version:

- **Tapper Wizard improvements**
- **Animator's twinkle effect made more realistic**
- **Fade Tool Settings and Intensity Tool Settings can be toggled on and off**
- **New keyboard shortcuts for selecting the current tool**
- **Keyboard editing while using the Animator made easier**
- **File saving made safer**
- **Track bar of active track highlighted**
- **Bug fixes**

#### Tapper Wizard Improvements

The Tapper Wizard was improved in several ways:

- It now knows about timing grids. You can select an existing grid to use, or create new grids to use, from within the Tapper Wizard itself.
- Inserting timings and inserting lighting effects can now be done independently of each other - you can do either or both.
- You can play a particular part of a song, rather than the whole song. When the Tapper Wizard is first opened, its play range will automatically be set to the active track's freeform play range, if there is one, or to its normal play range (such as play full sequence or play visible screen) if not.
- You can set the play speed, either to normal speed, half speed, or double speed.
- It can be used repeatedly without closing, with or without tapping again. For example, after applying your taps to the sequence, you could collect a whole new set of taps, or you could apply your existing taps to the sequence again, in a new way (such as applying them to a different channel, or with different flash and fade times), all without ever closing the Tapper Wizard.
- It supports undo and redo within itself; you do not have to close the Tapper Wizard to undo or redo its changes.
- It no longer relies on helper forms to collect information (such as the length of time that a flash should take); this information is now set via fields on the Tapper Wizard itself.
- The settings that you choose, such as whether to use a countdown, how long that countdown should be, whether to use the mouse, the keyboard, or both, what kind of effects or timings should be inserted, and so forth, are remembered, so that you do not have to change them every time that you enter the Tapper Wizard.

#### Animator's Twinkle Effect Made More Realistic

Recent efficiency improvements to the Animator increased the speed it could redraw at. This had the side effect of making its twinkle effects twinkle too quickly, almost looking like shimmers. The Animator's twinkle effect has now been slowed back down, to more closely resemble the twinkle effect on actual lights.

Please note that this change does not affect the way that twinkle behaves on your lights at all; they
will behave exactly as they always have. It only affects how twinkle is represented in the Animator (which is an approximation, not an exact representation, of how it looks on actual lights).

**Fade Tool Settings and Intensity Tool Settings Can Be Toggled On and Off**

In previous versions, clicking of the Fade Tool Settings toolbar button would open the Fade Tool Settings dialog, as would clicking on the Tools menu's Fade Tool Settings item. The only way to close the dialog was to click on its Windows close button, or to use the escape key. Now, the toolbar button (or the menu item) can be used as a toggle - clicking it once shows the dialog; clicking it again hides it.

A similar change was made for the Intensity Tool Settings dialog.

**New Keyboard Shortcuts for Selecting the Current Tool**

When editing sequences via the keyboard, previous versions would allow you to hit the Enter key to apply the current tool to the selected area of the sequence. Alternatively, to apply a different tool, you could hit some other key, specific to that tool; this would leave the current tool the same as it was. For example, if the current tool was the shimmer tool, you could hit Enter to apply a shimmer, or "T" to apply a twinkle.

However, the current tool itself could not be selected except via the toolbar, or menu items on the Tools menu. It can now be selected via the keyboard as well, by using Shift in addition to the desired effect's normal key. For example, Shift-T will change the current tool to change the current tool to be the twinkle tool. Note that this leaves the sequence itself untouched (but you can still hit Enter to apply the current tool to the sequence, or one of the specific keys to apply some other tool).

Due to this change, certain existing keyboard shortcuts had to be remapped. Specifically, Shift-S, Shift-T, Shift-I, Shift-U and Shift-D used to change the current custom tool to be a custom shimmer, twinkle, intensity, fade up, or fade down, respectively. These have been replaced with Ctrl-Shift-S, Ctrl-Shift-T, Ctrl-Shift-I, Ctrl-Shift-U, and Ctrl-Shift-D, respectively.

**Keyboard Editing while Using the Animator Made Easier**

When you click on a control in the Animator, after that control's operation has completed, the focus is now immediately given back to the sequence grid. The effect of this is that you can continue using the keyboard to edit the sequence without needing to mouse-click on it every time you change something in the Animator.

**File Saving Made Safer**

Previously, when the Sequence Editor saved a sequence, it would delete the backup file of that sequence, then rename the existing save file to the backup, then write a new version of the save file, then verify that it could load the new version of the save file. If it could not load the new version, it would give a warning message saying so, and giving the name of the backup file.

Instead, it now writes the sequence to a temporary file, then verifies that it can load that temporary file. Only if it can load the temporary file does it then proceed to delete the backup file, rename the existing save file to the backup, and finally rename the temporary file to the real save file name.
In the Sequence Editor, the track bar of the currently active track in a sequence is now colored green, so as to make it easily distinguishable from the other tracks.

**Bug Fixes**

- In the Sequence Editor, if the total time of a track was increased, and that track was currently using a fixed timing grid, an error message would pop up saying that timings cannot be added to fixed grids.
- If the Windows option "Hide extensions for known file types" was turned on, the New and Open dialog's "Existing Sequence" tab would not properly display the type of each file.

**What's New in Version 2.3.8**

This version fixes the following bugs:

- In the Sequence Editor, when the mouse was moved to the left of the channel bar, an error message would sometimes pop up, saying "Invalid centisecond for finding timing", followed by a negative number. This would always happen when the mouse was dragging, and sometimes happen otherwise.
- On some computers running Windows Vista, installation would fail, giving an error about Microsoft's MDAC component.

**What's New in Version 2.3.6**

This version fixes the following bug: Upon upgrade from a previous version of Light-O-Rama, if the user chose a different directory to store sequence and audio files than was chosen for the previous version, the post-install process would neglect to copy the files from the old directory to the new one.

**What's New in Version 2.3.4**

The following changes were made for Light-O-Rama version 2.3.4:

- **Timing grids**
- **The Light-O-Rama Verifier**
- **Beat Wizard and VU Wizard improvements**
- **Initial play of sequences sped up**
- **Events straddling the start of a play range are played**
- **New and Open dialog improvements**
- **New musical sequence's initial channels can be based on a channel configuration file**
- **New musical sequence's artist, album, and song names pulled from MP3**
- **Support for normally closed input triggers**
- **Interactive triggers can be tested in the Hardware Utility**
- **Maximum and minimum intensities read from controller**
- **Extra Information in sequence grid tooltips**
- **Control Panel's status window can be minimized**
- **Fades are smoother in the Animator**
- **Animator CPU utilization improved**
- **Animator redraw throttling configurable**
- **Zooming with the Animator's autosize mode**
- **Bug fixes**

© 2010 Light-O-Rama, Inc.
Timing Grids

A timing grid is a collection of timings. A sequence can have more than one timing grid, but only one (per track) is displayed at any given time. You can quickly change which timing grid is displayed at any time by selecting from the Tracks and Timings toolbar's timings dropdown list.

There are two types of timing grids: fixed timing grids, which have timings at equal distances from each other, and which cannot have timings added, removed, or moved, and freeform timing grids, which can have timings anywhere, and which can have timings added, removed, or moved.

Timing grids are intended to better fulfill a role that was fulfilled in previous versions of Light-O-Rama by tracks: Allowing different sets of timings to be used on the exact same channels.

For example, perhaps you have a song for which you would like some lighting effects sequenced to the sound of the bass drum, and other lighting effects sequenced to the sound of the lead guitar. You could simply add timings for both, but this could make it easy to forget which timing is for which instrument; it could also make the display seem too cluttered with timings.

To solve this problem in previous versions of Light-O-Rama, you could duplicate the track to a new track, so that you had two different tracks in the sequence, both with the same channels as each other. The two tracks could use different timings, one track representing the bass drum and the other representing the lead guitar.

You can still do that in this new version of Light-O-Rama, but you can now instead solve the problem by using timing grids. Instead of adding a second track, you could add a second timing grid. One timing grid would represent the bass drum, and the other would represent the lead guitar. You could quickly switch which timing grid is displayed using the Tracks and Timings toolbar's timings dropdown list, changing back and forth between drum and guitar as appropriate, all with only a single track.

The Tracks and Timings toolbar also has a timings button; clicking on it will open a popup menu with various timings grid-related options, such as adding a new timing grid or deleting an existing one.

When this new version of Light-O-Rama opens a sequence created with a previous version (in which there was no such thing as a timing grid), it will automatically create one freeform timing grid per track in the sequence.

The Light-O-Rama Verifier

The new Light-O-Rama Verifier program can be used to check for certain types of problems with your Light-O-Rama configuration, schedule, shows, and sequences. By using the Verifier, you may be able to fix these problems before they cause any issues when your show is played.

Beat Wizard and VU Wizard Improvements

In previous versions, the Beat Wizard and the VU Wizard would always add timings, regardless of whether they were also adding effects or not. They can now add timings and effects independently of each other.

Also, when inserting effects, they can now optionally snap them to the timings being used.
Initial Play of Sequences Sped Up

The amount of time that it takes for a sequence to start playing the first time after it is loaded (or after it is changed or the play range is changed) has been decreased.

Events Straddling the Start of a Play Range Are Played

In the Sequence Editor, if the play range is set to anything other than the full sequence, and an event starts before the play range starts but ends during (or after) the play range, previous versions of Light-O-Rama would not control the lights based upon that event. Instead, now, the portion of the event within the play range is sent to the lights (for example, if the event is a fade up from 0% to 100% from 36 seconds to 38 seconds, and the play range starts at 37 seconds, the lights will be sent a command to fade up from 50% to 100%).

New and Open Dialog Improvements

Several improvements were made to the Sequence Editor's New and Open dialog:

In previous versions, the dialog was a fixed size, which could not be changed. It can now be resized or maximized, and will remember its sizing and positioning even after the Sequence Editor is closed and restarted.

The dialog's Existing Sequence tab used to always show a list of folders and sequences in a single way. It now has an option to change the view, similarly to Windows Explorer. For example, if the "Details" view is selected, then in addition to file names, details such as file sizes and modification dates will be displayed. Clicking on a column header in the "Details" view will sort the files by that column; clicking on it again will sort in reverse order. The dialog will remember the selected view and sorting behavior even after the Sequence Editor is closed and restarted.

The Existing Sequence tab now also has a "Search" box. If you type something into this box, only files with that somewhere in their name will be listed. Wildcard characters (*, ?, and #) are supported in the search box.

The Standard Toolbar's "Open" button would previously always open the dialog to the "Existing Sequence" tab. It now instead opens it to whichever of "Existing Sequence" or "Recent Sequence" was most recently used.

New Musical Sequence's Initial Channels Can Be Based on a Channel Configuration File

When you create a new musical sequence, the New Musical Sequence dialog now lets you base the initial channels for the sequence off of the contents of a channel configuration file, rather than simply specifying a number of channels.

New Musical Sequence's Artist, Album, and Song Names Pulled from MP3

If you create a musical sequence based on an MP3 file, the New Musical Sequence dialog automatically uses the artist, album and song names from the MP3 itself (if the MP3 is tagged with this information). You can still change these in the dialog if you wish.

Support for Normally Closed Input Triggers
Previous versions of Light-O-Rama only supported normally open circuits for use as input triggers. Normally closed circuits are now supported as well, via the Hardware Utility's LOR controller configuration screen.

You may need to update the firmware of your controller in order to take advantage of this new feature.

**Interactive Triggers Can Be Tested in the Hardware Utility**

The Hardware Utility's LOR controller testing screen can now be used to test input triggers from LOR controllers.

**Maximum and Minimum Intensities Read from Controller**

The Hardware Utility's LOR controller configuration screen can now read the maximum and minimum intensity settings of a Light-O-Rama controller from the controller itself.

You may need to update the firmware of your controller in order to take advantage of this new feature.

**Extra Information in Sequence Grid Tooltips**

The tooltip displayed in the Sequence Editor when the mouse hovers over a cell in a sequence now includes more information than before, including details on the effect event being hovered over.

You can configure various settings about the tooltips, such as how long they take to open and how they close, via the Display Preferences dialog.

**Control Panel's Status Window Can Be Minimized**

The status window of the Light-O-Rama Control Panel can now be minimized to the Windows task bar.

**Fades Are Smoother in the Animator**

The Animator used to display fades in a somewhat jerky manner, only updating the display after the color of a cell has changed by a fairly significant amount. Depending upon the speed of the fade, this would lead to fades more as steps through several intensities rather than as actual fades (note that this only affected the appearance of the Animator, not the appearance of any real lights that you had hooked up via controllers). Fades should now appear more smoothly in the Animator.

**Animator CPU Utilization Improved**

Various changes were made to the Animator to decrease the amount of CPU time that it takes to display the animation.

**Animator Redraw Throttling Configurable**

During play, the Animator only redraws the animation every so often, rather than every time that something changes. This is to try to ensure that it does not use too much CPU time. In the past, the amount of time between redraws was a certain constant value; now, you can modify it in the Display Preferences dialog, to try to strike an appropriate balance between CPU usage and
smoothness of display for your individual computer.

**Zooming with the Animator's Autosize Mode**

When the Animator's controls are hidden, expanding and contracting the Animator's window is supposed to also automatically resize the drawing area within the window. However, due to certain sizing requirements, the drawing area can only be certain possible sizes for any given animation. So, when the window was manually resized by clicking and dragging a side or a corner, the drawing area would remain the same size, until the window got large enough to hold the next possible size, at which time the drawing area would "jump" to the new size.

To make this autosizing quicker and easier, the ability to manually resize by dragging a side or a corner of the window has been replaced by "zoom" buttons on the toolbar, which will immediately resize the window (and the drawing area) to the next possible size.

**Bug Fixes**

This release fixes the following issues:

- If the same show had been scheduled twice back-to-back, it would have simply continued playing rather than stopping and restarting.
- If a channel was set up to represent a subsequence, changing the subsequence file associated with the channel would not cause the channel's main sequence to be marked as having unsaved changes.
- If a musical sequence based on a MIDI file was playing in the Sequence Editor, and was paused or stopped before its natural end, and the sequence had used the MIDI Wizard, then the Sequence Editor would not send out MIDI commands saying to stop sounds. This caused whatever notes happened to be playing when the sequence was paused or stopped to continue playing indefinitely.
- If the VU Wizard were used to toggle cells on and off during part of a song, as opposed to the entire song, it would sometimes get the toggling backwards, turning on cells that should have been turned off, and vice versa.
- If the VU Wizard were used to toggle cells on and off during part of a song, as opposed to the entire song, it would not necessarily get the state of the first or the last cell in the range correct.
- If the VU Wizard were set up such that the entire selected area of the song was below the specified peak threshold, an error box would appear, saying "Subscript out of range".
- If an animation had a background image, and the Animator's controls were hidden, resizing the window would not necessarily keep the image's proportions as they were.
- If the Animator's controls were hidden, resizing the window would only automatically resize the animation if it had a background image.
- The menu items on the Wave Form submenu of the Sequence Editor's View menu would not become checked until one of them (or the View Waveform button on the Standard Toolbar) was clicked.
- When the Sequence Editor's New and Open dialog is first opened, its dropdown list of folders did not include all of the immediate child folders of "My Computer".
- In the Hardware Utility's Test Console, clicking the "All Off" or "All On" buttons would move the intensity sliders appropriately, but would not update the text boxes beneath them to say the new intensities.
- If Windows suspended while the Sequence Editor was open, and a USB adapter was in use for an LOR comm port, then when Windows resumed, the Sequence Editor would be locked up.
- The Hardware Utility would shut down without warning if "Lights Off" or "All Off" were pressed while the LOR comm port was set to a port number that could not be initialized.
- The Hardware Utility would shut down without warning upon trying to initialize an X10 CM-11A...
device on a port that had (till that point) been assigned to LOR devices.

What's New in Version 2.1.6

This version fixes the following bugs:

- If the waveform display were used with a completely silent audio file, the Sequence Editor would crash.
- If a sequence had a Windows shell command, and it were saved to a different filename than it had been loaded with, future changes to the Windows shell command in one of the two sequences would affect the Windows shell command in the other sequence as well.
- Shows scheduled by the Simple Show Builder, and run via the PC, would not necessarily end at their appropriate time.

What's New in Version 2.1.4

This version fixes the following bugs:

- In certain situations, adding a sequence to an MP3 Player Showlist would fail, with an error message saying "Path/File Access error".
- Sequences downloaded to an MP3 director would have their final lighting effect cut off prematurely.
- The Sequence Editor's New Musical Sequence Preferences dialog would not allow you to change the default timings to certain values ("MIDI Wizard", "Beat Wizard", and "VU Wizard") if you opened the dialog via the "New Musical Sequence Preferences" menu item on the Preferences submenu of the Edit menu.

What's New in Version 2.1.2

The following changes were made for Light-O-Rama version 2.1.2:

- Licensing
- Custom fade/intensity twinkles and shimmers
- Triggered interactive sequences
- Show startup options
- Windows shell commands
- DMX intensity
- The New and Open dialog
- Keep lights on at end of play
- Automatic channel settings for newly created sequences
- Events can be dragged with timings
- Change in behavior for mouse switching tracks
- Animation sequences in the musical section cut off at end of show
- "Max Units" in Hardware Utility changed to "Max Unit ID"
- Bug fixes

Licensing

The Light-O-Rama Software Package must now be registered with a valid license in order to unlock its full potential. There are several different license levels, each with different features available. Additionally, Light-O-Rama can be run without a license, as a Demo version; the Demo version cannot be used to actually control lights, though.
Existing customers who have purchased earlier versions of the Light-O-Rama software package are entitled to a free license of the highest level ("Advanced").

For details about registering and about the features available with the different licenses, please see Registering Light-O-Rama and Feature Comparison.

**Custom Fade/Intensity Twinkles and Shimmers**

In previous versions of Light-O-Rama, twinkling or shimmering the lights could only be done at full intensity. You can now use new custom tools to twinkle or shimmer the lights while fading them up or down, or at some intensity other than full intensity.

Existing Light-O-Rama controllers may need firmware upgrades to take advantage of this new feature; if a custom twinkle or shimmer is sent to a controller without the upgrade, it will react as if it were a "regular" twinkle or shimmer - i.e. it will twinkle or shimmer at full intensity.

**Triggered Interactive Sequences**

In addition to being able to control lights, some Light-O-Rama controllers can now act as input triggers. This allows sequences to be played on demand during a show - for example, your display may have a group of buttons that people can press, each of which will cause a different song to be played.

For details, please see the help file page "Interactive Groups".

**Show Startup Options**

In previous versions of Light-O-Rama, the sequences in a show would start playing immediately at the show's scheduled start time. There is now more flexibility with regards to this; for example, you could hook a big red button labeled "Start the Show" up to one of your Light-O-Rama controllers, and the show will not be started until that button is pushed.

For details, please see "Show Startup Options".

**Windows Shell Commands**

Your sequences can now be configured so that, whenever one is played, Light-O-Rama will execute any arbitrary Windows command that you associate with that sequence.

An example of how this might be useful: If you broadcast the songs playing during your show over the radio, and have hardware allowing you to broadcast RDS ("Radio Data System") information, you can now set your sequences up so that, whenever one is played, Light-O-Rama will tell Windows to tell your RDS program to broadcast the name of the song for that sequence.

For details, please see the help file page "Windows Shell Commands".

**DMX Intensity**

A new effect, "DMX Intensity", has been added. This can be used to specify 256 possible intensities (from 0 to 255), rather than the regular 101 possible intensities (from 0 to 100). This is useful for DMX devices, which can take up to 256 possible intensities.
Note: The DMX intensity tool is not available by default in the Sequence Editor - for example, by default, no toolbar button will be displayed for it. To enable the tool, select "Allow DMX Editing" from the DMX Preferences menu.

The New and Open Dialog

The Sequence Editor's new "New and Open dialog" allows you to create a new sequence, or open an existing one. This dialog is opened by default when the Sequence Editor starts up (although this behavior can be suppressed), and also when something like "New" or "Open" is selected from the File menu or the Standard toolbar.

Keep Lights On at End of Play

For most sections in a show, you can now use the Show Editor to specify whether or not sequences in that section will automatically turn their lights off when they end playing.

There are two exceptions: First, the Background section does not allow this setting. Second, the Interactive section allows you to control this for each interactive group individually, rather than for the section as a whole.

Automatic Channel Settings for Newly Created Sequences

When creating a new musical sequence or new animation sequence, you now have the option to automatically configure the channels in the new sequence to use standard Light-O-Rama controllers. The first channel will be set up to use Light-O-Rama unit 1 circuit 1, the next unit 1 circuit 2, and so forth, then on to unit 2, and so forth. All such channels will be configured to use the regular LOR network.

Events Can Be Dragged with Timings

When a timing is dragged in the Sequence Editor, to change the time it is at, there is now an option to also drag any effect events that start or end at that timing along with it.

This option is controlled via the Edit menu's "Drag Events with Timings" checkbox.

Change in Behavior for Mouse Switching Tracks

Switching to another track via the mouse in the Sequence Editor now causes the selected area for that track to be set to the cell that was clicked, even if that cell is within what used to be the selected area for that track. In particular, if a tool other than "Select" is enabled, that tool will be applied to the new selection, not the old one.

Animation Sequences in Musical Section Cut Off at End of Show

In previous versions, when a show reached its scheduled end, if a sequence from the musical section of the show happened to be playing, that sequence would continue playing to its natural end before the shutdown section of the show would begin. Now, that is only the case for musical sequences; if the sequence is an animation sequence, it will abruptly stop at the scheduled end of show, regardless of the fact that it is in the musical section of the show.

"Max Units" in Hardware Utility Changed to "Max Unit ID"
When the Hardware Utility is asked to automatically detect units, it must individually search for each possible unit ID. This may take some time to do. To speed this up, the Hardware Utility allowed you to specify a maximum number of units to search for, in a box labelled "Max Units". For example, if you set "Max Units" to "3", the Hardware Utility would search for a controller with unit ID 01, another with unit ID 02, and a third with unit ID 03. It would not check for any unit IDs past 03. However, this often led to the following confusion:

Unit IDs are given in hexadecimal notation. So, for example, the next unit ID after 09 is not 10, but 0A. That is followed by 0B, 0C, 0D, 0E, and 0F, and only then does 10 come. So, if a person's highest unit ID was 10, they might be mislead to thinking that they should input "10" into "Max Units". But "Max Units" was merely a count, not an ID, meaning that the Hardware Utility would only search for the first ten possible unit IDs, i.e. 01 through 09 and 0A. Therefore, unit 10 would not be found (as it is actually the sixteenth possible unit ID).

To get rid of this common source of confusion, "Max Units" was changed to "Max Unit ID". So now, for example, entering "10" will search for unit IDs 01 through 09, unit IDs 0A through 0F, and unit ID 10.

**Bug Fixes**

This release fixes the following issues:

- If the Play Again button on the Standard Toolbar of the Sequence Editor were hit quickly two times in succession, an error message box would appear.
- If the "turn a channel on and off" feature of the VU Wizard were used on only part of a musical sequence, it would correctly turn the channel on and off in that part, but would additionally turn everything in the channel past that part off.
- In certain situations, when scrolling through tracks in the Sequence Editor, the track bar for some tracks would not be displayed, and instead part of the previously displayed channel grid would be displayed where the track bar should have been.
- If certain Light-O-Rama entries in the Windows registry were mistakenly deleted (for example, by a third-party registry cleaning program), and a musical sequence were modified and saved, the name of the sequence's media file would not be saved along with it, and you would be unable to modify the sequence again to tell it the name of the media file. This effectively means that the musical sequence would be "transformed" into an animation sequence. This no longer occurs. Note, though, that Light-O-Rama still might not be able to play the sequence, as those registry entries tell it where to look for media files. But after the issue with registry is corrected, Light-O-Rama will now play those musical sequences as normal.
- If a sequence had a channel that was set up to be a Light-O-Rama controller, but did not have its unit ID set, that sequence would not play in the Show Player.
- Removing a channel that was in more than one track from a track would not cause the sequence to be marked as having unsaved changes.
- If paste by cell is enabled, and effect events copied from a larger cell are pasted to a smaller cell, those events are "shrunk" to fit into the smaller cell. If such an event had to be shrunk to less than a centisecond in length, pasting would fail, giving an error message "Start time cannot be less than end time". Now, events shrunk to less than a centisecond are simply skipped when pasting.
- When creating an SD card for an MP3 Director, a valid COM port is no longer required.
- Some machines were having problems downloading standalone sequences to controllers. The reliability of downloading has now been improved.
- When setting a unit ID via the Hardware Utility, the dropdown boxes allowing you to select a unit ID only show unit IDs from 01 up to the unit ID specified in the Hardware Utility's "Max Unit ID" setting. Previously, though, changing "Max Unit ID" would not change the values listed in the
dropdown boxes, until the Hardware Utility was closed and then restarted. Now, the new values will be available immediately, without needing to close and restart.

What's New in Version 2.0.16

The following changes were made for Light-O-Rama version 2.0.16:

- Simple Show Builder updated
- Bug fixes

Simple Show Builder Updated

Previous releases of Light-O-Rama version 2 included the same Simple Show Builder as was used in Light-O-Rama version 1. It therefore could not be used with sequences that were created using the version 2 Sequence Editor.

Simple Show Builder has now been updated so that it can be used with sequences that were created using either version 1 or version 2.

Bug Fixes

This release fixes the following issues:

- Various tools such as the Beat Wizard, VU Wizard, and Waveform Display had problems with certain audio files, resulting in an error message saying "Can't init conversion" appearing, after which these tools would be unusable with those files. This release fixes this issue (at least in the known situations that it happened in).
- The Beat Wizard would crash when used with certain audio files on some customers' machines.
- If either "Close All Files" or "Close All Files Except This" was used, and one of the sequences being closed had its Animator window open, an error message would pop up saying "Error Loading Animation Form".

What's New in Version 2.0.14

The following changes were made for Light-O-Rama version 2.0.14:

- New play ranges
- Freeform play mode
- Space Bar to play: enter to apply tool
- Subdividing cells
- Skewing tracks
- Waveform height
- Waveform display modes
- Waveform colors
- Bug fixes

New Play Ranges

Two new play ranges have been added to the Sequence Editor: "From Selection" plays from the start of the selection to the end of the sequence, and "To Selection" plays from the start of the sequence to the end of the selection.
**Freeform Play Mode**

You can now use the keyboard to select an arbitrary time range for future playing. Please see "Freeform Play Mode" for details.

**Space Bar To Play; Enter To Apply Tool**

In the Sequence Editor, the space bar can now be used to start a sequence playing, and then to stop it. If a freeform play range has been selected, that range will be played; otherwise, play will be in "from selection" mode - that is, it will start at the start of the current selection, and go until the end of the sequence. This can be used to effectively pause and unpause play.

In previous versions of Light-O-Rama, the space bar was used to apply the current effect tool to the selected cells. That is now done using the enter key instead.

**Subdividing Cells**

The Sequence Editor can now subdivide the selected cell or cells into a new number of cells (which you select). Each cell is subdivided into the specified number of cells, and all of the new cells within any particular old cell will be of the same length (or as close to the same length as possible).

For example, if you select two cells, the first from 3 seconds to 7 seconds, and the second from 7 seconds to 7.5 seconds, and ask the Sequence Editor to subdivide them into two cells each, you will wind up with four cells: From 3 to 5, from 5 to 7, from 7 to 7.25, and from 7.25 to 7.5.

This can be done via "Subdivide Timings" on the Timings submenu of the Edit menu, or via "Subdivide Timings" on the right-click context menu.

**Skewing Tracks**

The Edit menu of the Sequence Editor now has a new menu item, "Skew Track". This lets you move all of a track’s events, timings, and loops by a specified amount of time, either to the left (i.e. earlier in time) or to the right (i.e. later in time).

**Waveform Height**

In previous versions of Light-O-Rama, the waveform of a musical sequence was either displayed or not. Now, if it is displayed, it can be displayed at two different heights: full height and half height. Full height is the same as the height that was used in previous versions of Light-O-Rama.

Half height and full height (and "off") can be selected from the Wave Form submenu of the View menu.

**Waveform Display Modes**

The waveform of a musical sequence can now be displayed in three different ways: "full mode", showing zero volume at the center and loud volumes above and below it; "fold mode", showing zero at the bottom and folding the two halves of full mode onto the top; "top mode", showing zero at the bottom and the top half of full mode above it. "Full mode" is the same as the way the waveform was always displayed in previous versions of Light-O-Rama.

To set the display mode, right-click on the waveform, and select the desired mode from the listed
choices in the popup menu.

**Waveform Colors**

The colors used to display the waveform of a musical sequence are now configurable. To choose new colors, right-click on the waveform, and select "Change Colors" from the popup menu.

**Bug Fixes**

This release fixes the following issues:

- In the Channel Property Grid, if a channel was set up with a device type but no unit number and/or circuit number, it might later be displayed (in both the Channel Property Grid and the Channel Settings dialog) as if it had a unit number and/or circuit number set (although it still did not).
- When printing from the Channel Property Grid, unit numbers of some Light-O-Rama controllers would be mislabelled, as would device types of certain non-Light-O-Rama controllers.
- If a sequence was changed, but not yet saved, and "Revert to Saved" was selected from the File menu, the sequence would be properly reloaded, but could not be played again until it was closed and reopened.
- Several dialog windows had a problem where, if the dialog was closed by hitting the enter key rather than by clicking the OK button, changes to the last field modified might not be acted upon.
- If a channel was in two or more tracks, and had a shimmer effect, the effect would not be displayed properly in the Animator.
- If a sequence was playing in the Sequence Editor, and some other sequence was not playing but had its Animator open, clicking on that Animator's play button would set off a string of errors. Now, instead, it simply does not start play (while the other sequence is playing).
- A problem with undoing and redoing changes in sequences with loops was fixed.
- Highlight Current Event on the Play menu is supposed to control whether or not the current event is displayed with a thick border (as if it were the selection) during play. It did so, but it also mistakenly controlled whether the selection was displayed or not while play was not happening.
- If a musical sequence's media file did not have its "Ready for Archiving" flag turned on (in the file's properties in Windows Explorer), the Sequence Editor would not play the sequence, complaining that the media file could not be found.
- If the Sequence Editor played a musical sequence at quarter, half, double or quadruple speed, and the directory its media file was in contained a period in its name, sometimes the wrong media file would be played.

**What's New in Version 2.0.12**

This release fixes the following issues:

- A show would pause indefinitely if the Show Player was asked to play a musical sequence whose media file was missing.
- Musical sequences played during the startup and shutdown sections of a show would control the lights, but would not play audio.
- Commands for X10 channels were often getting lost.

**What's New in Version 2.0.8**

This release contains the following bug fixes:

- The Tapper Wizard's dropdown list allowing you to select the track to use did not work properly,
leading to the taps being put into whatever track had been selected at the time that the Tapper Wizard was opened, rather than into the one that was selected in the list.

- The VU Wizard’s option to operate on only a portion of the song, as opposed to the entire song, did not work properly.
- Importing channel configuration into a sequence did not mark that sequence as having unsaved changes.
- Communication with the controllers is kept alive during the loading of sequences. This is to fix an issue where, after the loading of a large sequence, the PC would have to resynchronize with the controllers due to communication having been paused. This resynchronization could have taken some time, causing strange effects immediately after synchronization.
- If an error occurs while communicating with the controllers, Light-O-Rama tries to reestablish communications, in the hopes that the error was merely a temporary glitch. However, for certain types of errors, it would not try to do so, leading to the communications being permanently down.

What's New in Version 2.0.4

Version 2.0.4 fixes a bug where X10 channels were not being controlled during shows.

What's New in Version 2.0.0

The following new features, changes, and fixes have been made for Light-O-Rama version 2.0.0:

- Tracks
- Sequence-in-sequence play
- Background and foreground effects
- Universal undo and redo
- Channel positioning
- Mouse scroll wheel support
- Pasting timings between sequences
- Video playback
- Intensity and fade presets
- The Beat Wizard
- The VU Wizard
- Recording of individual instruments in the MIDI Wizard
- Multiple Light-O-Rama networks
- More media support
- Animator background image
- The Channel Property Grid
- Pasting effects: by time or by cell
- Holiday Lights Designer support
- XML sequence files
- Microsoft Windows Vista support
- Animator window CPU usage decreased
- Animator’s maximum rows and columns increased
- Sequence Editor's keyboard support improved
- New look for the shimmer effect
- Channel settings form directly accessible via the channel's button
- Bug fixes and internal improvements

Tracks

Previously, a sequence was composed of channels, loops, and timings. Now, instead, a sequence
is composed of **tracks**. Tracks, in turn, have channels, loops, and timings.

Two tracks in the same sequence can have different channels, or they can share channels with each other. They have different sets of loops and timings than each other. In an animation sequence, tracks can be of different lengths than each other.

Two tracks, with the same channels, in one sequence

A brief example of how this may be useful:

In a musical sequence, you may want to have some timings representing a bass drum, other timings representing a guitar, and yet another representing something totally unrelated to the song. Before tracks, in Light-O-Rama version 1, you could add all of these timings to your sequence, but it might be difficult to remember, while building the sequence, which timings were for which purpose. The more unrelated timings that you added to the sequence, the more confusing the sequence as a whole would become.

Now in Light-O-Rama version 2, instead, you can build a single sequence with multiple separate tracks, each with only one of those sets of timings, making each set of timings cleaner and simpler to understand. Plus, you can share channels between two or more tracks, have different channels in different tracks, or both.

Sequences are initially created with a single track. Another track can be added via the Edit menu’s “Add New Track” or “Duplicate Track” items (the latter of which will share all channels in the current track with the new track), or via new items on the channel buttons’ popup menus (“Copy to New Track” and “Move to New Track”).

To share an individual channel between multiple tracks, do not simply set two different channels to use the same unit number, circuit number, et cetera, as this will likely have unexpected and undesired results. Instead, use the “Copy to New Track” or “Copy to Track Number...” function on the channel's popup menu:
Share a channel with another track by copying it to the other track.

If a sequence has more than one track, the tracks are separated in the display by a track bar, labelled (for example) "Track 1" or "Track 2". If the track has been given a name, it will also be displayed here (for example, "Track 2: Front Yard Mini-trees"). Clicking on this bar gives a popup menu containing various track-related items:

**Sequence-in-Sequence Play**

A channel in a sequence can now be set to represent another sequence (rather than representing a physical circuit), known as a "subsequence". This is done in the Channel Settings dialog, by changing the "Device Type" to "Sequence" (rather than to "Light-O-Rama Controller", "Digital IO Card", or so forth), and choosing the filename of the sequence in the "Sequence" box:
Channel settings for sequence-in-sequence play

A subsequence will play only when the channel that it is a subsequence of is turned on, and will continue playing as long as the channel is on. If the channel is turned off and then turned back on, the subsequence will start over from its beginning.

**TIP:** Don't try to control the same physical circuit with both a channel in a subsequence and a channel in the main sequence. Doing so will probably cause unexpected results, as the two channels will vie for control of the circuit.

**Background and Foreground Effects**

Turning on background effects or foreground effects in the Sequence Editor will affect the behavior of tools (such as "Fade Up", "Twinkle", "Set Intensity", et cetera) in the following manner:

If "Background Effects" has been turned on, the tool only applies to those selected cells that are completely off (that is, at intensity zero for their entire duration).

If "Foreground Effects" has been turned on, the tool only applies to those selected cells that are not completely off.

Some examples:
Universal Undo and Redo

The Sequence Editor's undo and redo used to only work for the effect tools (such as "on", "off", "fade up", "twinkle", and so forth). You can now undo and redo a much wider variety of things - adding channels, moving timings, changing loops, drawing in the Animator, and many others.

Channel Positioning

Channels can now be moved up and down in the Sequence Editor. There are two ways to do this: First, the channel buttons' right-click popup menu now includes "Move Up" and "Move Down", which will move the channel by one spot. Second, a channel button can now be mouse dragged to a new position.

Mouse Scroll Wheel Support

The mouse scroll wheel now works in the Sequence Editor. Scrolling with the wheel causes the displayed channels in the active sequence to scroll.

Pasting Timings between Sequences

Previously, timing ranges copied from a sequence could only be pasted into that same sequence. Now, a timing range copied from one sequence can be pasted into a different sequence.

Video Playback

The Show Player and the Sequence Editor can now use video files (in addition to the previously available audio files) to create sequences. The video output can be displayed during play.

In the Sequence Editor's Edit/Preferences menu, there is now a new item called "Video Preferences", which gives control over how video files will be used (both in the Sequence Editor and during scheduled shows):
These options can also be temporarily changed in the Sequence Editor via the View/Video menu. However, changes made this way will only affect the Sequence Editor (not the Show Player), and will only last during the current use of the Sequence Editor - that is, the next time that the Sequence Editor is started, the video preferences as set in "Edit/Preferences/Video Preferences will be used again).

Intensity and Fade Presets

The Sequence Editor's Set Intensity, Fade Up and Fade Down tools now have ten preset values (or ranges). The old "Tool Options" dialog was replaced with the Fade Tool Settings and Intensity Tool Settings dialogs to set these presets:
Fade Settings, with fade up 50-75% and fade down 100-0% selected

The Sequence Editor comes with default preset values (such as 10%, 20%, and so forth) build in; if you want to change any of the presets, you can do so by clicking the settings tool's "EDIT" button:

Changing an intensity preset to 37%

The values of the presets for both intensities and fades can also automatically be set using Load Intensities and Fades from Current Sequence, of the Tools menu. This will figure out the most commonly used percentages for both intensities and fades existing in the current sequence, and set the preset values to them.

The Beat Wizard
The \textit{Sequence Editor}'s new \textit{Beat Wizard} can be used to automatically analyze a song to try to determine its beat, and to populate a \textit{musical sequence} with \textit{timings} or \textit{effects} based upon that beat. The Beat Wizard can be found in the Sequence Editor's \textit{Tools menu}. It is also available as one of the options for \textit{creating a new musical sequence}, and for \textit{creating a new track}.

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{beat_wizard.png}
\caption{The Beat Wizard}
\end{figure}

\begin{figure}[h]
\centering
\includegraphics[width=\textwidth]{vu_wizard.png}
\caption{The VU Wizard}
\end{figure}

\textit{The VU Wizard}

The \textit{Sequence Editor}'s new \textit{VU Wizard} is a VU meter-like tool that can be used to automatically populate a \textit{musical sequence} based upon peaks in the audio. The VU Wizard can be found in the Sequence Editor's \textit{Tools menu}, and is also available as one of the options for \textit{creating a new musical sequence}, and for \textit{creating a new track}.
The VU Wizard can now automatically create lighting effects for a musical sequence based on the notes played by individual instruments in a MIDI file.
The MIDI Wizard's can automatically create lighting effects based on the notes played in a MIDI file.

**Multiple Light-O-Rama Networks**

Previously, only a single COM port could be used for Light-O-Rama controllers. Now, up to four Light-O-Rama networks can be used simultaneously on the same computer, on different COM ports.

The same unit and circuit number can be used on multiple networks simultaneously and independently, with different effects happening on the different networks.
Up to four different networks can be used for LOR controllers

**More Media Support**

Various new media file types (including Windows Media Files and certain types of videos) are now supported for *musical sequences.*
Various supported media types

**Animator Background Image**

A sequence’s animation can now be set up to have a background image, such as a picture of a house on which Christmas lights are to be placed.
The Animator, with a background image

**The Channel Property Grid**

The [Sequence Editor’s](sequence_editor) new [Channel Property Grid](channel_property_grid) is a window showing information about all of the channels in a sequence (their color, device type, unit number, et cetera), and allowing changes to those properties in a (hopefully) convenient manner. This can be accessed via the Sequence Editor’s [Tools menu](tools_menu).
The Channel Property Grid

**Pasting Effects: By Time or By Cell**

When pasting effects in the Sequence Editor, you can now choose to insert the events into the destination based upon either the length of the copied events or else the relative lengths of the copied and destination cells.

For example, consider timings at 0 seconds, 1 second, and 2 seconds. Between 0 and 1 is a fade up, and between 1 and 2 is a fade down:

![Sequence Editor](image)

Events to be copied

These events will be copied, and pasted to the time starting at 5 seconds. There are timings at 5 seconds, 7 seconds, and 7.5 seconds:

![Sequence Editor](image)

Where they will be pasted to

If "Paste by Cell" is selected, then there will be a fade up from 5 to 7, and a fade down from 7 to 7.5
(this is the same way that pasting always behaved in version 1 of Light-O-Rama):

If "Paste by Time" is selected, then there will be a fade up from 5 to 6, and a fade down from 6 to 7. The timings at 7 and 7.5 are ignored; only the original lengths of the events are used:

You can switch between these two modes by selecting "Set Paste Mode" in the Sequence Editor's Edit menu.

**Holiday Lights Designer™ Support**

Light-O-Rama can now interact with Holiday Lights Designer™, a third-party application by Holidaysoft®.

Holiday Lights Designer™ can be used to virtually place lights and decorations on images of your home or business, and Light-O-Rama can now send Holiday Lights Designer™ commands during play to make those virtual lights behave as your real lights would during a show.

To send commands to Holiday Lights Designer™, first set the Holiday Lights Designer Preferences in the Sequence Editor under the Edit menu. After this is done, commands can be sent from the Sequence Editor by turning on "Control Holiday Lights Designer" in the Play menu, or from the Show Player by selecting "Holiday Lights Designer On" in the Light-O-Rama Control Panel.

Version 4.0 or above of Holiday Lights Designer™ is required to take advantage of Light-O-Rama interaction.

For more information about Holiday Lights Designer™, please see the Holidaysoft website.

**XML Sequence Files**

Sequence files (and channel configuration files) are now saved as XML files. LOR 2 understands both these new sequence files and the old LOR 1 style sequence files.

If an LOR 1 file is modified and saved by LOR 2, it is automatically updated to the new LOR 2 style. This means that LOR 1 will no longer understand the updated file. However, to be safe, a copy of the original LOR 1 save file is automatically created, and labelled as an LOR 1 file. For example, if the LOR 1 sequence file "lights.las" is converted to an LOR 2 file, then a copy of the original LOR 1 file will be created, named "lights.las.v1.bak".
Microsoft Windows Vista Support

Various changes were made to better support Light-O-Rama on the Microsoft Windows Vista operating system.

Animator Window CPU Usage Decreased

The Sequence Editor's Animator window now uses significantly less CPU during play than it used to.

Animator's Maximum Rows and Columns Increased

The Animator window now supports up to two hundred rows and columns:

Animation with 200 rows and 200 columns

Sequence Editor's Keyboard Support Improved

Several changes were made to make using the keyboard easier in the Sequence Editor. For example:
The "enter" key now chooses the "OK" button on most forms;
The "escape" key now chooses the "Cancel" button on most forms;
The "tab" key circulates between controls in a more sane order;
Many Alt-key shortcuts were added to various forms;
The various menus were reorganized so as to cause less conflict among their various items' shortcut hotkeys.

New Look for the Shimmer Effect

The shimmer effect is now drawn (in the Sequence Editor) using diagonal lines, instead of the previous vertical lines. This will hopefully make them stand out more against the background of vertical lines which represent timings.

Note that this change is simply for display of the sequence in the Sequence Editor; the actual appearance of the shimmer effect on controlled lights is unaffected by this.

Channel Settings Form Directly Accessible via the Channel's Button

In the Sequence Editor, left-clicking and right-clicking on a channel button used to both bring up a context menu of channel-related functions (such as adding, deleting, and moving channels). Right-clicking still does that, but left-clicking now brings up the channel's settings form instead:
Bug Fixes and Internal Improvements

Several bug fixes have been made, including but not limited to the following:

- If a show includes a musical cleanup sequence, it is supposed to be played after each song. Instead, it was being played only at the end of the show, just before the first shutdown sequence.
- Some musical sequences, when played in the Sequence Editor, would reach the end of their audio file, but would not cause the Sequence Editor to exit from play mode.
- Certain audio files would not play their audio.
- The Sequence Editor incorrectly determined the total length of certain audio files.
- When a musical sequence was played in the Sequence Editor using the "Visible Screen" play range, the display would sometimes jump to an adjacent portion of the sequence, rather than remaining on the initially visible portion of the sequence.
- Attempting to delete the first timing in a sequence (at time zero) would cause the Sequence Editor to crash.
- Attempting to resize multiple timings (simultaneously) using the Sequence Editor's "Resize Timings to ..." function (on the right-click popup menu) would cause the Sequence Editor to crash if the sequence happened to be more than 5:27.67 long.
- When the Sequence Editor displayed fades using gradual changes in colors (as opposed to when it displayed them using ramps), it would sometimes draw the end of a fade event past where it should have been.
- The Tapper Wizard's option to not use a countdown before the song begins did not work.
- When a sequence was playing at a speed other than the normal speed (for example, through the "Play Speed" menu item in the Sequence Editor, or due to a loop that was set up to increase or decrease speed each time through), if a fade up or a fade down was done, the lights would not properly take the speed of the sequence into account when determining how quickly to fade. For example, a fade up from 0 to 100% that normally takes one second, played at half speed, should fade up from 0 to 100% in two seconds. Instead, it would fade up from 0 to 100% in the first second, and then remain at 100% for the entire second second.
- When the Cleanup or Delay portion of a show was modified in the Show Editor, the Save button would not become enabled.
- The Sequence Editor's audio waveform display (and its positioning line) did not exactly match up with the time of the rest of the display. This was especially noticeable at very high zoom levels.
- When moving a timing in a sequence by clicking and dragging it in the Sequence Editor, sometimes the timing before the selected one would be moved.
- When a musical sequence was opened in the Sequence Editor, and the "View Wave Form by Default" option was selected, if the sequence's audio file no longer existed (or otherwise could not be opened), the Sequence Editor would crash.
- If a musical sequence was played in the Sequence Editor, and the sequence's audio file no longer existed (or otherwise could not be opened), nothing would appear to happen. The Sequence Editor now instead shows an error message box describing the problem.

Various internal improvements have been made as well.

What's New in Version 1.5.0

The following new features, changes, and fixes have been made for Light-O-Rama version 1.5.0:

- Tapper Wizard Behavior Change
What's New? 59

© 2010 Light-O-Rama, Inc.

- Channel Deletion Fix
- Channel Button Feedback during Loops Fixed
- Animator Fix

**Tapper Wizard Behavior Change**

When the Tapper Wizard’s "toggle" and "snap to existing events" options are used together, both the beginning time and the end time of each toggle are snapped to existing events. This causes the combination to behave in a way that is probably more similar to what most people would expect.

**Channel Deletion Fix**

Various problems occurred when the last channel in a sequence was deleted. These have been fixed.

**Channel Button Feedback during Loops Fixed**

When the Sequence Editor was used to play a sequence with a loop, and the end of the loop was reached, just before going back to the beginning of the loop, the channel buttons' color displays would sometimes briefly act upon the event just after the loop. This has been fixed. Note that it did not affect the actual display of lights; it only affected the display within the Sequence Editor itself.

**Animator Fix**

If the Animator was sized so that scroll bars were necessary, the "draw" and "erase" functions would act upon the wrong cells. This has been fixed.

**What's New in Version 1.4.0**

- Time Scale
- Copy and Paste Timings
- Animation Saved in Channel Configuration Export
- Right-Click in Animator Now Erases
- Duration in Status Bar
- Play Again
- Several Zoom Improvements
- Delete Selected Events
- Animator Efficiency
- Manual Stop Stays in Position
- Program's Main Window Remembers Its Position
- Bug Fixes and Internal Improvements

**Time Scale**

In the Sequence Editor, at the top of each sequence, a time scale is optionally displayed. Also, during play, the button to the left of this scale now displays the current time offset.

Whether the time scale is displayed or not for any particular sequence can be controlled via the View menu, or via a button on the toolbar. It can be turned on or off by default using the Display Preferences dialog on the Edit menu.

**Copy and Paste Timings**
In the Sequence Editor, you can now copy and paste timings - that is, make new cells having the same duration and relative positions as some existing timings.

To copy a set of timings, select the range of cells that you want to copy, and then copy them in one of three ways:

- Select "Copy Timing" from the Edit menu;
- Select "Copy Timing" from the right-click context menu;
- Using the keyboard, hold the "Shift" key and simultaneously hit the "Delete" (or "Del") key.

Once these timings are copied, you can paste them in one of several ways:

- Via the right-click context menu:
  - "Paste timing at (the centisecond that was right-clicked)";
  - "Paste timing at ...", which brings up a dialog box asking the centisecond to paste to (defaulting to the centisecond that was right-clicked);
  - "Paste timing multiple", which is similar, but also asks how many times you would like to paste the timings consecutively, or if you wish to keep pasting them all the way to the end of the file.
- Via the Edit menu, using "Paste Timing". This is the same as the right-click menu's "Paste timing multiple", except that the starting centisecond defaults to the start of the current selection, rather than the right-clicked centisecond.
- Using the keyboard, hold the "Shift" key and simultaneously hit the "Insert" (or "Ins") key. This is the same as "Paste Timing" from the Edit menu.

**Animation Saved in Channel Configuration Export**

When a sequence's channel configuration is saved (using "Export Channel Configuration" from the Edit menu of the Sequence Editor), the sequence's animation is saved along with it. When the channel configuration is later imported into another sequence (using "Import Channel Configuration" from the same menu), the user is given the option to import the animation as well.

**Right-Click in Animator Now Erases**

The right mouse button can now be used to erase cells in the Animator.

**Duration in Status Bar**

The status bar along the bottom of the Sequence Editor now shows not only the total time and selected time range, but also the duration of the selected time range.

**Play Again**

You can now tell the Sequence Editor to "play again". This causes it to play the last thing that you asked it to play, regardless of the current play settings. For example, if you choose a certain time range, with the play range set to "Selection", the Sequence Editor will play that selection. After play ends, you may fix some problem that you noticed, which causes the selected time range to change. If you wanted to play the same time range again, previously, you would have to re-select that time range. Now, you can instead simply hit "Play Again".

There are two ways to do this: Via the "Play Again" item of the Play menu, and via a new toolbar...
Several zoom improvements have been made in the Sequence Editor:

- The "Zoom In" and "Zoom Out" buttons on the toolbar have been replaced by individual buttons for "Zoom Channels In", "Zoom Channels Out", "Zoom Time In", and "Zoom Time Out".
- Preferred zoom settings can now be saved or restored via the Zoom Preferences dialog on the Edit menu. The saved zoom preferences are used by default when opening or creating new sequences.
- Keyboard shortcuts now exist to zoom in various directions: Alt-Up and Alt-Down to zoom channels in and out, and Alt-Left and Alt-Right to zoom time in and out. Also, Alt-Page-Up and Alt-Page-Down to go to the minimum or maximum channel zoom settings, and Alt-Home and Alt-End for the minimum and maximum time zoom settings.

Delete Selected Timings

In the Sequence Editor, several timings can now be deleted at once, by selecting a range of timings and choosing "Delete Selected Timings" from the right-click context menu.

Animator Efficiency

The Animator has been made more efficient, using less CPU during play. This improves the jerkiness that was seen on some machines during play while the Animator window was open.

Manual Stop Stays in Position

When you manually stop play of a sequence (as opposed to letting it stop by reaching its natural end), the Sequence Editor now continues to display the screen that was being displayed when play was stopped.

Program's Main Window Remembers Its Position

When you start the Sequence Editor, its main window is now opened in the same position that it was in the last time it was closed.

Bug Fixes, Internal Improvements

Several bug fixes and internal improvements have been made.

3 Feature Comparison

The Light-O-Rama software package must be registered, with a valid license, in order to be used to its full potential. Several different license levels exist, each having different features: Basic, Basic Plus, Standard, and Advanced. Additionally, there is an unlicensed Demo version (which is the same as the Basic version, except that it cannot be used to actually control lights, and has encrypted save files).

You will be given a chance to register your Light-O-Rama software at the time that you install it. To
register after that time, or to upgrade to a higher level license, please see the “Register Light-O-Rama
" (or “Upgrade Light-O-Rama") menu item on the Sequence Editor's Help menu, or on the Control
Panel's popup menu.

The following chart summarizes what features are available with each license level, with detail on each
coming after the chart.
If a feature is listed as "(demo mode)", it means that the feature can be used with this license to see
what it's like, but it won't be fully supported. For example, if you try one of the Sequence Editor's demo
mode features while building a sequence, you won't be able to save your changes to that sequence.
Please see the details for each feature for exactly what "demo mode" means for that feature.

Any features not listed here are available with all license levels.

<table>
<thead>
<tr>
<th>FEATURE</th>
<th>DEMO</th>
<th>BASIC</th>
<th>BASIC PLUS</th>
<th>STANDARD</th>
<th>ADVANCED</th>
</tr>
</thead>
<tbody>
<tr>
<td>Number of LOR Units Supported</td>
<td>0</td>
<td>2</td>
<td>4</td>
<td>8</td>
<td>UNLIMITED</td>
</tr>
<tr>
<td>Number of Tracks Supported</td>
<td>2</td>
<td>2</td>
<td>2</td>
<td>4</td>
<td>UNLIMITED</td>
</tr>
<tr>
<td>Full Access XML Data Storage</td>
<td>No</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Beat Wizard (demo mode)</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>VU Wizard (demo mode)</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Video Playback (Windowed Mode)</td>
<td>No</td>
<td>No</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Show On Demand</td>
<td>No</td>
<td>No</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Schedule Shows Based on Day of Year</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Startup Sequences in Shows</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Shutdown Sequences in Shows</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Background Sequences in Shows</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Sequence in Sequence</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>YES</td>
</tr>
<tr>
<td>MIDI Wizard (demo mode)</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
<td>YES</td>
</tr>
<tr>
<td>Triggered Interactive Sequences</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>(demo mode)</td>
<td>YES</td>
</tr>
<tr>
<td>Show Startup Options</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Execute Windows Shell Commands</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Full Screen Video Playback</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Multiple Networks</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>DMX Intensity</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
</tbody>
</table>
### Feature Comparison

<table>
<thead>
<tr>
<th>FEATURE</th>
<th>DEMO</th>
<th>BASIC</th>
<th>BASIC PLUS</th>
<th>STANDARD</th>
<th>ADVANCED</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dasher Controllers Supported</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>X10 Controllers Supported</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>Digital IO Cards Supported</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
<tr>
<td>BSOFT Digital IO Cards Supported</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>No</td>
<td>YES</td>
</tr>
</tbody>
</table>

### Number of LOR Units Supported

Except for the Advanced license level (which supports an unlimited number of Light-O-Rama controllers), each license level will send lighting commands to a limited number of Light-O-Rama controllers: Basic supports a single controller, Basic Plus supports four, and Standard supports eight.

Whether a particular controller is supported or not depends on its unit ID. For example, the Basic license level will send lighting commands only to unit ID numbers 1 and 2, while the Standard license level will send lighting commands to any unit that has a unit ID between 1 and 8.

Regardless of whether a particular unit will be sent lighting commands, you can always use the Sequence Editor to build sequences using that unit; Light-O-Rama simply will not control the lights for that unit unless you upgrade to a higher license level.

The unlicensed Demo version will not send lighting commands to any controllers, so you cannot use it to actually control your lights.

### Number of Tracks Supported

A sequence may have multiple tracks; however, certain license levels will only support a limited number of tracks in any given sequence. The Demo, Basic, and Basic Plus levels support two tracks per sequence, Standard supports four, and Advanced supports an unlimited number of tracks per sequence.

You will not be able to add new tracks to a sequence if it already has the maximum supported number. However, you can still open sequences that have more tracks (for example, a sequence that was created by someone who has a higher license level than you do). In this case, the extra tracks will be displayed in the Sequence Editor, but you will not be able to modify them, and any lighting effects in those tracks’ channels will not actually control your lights during play.

### Full Access XML Data Storage

When a sequence is saved using a licensed version of Light-O-Rama, its save file uses a standard XML format, which is designed to be understandable by people. Technically advanced users may feel comfortable editing these XML-based sequence files directly with a text editor, or even building their own tools that can be used with these files (although please be careful when doing so, as it is not terribly difficult to make a small mistake which may render the sequence file incomprehensible to the Light-O-Rama software package).

On the other hand, when a sequence is saved using the unlicensed Demo version, it is saved
encrypted, and so the file itself cannot be easily understood or modified by anyone or anything except the Light-O-Rama software package. Additionally, data from an encrypted sequence cannot be copied and pasted, except on the computer that the sequence was originally encrypted on.

No matter whether a sequence is saved using the open XML format or using encryption, the Light-O-Rama software itself will still be able to use it.

If you create an encrypted sequence using the unlicensed Demo version, and later purchase a license, you can unencrypt the sequence by resaving it on the same computer it was originally encrypted on, using your licensed version of the software.

**Beat Wizard**

The Beat Wizard can be used to analyze a song to try to determine its tempo, and to automatically place timings and lighting effects into a sequence based upon that tempo. It is fully supported in license levels Basic Plus, Standard, and Advanced.

It is not supported in license level Basic (nor in the unlicensed Demo version). However, you can still try it out in a "demo mode" to see what it is like; after trying it on a sequence, you will not be able to save your changes. You will be given a warning about this when you try it, along with a chance to back out before committing to using it. Additionally, if you do decide to use it, and your sequence already has unsaved changes, you will be given a chance to save them before you actually use this feature.

**VU Wizard**

The VU Wizard can be used to analyze a song to find peaks in the audio - much like a VU meter - and to automatically place timings and lighting effects into a sequence based upon those peaks. It is fully supported in license levels Basic Plus, Standard, and Advanced.

It is not supported in license level Basic (nor in the unlicensed Demo version). However, you can still try it out in a "demo mode" to see what it is like; after trying it on a sequence, you will not be able to save your changes. You will be given a warning about this when you try it, along with a chance to back out before committing to using it. Additionally, if you do decide to use it, and your sequence already has unsaved changes, you will be given a chance to save them before you actually use this feature.

**Video Playback (Windowed Mode)**

You can build musical sequences based on audio files (such as MP3) or on video files (such as WMV). When a musical sequence is played, the sound will always play, but the actual video (or audio visualization) will only be displayed for license levels Basic Plus, Standard, and Advanced. License level Basic will not display video (or audio visualization).

Additionally, your license level may or may not support video playback in full screen mode; see "Full Screen Video Playback" for details.

**Show On Demand**

Using license level Basic Plus or above, you can cause a show to be played without having scheduled it. This is done via the "Show On Demand" menu item of the Light-O-Rama Control
Panel's popup menu.

Schedule Shows Based on Day of Year

The Light-O-Rama Schedule Editor can be used to schedule shows to play in two different ways: by the day of the week (such as "from 6:00 PM to 9:00 PM on Friday") or by the day of the year (such as "from 9:00 AM to 9:00 PM on December 25th").

However, scheduling based on the day of the year is fully supported only in license levels Basic Plus, Standard, and Advanced.

Using the Basic license level, you will still be able to use the Schedule Editor based on the day of the year in a sort of "demo mode" to see what it is like, but the Light-O-Rama Show Player will not actually play shows that are scheduled this way - it will only play shows that were scheduled by the day of the week.

Startup Sequences in Shows

The Light-O-Rama Show Editor can be used to build shows with several different sections. Among these is the Startup Section. Sequences in the Startup Section are played immediately upon the show starting up, one at a time, in order. After all of them have been played, the main portion of the show (i.e. the Animation Section and the Musical Section) begins.

However, this section is fully supported only with the Standard and Advanced license levels.

Using the Basic and Basic Plus license levels, you will still be able to use this section in the Show Editor in a sort of "demo mode", to see what it is like. However, the Light-O-Rama Show Player will not actually play the sequences in a show's Startup section; instead, the show will simply begin play directly with the Animation Section and the Musical Section.

Shutdown Sequences in Shows

The Light-O-Rama Show Editor can be used to build shows with several different sections. Among these is the Shutdown Section. When the scheduled end time for the show is reached, the main portion of the show (the Animation Section and the Musical Section) stops, and the sequences in the Shutdown Section are then played, one at a time, in order. After they have all finished, the show is truly finished.

However, this section is fully supported only with the Standard and Advanced license levels.

Using the Basic and Basic Plus license levels, you will still be able to use this section in the Show Editor in a sort of "demo mode", to see what it is like. However, the Light-O-Rama Show Player will not actually play the sequences in a show's Shutdown section; instead, when the scheduled end time for the show is reached, the Animation Section and the Musical section will stop, and the show will be over.

Background Sequences in Shows

The Light-O-Rama Show Editor can be used to build shows with several different sections. Among these is the Background Section. All sequences in the Background Section will play simultaneously, looping back to their starts when they reach their ends, throughout the entire course
of the show.

However, this section is fully supported only with the Standard and Advanced license levels.

Using the Basic and Basic Plus license levels, you will still be able to use this section in the Show Editor in a sort of "demo mode", to see what it is like. However, the Light-O-Rama Show Player will not actually play the sequences in a show's Background Section.

Sequence in Sequence

Sequences can themselves contain subsequences - a parent sequence containing a child sequence. The parent sequence can be set to start or stop the child sequence at any given point during play.

However, subsequences are only fully supported with the Advanced license level.

Using other license levels, you will still be able to use subsequences in a sort of "demo mode", to see what they are like, but you will not be able to save changes to your sequence after having done so.

MIDI Wizard

The MIDI Wizard can be used to automatically insert timings and lighting effects into a musical sequence that is based upon a MIDI song. For example, it can make your lights chase each other in time to the music, or turn certain channels on or off based upon what notes are being played.

However, the MIDI Wizard is fully supported only with the Advanced license level.

Using other license levels, you will still be able to use the MIDI Wizard in a sort of "demo mode", to see what it is like, but you will not be able to save changes to your sequence after having done so.

Execute Windows Shell Commands

Using the Advanced license level, Light-O-Rama can optionally tell Windows to execute any arbitrary command that you specify when a particular sequence is started. An example of how this might be used: If you broadcast the songs playing during your show over the radio, you might set your sequences up so that they tell Windows to tell your RDS ("Radio Data System") program to also broadcast the name of the song, allowing people with RDS-enabled radios to see the name of the song currently playing in your show.

Triggered Interactive Sequences

In addition to being able to control lights, some Light-O-Rama controllers can also accept input, acting as triggers to start particular sequences on demand during a show. For example, as part of your display, you could have several buttons for people to push, each of which will play a particular song.

However, this feature is fully supported only with the Advanced license level.

Using other license levels, you will still be able to use this section in the Show Editor in a sort of "demo mode", to see what it is like. However, the Light-O-Rama Show Player will not actually play
any sequences which are triggered during your show.

Show Startup Options

Normally, the sequences in a show will start playing immediately at the show's scheduled start time. The Advanced license level allows more control over this; for example, you could hook a big red button labeled "Start the Show" up to one of your Light-O-Rama controllers, and the show will not start until that button is pushed.

For details, please see "Show Startup Options".

Full Screen Video Playback

When a musical sequence is based upon a video file (such as a WMV file), the Advanced license level can show the video in full screen mode (and similarly, it can show full screen audio visualizations for musical sequences based upon audio files).

Lower license levels cannot show full screen video (or full screen audio visualizations), but they may still be able to show video and visualizations in a window instead of in full screen. See Video Playback (Windowed Mode) for details.

Multiple Networks

The Light-O-Rama Software Package can send lighting commands to Light-O-Rama controllers over up to four Comm ports simultaneously. This has several potential uses, especially for people with large numbers of controllers, or lights spread out physically far from each other.

However, this is supported only in the Advanced license level. Other license levels will send lighting commands to Light-O-Rama controllers only over a single Comm port.

DMX Intensity

Light-O-Rama allows the possible intensity of most lighting effects ranges from 0 to 100, i.e. a percentage of full intensity. DMX devices, however, are capable of taking 256 different intensities (from 0 to 255), rather than 101. Light-O-Rama supports this possibility via the DMX Intensity tool.

However, this is only supported in the Advanced license level. Other license levels will not have access to the DMX Intensity tool.

Dasher Controllers Supported

The Advanced license level can send lighting commands to Dasher controllers, in addition to Light-O-Rama controllers. Lower license levels can only send lighting commands to Light-O-Rama controllers.

X10 Controllers Supported

The Advanced license level can send lighting commands to X10 controllers, in addition to Light-O-Rama controllers. Lower license levels can only send lighting commands to Light-O-Rama controllers.
Digital IO Cards Supported

The Advanced license level can send lighting commands to digital IO cards, in addition to Light-O-Rama controllers. Lower license levels can only send lighting commands to Light-O-Rama controllers.

BSOFT Digital IO Cards Supported

The Advanced license level can send lighting commands to BSOFT digital IO cards, in addition to Light-O-Rama controllers. Lower license levels can only send lighting commands to Light-O-Rama controllers.

4 Light-O-Rama Concepts

Light-O-Rama allows your computer to control your lights and other equipment in synchronized displays. Such a display is organized in a few levels:

At the lowest level, a sequence contains commands to be sent to your Light-O-Rama hardware, which will actually control your lights. For example, a sequence might contain a command to turn on one string of lights while making another string twinkle, and two seconds later, fading the first string down while fading the second string up. A sequence can contain commands for many circuits.

![Sequence Diagram]

A sequence contains commands for individual strings of lights

Typically, people build a sequence per song that they want in their display (known as musical sequences), each one containing all of the lighting commands for its particular song. People also build animation sequences, not associated with any particular song, and often build one for each independent part of their display - for example, one animation sequence to control a group of snowmen having a snowball fight, and another to control a tin soldier firing a cannon.

Sequences can be grouped together into shows. A show allows several sequences to be played at the same time, or sequentially, or in random order. A show can contain different sections - for example, some sequences might be played only at the beginning of a show, others only at the end, others in between, and still others for the entire duration of the show.
Finally, shows can be scheduled to be played at certain times. Only one show (at most) can be playing at any given time, but any number of shows can be scheduled for different times, and the same show can be scheduled to play at many different times.

**4.1 Sequences**

A sequence is a set of commands to be sent to lights - for example, a sequence may command the lights to *turn on* when the sequence starts, *turn off* a second later, stay off for a tenth of a second, start *twinkling* for the next two seconds, and then *fade up*, from completely off to completely on, during the next three seconds.

A sequence can control multiple sets of lights independently of each other. Each set of lights should be hooked up to a particular circuit on a particular controller; each such circuit is referred to as a "channel". Additionally, for RGB devices, capable of changing color, three independent channels (a red, a green and a blue) can be grouped together into a single *RGB channel*.

There are two types of sequences: *animation sequences* and *musical sequences*. Musical sequences are associated with songs (or sound effects, videos, et cetera); the lights can be made to turn off and on (and do other *effects*) in sync with the music. Animation sequences are not associated with songs. Many sequences can be played simultaneously, but at most one musical sequence can be playing at a
time - all others must be animation sequences. This means that you can control some of your lights in sync to a song via a musical sequence, while simultaneously controlling other lights independently, via animation sequences.

The Light-O-Rama Sequence Editor is used to create and modify sequences. After creating sequences with the Sequence Editor, you can package sequences together into a show, using the Show Editor, and then schedule shows to be played at certain times using the Schedule Editor. The Show Player (if enabled, via the "Enable Schedule" on the Light-O-Rama Control Panel) will monitor your schedule and play your shows at the appropriate times.

For example, here is a simple sequence, containing six channels, as represented in the Sequence Editor. As time passes (from left to right), you can see that the first channel is turned on, then it is turned off and the second channel is turned on, then that is turned off and the third channel is turned on, and so forth, through the six channels:

![A simple sequence, with lights turning on and off, chasing through six channels](image)

The vertical lines in the grid, representing distinct points in time, are known as timings. These timings do not have any direct effect on how your lights will look; instead, they allow you to select time ranges for lighting effects to happen, using various tools in the Sequence Editor.

Timings are grouped together into timing grids. A sequence can have more than one timing grid; which one is currently displayed can be controlled via the "Timings" dropdown box in the Tracks and Timings toolbar. For example, the timing grid currently displayed in the sequence shown above has a timing every half a second, and is shown in the dropdown box as "Fixed Grid: 0.50". "Fixed Grid" in this means that the timings are all a certain length of time apart, and that they cannot be moved, deleted, or added to; "0.50" is that length of time (in this case, half a second).
In addition to “fixed” timing grids, a sequence can also have “freeform” timing grids. In a freeform timing grid, timings can be at any location, and can be moved, added, and deleted. For example, here is the same sequence, but now with a freeform timing grid displayed:

![Image of Light-O-Rama Sequence Editor](image)

The same sequence, with a freeform timing grid

Note that the timings in this freeform grid are not the same distance from each other. Also note that the timings and the effects do not line up with each other - there is no reason that they would have to. This is so as to allow flexibility in where effects can be applied, without cluttering the display with many timings.

For example, perhaps you might want a sequence to have some effects that are following the drumming in a song, and other effects that are following the lead guitar. You could simply add timings representing both the drumming and the guitar to a single timing grid, but if you do, it could be difficult to remember which timing is for which instrument; also, the display might become cluttered with so many timings. So, instead, you could put the timings for the drums into one timing grid, and the timings for the guitar in another timing grid, and use the dropdown box to easily switch between the two timing grids as appropriate. The effects that you add using the timing grid for the drums will not necessarily line up with the timing grid for the guitar, nor the effects added using the timing grid for the guitar with the timing grid for the drums, but neither should they.

A sequence can contain multiple tracks. A track is a group of channels. Each track can have its own channels, or can share channels with other tracks, or both. Each track can be switched to display any particular timing grid at any time, independently of every other track.

Animation sequences (but not musical sequences) can be set up to use loops. When playing a
sequence that contains a loop, when the end of the loop is reached, the sequence will jump back to the beginning of the loop. It will do this a certain number of times (that you specify), and then will continue past the end of the loop. Each time that it jumps back, you can make it go through the loop faster, slower, or the same speed as before. There can be many loops in a sequence (set up for different time ranges), and loops can even contain other loops.

Each sequence can have an animation associated with it. This lets you draw how your lights will be laid out. When you play a sequence in the Sequence Editor and display its animation, the drawing will behave just like your lights will - your drawing will turn on and off, fade up and down, and so forth.

A sequence can also contain another sequence as a subsequence. The subsequence can be turned on or off at different points in the main sequence, and its effects will play only when it is turned on.

For more detailed information on sequences, please refer to the following sections:

- The Sequence Editor
- Animation Sequences
- Musical Sequences
- Tracks
- Channels
- RGB Channels
- Timings
- Effects
- Loops
- Animations
- Subsequences
- Windows Shell Commands

### 4.1.1 Animation Sequences

An animation sequence is a sequence that is not associated with a song (or video, or other audio file). This is as opposed to a musical sequence.

There are some other differences between animation sequences and musical sequences:

- Animation sequences can contain loops, which musical sequences cannot;
- Tracks in an animation sequence can be of different lengths, while tracks in a musical sequence must be the same length;
- Various song-related tools such as the Beat Wizard, MIDI Wizard, VU Wizard and Tapper Wizard are only available for musical sequences.
- Generally speaking, only one musical sequence can be played at a time (although there is an exception to this, described in the help page on musical sequences), whereas many animation sequences can be played simultaneously.

To create an animation sequence in the Sequence Editor, use the New Animation dialog.
4.1.2 Musical Sequences

A musical sequence is a sequence that is associated with a song (or video, or other audio file), allowing you to synchronize the song with lighting effects. This is as opposed to an animation sequence.

There are some other differences between animation sequences and musical sequences:

- Animation sequences can contain loops, which musical sequences cannot;
- Tracks in an animation sequence can be of different lengths, while tracks in a musical sequence must be the same length;
- Various song-related tools such as the Beat Wizard, MIDI Wizard, VU Wizard and Tapper Wizard are only available for musical sequences.
- Generally speaking, only one musical sequence can be played at a time (although there is an exception to this, noted below), whereas many animation sequences can be played simultaneously.

The exception to the rule that "only one musical sequence can be played at a time" is that musical sequences put into any section of a show other than the musical section are, effectively, treated as animation sequences. That is, their associated songs will not be played, and more than one of them can be played simultaneously.
To create a new musical sequence in the Sequence Editor, use the New Musical Sequence dialog.

### Channels

A channel is a part of a sequence, representing a particular circuit on a particular controller, which you have lights hooked up to. The Sequence Editor can be used to assign effects to channels, to make the lights turn on and off, fade, shimmer, twinkle, and so forth.

Channels have several properties that define exactly which string of lights they relate to:

- Device type, which is the type of controller (for example, a Light-O-Rama controller or an X10 controller);
- Network, which is the COM port that this channel's controller is hooked up to the PC over;
- Unit, which is the unit ID of the controller, allowing different controllers to be distinguished from each other;
- Circuit, which represents one particular string of lights hooked up to the controller.

Not all device types have all of these properties - for example, X10 controllers have a unit ID, but no
circuit number. Please see the help pages on the various types of controllers for details.

Additionally, there is a "special" device type: a subsequence. A channel set up with this device type does not represent a strand of lights. Instead, it represents another sequence, that the main sequence can turn on and off at different points in time.

Channels also have names and colors associated with them. These have no effect on the way that your lights will look; they only effect how the sequence is displayed in the Sequence Editor. It could be convenient to set them up in meaningful ways. For example, you might want to name the channel associated with a string of red lights running through the bushes in your front yard as "Front Bushes (Red)", and set its color to some shade of red.

In the Sequence Editor, channels are represented as horizontal rows. On the left side of a row is a channel button, labelled with the name of the channel; on the right side is a grid showing what effects are assigned to the channel at what times. For example, the following sequence has six channels, and they are named, simply, "Channel 1" through "Channel 6". One of them ("Channel 4") has an effect: a fade up, from zero seconds to one second:

![A sequence with six channels - one on each row - and a fade up on the fourth channel](image)

To turn a channel on or off at a certain time, or do other effects such as fades or twinkles, select the effect that you want, and click on the cell or cells for the times that you want that effect to take place. See Editing Sequences Using the Keyboard and Editing Sequences Using the Mouse for more details on this.

Between the channel buttons and the grid is a thick grey vertical bar. You can change the size of the channel buttons by clicking and dragging this bar. Clicking the bar (without dragging) will hide the channel buttons entirely; clicking it again will make them reappear. You can also control whether channel buttons are displayed or hidden from the View menu, and from the standard toolbar, and set your default preference in the Display Preferences menu.

Clicking on a channel's button brings up the Channel Settings dialog. This allows control over various things like the channel's name, color, unit, and circuit:
The Channel Settings dialog

Right-clicking on a channel's button brings up a popup menu with various channel-related tools:

Channel buttons can be dragged up and down to rearrange their order. This has no effect on your lights; it only affects the order that they are displayed in the Sequence Editor.

When you play a sequence in the Sequence Editor, its channel button flashes with the color that you selected as it turns on and off; it will also fade up and down, shimmer, twinkle, and so forth, just as your lights will. If you do not wish to see the channel buttons change color during play, you can turn it off temporarily in the Play menu or the standard toolbar, or set your default preference in the Display Preferences menu.
The Channel Property Grid can be used to view and change many channels’ settings at once:

![The Channel Property Grid](image)

A channel can be in a single track, or shared among more than one track. By default, there is one track in a sequence, and all channels in the sequence are in that track. To share a channel between tracks, do not simply set up two different channels having the same unit number, circuit number, etcetera in the two tracks; this will have unexpected and undesired results, as the two different channels will compete with each other for control of the same circuit. Instead, share a channel by copying it to the other track. There are several ways to do this; see the help page on tracks for details.

For RGB devices, which can change colors, three separate channels (a red, a green, and a blue) can be grouped together into a single RGB channel.

For more detailed information on how to create and modify channels in the Sequence Editor, please see:

- Channel Buttons
- Channel Settings
- Channel Buttons’ Popup Menu
- The Channel Property Grid

### 4.1.4 RGB Channels

An RGB channel is a group of three channels - a red channel, a green channel, and a blue channel - representing a single pixel on an RGB device (which can change colors), such as a pixel on a Cosmic Color Ribbon. In the Sequence Editor, an RGB channel is represented by a black row in a sequence (as opposed to normal channels, which are represented by grey rows). Lighting effects on an RGB channel are represented in the row as colors:
A sequence with an RGB channel followed by several normal channels.

To the left of an RGB channel's button is a small button with red, green, and blue stripes. Clicking on this button will expand the view of the RGB channel so that its constituent red, green, and blue channels can also be seen (and clicking it again will collapse the view to hide those constituent channels):

The RGB channel's lighting effects can be modified by applying tools (such as Shimmer or Toggle or Fade Up) to its constituent channels, but they can also be modified directly by using the Color Fade tool on the RGB channel itself. This tool allows you to specify a start color and an end color; when applied to a time range in the RGB channel, it will cause that time range to gradually fade from the start color to the end color.

An important thing to note here, though, is that the colors displayed on your screen in the Sequence Editor are not necessarily the same colors that will appear on your actual RGB device, and in some cases may actually be very different. Different RGB devices may produce different colors when their constituent R, G, and B channels are sent the exact same intensities. So, you may have to experiment a bit to figure out colors as displayed in the Sequence Editor that wind up looking the way you want on your actual RGB devices.

Another tool which may be particularly useful for RGB channels is the Fill tool, which (on a normal channel) allows you to click an empty area and cause it to become a fade from the preceding intensity to the following intensity. For example, if you have a normal channel which has a fade up from 40 to 60, followed by the lights being off, followed by a fade down from 80 to 20, then applying the Fill tool to the area where the lights are off will cause that area to become a fade up from 60 to 80 (because the effect
preceding the empty area ended at intensity 60, and the effect following the empty area started at 80). On an RGB channel, the Fill tool will instead cause a color fade from the preceding color to the following color, hopefully allowing you to quickly set up smooth color transitions across several different colors.

The Chase and Repeat tools may also be of particular use on RGB channels. The Chase tool causes the lighting effects in a single channel (or RGB channel) to be applied through a range of following channels (or RGB channels), offset in time a bit with each passing row, so that the effect seems to be “chasing” through the channels (or RGB channels) as time passes. The Repeat tool causes one or more copies of the lighting effects in your selection to be applied immediately following your selection.

Other tools, such as Shimmer or Toggle or Fade Up, can also be applied to RGB channels. Doing so will cause the tool to be applied to each of the RGB channel's constituent channels. For example, applying the Fade Up tool, with intensities 0 to 100, to an RGB channel will cause each of the red, green, and blue channels to fade up from 0 to 100, thus making the RGB channel itself fade from black to white.

Such tools can also be directly applied to the constituent channels of an RGB channel (as opposed to the RGB channel itself), allowing for finer grained control over the behaviour of the RGB channel.

Clicking on an RGB channel's button will open the RGB Channel Settings dialog, allowing control over various settings such as the units and circuits of the constituent channels:

![RGB Channel Settings dialog](image)

Right-clicking on an RGB channel's button will open up a popup menu with various channel and RGB channel-related tools:
RGB channels can be added to a sequence in a few ways, all via the Channel/RGB Channel Button Popup Menu. First, the "Insert Device" menu item has options to insert a Cosmic Color Device or a generic RGB device, both of which will result in RGB channels being added to the sequence. Second, the "Insert RGB Channels" menu item will create new RGB channels. Third, existing regular channels can be converted to RGB channels via the "Convert to RGB Channel" menu item.

4.1.5 Timings

Timings are the times in a sequence at which you can command the lights to do various effects - to turn on, turn off, fade up, fade down, and so forth.

Timings are represented in the Sequence Editor by vertical grey lines. For example, the following sequence has timings every half a second, at 0.5 seconds, 1 second, 1.5, 2, 2.5, 3, and so forth:
Timings can be set to an effect by selecting the appropriate tool (such as the "Fade Up" tool) and clicking on the space (please see "Editing Sequences Using the Keyboard" and "Editing Sequences Using the Mouse" for details). For example, selecting the "On" tool and clicking the cell between 1 second and 1.5 seconds for Channel 2 results in:

```
The second channel has been turned on, between 1 second and 1.5 seconds
```

Timings do not have to be equally spaced (as they are in the above example). For example, the following sequence has timings at 0.37 seconds, 1 second, and 3.2 seconds:

```
A sequence with timings at 0.37 seconds, 1 second, and 3.2 seconds
```

**Timing Grids**

A set of timings is known as a "timing grid". A sequence can have more than one timing grid, with one being shown at a time (or, if the sequence has more than one track, one per track at a time). The timing grid that is currently shown can be changed by selecting from the "Timings" dropdown box on the Tracks and Timings Toolbar. There are two types of timing grids: fixed grids and freeform grids.

**Fixed Timing Grids**

In a fixed timing grid, each timing is the same length of time from the next timing. For example, a fixed timing grid might have a timing every second, or every tenth of a second.

The timings in a fixed timing grid cannot be moved, deleted, or added to.

**Freeform Timing Grids**

In a freeform timing grid, timings do not have to be equidistant. For example, a freeform timing grid
might have one timing at time 1.00 (i.e. one second), another half a second later at time 1.50, and another 2.2 seconds past that at time 3.70.

The timings in a freeform grid can be moved or deleted, and new timings can be added.

Creating, Deleting, and Modifying Timings

Timings can be automatically inserted into a sequence when it is created, in a variety of ways. For example, you can tell the Sequence Editor to insert timings every so often - for example every half second, or, for a musical sequence, insert timings based on the song itself using various tools like the Beat Wizard, VU Wizard, Tapper Wizard, and MIDI Wizard. If you tell it to insert timings every so often (such as every half second), it will give you the option to create them in a fixed timing grid or a freeform timing grid; if you tell it to use one of the tools, or not to insert timings, it will use a freeform timing grid. Please see the New Animation dialog and New Musical Sequence dialog for details.

These tools (such as the Beat Wizard and MIDI Wizard) can also be used after the sequence has been created, by selecting them from the Tools menu.
Timings in a freeform timing grid can be moved by clicking and dragging them. Or, if you wish, this behavior can be turned off by selecting "Lock Timings" in the Edit menu.

Timings can also be added, deleted, and resized in a variety of other ways:

- On the Edit menu:
  - Copy and paste timings
  - Insert multiple timings
  - Delete extraneous timings
  - Switch timing grid
- On the right-click context menu:
  - Copy timing
  - Paste timing at...
  - Paste timing at (centisecond)
  - Paste timing multiple
  - Insert timing at...
  - Insert timing at (centisecond)
  - Insert multiple timings
  - Delete timing at...
  - Delete selected timings
  - Resize timings to...
  - Resize timings to equal times
- Using the Tracks and Timings toolbar

### 4.1.6 Effects

Light-O-Rama allows you to make your lights behave in a variety of ways. In addition to simply turning them on and off, you can turn them on to varying levels of brightness, have them fade up or down, shimmer, or twinkle.

You can assign these effects to channels in a sequence using the Sequence Editor. There are various ways to apply the effects to a sequence; see Editing Sequences Using the Keyboard and Editing Sequences Using the Mouse for details. One simple way is to select the effect's tool from the Tools toolbar, and click on a cell or range of cells that you want to apply the effect to.

Most of these effects require that you use Light-O-Rama controllers. Although Light-O-Rama can control other types of devices (such as X10 controllers or digital IO cards), only "on" and "off" are supported in these non-LOR controllers.

- On, Off, and Set Intensity
- Twinkle
- Shimmer
- Fade Up and Fade Down
- Custom Fade/Intensity Twinkles and Shimmers
- DMX Intensity

Related to effects are the effect editing modes: background effects, foreground effects, and regular effects. These are not themselves effects, but are ways to use the Sequence Editor to turn effects on based upon the existing effects. For example, with background effects mode on, if some cells are selected and the "twinkle" tool is used, only the selected cells that are currently off will be changed to twinkles. The other cells - those that are on or at some intensity, have fades, shimmers, or twinkles, will remain unchanged.
On, Off, and Set Intensity

The "On" and "Off" effects will turn a string of your lights to their full brightness or completely off, respectively. Additionally, the "Set Intensity" effect allows you to specify a percentage of full brightness - for example, 50% bright.

In the Sequence Editor, an "on" effect is displayed as a cell having the color that you chose for the channel, and an "off" effect is displayed as a light grey cell. "Set intensity" is displayed as a color somewhere in between the two (depending upon the intensity chosen). For example, the following picture shows a sequence with two channels (one red and one green), each being on for the first half second, off for the next, then 50% on, then off again, then 20% on, and then off again:

![Different levels of intensity](image)

Alternatively, you can choose to have varying intensities displayed not by varying colors, but by filling in the cells to varying degrees. This is done by selecting "View Fades as Ramps" from the View menu (or, to make this your default, by setting it in the Display Preferences dialog of the Edit menu). For example, here is the exact same sequence, but this time with "View Fades as Ramps" turned on:

![The same sequence, with "View Fades as Ramps" turned on](image)

The brightness used by the "Set Intensity" tool can be controlled by the Intensity Tool Settings dialog:

![The Intensity Tool Settings dialog, with 70% intensity selected](image)

Any of the ten values listed on the Intensity Tool Settings dialog can be changed, by clicking its "Edit" button to open the Intensity Tool Options dialog.

In the Tools toolbar, the "On" tool's button shows a green square, the "Off" tool's shows a red
square, and the "Set Intensity" tool's shows three green columns of varying heights. Additionally, there is a "Toggle" tool, which can be used to turn any cell that is off to on, and any other cell to off. The "Toggle" tool's button shows two blue squares, one in front of the other. Finally, the Intensity Tool Settings dialog's button looks like the Set Intensity button, but with a question mark in front of it:

```
[On]  [Off]
[Set Intensity]  [Toggle]
[Intensity Settings]
```

Intensity-related toolbar buttons

"Set Intensity" is only supported on Light-O-Rama controllers. If it is used on a different device type, any intensity greater than 10% is considered "on", and lesser percentages are considered "off".

**Twinkle**

The "Twinkle" effect causes your lights to quickly vary between on and off.

The difference between "Twinkle" and "Shimmer" is that twinkle is more random: Two different strings of lights that are both told to shimmer at the same time will quickly turn off and on in sync with each other; if they are instead told to twinkle, they will still quickly turn off and on, but not in sync with each other.

In the Sequence Editor, twinkle is represented with crossed diagonal hatching:

```
Twinkle toolbar button
```

Twinkle is only supported on Light-O-Rama controllers. If it is used on a different device type, it will simply turn the lights on to their full brightness.

The Twinkle tool itself twinkles the lights at full intensity. You can also twinkle the lights while fading up or fading down, or at some intensity other than full intensity, by using a custom tool instead of the Twinkle tool.
Shimmer

The "Shimmer" effect causes your lights to quickly vary between on and off.

The difference between "Shimmer" and "Twinkle" is that twinkle is more random: Two different strings of lights that are both told to shimmer at the same time will quickly turn off and on in sync with each other; if they are instead told to twinkle, they will still quickly turn off and on, but not in sync with each other.

In the Sequence Editor, shimmer is represented with diagonal lines:

![Sequence Editor with shimmer]

Two channels, each with shimmer between 1 second and 2 seconds

On the Tools toolbar, the Shimmer tool is represented by a button with wavy lines:

![Shimmer toolbar button]

Shimmer is only supported on Light-O-Rama controllers. If it is used on a different device type, it will simply turn the lights on to their full brightness.

The Shimmer tool itself shimmers the lights at full intensity. You can also shimmer the lights while fading up or fading down, or at some intensity other than full intensity, by using a custom tool instead of the Shimmer tool.

Fade Up and Fade Down

The fade tools will make the brightness of your lights gradually change, either brighter or less bright. Both the starting brightness and the ending brightness can be specified, anywhere from 0% to 100%, as can the length of time that it takes to fade from one to the other.

In the Sequence Editor, fades are represented by gradually varying colors, between light grey (representing 0%) and the color that you assigned to the channel (representing 100%). For example, the following picture shows a sequence with four channels (two red and two green), all fading over the course of the first second of the sequence. The first channel fades up from 0% to 100%; the second from 25% to 100%; the third fades down from 100% to 0%; the fourth from 100% to 25%:
Alternatively, you can choose to have fades displayed not by varying colors, but by filling in the cells to varying degrees. This is done by selecting "View Fades as Ramps" from the View menu (or, to make this your default, by setting it in the Display Preferences dialog of the Edit menu). For example, here is the exact same sequence, but this time with "View Fades as Ramps" turned on:

The starting and ending brightnesses used by the Fade Up and Fade Down tools can be controlled via the Fade Tool Settings dialog:

Any of the ten values on the Fade Tool Settings dialog can be changed, by clicking its "Edit" button to open up the Fade Tool Options dialog.

On the Tools toolbar, the Fade Up and Fade Down tools are represented as blue up and down arrows in front of green triangles. The Fade Tool Settings dialog's button looks like that of the Fade Up tool, but with a question mark in front of it:
Fade-related toolbar buttons

Fades are only supported on Light-O-Rama controllers. If one is used on a different device type, it will simply immediately turn the lights completely on or completely off, based on the ending brightness of the fade (fades ending at greater than 10% brightness are considered "on", and others are considered "off").

Custom Fade/Intensity Twinkles and Shimmers

Only one of the Twinkle, Shimmer, Fade Up, Fade Down, and Set Intensity tools can be selected at any given time. They can therefore be used, for example, to twinkle the lights, or to fade the lights up, but not both. However, you can still twinkle the lights while fading them up, in another way: By using the Custom tool.

On the Tools toolbar, the Custom tool is shown as a large yellow star. To the right of it are five buttons, which are enabled when the Custom tool is selected (and disabled if any other tool is selected). These five buttons allow you to select "twinkle" or "shimmer", and "set intensity", "fade up", or "fade down". Each of these five looks like the corresponding button for the base effect (such as "twinkle"), with a smaller yellow star in its lower right corner.

For example, to select a tool that will let you twinkle the lights while fading them up, select the yellow star "Custom" button. The five custom option buttons will then become enabled; select the "Custom Twinkle" button and the "Custom Fade Up" button.

The regular fade tool settings apply to faded twinkles and shimmers, and the regular set intensity tool settings apply to set intensity twinkles and shimmers.

If you have an older Light-O-Rama controller, it may need a firmware upgrade before it will be able to twinkle or shimmer while fading, or at any intensity other than full intensity. If a custom twinkle or shimmer is sent to such a controller that does not have the appropriate firmware upgrade, it will react as it would to a "standard" twinkle or shimmer - i.e. it will twinkle or shimmer at full intensity.

A twinkling fade up followed by a shimmering fade down
DMX Intensity

The intensity for most effects - such as fades - can vary between zero and 100. The DMX intensity effect, however, can vary between zero and 255.

This is useful for sending DMX commands to DMX devices via a Light-O-Rama controller: the DMX protocol supports intensities from zero to 255, and so this effect allows Light-O-Rama to send any of the 256 possible DMX intensities to a device, instead of only 101 of them. However, please note that not all Light-O-Rama controllers support this functionality; DMX intensity events sent to a controller that does not support them will simply be ignored. To check whether any particular controller supports it, please refer to that controller's documentation.

The DMX intensity tool is not enabled in the Sequence Editor by default - that is, by default, the Sequence Editor will not show a toolbar button for the DMX intensity tool, nor a menu item in the Tools menu, nor allow a keyboard shortcut for it. To enable these things, make sure that "Allow DMX Editing" is checked in your DMX Preferences.

When DMX editing is enabled and the DMX intensity tool is selected, a dialog will appear allowing you to set the exact DMX intensity that will be used whenever the tool is used on a cell or group of cells:

The intensity can be set in this dialog in several ways: by moving the slider, by typing in the text box, by using the up/down buttons next to the text box, or by selecting any of the preset intensity buttons. Additionally, the values of the preset buttons can be changed by clicking the "Edit" button:
Background and Foreground Effects

Background and foreground effects are not themselves effects, but are rather modes of editing effects in the Sequence Editor. These modes affect the behavior of tools (such as "Twinkle" and "Fade Up") in the following manner:

If background effects have been turned on, the tool only applies to those selected cells that are completely off (that is, at intensity zero for their entire duration).

If foreground effects have been turned on, the tool only applies to those selected cells that are not completely off.

If neither background effects nor foreground effects have been turned on, the tool will apply to all selected cells. This is referred to as "regular effects".
Some examples:

Before a background fade up

After a background fade up

Before a foreground fade up

Before a foreground fade up

© 2010 Light-O-Rama, Inc.
After a foreground fade up

Background and foreground effects can be turned on and off in several ways:

- Via the Tools Menu ("Tools/Background Effects" and "Tools/Foreground Effects");
- Via the Tools toolbar;
- Via the keyboard:
  - The "A" key ("bAckground") will cause the next keystroke (and only the next keystroke) to use background effects mode rather than whatever mode is currently selected;
  - "Shift-A" will cause background effects to be turned on until it is explicitly turned off;
  - Similarly, "O" and "Shift-O" ("fOreground") for foreground effects, and "E" and "Shift-E" ("rE gular") for regular effects (i.e. for turning off both background and foreground effects).

These tools are also available via the effect grid's right-click popup menu, for single-shot use, like the other tools (for example "on", "twinkle", and "fade up").

### 4.1.7 Loops

An animation sequence (but not a musical sequence) can contain loops. When the Show Player or the Sequence Editor plays a sequence with loops, when the end of a loop is reached, the sequence will go back to the beginning of the loop. This will happen a certain number of times (which you specify), after which the sequence will continue on past the end of the loop.

Each time through a loop, you can have the sequence speed up, slow down, or remain at the same speed.

A sequence can contain many loops. Loops can be nested - that is, a loop can contain other loops.

In the Sequence Editor, loops are shown in a white row, above the grey rows representing channels. For example, the following picture shows a sequence with a loop starting at 1 second and ending at 2 seconds:

![A sequence with a loop, starting at 1 second and ending at 2 seconds](image)

More than one loop can be in a sequence. For example, here is the same sequence, with a second loop added, from 2.5 seconds to 3 seconds:
Two loops in a sequence

Loops can contain loops; this is represented by having multiple rows of loops. For example, in the following picture, a second loop level has been added, and a loop was put into it from 0.5 seconds to 3 seconds, thus containing both of the loops of the lowest loop level:

A loop containing loops

To use loops in an animation sequence, you first must use the "Turn on Loops" option in the Edit menu of the Sequence Editor (or, alternatively, specify that you want to use loops when you create the sequence in the New Animation dialog).

To create a loop, select the appropriate time range and the loop level, either by clicking and dragging the mouse in the white loop rows or by using the keyboard. The Loop Context menu will pop up:

The Loop Context menu

After selecting "Insert Loop". You will then be prompted for how many times the loop should loop back, and then whether (and by how much) it should increase, decrease, or remain the same speed in each pass through the loop:
Inserting a loop: How many times should it loop back?

Inserting a loop: Should it speed up or slow down?

Clicking on an existing loop also brings up the Loop Context menu, but with additional menu items, such as displaying information about the loop and removing the loop:
The Loop Context menu, on an existing loop

Several of these menu items can also be accessed by clicking on the loop level's button (specifically, the ones dealing with loop levels, such as "Add Loop Level Above" and "Remove Loop Level").

4.1.8 Tracks

A sequence can contain multiple tracks, with each track being a group of channels. A channel can be in one track, or can be shared among multiple tracks. For example, the following sequence has two tracks, and two channels, with both of the channels being in both of the tracks:

Notice that the two tracks have different timings than each other - in this case, the top track has timings every tenth of a second, and the bottom track every half a second.

All sequences are initially created with a single track. There are a few ways to add another track using the Sequence Editor:

- In the Edit menu:
  - "Add New Track" will add a track with entirely new channels.
  - "Duplicate Track" will add a new track and share all of the channels of the currently selected track with it.
- On a channel button's right-click popup menu:
  - "Copy to New Track" will add a new track and copy the channel to it, while also giving you the option to automatically insert new channels as well.
  - "Move to New Track" does much the same, except that the channel will be moved, not copied, to the new track.
- Using the Tracks and Timings toolbar

**Important:** To share a channel between tracks, make sure to use one of the above duplication or copying commands. Do not simply set two different channels in different tracks to the same unit ID, circuit number, et cetera. Doing that will have unexpected and undesired results, as the two different channels compete for control over the same physical circuit.

If a sequence has more than one track, each will be displayed with a preceding track bar. The bar will
be labeled with the track’s number within the sequence (the track at the top is track #1, the next one down is track #2, and so forth). If the track is given a name (such as by "Change Track Name" of the Edit menu), it will also be displayed on the bar:

Clicking on a track bar brings up the track bar’s popup menu, containing various track-related functions (such as renaming the track, moving the track up or down in the sequence, duplicating the track to a new track, or deleting the track):

If the "Hide Track" item on that popup menu is selected, the track will no longer be displayed. However, the track's track bar still will be, and will indicate that the track has been hidden; clicking on it again to bring up the popup menu will now allow you to "Show Track":

© 2010 Light-O-Rama, Inc.
4.1.9 Animations

Each sequence that you create may have an animation associated with it. This is a simple drawing of the layout of the lights that will be used in the sequence. Note that this “animation” should not be confused with “animation sequence”. Both animation sequences and musical sequences can have animations.

When you play a sequence using the Sequence Editor, you can also watch the sequence's animation. The drawing will change as if it were the lights that the sequence controls - that is, parts of the drawing will turn on and off, fade up and down, twinkle, and shimmer, just as the sequence commands.

A sequence's animation can be assigned a background image (for example, a photo of your house), which you can draw the lights on top of.

To view or edit a sequence's animation in the Sequence Editor, select "Animation" from the View menu, or click the “View Animation” button in the Standard toolbar.

For details on how to create and modify animations, please see the Animator.
4.1.10 Subsequences

A subsequence is a sequence that is used as a part of another sequence (its "parent sequence", or "the main sequence"). The subsequence is represented in the main sequence as a channel, with a special device type of "Sequence", as opposed to "Light-O-Rama controller", "X10 controller", or so forth.

For example, the following Channel Settings dialog shows a channel that is a subsequence:

The Animator, with lights drawn on top of a background photo of a house
A channel for a subsequence can be turned on and off, using the Sequence Editor, in the same ways that other channels can be. When the channel in the main sequence is turned on, the subsequence will begin playing, from its beginning. It will continue playing for as long as the channel remains on; if play of the subsequence reaches its end before the channel has been turned off in the main sequence, the subsequence will simply loop back to its beginning and continue playing.

When the channel in the main sequence is turned off, the subsequence will stop playing. If the channel is subsequently turned back on, the subsequence will start playing again, from its beginning (not from the last point that it left off at).

If you have the Animator open, it will not show the play of your subsequence. Only the events in your main sequence will be displayed. This only affects the display in the Animator; your actual lights will reflect play of both the main sequence and its subsequences.

**Tip:** Do not set up the same physical unit and circuit to be a channel in a sequence and a channel in a subsequence of that sequence (or two channels in two different subsequences of a sequence). Doing so will likely cause unexpected and undesired results, as the two channels compete for control over the same physical circuit.

**Tip:** If you have a sequence open in the Sequence Editor, and it contains a subsequence, and you play the main sequence, and then modify and save the subsequence, your changes to the subsequence will not be reflected if you then play the main sequence again. The subsequence is loaded into the main sequence only the first time that the main sequence is played, after having been opened (this is so that play is not slowed down during your shows). To see your subsequence changes reflected in the play of the main sequence, close and reopen the main sequence.

### 4.1.11 Windows Shell Commands

When a sequence is started, Light-O-Rama can optionally also execute an arbitrary Windows command, running any program that you specify.
For example, some people broadcast the songs that play during their shows over radio, and would like
the name of the song to be broadcast along with it, using the RDS ("Radio Data System") protocol,
allowing people with RDS-enabled radios to see the name of the song that they are listening to. RDS is
not directly supported by Light-O-Rama, but you could set up your musical sequences so that,
whenever one of them is played, Light-O-Rama will tell Windows to tell your RDS program to broadcast
the name of the song for that sequence.

To set up a sequence to execute a Windows command, select "Windows Command" from the
Sequence Editor's Edit menu. After that, whenever that sequence is played (either by the Sequence
Editor or the Show Player), the command will be executed.

Note, though: If the Show Player is running when you change the command associated with a
sequence, you may have to stop and start the Show Player in order for this change to be picked up.

This feature is available only for the Advanced feature level.

Sharing Sequences between Computers, and Security

The ability to execute an arbitrary Windows command is very powerful, and even potentially harmful - for
example, you could execute a command which will install spyware on your machine. Therefore, it would
not be wise to execute whatever Windows command another person chose, unless you are absolutely
sure that the command they chose is safe and harmless.

For this reason, Light-O-Rama imposes a security measure: The command to be executed is not stored
directly in the sequence file itself. Instead, the sequence file contains a key for an entry in another file
("cmdmap.lcm", located in your Light-O-Rama sequences directory); that entry specifies the Windows
command to be executed. If that file doesn't contain an entry for that key, Light-O-Rama simply does
not execute any command when the sequence plays.

So, you can use sequences created by other people without fear of spyware or other harmful programs,
as long as you continue to use your own version of cmdmap.lcm, not a copy of the other person's
cmdmap.lcm.

However, this means that if you yourself use Light-O-Rama on two separate machines - for example one
to create your sequences on, and another to run your shows on - you will have to copy your "real"
version of cmdmap.lcm from one machine to the other if you want your sequences to execute Windows
shell commands. You would typically do this at the same time that you copy your sequences
themselves over from one machine to the other.

4.2 Shows

What is a Show?

A show is a collection of sequences, to be played as a set. After creating sequences with the
Sequence Editor, you can build a show from them using the Show Editor. Shows can then be
scheduled to play at certain times, using the Schedule Editor, and are then actually played by the
Show Player.

Assuming that your license level is at least Basic Plus, you can also cause a show to be played on
demand, without scheduling it, via the Light-O-Rama Control Panel.
There are six different parts to a show, each of which consists of sequences:

- **The Background Section**
- **The Startup Section**
- **The Animation Section**
- **The Musical Section**
- **The Interactive Section**
- **The Shutdown Section**

Each of these parts is optional. For example, a show can be built having only a musical section and a shutdown section.

By default, when a show is being played in the Show Player, any given sequence in the show will not be loaded until when it is about to be played for the first time. Depending upon the size of the sequence and the power of the computer, it may take a human-noticeable amount of time to load a sequence; if so, this may cause an undesired delay between sequences, the first time they are played. So, optionally, you can choose to preload all sequences before any of them are played.

Additionally, if your Light-O-Rama software license is for the Advanced feature level, you can modify exactly how your show will start up - for example, immediately at its scheduled start time, or after a certain circuit on a certain Light-O-Rama controller has been triggered (for example, by someone hitting a "start" button). See "Show Startup Options" for details.

Note that the duration of a show is not part of the show itself; rather, it is determined by the schedule.

**The Background Section**

When a show is started (at a time determined by the schedule), all of the sequences in the show's background section will start playing, simultaneously. When such a sequence reaches its end, it will simply loop back to its beginning and keep playing. All of these sequences will continue playing in this way until the show ends (also at a time determined by the schedule).

If your Light-O-Rama software license is for the Advanced feature level, you additionally have control over whether this section (and/or the rest of your show) starts immediately at its scheduled time, or upon an input trigger (for example, when someone hits a "start" button). See "Show Startup Options" for details.

Only animation sequences can be used in the background section of a show.
The Startup Section

When a show is started (at a time determined by the schedule), the sequences in its startup section will be played, one at a time, in order. After they all have finished, the main portion of the show will begin, consisting of the animation section and the musical section.

You can control whether or not sequences in this section will automatically turn their lights off when they reach their end by setting the "Turn used lights off at the end of each sequence" checkbox.

If your Light-O-Rama software license is for the Advanced feature level, you additionally have control over whether this section (and the rest of your show) starts immediately at its scheduled time, or upon an input trigger (for example, when someone hits a "start" button). See "Show Startup Options" for details.
The startup section in the Show Editor, with three sequences

The Animation Section

After a show’s startup section has completed, its animation section will begin (as will its musical section).

Sequences in the animation section can be played concurrently or sequentially. If you choose to play them sequentially, the first in the list (as displayed in the Show Editor) will be played, and when it finishes, the next will be played, and so forth. After all of them have been played, the first in the list will be played again. This pattern will continue until the show is shut down (at a time determined by the schedule).

If they are played concurrently, all of them will be played at once, and whenever one reaches its end, it will simply loop back to its beginning and keep playing. Again, this will continue until the show is shut down.

You can control whether or not sequences in this section will automatically turn their lights off when they reach their end by setting the “Turn used lights off at the end of each sequence” checkbox.

Only animation sequences can be used in the animation section of a show.
The animation section in the Show Editor, with five sequences, played sequentially

The Musical Section

After a show’s startup section has completed, its musical section will begin (as will its animation section).

Only one sequence from the musical section will play at a time. They can be played in the order listed in the Show Editor, or shuffled randomly. If shuffled randomly, you can also control two different aspects of how shuffling is done: Whether or not a sequence is allowed to be played a second time before all sequences have played once, and whether or not a sequence is allowed to play twice in a row (this latter does not apply if you have only one sequence in the musical section - it will definitely be played back-to-back).

Play will continue until the show is shut down (at a time determined by the schedule). If the sequences are to be played in the order listed, and the end of the list is reached before the show is to shut down, play will loop back to the first sequence in the list.

Optionally, a “cleanup sequence” can also be specified in the musical section. If so, that sequence will be played immediately after the completion of any sequence in the musical section, before the next one begins. Also optionally, a delay can be specified between songs.
You can control whether or not sequences in this section will automatically turn their lights off when they reach their end by setting the "Turn used lights off at the end of each sequence" checkbox.

The musical section in the Show Editor, with several sequences, shuffled, with a delay and a cleanup sequence

The Interactive Section

Some Light-O-Rama controllers can be used not only to control lights, but also to accept input from people, causing Light-O-Rama to play sequences on demand. For example, you could have a big red button as part of your display, which, when pressed, will cause Light-O-Rama to start playing a particular song or songs.

This is controlled through the interactive section of the show. You can use this tab in the Show Editor to specify what sequences are to be played when which inputs are triggered. Please see the separate page on interactive groups for details.

Note that, unlike for the other sections of the show, the Show Editor's "Interactive" tab actually lists groups of sequences, rather than directly listing sequences. Again, please see the page on interactive groups for details on how to create and modify these groups of sequences.

You can control whether or not sequences in this section will automatically turn their lights off when
they reach their end by setting the “Turn used lights off at the end of each sequence” checkbox, but unlike in other sections of the show, this setting is controlled individually for each interactive group, rather than for the section as a whole.

The Shutdown Section

When the end of a show is reached (at a time determined by the schedule), its animation section and musical section will end, and its shutdown section will begin. Sequences in the shutdown section will play, one at a time, in the order listed in the Show Editor. After they all have completed, the show is truly finished.

You can control whether or not sequences in this section will automatically turn their lights off when they reach their end by setting the “Turn used lights off at the end of each sequence” checkbox.
The shutdown section in the Show Editor, with two sequences

Show Startup Options

If your Light-O-Rama software license is for the Advanced feature level, you have more control over exactly how your show will start up:

- Immediate startup
- Triggered startup
- Immediate background startup

To choose which way you want your show to start, select the "Options" button at the top of the Show Editor. This will bring up the following dialog, which has a "Startup Type" section where you can choose which way the show will start:
Immediate Startup

In immediate startup mode, your show will begin immediately at its scheduled start time.

This is equivalent to the same way that shows always started in earlier releases of Light-O-Rama.

Triggered Startup

In triggered startup mode, your show will start when a specified circuit on a specified Light-O-Rama controller is triggered (as long as it is triggered during the show's scheduled run time). For example, you could hook up a big red button labeled "Start the Show" to a controller.

Immediate Background Startup

In immediate background startup mode, your show's Background section will start immediately at the show's scheduled start time, but the rest of the show will not start until a specified circuit on a specified Light-O-Rama controller is triggered (as long as it is triggered during the show's scheduled run time).

Sequence Loading Options

By default, when a show is being played in the Show Player, any given sequence in the show will not be loaded until when it is about to be played for the first time. Depending upon the size of the sequence and the power of the computer, it may take a human-noticeable amount of time to load a sequence; if so, this may cause an undesired delay between sequences, the first time they are played. So, optionally, you can choose to preload all sequences before any of them are played. To do so, click on the "Options" button in the Show Editor's toolbar, and then select "Sequences are loaded before any are played" from the "Sequence Loading" section of the options dialog:
Some Light-O-Rama controllers can be used not only to control lights, but also to accept input that can be used to trigger a sequence or sequences. For example, your display might have several buttons for people to press, each of which will cause Light-O-Rama to play some particular song on demand.

This is controlled through the Interactive Section of a show. Unlike the other sections of a show, the Show Editor’s “Interactive” tab displays not sequences, but groups of sequences, known as “interactive groups”. Each group matches individual circuits on individual controllers with individual sequences to be played when those circuits are triggered.

Only one musical sequence can be playing at any given time. Therefore, if a musical sequence from an interactive group is triggered, any musical sequence that happens to already be playing will be stopped (for one exception to this, see the “Jukebox” type of interactive group, below).

- **Types of Interactive Groups**
  - Jukebox
  - Soundboard
  - Magic Toy
- **Choosing Sequences for a Group**
Types of Interactive Groups

When you click the large "+" button, to add a new interactive group to the show, you will then be prompted to choose the type of interactive group to add:
Choosing the type of a new interactive group

There are three types of interactive groups:

- **Jukebox**
- **Soundboard**
- **Magic Toy**

After choosing which type of interactive group you want, you will be given a choice of which sequences to put in the group.

**Jukebox**

"Jukebox" interactive groups allow you to define a group of sequences, each hooked up to be triggered by an individual circuit on some LOR controller, such that only one sequence in the group can be playing at any given time, and if one already is playing when another is triggered, the first will continue playing uninterrupted, and the trigger will be ignored.

If you assign more than one sequence to a single circuit in a single jukebox, then whenever that circuit is triggered, the “next” sequence in the list, round-robin, will be played.
Both musical sequences and animation sequences can be placed into a jukebox interactive group.

**Soundboard**

"Soundboard" interactive groups are similar to jukebox interactive groups in that only one sequence in the group can be playing at any given time. However, unlike jukebox interactive groups, triggering a sequence while another sequence from the group is currently playing will cause the playing sequence to stop, and the triggered sequence to start.

If you assign more than one sequence to a single circuit in a single soundboard, then whenever that circuit is triggered, the "next" sequence in the list, round-robin, will be played.

Both musical sequences and animation sequences can be placed into a soundboard interactive group.

**Magic Toy**

"Magic toy" interactive groups allow you to set up a group of sequences such that many of them can be started simultaneously by a single trigger. Any sequences already playing from the group will be stopped when the new set is started.

Only animation sequences (as opposed to musical sequences) can be placed into a magic toy interactive group.

**Choosing Sequences for a Group**

After you choose the type of your new interactive group, or upon editing an existing group, you will be shown a list of the triggers for the group:
When you add a new trigger to this list (by clicking the large "+" button) or edit an existing trigger, you will be given a choice of which sequences are assigned to the trigger, and which circuit on which unit of which network triggers them. You can also assign a name to the trigger.
4.3 Schedules

What Is a Schedule?

The schedule is at the top of the Light-O-Rama schedule/show/sequence hierarchy:

- The schedule is created and modified by the Light-O-Rama Schedule Editor, and played by the Light-O-Rama Show Player.
- It consists of shows, which are created and modified by the Light-O-Rama Show Editor. The schedule schedules these shows to be played at certain times.
- Shows consist of sequences, which are created and modified by the Light-O-Rama Sequence Editor.
- Sequences are composed of commands to be sent to your lights, producing various lighting effects.

The schedule has two parts: the weekly schedule and the calendar schedule. The weekly schedule contains information on shows that should be played on a recurring, weekly basis - for example, every Wednesday night from 7:00 PM to 10:00 PM. The calendar schedule contains information on shows that should be played once, at a specific date and time.

When the Light-O-Rama Show Player looks at the schedule to decide whether a show should be played, it first checks the calendar schedule to see if it has any shows scheduled for the current date and time. If there are, the Show Player will play that show. Otherwise, the Show Player will
Example

Suppose you have a single show which you want to play every Friday and Saturday night, from 7:00 PM to 10:00 PM, except for Christmas Eve (when you want it to run from 5:00 PM to 11:00 PM) and Christmas Day (when you want it to run from 8:00 AM to 2:00 PM). Then you would put the Friday and Saturday shows into the weekly schedule, and the Christmas Eve and Christmas Day shows in the calendar schedule. The Light-O-Rama Show Player would then follow the weekly schedule on every day except Christmas Eve and Christmas Day, when it would then follow the calendar schedule.

Considerations

- Unlike the Show Editor, which can be used to create many shows, and the Sequence Editor, which can be used to create many sequences, the Schedule Editor only maintains a single schedule, and the Show Player only uses that single schedule.
- The Show Player will not play any scheduled shows unless it is started and scheduled shows are enabled, via "Enable Schedule" in the Light-O-Rama Control Panel.
- After modifying your schedule in the Schedule Editor, make sure to save it. Changes to your schedule will not be picked up by the Show Player until the schedule has been changed.

4.3.1 The Weekly Schedule

The weekly schedule is part of the schedule, saying which shows should be played when. The other part of the schedule is the calendar schedule.

The difference between these two parts of the schedule is that the weekly schedule allows you to specify shows that should be played by the Light-O-Rama Show Player on a recurring, weekly basis, while the calendar schedule allows you to specify shows that should be played by the Show Player once, at a specific date and time. For example, the weekly schedule would be used to have a show run every Thursday between 5:00 PM and 10:00 PM, while the calendar schedule would be used to have a show playing specifically on Christmas Eve.

Both parts of the schedule are created and modified using the Light-O-Rama Schedule Editor, and shows in them are played at the scheduled times by the Light-O-Rama Show Player (assuming that "Enable Schedule" has been turned on in the Light-O-Rama Control Panel). The Show Player, when deciding whether a show should be played, will first check the calendar schedule, and only play a show from the weekly schedule if none is scheduled for the current date and time in the calendar schedule.

The following picture shows the weekly schedule, as displayed in the Schedule Editor, with two different shows scheduled:

- "Weekday Show.lss", run Mondays to Thursdays from 5:00 PM to 9:00 PM, and Fridays 5:00 PM to 11:00 PM;
- "Weekends.lss", run Saturdays from 1:00 PM to 11:00 PM, and Sundays from 1:00 PM to 9:00 PM.
The weekly schedule, as displayed in the Schedule Editor, with some scheduled shows

For details on creating and modifying the weekly schedule, please see the Schedule Editor.

4.3.2 The Calendar Schedule

The calendar schedule is part of the schedule, saying which shows should be played when. The other part of the schedule is the weekly schedule.

The difference between these two parts of the schedule is that the weekly schedule allows you to specify shows that should be played by the Light-O-Rama Show Player on a recurring, weekly basis, while the calendar schedule allows you to specify shows that should be played by the Show Player once, at a specific date and time. For example, the weekly schedule would be used to have a show run every Thursday between 5:00 PM and 10:00 PM, while the calendar schedule would be used to have a
show playing specifically on Christmas Eve.

Both parts of the schedule are created and modified using the Light-O-Rama Schedule Editor, and shows in them are played at the scheduled times by the Light-O-Rama Show Player (assuming that "Enable Schedule" has been turned on in the Light-O-Rama Control Panel). The Show Player, when deciding whether a show should be played, will first check the calendar schedule, and only play a show from the weekly schedule if none is scheduled for the current date and time in the calendar schedule.

The following picture shows the calendar schedule, with a show named "Christmas Eve.lss" scheduled to be run on December 24, 2007 from 5:00 PM to 11:00 PM:
For details on creating and modifying the calendar schedule, please see the Schedule Editor.

4.4 Hardware

Light-O-Rama can control your lights via several different kinds of hardware controllers. Primary among these, of course, are Light-O-Rama controllers, but all of the following types of controllers can be used:

- Light-O-Rama controllers
- Dasher controllers
- Digital IO cards
- BSOFT digital IO cards
- X10 controllers

Most lighting effects (such as fading, twinkling, and shimmering) are only supported on Light-O-Rama controllers. Other controllers can only be turned on (to full brightness) or off.

When a channel is created in a sequence using the Sequence Editor, the kind of controller (known as "device type") can be assigned to it in a couple of ways:

- In the Channel Settings dialog, accessible by left-clicking the channel's button or by selecting "Change Channel Settings" on the channel's right-click popup menu;
- Via the Channel Property Grid, accessible by selecting "Channel Property Grid" in the Tools menu.

The Channel Settings dialog is most useful for changing a single channel, while the Channel Property Grid is more useful for changing many channels at once.
4.4.1 Light-O-Rama Controllers

Light-O-Rama allows your computer to control your lights via a variety of hardware controllers. Primary among these are Light-O-Rama controllers. Other kinds of controllers can be used, but most lighting effects (such as fading and twinkling) are only supported on Light-O-Rama controllers.

Some Light-O-Rama controllers can also act as input triggers, allowing you to start particular sequences on demand (such as when a person pushes a button).

Unit IDs

Each Light-O-Rama controller is assigned a unit ID. A unit ID is an identifier for the controller, and is two characters long, with each character being a digit (0-9) or a letter from A to F. For example, 37, 25, 4B, C8, and DA are all valid unit IDs. Some such combinations are reserved, though, and should not be used for as a unit ID. Specifically, 00 and F1 through FF are not valid unit IDs.

Controllers will only react to lighting commands that are intended for their own unit ID; if two controllers on the same network have the same unit ID, both will react simultaneously to the same commands.

The unit ID of a controller is set in one of two ways, depending upon the type of controller:

- Most controllers have physical switches on them that allow you to set the unit ID by moving the switches.
- Otherwise, the Hardware Utility can be used to select a unit ID for controllers without such switches.

It is generally a good habit to assign your unit IDs sequentially starting at 01. This is not necessary,
but it will speed up some maintenance such as configuring and testing your controllers in the
Hardware Utility.

Circuit IDs

Within a controller, each string of lights is assigned a specific circuit ID. This allows Light-O-Rama
to make different lights do different effects at the same time, using the same controller.

Standalone Mode and Computer Controlled Mode

Light-O-Rama controllers can be set up in standalone mode, in which a sequence is downloaded to
them in advance via the Hardware Utility, or hooked up to your computer via a COM port, in which
case the Light-O-Rama Show Player will send them lighting commands (during scheduled shows),
or the Light-O-Rama Sequence Editor will (on demand for a single sequence).

A controller in standalone mode can also send lighting commands to other controllers that are
hooked up to it via phone lines or data lines, similarly to the way that the Show Player or Sequence
Editor would. Therefore, in standalone mode, a sequence only needs to be downloaded (via the
Hardware Utility) to a single controller; the other controllers hooked up to it will receive their
commands from it.

Only one source of lighting commands should be present in any group of controllers that are hooked
up to each other - either the Show Player, the Sequence Editor, or a single controller with a
downloaded sequence. Having more than one source of commands will cause unexpected and
undesired results, as lighting commands will be missed or garbled.

Light-O-Rama Networks

The Show Player and Sequence Editor can control up to four different networks of Light-O-Rama
controllers, each hooked up over a different COM port. These networks are referred to as
"Regular" (which is the default), "Aux A", "Aux B", and "Aux C".

One main use of multiple networks is for displays with very large numbers of controllers; they enable
more lighting commands to be sent out at a single time. They also allow you to set up a sort of star
network centered on your PC, rather than a long daisy chain of controllers; both of these may make
such sequences perform more smoothly.

Another use is for displays whose controllers are hooked up using wireless communications, via a
Light-O-Rama Easy Light Linker. Wireless communications has a lower top speed than wired, but
using multiple wireless networks allows commands to be sent over all of them simultaneously. So,
depending upon how many controllers you have and how many lighting effects you send them during
your show, using multiple wireless networks could make your show perform more smoothly than
using a single wireless network.

It is simplest, though, to just use a single Light-O-Rama network, and in many situations, this is
perfectly sufficient.

The COM ports represented by each of the networks can be set via the Network Preferences dialog
of the Edit menu of the Sequence Editor. For example, the following picture shows COM3 assigned
to the Regular network, COM4 to Aux A, COM5 to Aux B, and leaves the Aux C network with no
COM port assigned:
Assigning Circuits to Channels

When a sequence is created using the Sequence Editor, each of its channels can be assigned a string of lights using the Channel Settings dialog or the Channel Property Grid (the former is more convenient for modifying a single channel, while the latter is more convenient for modifying multiple channels at once).

For Light-O-Rama controllers, these allow you to set the network, unit ID, and circuit ID assigned to the channel. Without these being assigned for a channel, any lighting effects made for that channel will not happen on your actual lights.

For example, the following Channel Settings dialog shows a channel for a Light-O-Rama controller on the regular network, with unit ID 03 and Circuit ID 7:
The Channel Settings dialog for a Light-O-Rama controller

The Channel Settings dialog can be accessed by left-clicking on the channel's button, or by selecting "Change Channel Settings" from the channel button's right-click popup menu. The Channel Property Grid can be accessed by selecting "Channel Property Grid" from the Tools menu.
4.4.2 Dasher Controllers

In addition to Light-O-Rama controllers and various other types of controllers, Light-O-Rama can control your lights that are hooked up to Dasher controllers.

Limitations of Dasher Controllers

Not all of Light-O-Rama’s lighting effects are supported on Dasher controllers; to use effects other than "on" or "off" (such as twinkling, shimmering, fading, and brightness intensities other than "totally off" or "full brightness"), you must use Light-O-Rama controllers.

The Dasher Port

All Dasher controllers that you will use must be hooked up to your computer over a single COM port, known as the Dasher Port. You can select which COM port is the Dasher port in the "Additional Ports" section of the Network Preferences dialog of the Edit menu of the Sequence Editor.

The Network Preferences dialog, with the Dasher Port set to COM8

Unit IDs
Each Dasher controller has a unit ID, identifying which controller it is. A controller will only react to lighting commands for its unit ID. For a Dasher controller, the unit ID is a number between 1 and 106.

Circuit IDs

Each Dasher controller has eight circuits, each of which can control independent strings of lights. A circuit is on a Dasher controller identified by a circuit ID between 1 and 8.

Assigning Circuits to Channels

When a sequence is created using the Sequence Editor, each of its channels can be assigned a string of lights using the Channel Settings dialog or the Channel Property Grid (the former is more convenient for modifying a single channel, while the latter is more convenient for modifying multiple channels at once).

For a Dasher controller, these allow you to set the unit ID and circuit ID assigned to a channel. Without these being set, controllers will not react to lighting effects that you have put into your sequence.

For example, the following shows the Channel Settings dialog for a channel assigned to circuit 7 of a Dasher controller with unit ID 37:

Channel Settings for a Dasher controller

The Channel Settings dialog can be accessed by left-clicking on the channel's button, or by selecting "Change Channel Settings" from the channel button's right-click popup menu. The Channel Property Grid can be accessed by selecting "Channel Property Grid" from the Tools menu.

Importing Dasher Files
In addition to being able to use Dasher controllers, Light-O-Rama can also import sequences created using the Dasher program, and convert them to Light-O-Rama sequences that can be used in your shows.

To convert a Dasher sequence to a Light-O-Rama sequence, simply open the Dasher sequence using the Sequence Editor (for example, via "Open" of the File menu). Light-O-Rama will detect that it is a Dasher sequence, and prompt you on how to import it:

The Dasher Import dialog

The reason for this dialog is one of the differences between Light-O-Rama and the Dasher program: Dasher sequences must always be associated with an audio file, even if you don't want any sound to play while the sequence is controlling the lights. Often, people who used Dasher but did not want sound during a particular sequence would therefore create audio files that had no sound in them.

Light-O-Rama, on the other hand, has no need for such "empty" audio files. A Light-O-Rama musical sequence is associated with an audio (or video) file, and a Light-O-Rama animation sequence is not.

When you ask Light-O-Rama to import a file that was created using Dasher, it does not know whether the audio file used by the Dasher sequence is "empty" or not. If it is, then Light-O-Rama has no need for the audio file. So, the Sequence Editor displays this dialog asking you whether it really needs this audio file or not.

Finally, after importing a Dasher sequence, make sure to save it. It will be saved as a Light-O-Rama sequence. Only the new Light-O-Rama sequence can be used in your shows; the old Dasher
sequence that it was imported from cannot.

4.4.3 Digital IO Cards

In addition to Light-O-Rama controllers and various other types of controllers, Light-O-Rama can control your lights that are hooked up to digital IO cards.

Note: This page does not apply to BSOFT digital IO cards. Light-O-Rama can control BSOFT digital IO cards, but if your digital IO card is a BSOFT digital IO card, please see the separate help file page for such cards.

Requirements

In order to use digital IO cards with Light-O-Rama, your computer must have the Universal Library and the InstaCal program.

Limitations of Digital IO Cards

Not all of Light-O-Rama's lighting effects are supported on digital IO cards; to use effects other than "on" or "off" (such as twinkling, shimmering, fading, and brightness intensities other than "totally off" or "full brightness"), you must use Light-O-Rama controllers.

Unit IDs

Each digital IO card has a unit ID, identifying which controller it is. A controller will only react to lighting commands for its unit ID. For a digital IO card, the unit ID is a number between 0 and 99.

Circuit IDs

Each digital IO card can control multiple strings of lights independently. To identify each such string, it is assigned a circuit ID between 0 and 191.

Assigning Circuits to Channels

When a sequence is created using the Sequence Editor, each of its channels can be assigned a string of lights using the Channel Settings dialog or the Channel Property Grid (the former is more convenient for modifying a single channel, while the latter is more convenient for modifying multiple channels at once).

For a digital IO card, these allow you to set the unit ID and circuit ID assigned to a channel. Without these being set, controllers will not react to lighting effects that you have put into your sequence.

For example, the following shows the Channel Settings dialog for a channel assigned to circuit 3 of a digital IO card with unit ID 37:
The Channel Settings dialog can be accessed by left-clicking on the channel's button, or by selecting "Change Channel Settings" from the channel button's right-click popup menu. The Channel Property Grid can be accessed by selecting "Channel Property Grid" from the Tools menu.

### 4.4.4 BSOFT Digital IO Cards

In addition to Light-O-Rama controllers and various other types of controllers, Light-O-Rama can control your lights that are hooked up to BSOFT digital IO cards.

**Note:** This page does not apply to any digital IO cards except BSOFT digital IO cards. Light-O-Rama can control other digital IO cards, but if your digital IO card is not a BSOFT digital IO card, please see the separate help file page for such cards.

#### Requirements

In order to use BSOFT digital IO cards with Light-O-Rama, your computer must have the Universal Library and the InstaCal program.

#### Limitations of BSOFT Digital IO Cards

Not all of Light-O-Rama's lighting effects are supported on BSOFT digital IO cards; to use effects other than "on" or "off" (such as twinkling, shimmering, fading, and brightness intensities other than "totally off" or "full brightness"), you must use Light-O-Rama controllers.

#### Unit IDs

Each BSOFT digital IO card has a unit ID, identifying which controller it is. A controller will only react to lighting commands for its unit ID. For a BSOFT digital IO card, the unit ID is a number between 0 and 99.
Circuit IDs

Each BSOFT digital IO card can control multiple strings of lights independently. To identify each such string, it is assigned a circuit ID between 0 and 95.

Assigning Circuits to Channels

When a sequence is created using the Sequence Editor, each of its channels can be assigned a string of lights using the Channel Settings dialog or the Channel Property Grid (the former is more convenient for modifying a single channel, while the latter is more convenient for modifying multiple channels at once).

For a BSOFT digital IO card, these allow you to set the unit ID and circuit ID assigned to a channel. Without these being set, controllers will not react to lighting effects that you have put into your sequence.

For example, the following shows the Channel Settings dialog for a channel assigned to circuit 7 of a BSOFT digital IO card with unit ID 3:

The Channel Settings dialog for a BSOFT digital IO card

The Channel Settings dialog can be accessed by left-clicking on the channel's button, or by selecting "Change Channel Settings" from the channel button's right-click popup menu. The Channel Property Grid can be accessed by selecting "Channel Property Grid" from the Tools menu.

4.4.5 X10 Controllers

In addition to Light-O-Rama controllers and various other types of controllers, Light-O-Rama can control your lights that are hooked up to CM11A X10 controllers.

Limitations of X10 Controllers
Not all of Light-O-Rama’s lighting effects are supported on X10 controllers; to use effects other than "on" or "off" (such as twinkling, shimmering, fading, and brightness intensities other than "totally off" or "full brightness"), you must use Light-O-Rama controllers.

Additionally, X10 controllers do not react quickly to commands, so they are best used for portions of your display that are mostly static, changing infrequently. For more dynamic displays, it is best to use Light-O-Rama controllers.

X10 is a very slow control mechanism. Commands take, on average, a full second to complete. When building a sequence that uses X10 controllers, you should not send commands to X10 devices more frequently than once a second. Note that turning on one light and turning off another is two commands, not one.

Light-O-Rama will allow up to fifty commands to be queued up to X10 controllers at any time. If that number is exceeded, then commands will be lost.

The X10 Port

All X10 controllers that you will use must be hooked up to your computer over a single COM port, known as the X10 Port. You can select which COM port is the X10 port in the “Additional Ports” section of the Network Preferences dialog of the Edit menu of the Sequence Editor.
The Network Preferences dialog, with the X10 port set to COM4

Unit IDs

Each X10 controller has a unit ID, consisting of its X10 house code followed by its X10 unit code. X10 house codes are letters ranging from A to P, while X10 unit codes are numbers ranging from 1 to 16; hence, the X10 unit ID ranges from "A-1" to "P-16".

Assigning Circuits to Channels

When a sequence is created using the Sequence Editor, each of its channels can be assigned a string of lights using the Channel Settings dialog or the Channel Property Grid (the former is more convenient for modifying a single channel, while the latter is more convenient for modifying multiple channels at once).

For an X10 controller, these allow you to set the unit ID assigned to a channel. Without this being set, controllers will not react to lighting effects that you have put into your sequence.

For example, the following shows the Channel Settings dialog for a channel assigned to X10 controller C-7:
The Channel Settings dialog can be accessed by left-clicking on the channel's button, or by selecting "Change Channel Settings" from the channel button's right-click popup menu. The Channel Property Grid can be accessed by selecting "Channel Property Grid" from the Tools menu.

5 The Light-O-Rama Software Package

The Light-O-Rama software package is a suite of programs, each helping with a different portion of computerized control of your lights to help build a dynamic display:

- The Control Panel runs in your system tray, and gives convenient access to control over your shows.
- The Sequence Editor is used to create, modify, and test sequences.
- The Show Editor is used to package sequences together into shows.
- The Schedule Editor is used to schedule shows to play at certain times.
- The Simple Show Builder is an alternative to the Show Editor and the Schedule Editor. It is generally simpler to use, but less flexible.
- The Show Player monitors the schedule, and plays the scheduled shows at the appropriate times.
- The Hardware Utility can be used to test your controllers, and to download sequences to them to be used in standalone mode.
- The ServoDog Utility can be used to configure Light-O-Rama ServoDog controllers.
- The Verifier can be used to check for certain types of problems with your Light-O-Rama configuration, schedule, shows and sequences.
- The Diagnostic is a troubleshooting tool that displays various information about your Light-O-Rama configuration.
- The Offline Registration Utility can be used to register Light-O-Rama on a computer that does not have access to the internet.

Additionally, several add-ons can be used with Light-O-Rama (these are not supplied as a part of the Light-O-Rama software package).
The Light-O-Rama software package must be registered with a valid license in order to use it to its full potential. There are several different possible license levels, each having different features available. Light-O-Rama can also be used unlicensed, in Demo mode, but you will not be able to actually control lights while in Demo mode.

5.1 Registering Light-O-Rama

The Light-O-Rama Software Package must be registered, with a valid license, before it can be used to its full potential. Without a license, Light-O-Rama can be used as a demo, but it will not actually control your lights.

There are several different license levels, each having different features available; please see the feature comparison for details.

To register Light-O-Rama first visit the Light-O-Rama website, and purchase a license. You will then be able to enter your license information in any of a few different ways: When you first install the software, or using the "Register Light-O-Rama" (or "Upgrade Light-O-Rama") menu items on the Sequence Editor's Help menu or on the Control Panel's popup menu.

Doing any of these things will open the Registration dialog:

If your computer is connected to the internet, you can register simply by entering the name and license key from your license information, and clicking "Register" (the license name and key can be copied and pasted from the email in which they were sent to you). Light-O-Rama will then automatically verify your license information, and, if it is valid, register your computer.

You may then have to close any Light-O-Rama programs that are running, and then restart them, before all of your newly available features will be available.

If your computer is not connected to the internet, click on the link at the bottom of the Registration dialog in order to register offline.
5.1.1 Registering Offline

If your computer is connected to the internet, you can register Light-O-Rama directly in the Registration dialog. If not, though, you can still register while offline. Open the Registration dialog and click the link at its bottom (“Need to register offline? Click here.”).

Doing so will open the Offline Registration dialog:

![Offline Registration Dialog](image)

First, enter your license name and license key (these can be copied and pasted from the email in which they are sent to you).

Next, click “Show Offline Registration Key”.

At this point, you will need to use your offline registration key to get an offline authorization key. There are two ways to do this:

First, if you have another computer, which is connected to the internet and which has Light-O-Rama installed, you can run the Offline Registration Utility on that computer. Make sure to have your license...
name, license key, and offline registration key available to enter onto that computer; the Offline Registration Utility will use them to create an offline authorization key.

If you do not have another computer that you can use to run the Offline Registration Utility, then you can obtain an offline authorization key by calling Light-O-Rama, at the telephone number shown on the form. Provide the person you speak to with your license name, license key, and offline registration key, and they will provide an offline authorization key to you.

After you have obtained an offline authorization key, type it into the boxes near the bottom of the form, and click “Register”.

After you have successfully registered, you may need to close any Light-O-Rama programs that are running and restart them before all of your newly available features can be used.

5.2 Control Panel

What is the Light-O-Rama Control Panel?

The Light-O-Rama Control Panel is an application that runs in your system tray, allowing convenient access to other programs in the Light-O-Rama software package, as well as control over your displays.

The Light-O-Rama control panel must be running in order for the Show Player to play your scheduled shows (additionally, “Enable Schedule” must be turned on).

Running the Light-O-Rama Control Panel

To run the Light-O-Rama Control Panel, select it from your computer's Start menu, under All Programs / Light-O-Rama / Light-O-Rama Control Panel:

Once running, the Control Panel will show up as a Light-O-Rama light bulb icon in your system tray:

The color of the light bulb describes the current state of the Show Player: If scheduled shows are currently enabled, it will be blue; if they are disabled, but shows on demand are enabled, it will be orange; if shows are disabled entirely, it will be red.
If you wish, you can set it up so that the Control Panel will automatically be run whenever your computer starts up (and therefore you won't have to start it via the Start menu anymore). To do this, select **Launch at Startup** from the Control Panel's popup menu.

The Status Window

Left-clicking on the Light-O-Rama Control Panel's icon in your computer's system tray opens up the Light-O-Rama status window. This window shows whether or not the **Light-O-Rama Show Player** is currently monitoring your **schedule** to play **shows** at their scheduled times, and, if so, whether a show is currently running, what show that is, and what the next show will be.

It also shows various log messages, indicating such things as that a show or a **sequence** is starting or stopping, that an error occurred playing a sequence, or that an **interactive trigger** was detected. The "Clear Log" button will clear out all existing messages from the display, and "Copy Log" will copy the log messages to your computer's clipboard, so that you can paste them into a file. Please note that the log does not retain its messages indefinitely; it will periodically clear earlier messages out.

If that status window says that Light-O-Rama is "disabled", your scheduled shows will not play. If you wish to enable them, select "Enable Schedule" from the Control Panel's right-click popup menu. Similarly, if the status window says that they Light-O-Rama is "enabled", your scheduled shows will play; if you wish to disable them, select either "Disable Shows Gracefully" or "Disable Shows Immediately".

The status window can also say that Light-O-Rama is "enabled (only for on demand shows)", in which case your scheduled shows will not play, but **on demand shows** will. In this situation, you will be able to either enable your scheduled shows or disable shows entirely (either gracefully or immediately).
The status window, with scheduled shows enabled and a show currently playing

Light-O-Rama 2.5.3 is currently **ENABLED**

Current Activity: Playing: hermajesty.lss
From 4:10:37 PM to 5:00 PM

Next Activity: Wait for next show
From 5:00 PM to Thursday 4:10:37 PM

4:06:31 PM: Show Player starting
4:06:31 PM: Schedule loaded
4:06:36 PM: Show Player initialized
4:10:37 PM: Starting show: C:\Users\Bob\Desktop\LOR Data\Sequences\hermajestySequence.lss
4:10:37 PM: Loading sequence: C:\Users\Bob\Desktop\LOR Data\Sequences\hermajestySequence.lss
4:10:39 PM: Starting Musical: C:\Users\Bob\Desktop\LOR Data\Sequence

The status window, with scheduled shows enabled, but no show currently playing

Light-O-Rama 2.5.3 is currently **ENABLED**

Current Activity: No show is active
From Tuesday 4:01 PM to Wednesday 4:10:37 PM

Next Activity: Play: hermajesty.lss
From 4:10:37 PM to 5:00 PM

4:06:31 PM: Show Player starting
4:06:31 PM: Schedule loaded
4:06:36 PM: Show Player initialized
The Light-O-Rama Software Package

The status window, with on demand shows enabled, but not scheduled shows:

Light-O-Rama 2.7.1 is currently **ENABLED (only for on demand shows)**

Current Activity: Playing: hermajesty.lss (on demand)
Plays continuously

Next Activity:

11:41:35 AM: Show Player starting (for on demand shows)
11:41:35 AM: Schedule loaded
11:41:35 AM: Request for show on demand received: C:\Users\Bob\Desktop\LOR Data\Sequences
11:41:39 AM: Show Player initialized
11:41:40 AM: Starting show: C:\Users\Bob\Desktop\LOR Data\Sequences
11:41:40 AM: Loading sequence: C:\Users\Bob\Desktop\LOR Data\Sequences
11:41:40 AM: Starting Musical: C:\Users\Bob\Desktop\LOR Data\Sequences

The status window, with on demand shows enabled, but not scheduled shows:

Light-O-Rama 2.5.3 is currently **DISABLED**

The status window, with shows disabled

The Popup Menu

© 2010 Light-O-Rama, Inc.
Right-clicking on the Light-O-Rama Control Panel's icon in the system tray brings up a popup menu. This menu contains items to quickly launch other programs in the Light-O-Rama software package, and to control your display in various ways:

- **Register (or Upgrade) Light-O-Rama**
- **Sequence Editor**
- **Show Editor**
- **Simple Show Builder**
- **Schedule Editor**
- **Verifier**
- **Status**
- **Hardware Utility**
- **ServoDog Utility**
- **Enable Schedule**
- **Disable Shows Gracefully**
- **Disable Shows Immediately**
- **Show On Demand**
- **Shut Down Show On Demand**
- **Launch at startup**
- **Do not launch at startup**
- **Holiday Lights Designer On**
- **Holiday Lights Designer Off**
- **Unload Light-O-Rama**
- **Close Menu**
- **Help**
Register (or Upgrade) Light-O-Rama

Selecting "Register Light-O-Rama" (or "Upgrade Light-O-Rama") from the Control Panel's right-click popup menu allows you to register your Light-O-Rama software, or to upgrade to a higher level license, unlocking various features.

This item will show up as "Register Light-O-Rama" if you are using the unlicensed Demo version of the software, or "Upgrade" if you are using a license, but it is not the highest possible license level. If you are using the highest possible license level, this item will not be displayed at all.

Sequence Editor

Selecting "Sequence Editor" from the Control Panel's right-click popup menu launches the Light-O-Rama Sequence Editor, used to create, modify, and test sequences.

Show Editor

Selecting "Show Editor" from the Control Panel's right-click popup menu launches the Light-O-Rama Show Editor, used to create and modify shows.

Simple Show Builder
Selecting "Simple Show Builder" from the Control Panel's right-click popup menu launches the Light-O-Rama Simple Show Builder, which is intended as an easier to use, but less flexible, alternative to the Show Editor and the Schedule Editor.

**Schedule Editor**

Selecting "Schedule Editor" from the Control Panel's right-click popup menu launches the Light-O-Rama Schedule Editor, used to schedule shows to be played by the Light-O-Rama Show Player.

**Verifier**

Selecting "Verifier" from the Control Panel's right-click popup menu launches the Light-O-Rama Verifier, used to check for certain problems with Light-O-Rama's configuration, schedule, scheduled shows, and scheduled sequences.

**Status**

Selecting "Status" from the Control Panel's right-click popup menu opens the Light-O-Rama status window, which displays information such as whether shows are currently enabled, and what show (if any) is currently playing.

**Hardware Utility**

Selecting "Hardware Utility" from the Control Panel's right-click popup menu launches the Light-O-Rama Hardware Utility, used for various things such as testing controllers and downloading sequences to them for use in standalone mode.

**ServoDog Utility**

Selecting "ServoDog Utility" from the Control Panel's right-click popup menu launches the Light-O-Rama ServoDog Utility, used to configure Light-O-Rama ServoDog controllers.

**Enable Schedule**

Selecting "Enable Schedule" from the Control Panel's right-click popup menu causes the Light-O-Rama Show Player to monitor your schedule and to play your shows at their scheduled times.

Note that on demand shows can be played regardless of whether your scheduled shows are enabled or not.

When scheduled shows are enabled, the light bulb icon in the computer's system tray will be blue.

**Note:** If "Enable Schedule" is greyed out, this means that it has already been selected, and the Show Player is monitoring your schedule. To stop the Show Player from monitoring your schedule, select "Disable Shows Gracefully" or "Disable Shows Immediately".

**Disable Shows Gracefully**

Selecting "Disable Shows Gracefully" from the Control Panel's right-click popup menu causes the Light-O-Rama Show Player to put your current show (if one is running) into shutdown mode, and to stop monitoring your schedule for shows to be played. When the show goes into shutdown mode,
any song from the Musical section that is currently playing will be allowed to finish, and then the show's Shutdown section will start.

To instead shut down your show immediately, including abruptly stopping any sequences or song that might be playing, choose Disable Shows Immediately instead.

When shows are disabled, the light bulb icon in the computer's system tray will be red.

**Note:** If "Disable Shows Gracefully" is greyed out, this means that the Show Player is not monitoring your schedule. To have the Show Player start monitoring your schedule, select "Enable Schedule".

**Disable Shows Immediately**

Selecting "Disable Shows Immediately" from the Control Panel's right-click popup menu causes the Light-O-Rama Show Player to immediately stop your current show (if one is running), and to stop monitoring your schedule for shows to be played.

Stopping your show immediately will abruptly stop your sequences, including any song that happens to be playing. To have the Show Player stop your show more gracefully, choose Disable Shows Gracefully instead.

When shows are disabled, the light bulb icon in the computer's system tray will be red.

**Note:** If "Disable Shows Immediately" is greyed out, this means that the Show Player is not monitoring your schedule. To have the Show Player start monitoring your schedule, select "Enable Schedule".

**Show On Demand**

Selecting "Show On Demand" from the Control Panel's right-click popup menu causes the following dialog to open:

![Show On Demand dialog](image)

Using this dialog, you can choose a show file to play immediately, or at a certain time, without needing to add it to your schedule. You can choose to let it play until a certain time, or else indefinitely, in which case it will not stop until you "shutdown show on demand", "disable shows gracefully", "disable shows immediately", or "unload Light-O-Rama".
If a show is already playing at the time the on demand show is supposed to start, the playing show will be allowed to stop gracefully before the on demand show will start. That is, if a sequence from its Musical Section is currently playing, that sequence will be allowed to continue to play until its natural end; also, the sequences from its Shutdown Section, if any exist, will be played (after the current sequence from the Musical Section ends, or immediately if there is no current sequence from the Musical Section).

If "Show On Demand" is used when scheduled shows are disabled, it will not enable your scheduled shows; only your on demand show will play (if desired, though, you can enable your scheduled shows too, simply by clicking "Enable Schedule"). When this is the case, the light bulb icon in the computer's system tray will be orange.

Please note that the Show On Demand feature is only available for license level Basic Plus and higher.

**Shut Down Show On Demand**

If an on demand show is currently playing, selecting "Shut Down Show On Demand" from the Control Panel's right-click popup menu will cause the on demand show to stop. It will be allowed to stop gracefully; that is, if a sequence from its Musical Section is currently playing, that sequence will be allowed to continue to play until its natural end; also, the sequences from its Shutdown Section, if any exist, will be played (after the current sequence from the Musical Section ends, or immediately if there is no current sequence from the Musical Section).

After the on demand show stops, if scheduled shows are enabled, the Show Player will start whatever show is scheduled for the current time (if any).

"Shut Down Show On Demand" can also be used to cancel an on demand show that has been requested, but not yet started (either due to its start time not having been reached, or else due to another show still being in the process of shutting down).

**Launch at startup**

Selecting "Launch at startup" from the Control Panel's right-click popup menu causes the Light-O-Rama Control Panel to automatically run whenever your computer starts up.

**Note:** If "Launch at startup" is greyed out, this means that it has already been selected, and the Control Panel will automatically start up whenever your computer starts up. To stop this from happening, select "Do not launch at startup".

**Do not launch at startup**

Selecting "Do not launch at startup" from the Control Panel's right-click popup menu prevents the Light-O-Rama Control Panel from automatically running whenever your computer starts up. If this is selected, then to start the Control Panel after your computer starts, run it from your computer's Start menu.

**Note:** If "Do not launch at startup" is greyed out, this means that it has already been selected, and the Control Panel will not automatically start up whenever your computer starts up. To have it automatically start when your system starts, select "Launch at startup".

**Holiday Lights Designer On**
Selecting "Holiday Lights Designer On" from the Control Panel's right-click popup menu causes Light-O-Rama to send lighting commands to Holiday Lights Designer whenever a sequence is played (whether by the Show Player or the Sequence Editor). Holiday Lights Designer is a third party add-on that allows you to virtually place Christmas lights and holiday decorations on images of your home or business.

Version 4.0 or above of Holiday Lights Designer™ is required to take advantage of Light-O-Rama interaction.

**Note:** If "Holiday Lights Designer On" is greyed out, this means that it has already been selected, and Light-O-Rama will send commands to Holiday Lights Designer. To stop it from doing so, select "Holiday Lights Designer Off".

### Holiday Lights Designer Off

Selecting "Holiday Lights Designer Off" from the Control Panel's right-click popup menu prevents Light-O-Rama from sending lighting commands to Holiday Lights Designer whenever a sequence is played (whether by the Show Player or the Sequence Editor). Holiday Lights Designer is a third party add-on that allows you to virtually place Christmas lights and holiday decorations on images of your home or business.

Version 4.0 or above of Holiday Lights Designer™ is required to take advantage of Light-O-Rama interaction.

**Note:** If "Holiday Lights Designer Off" is greyed out, this means that it has already been selected, and Light-O-Rama will not send commands to Holiday Lights Designer. To make it send commands, select "Holiday Lights Designer On".

### Unload Light-O-Rama

Selecting "Unload Light-O-Rama" from the Control Panel's right-click popup menu will shut down both the Light-O-Rama Control Panel and the Light-O-Rama Show Player. Your scheduled shows will not run while these are shut down.

To start the Light-O-Rama Control Panel again, run it from your computer's Start menu. Or, if "Launch at startup" has been enabled, the Control Panel will automatically run the next time that your computer starts up.

### Close Menu

Selecting "Close Menu" from the Control Panel's right-click popup menu will close the popup menu. The Light-O-Rama control panel will still remain active.

### Help

Selecting "Help" from the Control Panel's right-click popup menu will open up the Light-O-Rama help files.

### 5.3 Sequence Editor

The Light-O-Rama Sequence Editor is a tool used to create sequences, which are files that contain commands to be sent to controllers to produce various lighting effects - to turn lights on and off, make
them twinkle or shimmer, fade up or down, and so forth.

After creating sequences with the Sequence Editor, they can be grouped together into shows, using the Show Editor. Shows can then be scheduled to run at certain times, using the Schedule Editor, and the Show Player can be used to monitor the schedule and play those shows at the scheduled times.

A sequence is represented in the Sequence Editor as a grid, with rows being channels and columns being timings. A cell in the grid represents the lighting effect or effects on that channel at that time. For example, the following sequence has four channels. At the start of the sequence, the first channel turns on. It stays on for half a second, then turns off, and the second channel then turns on. Then it turns off, and the third turns on, and then the third turns off and the fourth turns on. This brings us two seconds into the sequence, at which point all four channels fade down, for a second. After that, the first and fourth channels start shimmering, while the second and third fade up:

![A sequence with four channels, and various lighting effects](image)

Notice that one cell is highlighted with a thick black box - the cell of the first channel from 3 seconds to 3.5 seconds. That is the currently selected cell. Various tools can be applied to the selected cell (or cells), for example to change the lighting effect used on that channel at that time.

For more detailed information about sequences and the Sequence Editor, please see the help file page on sequences, and the following topics:

- Editing Sequences Using the Keyboard
- Editing Sequences Using the Mouse
- The Menu Bar
- Toolbars
- The Right-Click Context Menu
- Channel Buttons
- Track Bars
- Loop Menus
- The Channel Property Grid
- The Animator
- The Beat Wizard
- The MIDI Wizard
- The Tapper Wizard
- The VU Wizard
5.3.1 Editing Sequences Using the Keyboard

The keyboard can be used in several ways to help build sequences in the Sequence Editor:

- Selecting a Cell
- Selecting Multiple Cells
- Modifying Cells
- Copying, Cutting and Pasting
- Copying and Pasting Timings
- Undoing and Redoing
- Zooming
- Creating and Opening Sequences
- Saving Changes
- Refreshing the Display
- Help
- Freeform Play Mode
- Opening a Tooltip
- Other Keyboard Usage

Please also see Editing Sequences Using the Mouse.

Selecting a Cell

Sequences are displayed in the Sequence Editor as a grid. Rows represent channels or RGB channels, and columns represent timings. Cells in the grid therefore represent the lighting effects.
that will happen on channels at various points in time while the sequence is being played.

A cell, or a range of cells, can be selected, allowing you to apply various tools to it (such as specifying what lighting effects should take place in that cell). You can recognize the currently selected cell (or cells) by a thick black and white border. For example, in the following sequence, the cell of the third channel between 1 second and 1.5 seconds is selected:

![Time Scale Diagram]

The time between 1 and 1.5 seconds of the third channel is selected

You can change which cell is selected by using the arrow keys - Up, Down, Left and Right. Page Up and Page Down can also be used, to go up and down in the sequence by a page at a time.

If the currently selected cell is not the first cell in the currently selected channel (i.e. the cell starting at time zero), hitting the Home key brings you to the first cell in the currently selected channel. If, however, the first cell is already selected, then hitting the Home key will bring you to the first channel in the sequence. So, hitting the Home key twice in a row will bring you to the first cell in the first channel.

The End key works similarly, but for the last event and the last channel.

**Selecting Multiple Cells**

A range of cells can be selected by holding down the shift key while using the arrow keys (or Page Up, Page Down, Home, or End). For example, the following picture has four cells selected, two each from second and third channels:

![Time Scale Diagram with Multiple Selections]

Four cells are currently selected, two each in Channel 2 and Channel 3

**Modifying Cells**

Once you have selected a cell, or a range of cells, you can modify the cell or cells by pressing keys:
<table>
<thead>
<tr>
<th>Key</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Shift&gt;-A</td>
<td>Set the currently selected tool (for the Enter key or mouse click) to the <strong>Intelligent Fade</strong> tool</td>
</tr>
<tr>
<td>A</td>
<td><strong>Intelligent Fade</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-C</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Custom tool</strong></td>
</tr>
<tr>
<td>C</td>
<td><strong>Custom tool</strong> (e.g. twinkling fade down)</td>
</tr>
<tr>
<td>&lt;Ctrl&gt;&lt;Shift&gt;-D</td>
<td>Set the <strong>custom tool</strong> to fade down</td>
</tr>
<tr>
<td>&lt;Shift&gt;-D</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Fade Down</strong> tool</td>
</tr>
<tr>
<td>D</td>
<td><strong>Fade down</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-E</td>
<td>Turn on <strong>regular effects mode</strong> for subsequent keystrokes</td>
</tr>
<tr>
<td>E</td>
<td>Turn on <strong>regular effects mode</strong> for the next keystroke only</td>
</tr>
<tr>
<td>&lt;Shift&gt;-F</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Fill</strong> tool</td>
</tr>
<tr>
<td>F</td>
<td><strong>Fill</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-G</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Toggle</strong> tool</td>
</tr>
<tr>
<td>G</td>
<td><strong>Toggle</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-H</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Chase</strong> tool</td>
</tr>
<tr>
<td>H</td>
<td><strong>Chase</strong></td>
</tr>
<tr>
<td>&lt;Ctrl&gt;&lt;Shift&gt;-I</td>
<td>Set the <strong>custom tool</strong> to set intensity</td>
</tr>
<tr>
<td>&lt;Shift&gt;-I</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Intensity</strong> tool</td>
</tr>
<tr>
<td>I</td>
<td><strong>Set intensity</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-K</td>
<td>Turn on or off <strong>background effects mode</strong> for subsequent keystrokes</td>
</tr>
<tr>
<td>K</td>
<td>Turn on <strong>background effects mode</strong> for the next keystroke only</td>
</tr>
<tr>
<td>&lt;Shift&gt;-L</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Select tool</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-N</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>On</strong> tool</td>
</tr>
<tr>
<td>N</td>
<td><strong>On</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-O</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Color Fade</strong> tool</td>
</tr>
<tr>
<td>O</td>
<td><strong>Color fade</strong></td>
</tr>
<tr>
<td>&lt;Shift&gt;-R</td>
<td>Turn on or off <strong>foreground effects mode</strong> for subsequent keystrokes</td>
</tr>
<tr>
<td>R</td>
<td>Turn on <strong>foreground effects mode</strong> for the next keystroke only</td>
</tr>
<tr>
<td>&lt;Ctrl&gt;&lt;Shift&gt;-S</td>
<td>Set the <strong>custom tool</strong> to shimmer</td>
</tr>
<tr>
<td>&lt;Shift&gt;-S</td>
<td>Set the currently selected effect tool (for the Enter key or mouse click) to the <strong>Shimmer</strong> tool</td>
</tr>
<tr>
<td>S</td>
<td><strong>Shimmer</strong></td>
</tr>
<tr>
<td>&lt;Ctrl&gt;&lt;Shift&gt;-T</td>
<td>Set the <strong>custom tool</strong> to twinkle</td>
</tr>
</tbody>
</table>
Copying, Cutting and Pasting

The lighting effects in cells can be copied, cut, and pasted using the standard Windows copy, cut and paste keys, Ctrl-C, Ctrl-X, and Ctrl-V.

Note that the Light-O-Rama Sequence Editor supports two different pasting modes (paste by cell and paste by time), and a pasting option (paste from foreground). You can choose these settings using the Clipboards subpanel of the left-hand Tools Panel.

Copying and Pasting Timings

Timings can be copied using Ctrl-Insert, and inserted using Shift-Insert.

Undoing and Redoing

Changes to a sequence can be undone and redone using the standard Windows undo and redo keys, Ctrl-Z and Ctrl-Y. Note that this includes any changes to the sequence, not merely changes made using the keyboard.

Zooming
The view of a sequence's grid can be zoomed in and out using the keyboard. Both rows (channels) and columns (timings) can be zoomed.

To zoom in on channels - i.e. to make them bigger - use Alt-Down, and to zoom out, use Alt-Up. Alt-Page Down and Alt-Page Up also work, to zoom in and out as much as possible.

To zoom in on timings, use Alt-Right; to zoom out, use Alt-Left. Alt-End and Alt-Home zoom in and out as much as possible.

Creating and Opening Sequences

The New and Open Dialog can be opened using either Ctrl-N, Ctrl-O, or Ctrl-R. Ctrl-N will open it to its New Sequence tab, Ctrl-O will open it to its Existing Sequence tab, and Ctrl-R will open it to its Recent Sequence tab.

Saving Changes

Changes to a sequence can be saved using Ctrl-S. If this is a new sequence that has never before been saved, this will first prompt you for a filename to save the sequence to.

Refreshing the Display

Occasionally during play, the display of a sequence's grid may seem to blank out. This is typically caused when your computer happens to do something unrelated to Light-O-Rama, and temporarily takes the focus away from the Sequence Editor. The sequence itself is not affected, nor are the actual lights - only the Sequence Editor's display of the sequence is - and the display is typically returned to normal when play reaches the next screen (or stops). However, if you do not wish to wait for that, you can hit the F5 key to manually refresh the display.

Help

The Light-O-Rama help file can be opened by hitting the F1 key.

Freeform Play Mode

The space bar can be used to start and stop the current sequence either in "from selection" mode or, if a freeform play range has been selected, in freeform play mode. While playing, the up and down arrows can be used to define a freeform play range. If play is started with "Shift-Space" instead of just "Space", the freeform play range will be removed, and play will then start in "from selection" mode.

Opening a Tooltip

If your mouse is over the current sequence's grid, you can open a tooltip describing the cell it is pointing to by hitting the "P" key. This can be done regardless of whether you have set your display preferences to disable tooltips.

Other Keyboard Usage
The various menus on the menu bar can be accessed by holding down the Alt key while pressing a particular key for the menu in question:

<table>
<thead>
<tr>
<th>Key</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>&lt;Alt&gt;-E</td>
<td>The Edit menu</td>
</tr>
<tr>
<td>&lt;Alt&gt;-F</td>
<td>The File menu</td>
</tr>
<tr>
<td>&lt;Alt&gt;-H</td>
<td>The Help menu</td>
</tr>
<tr>
<td>&lt;Alt&gt;-P</td>
<td>The Play menu</td>
</tr>
<tr>
<td>&lt;Alt&gt;-T</td>
<td>The Tools menu</td>
</tr>
<tr>
<td>&lt;Alt&gt;-V</td>
<td>The View menu</td>
</tr>
<tr>
<td>&lt;Alt&gt;-W</td>
<td>The Window menu</td>
</tr>
</tbody>
</table>

After opening a menu, menu items can be selected using their hotkeys (indicated by an underlined letter). For example, pressing Alt-E followed by K will select "Duplicate Track" from the Edit menu. Keys such as Up, Down, Left, Right, Enter and Space can also be used to navigate these menus.

Many functions in the Light-O-Rama Sequence Editor cause dialog windows to open up. Those which have "OK" and "Cancel" buttons can typically have "OK" invoked by hitting the Enter key, and "Cancel" by hitting the Escape key.

Standard Windows keyboard navigation should work on these dialogs - for example, using the Tab key to tab between controls, or the arrow keys to choose which radio button in a group is selected.

Hotkeys exist on many of these dialogs, which allow you to select a specific control on the dialog by holding the Alt key and pressing the key of the underlined letter. For example, in the Channel Settings dialog (picture follows), the "Name" control can be selected by Alt-N, the "Color" control by Alt-C, and so forth:
5.3.2 Editing Sequences Using the Mouse

Sequences can be edited in the Light-O-Rama Sequence Editor using the mouse:

- Selecting a Cell
- Selecting Multiple Cells
- Modifying Cells
- Other Mouse Usage

See also "Editing Sequences Using the Keyboard".

Selecting a Cell

Sequences are displayed in the Sequence Editor as a grid. Rows represent channels, and columns represent timings. Cells in the grid therefore represent the lighting effects that will happen on channels at various points in time while the sequence is being played.

A cell, or a range of cells, can be selected, allowing you to apply various tools to it (such as specifying what lighting effects should take place in that cell). You can recognize the currently selected cell (or cells) by a thick black and white border. For example, in the following sequence, the cell of the third channel between 1 second and 1.5 seconds is selected:

Using the mouse, you can change which cell is selected by simply clicking in the cell that you want to be selected. However, unlike when you select a cell using the keyboard, this will not just select the cell - it will also apply the current effect tool (from the Tools toolbar) to the cell. So, for example, it might turn the cell on, or off, or cause it to twinkle, or fade up. So, if you want to just select a cell without changing its contents, either use the keyboard, or make sure that your current effect tool is the Selection tool.

Another option is to right-click in the desired cell. This will select the cell, and will not apply the current tool, but it will also bring up the right-click context menu. One exception: If you already have multiple cells selected, and you right click on one of those cells, that cell will not become the currently selected cell. Instead, the whole range of cells will remain selected, and the right-click context menu will pop up, applying to the entire range of cells.

Selecting Multiple Cells

You can select multiple cells using the mouse in two ways: either click and drag from the first to the last, or click in the first, move (without necessarily dragging) to the last, and shift-click in the last. Note that this will not just select the cells; it will also apply the current tool (from the Tools toolbar) to the cells. For example, it will make them shimmer, or fade down. So, if you want to select multiple cells without changing their contents, either use the keyboard, or make sure that the
current tool is the Selection tool.

Right-clicking can also be used to select multiple cells, but will bring up the right-click context menu rather than applying the current tool.

Modifying Cells

Simply selecting a cell or a range of cells will apply the current effect tool (from the Tools toolbar) to the selection.

Another option is to right-click on the cell or cells, which will bring up the right-click context menu. This menu has a variety of options for modifying the cells.

Other Mouse Usage

Various popup menus and dialogs can be obtained by using the mouse:

- Right-clicking on the sequence grid brings up the right-click context menu.
- Left-clicking on a channel button brings up that channel's Channel Settings dialog.
- Right-clicking on a channel button brings up that channel's popup menu.
- Left or right-clicking on a track bar brings up that track's context menu.
- Left or right-clicking on a loop level portion of the grid brings up the Loop Context menu.
- Left or right-clicking on a loop level's button brings up part of the Loop Context menu (the items related to the whole loop level, rather than individual loops).

Additionally, the menu bar and the toolbars can be accessed via the mouse in the standard way for Windows programs.

5.3.3 Time Format

Whenever the Light-O-Rama Sequence Editor asks you for a length of time, you can generally specify hours, minutes, seconds, and hundredths of a second. You don't have to specify all of them if you don't want to.

The general format is:

HH:MM:SS.hh

Where HH is hours, MM is minutes, SS is seconds, and hh is hundredths of a second. You usually do
not have to type all of that in, though; for example, if you are concerned only with seconds, you don’t have to type in anything about hours, minutes, or hundredths of seconds.

The Sequence Editor also uses this same format whenever it displays a length of time to you.

The following examples show how to specify various lengths of time:

<table>
<thead>
<tr>
<th>Length of Time</th>
<th>Format</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ten seconds</td>
<td>10</td>
</tr>
<tr>
<td>Ten and 37/100 seconds</td>
<td>10.37</td>
</tr>
<tr>
<td>Three minutes and ten seconds</td>
<td>3:10</td>
</tr>
<tr>
<td>Three minutes, ten and 37/100 seconds</td>
<td>3:10.37</td>
</tr>
<tr>
<td>Seven hours, three minutes, and ten seconds</td>
<td>7:03:10</td>
</tr>
<tr>
<td>Seven hours, three minutes, ten and 37/100 seconds</td>
<td>7:03:10.37</td>
</tr>
</tbody>
</table>

5.3.4 The Menu Bar

The Light-O-Rama Sequence Editor's menu bar gives access to a variety of different functionality. For detailed help, please refer to the help pages for each individual menu on the menu bar:

- The File menu
- The Edit menu
- The View menu
- The Tools menu
- The Play menu
- The Window menu
- The Help menu

5.3.4.1 The File Menu

The Light-O-Rama Sequence Editor's File menu has menu items related to things like creating, opening, and saving sequences.

Several of these menu items operate on the "currently selected sequence". Many sequences can be open simultaneously in the Sequence Editor, but only one is the currently selected sequence. It is distinguished by its bright blue title bar (as opposed to the pale blue title bar of unselected sequences). To select a sequence, simply click on its window.

- New
- Open
- Open Recent
- Close
- Close All Files
- Close All Files Except This
The Sequence Editor's File menu

New

Selecting "New" on the Sequence Editor's File menu opens the New and Open dialog, on its "New Sequence" tab, which gives a choice between creating a new animation sequence or a new musical sequence.

"New" has a keyboard hotkey: Ctrl-N.

Open

Selecting "Open" on the Sequence Editor's File menu opens the New and Open dialog, on its "Existing Sequence" tab, which lets you open an existing sequence using a file browser similar to Windows Explorer.

"Open" has a keyboard hotkey: Ctrl-O.

Open Recent

Selecting "Open Recent" on the Sequence Editor's File menu opens the New and Open dialog, on its "Recent Sequence" tab, which lets you open by selecting it from a list of the most recently opened sequences.

"Open Recent" has a keyboard hotkey: Ctrl-R.

Close

Selecting "Close" from the Sequence Editor's File menu closes the currently selected sequence.

If the sequence has unsaved changes, you will be prompted on whether you wish to save the changes or not; if the sequence has never been saved before, and you choose to save it, you will also be prompted to select a filename for the new sequence.
Close All Files

Selecting "Close All Files" from the Sequence Editor's File menu closes all open sequences.

If any of the sequences have unsaved changes, you will be prompted on whether you wish to save them or not; if any of the sequences have never been saved before, and you choose to save them, you will also be prompted to select filenames for the new sequences.

Close All Files Except This

Selecting "Close All Files Except This" from the Sequence Editor's File menu closes all open sequences except the currently selected sequence.

If any of the sequences being closed have unsaved changes, you will be prompted on whether you wish to save the changes or not; if a sequence being closed has never been saved before, and you choose to save it, you will also be prompted to select a filename for the new sequence.

Revert to Saved

Selecting "Revert to Saved" from the Sequence Editor's File menu reloads the currently selected sequence from its last save. Any changes made to the sequence since the last save will be lost.

Save

Selecting "Save" from the Sequence Editor's File menu saves the changes that you have made to the currently selected sequence. If the sequence was newly created and has never been saved before, Save will also prompt you for a filename to use for the new sequence.

Save has a keyboard hotkey: Ctrl-S.

Save As

Selecting "Save As" from the Sequence Editor's File menu saves the current sequence to a new filename. The old file will still exist, but will not include any of the changes that you made to the sequence since the last time that you saved it.

Exit

Selecting "Exit" from the Sequence Editor's File menu closes the Sequence Editor. If any currently open sequences have changes that have not yet been saved, you will be prompted for whether or not you want to save them.

5.3.4.1.1 The New and Open Dialog

The Sequence Editor's New and Open dialog is used to create new sequences, or to open existing sequences. It has three tabs:

- "New Sequence", to create a new musical sequence or a new animation sequence;
- "Existing Sequence", to open an existing sequence, using a file browser similar to Windows
Explorer;
- **Recent Sequence**", to open a sequence that had recently been opened, by selecting it from a list.

While the New and Open dialog is displayed, you can change the selected tab by hitting Control-Tab (to cycle forward through the tabs) or Control-Shift-Tab (to cycle backward), or simply by mouse clicking on the desired tab.

The New and Open dialog can be opened, on the appropriate tab, via the File menu’s "New", "Open", or "Open Recent" menu items, and also via the Standard Toolbar's "New Sequence" and "Open Sequence" buttons.

Also, by default, the New and Open dialog will open whenever the Sequence Editor is started (opening on the tab that had been used the last time the dialog was used). This behavior can be suppressed by checking the “Don’t show this screen when Light-O-Rama starts” checkbox. If you have suppressed it, and want to unsuppress it, simply uncheck the box the next time that you use the New and Open dialog.

**New Sequence**

The New and Open dialog's New Sequence tab allows you to create a new **musical sequence** or a new **animation sequence**. Simply select which you want, which will cause either the New Musical Sequence dialog or the New Animation dialog to open.
The New and Open dialog's "New Sequence" tab

Existing Sequence

The New and Open dialog's Existing Sequence tab lets you choose a sequence to open, using a file browser similar to Windows Explorer.

This also allows you to import sequences that were created using the Dasher program. Simply select the Dasher sequence, and you will be prompted on how you wish to import it.

The "Search for files named" box, below the list of files, causes the list to show only those files with the specified text somewhere in their name. It also supports three wildcard characters, "+", "?” and "#", meaning "zero or more characters", "exactly one character", and "exactly one digit", respectively.
Recent Sequence

The **New and Open dialog's Recent Sequence tab** lets you choose a sequence to open from a list of the sequences which had been opened the most recently.
The New and Open dialog's "Recent Sequence" tab

5.3.4.1.2 The New Animation Dialog

The **Sequence Editor's** New Animation dialog is used to create a new animation sequence. The New Animation dialog is opened by selecting "New Animation Sequence" from the **New and Open dialog's "New Sequence" tab**. The New and Open dialog, in turn, can be opened in a few ways:

- Selecting "**New**" from the **File menu**;
- Clicking the "**New Sequence**" button on the **Standard toolbar**;
- Using the **keyboard** shortcut Ctrl-N.

For detailed help, please refer to the following sections:

- **Who is the author of this new animation?**
- **How many channels should this animation use?**
- **Automatically set up channels to use standard LOR controllers**
- **How long should this animation be?**
- **How much time should be in between timings?**
- **Use a fixed timing grid**
- Use loops.
- Save these choices as defaults.
- Don't ask me this again.

The **New Animation** dialog

Who is the author of this new animation?

If you wish, you can put your name here. It will be saved with the sequence, and will be displayed as a part of the information available via "Sequence Info" of the View menu.

Once set, even if set to a blank value, this cannot be changed.

How many channels should this animation use?

Specify the number of channels that you want in this sequence. You can always change this later, by adding or removing channels, for example via the Channel Property Grid or via a channel's right-click popup menu.

**Note:** All channels specified here will be placed into a single track. More tracks can be added later, for example via Add New Track or Duplicate Track of the Edit menu.
Automatically set up channels to use LOR controllers

If you check this box, the channels in your newly created sequence will automatically be set up to use Light-O-Rama controllers. The first channel will be set up to use unit 1 circuit 1, the next unit 1 circuit 2, and so forth, up through unit 1 circuit 16, and then on to unit 2, and so forth. All such channels will be set up to use the regular LOR network.

How long should this animation be?

This allows you to specify the duration of the sequence. You will be able to change the value later, using "Change Total Time" in the Edit menu.

The time can include hours, minutes, seconds, and hundredths of a second. For details on the format used to specify various lengths of time, please see Time Format.

How much time should be in between timings?

This allows you to tell the Sequence Editor to automatically insert timings into the new sequence. Timings are the spots in time where you can easily place lighting effects - for example, turn a string of lights on, or have it twinkle, or have it fade down.

If you don't know how far apart you want timings to be, just take a guess. You can always insert, delete, or move timings later. Note that although the New Animation dialog only allows you to set timings up at equal lengths from each other, timings in general can be any length from each other. For example, you could later add a timing three seconds away from another, and a third timing half a second away from that one.

If you select "Some other value", you can enter any length you want, rather than one of the defaults. For details on the format used to specify various lengths of time, please see Time Format.

Use a fixed timing grid

Unless you chose "Don't add any timings" in response to the question "How much time should be in between timings?", then if this box is checked, the sequence's initial timing grid will be a fixed timing grid. Otherwise, it will be a freeform timing grid.

Use loops.

If you check the "Use Loops" checkbox, the newly created sequence will automatically include a loop level, which can be used to insert loops into the sequence.

If you create an animation sequence without having selected "Use Loops", and you later decide that you do want loops in the sequence, you can add a loop level by selecting "Turn on Loops" from the Edit menu.

Save these choices as defaults.

If you turn this checkbox on, your answers to the questions in this dialog will be saved so that whenever you create a new animation sequence in the future, those answers will automatically show up in this dialog as the default answers.
Don't ask me this again.

If you turn this checkbox on, then whenever you create new animation sequences in the future, you will not be presented with this dialog. Instead, the default answers to the questions will be used.

If you later decide that you want to change these defaults, you can do so by going to the New Animation Preferences dialog, from Preferences submenu of the Edit menu.

5.3.4.1.3 The New Musical Sequence Dialog

The Sequence Editor's New Musical Sequence dialog is used to create a new musical sequence. The New Musical Sequence dialog is opened by selecting "New Musical Sequence" from the New and Open dialog's "New Sequence" tab. The New and Open dialog, in turn, can be opened in a few ways:

- Selecting "New" from the File menu;
- Clicking the "New Sequence" button on the Standard toolbar;
- Using the keyboard shortcut Ctrl-N.

After doing one of these things, but before the New Musical Sequence dialog opens, you will be prompted to select the audio or video file that you want to build the new sequence based off of. After you select such a file, then the New Musical Sequence dialog will open.

For detailed help, please refer to the following sections:

- Author of this new sequence
- Musical Information
- Channel Setup
- Initial Timing
- Save as defaults.
- Don't ask me this again.
Author of this new sequence

If you wish, you can put your name here. It will be saved with the sequence, and will be displayed as a part of the information available via "Sequence Info" of the View menu.

Once set, even if set to a blank value, this cannot be changed.

Musical Information

If you wish, you can put the name of the artist, song, and album of the associated song here. It will be saved with the sequence, and will be displayed as a part of the information available via "Sequence Info" of the View menu.

If you are basing the sequence on an MP3 file, and the file is tagged with this information, it will automatically be placed into this section (though you can still change or delete it if you wish).

You can change this information later, via "Sequence Info" of the Edit menu.
Channel Setup

In this section, you can either specify the number of channels that you want in this sequence, or specify that the channels should be set up based upon a configuration file.

If you specify the number of channels, you can also check the "Using standard LOR controllers" checkbox, which will cause the channels in the new sequence to be automatically set up to use Light-O-Rama controllers. The first channel will be set up to use unit 1 circuit 1, the next unit 1 circuit 2, and so forth, up through unit 1 circuit 16, and then on to unit 2, and so forth. All such channels will be set up to use the regular LOR network.

Unless you use a channel configuration file, all channels specified here will be placed into a single track. More tracks can be added later, for example via Add New Track or Duplicate Track of the Edit menu.

You can always change the number of channels or their settings later, by adding or removing channels, for example via the Channel Property Grid or via a channel's right-click popup menu.

Initial Timing

This allows you to tell the Sequence Editor to automatically insert timings into the new sequence. Timings are the spots in time where you can easily place lighting effects - for example, turn a string of lights on, or have it twinkle, or have it fade down.

In addition to placing timings a certain length of time apart (a tenth of a second, a half second, a second, or "some other value"), add adding no timings at all ("Don't add any timings"), you can instruct the Sequence Editor to use various wizards to insert timings based upon the song itself:

- The MIDI Wizard can insert timings and effects based upon the beat of a MIDI song, as well as based on the individual notes played by different instruments in the song.
- The Tapper Wizard allows you to tap the keyboard or mouse while the song plays, and will record the times at which you tap.
- The Beat Wizard attempts to determine the tempo of the song, and insert timings and effects based upon it.
- The VU Wizard looks for peaks in the song, much like a VU meter, and inserts timings and effects based upon them.

Not all of these wizards are available for every type of media file; for example, the MIDI Wizard can only be used with MIDI files. Any wizards that cannot be used with the type of media file being used will be greyed out.

If you select "Some other value", you can enter any length you want, rather than one of the defaults. For details on the format used to specify various lengths of time, please see Time Format.

If you choose to have equally spaced timings, then you will be given the option to use a fixed timing grid or a freeform timing grid, by checking or unchecking the "Use a fixed timing grid" box. Otherwise, a freeform timing grid will be used.

Note that you can always insert, delete or move timings later, in a variety of ways.

Save as defaults.
If you turn this checkbox on, your answers to most of the questions in this dialog will be saved so that whenever you create a new musical sequence in the future, those answers will automatically show up in this dialog as the default answers.

The Musical Information section - i.e. the artist name, album name, and song name - will not be saved as defaults (though if you use an MP3 tagged with this information, it will automatically be placed into that section).

Don’t ask me this again.

If you turn this checkbox on, then whenever you create new musical sequences in the future, you will not be presented with this dialog. Instead, the default answers to the questions will be used.

If you later decide that you want to change these defaults, you can do so by going to the New Musical Sequence Preferences dialog, from Preferences submenu of the Edit menu.

5.3.4.2 The Edit Menu

The Light-O-Rama Sequence Editor's Edit menu contains menu items that let you modify sequences in a variety of ways, as well as to set your preferences for the behavior of the Sequence Editor.

Most of these menu items apply to the currently selected sequence, or to the active track of the currently selected sequence. There can be many sequences open in the Sequence Editor simultaneously, but only one is the currently selected sequence. It can be distinguished by its bright blue title bar (as opposed to the pale blue title bar of unselected sequences). You can select a sequence simply by clicking on its window.

- Undo and Redo
- Enable/Disable Undo Recording
- Cut, Copy, Paste, and Paste Multiple
- Set Paste Mode
- Copy and Paste Timings
- Select Columns, Select Rows, and Select All
- Change Track Name
- Skew Track
- Add New Track
- Duplicate Track
- Change Total Time
- Timings
  - Insert Multiple Timings
  - Subdivide Timings
  - Delete Extraneous Timings
  - Lock Timings
  - Drag Events with Timings
  - Confirm Long Timing Drags
- Turn on Loops
- Sequence Info
- Media File
- Windows Command
- Export and Import Channel Configuration
- Preferences
The Sequence Editor's Edit menu

**Undo and Redo**

These allow you to undo and redo changes that you make to a sequence. A wide variety of changes can be undone and redone - changing lighting effects, moving timings, inserting channels, and many more. The next change to be undone or redone is named in the menu item:

```
Undo Twinkle Ctrl+Z
Redo Add Timing Grid Ctrl+Y
Enable/Disable Undo Recording
Cut Ctrl+X
Copy Ctrl+C
Paste Ctrl+V
Paste Multiple
Set Paste Mode
Copy Timing Shift+Del
Paste Timing Shift+ins
Select
Change Track Name
Skew Track
Add New Track
Duplicate Track
Change Total Time
Timings
Turn on Loops
Sequence Info
Media File
Windows Command
Export/Import Channel Configuration
Preferences
```
There is a limit to how many changes will be remembered for the purposes of undo and redo, so if you make many changes to a sequence and then start undoing them all, you may eventually reach a point where you can't undo any more, even though you haven't undone all of the changes that you made.

Also, you will not be able to undo any changes made before the last time that you saved the sequence.

A related option is to use "Revert to Saved" from the File menu. This will reload the sequence as it was the last time that you saved, getting rid of all changes since that time.

Undo and redo have keyboard hotkeys: Ctrl-Z and Ctrl-Y, respectively.

Enable/Disable Undo Recording

Certain very large operations in the Sequence Editor could take a very long time to do. For example, skewing a track involves changing all of the timings, effects, and loops in the track; in a large sequence with many channels, this could take a prohibitively long time. Much of the time spent is actually due to recording the changes so as to later be able to undo and redo them.

For situations like this, you can disable undo recording before making such a change, which will speed up how long the change will take. You will not be able to undo any changes after doing so (except for changes that you make after re-enabling it later), so it is strongly suggested that you save your sequence before disabling undo recording.

Cut, Copy, Paste, and Paste Multiple

When editing a sequence, you can select an area using your mouse or keyboard, and cut or copy the lighting effects in that area. You can then paste the contents of that area to another spot - even to a spot within a different sequence. Note that this copies only the lighting effects, not the timings - see "Copy and Paste Timings" for how to copy timings.

"Paste Multiple" allows you to paste the cut or copied events multiple times in a row - even to the end of the sequence:
The Paste Multiple dialog

The Sequence Editor supports two different pasting modes - "paste by time" and "paste by cell" - and a pasting option, "paste from foreground". Which of these is selected will affect how the pasted effect events will look.

Cut, copy, and paste have keyboard hotkeys: Ctrl-X, Ctrl-C, and Ctrl-V, respectively.

Set Paste Mode

When a set of lighting effects is copied (or cut) in the Sequence Editor, it can be pasted in two different manners: "paste by cell", or "paste by time". You can control which paste mode is used via the "Set Paste Mode" submenu of the Edit menu, or via the Clipboards subpanel of the left-hand Tools panel.

There is also a pasting option, "paste from foreground". This can be also controlled via "Set Paste Mode" or the Clipboards subpanel.

Copy and Paste Timings

You can select a set of timings using the keyboard or the mouse, and use "Copy Timing" to copy them. After that, you can paste the timings to another point in the sequence (or even to another sequence) using "Paste Timing". Note that this copies only the timings, not any lighting effects (see "Cut, Copy, Paste, and Paste Multiple" for information on copying lighting effects).

For example, if you copy timings that are at 3 seconds, 3.5 seconds, and 5 seconds, and paste those timings starting at 7 seconds, you will wind up with timings at 7 seconds, 7.5 seconds, and 9 seconds.

Paste Timing allows you to optionally choose to paste the timings multiple times in a row:
The Light-O-Rama Software Package

You can also copy and paste timings via the right-click context menu, in a few ways. Depending on the situation, using one of them may be more convenient than doing so via the Edit menu. For example, one of the options on that menu allows you to paste the timings once to the exact spot that you right-clicked on, getting rid of the need for the Paste Timing Multiple dialog.

Copy Timing and Paste Timing have keyboard hotkeys: Shift-Del and Shift-Ins, respectively.

Select Columns, Select Rows, and Select All

These menu items allow you to select an entire column or set of columns (representing time) or an entire row or set of rows (representing channels), or both.

Change Track Name

Tracks can optionally be given names. They can be set when the track is created, or via this menu item. The track's name (if any) will be displayed on its track bar, among other places.

Skew Track

Skewing a track will move all of its events, timings, and loops by some specified amount of time. A track can be skewed either to the left - i.e. shifting its events (and such) earlier in time - or to the right - i.e. shifting them later in time.

After selecting "Skew Track" from the Edit menu, a window will open up, allowing you to choose the size and direction of the skewing:
After completing this dialog, the active track will be skewed by the amount, and in the direction, that you chose.

Here is an example of a simple sequence, before and after skewing to the left by one-quarter second:

**Add New Track**

This menu item allows you to add a new **track**, with new **channels**, to a **sequence**, using the **Add New Track dialog**.

**Tip:** To use the same channel in more than one track, do **not** simply set two channels in different tracks to point to the same **hardware controller** (i.e. to have the same unit number, circuit number, et cetera). Doing so will likely cause unexpected and undesired results, as the two channels compete.
for control over the same circuit. Instead, copy the channel to a new track or to an existing track. Or, if you want to share all the channels in a track with another track, duplicate the track.

Duplicate Track

This menu item instructs the Sequence Editor to duplicate all of the channels in the current track to a new track. The channels will be shared between the two tracks.

Change Total Time

This menu item allows you to change the duration of the active track. Note that all tracks in a musical sequence (as opposed to an animation sequence) must have the same length, so changing the length of one track in a musical sequence will automatically change the length of all of them.

For information on the format used to specify an amount of time, please see Time Format.
Timings

This submenu of the Sequence Editor’s Edit menu has various timing-related functions:

- Insert Multiple Timings
- Subdivide Timings
- Delete Extraneous Timings
- Switch Timing Grid
- Change Timing Grid Name
- Lock Timings
- Drag Events with Timings
- Confirm Long Timing Drags

Insert Multiple Timings

This allows you to insert multiple timings into the current selection, to divide it into equally-sized parts. For example, if you select an area whose time range is from 6 to 8 seconds, and use “Insert Multiple Timings” to insert three equally spaced timings, then the new timings will be inserted at 6.5, 7, and 7.5 seconds, splitting the selection into four equally spaced parts of half a second each.

See also Subdivide Timings, which divides each selected cell into equally-sized parts, as opposed to dividing the entire selection into equally-sized parts.

Subdivide Timings

This allows you to insert multiple timings into the current selection, dividing each selected cell into equally-sized parts. For example, if you select three cells, from 2 to 3 seconds, 3 to 3.6 seconds, and 3.6 seconds to 4 seconds, and use “Subdivide Timings” to subdivide into two cells, you will end up with six cells, from 2 to 2.5, 2.5 to 3, 3 to 3.3, 3.3 to 3.6, 3.6 to 3.8, and 3.8 to 4.

See also Insert Multiple Timings, which divides the entire selection into equally-sized parts, as opposed to dividing each selected cell into equally-sized parts.

Delete Extraneous Timings

The purpose of timings is to allow you to easily select a time range to apply a lighting effect to. Sometimes, a sequence winds up having timings which are not necessary for any of the existing lighting effects - for example, everything that was on before the timing is also on after the timing, everything twinkling before is twinkling afterwards, and so forth.

“Delete Extraneous Timings” lets you automatically get rid of all such timings. Deleting these timings is not really necessary - it makes no difference to how your lights will behave - but it may make your sequence easier to understand and to edit by reducing clutter. It may also be useful, for example, when using the Tapper Wizard’s “Snap to Existing Timings” functionality.

The following pictures are a before-and-after of deleting extraneous events. Note that the timing event at one second in the first picture is not necessary - every channel that is on before it is on after it, every one that is twinkling before it is twinkling after it, and so forth. The second picture - after deleting extraneous events - therefore does not have this timing. However, the way that the lights operate will be the same in both cases.
Before deleting extraneous timings

After deleting extraneous timings

Switch Timing Grid

Selecting this menu item opens a dialog window allowing you to switch which timing grid is currently used by the active track. You can switch to an existing timing grid simply by selecting it from the dropdown list, or switch to a new fixed or freeform timing grid, or a new freeform grid with copies of all the timings in the current grid, by clicking on the appropriate button:

Change Timing Grid Name

This menu item allows you to change the name of the current timing grid. The main purpose of giving a name to a timing grid is so that they can be easily distinguished when listed in places such
as the Tracks and Timings toolbar's timings dropdown list.

**Lock Timings**

Each timing in a sequence is a particular point in time (since the beginning of the sequence), and is represented by a vertical grey line. If "Lock Timings" is off (unchecked), and the current timing grid is a freeform timing grid, you can change the time of a timing by hovering over its line with your mouse (which will change your mouse cursor from a "pointer" cursor to an "east-west" cursor), and clicking and dragging the line to the left or the right.

If "Lock Timings" is on (checked), you cannot do this. This prevents you from accidentally changing the time of a timing while you're trying to modify the lighting effects in a cell between two timings.

See also "Drag Events with Timings", which controls whether or not effect events that start or end at the dragged timing will be dragged along with it.

**Drag Events with Timings**

Timings in a sequence can be dragged with the mouse to change the time that they are at (unless the Lock Timings option is turned on). If "Drag Events with Timings" is turned on, and any effect events start or end at the same time as the timing being dragged, they will be dragged along with it. If not, only the timing will move; the effect events will remain unchanged.

**Confirm Long Timing Drags**

If you change the time of a timing by dragging it with your mouse (as described in "Lock Timings"), and at some point in your drag you went past the previous timing or the next timing, the Sequence Editor guesses that you might not have actually intended to change the timing's time; rather, you might have accidentally clicked on the timing's line and dragged it while intending to do something else, like modifying the lighting effects near the timing.

In this case, the Sequence Editor will ask if you really want to change the timing, unless you turn off (i.e. uncheck) "Confirm Long Timing Drags", in which case it will simply move the timing without asking.

**Turn on Loops**

Animation sequences (but not musical sequences) can contain loops: When a certain point in the sequence - the end of a loop - is reached during play, play continues at the start of the loop instead of continuing straight through, until the loop has been done a certain number of times (which you can choose).

When an animation sequence is created using the New Animation dialog, you have the option to say that loops will be used in the sequence. Doing so will cause a white "loop level" row to be present above all of the grey "channel" rows in the sequence.

If you did not choose to use loops in the New Animation dialog, you will not get a loop level row in your sequence. However, if you later decide that you do want to use loops, you can use "Turn on Loops" to add a loop level to the sequence.

**Sequence Info**
This brings up a dialog displaying various information about the sequence, allowing you to change some of it:

- **Created By**: The creator of the sequence as specified in the New Animation dialog or the New Musical Sequence dialog. This value cannot be edited.
- **Created At**: The date and time at which the sequence was created. This value cannot be edited.
- **Modified By**: If you modify a file that was created by someone else, you can enter your name here, if you wish.
- **Music Artist**: For musical sequences, the artist who performed the song.
- **Music Title**: For musical sequences, the name of the song.
- **Music Album**: For musical sequences, the name of the album that the song is from.

The Edit Sequence Info dialog for a musical sequence

### Media File

This menu item allows you to specify the audio or video file that should be used with the current sequence. This may be useful, for example, if you have changed the directory that you store your media files in.

It is available only for musical sequences, not animation sequences.

### Windows Command

Selecting "Windows Command" from the Sequence Editor's Edit menu will open up a dialog allowing you to specify an arbitrary Windows shell command to be executed whenever the sequence is run (whether by the Sequence Editor or by the Show Player). This dialog also allows you to choose how the window for the command will be opened - for example, whether it will be maximized or not.
The Windows Shell Command dialog.

Export and Import Channel Configuration

Every channel in a sequence has various information associated with it, such as its name, display color, and hardware information such as the unit number of the controller and the circuit number of the string of lights on that controller.

You can set up this information in various ways, such as via the Channel Property Grid. However, it may be the case that you often want to do this the exact same way, for several different sequences, using the same channel names, hardware assignments, et cetera. Rather than manually setting it up every time, you can use the Export and Import Channel Configuration menu items.

Once you have the correct channel information set up for a particular sequence, you can choose "Export Channel Configuration" to save the channel information to a channel configuration file. When you create another sequence and you want to use the same controllers and the same circuits, you can simply choose "Import Channel Configuration" and select the channel configuration file that you previously exported to.

The saved channel configuration information also includes the animation associated with the exported sequence, so you will not have to redraw it every time.

If your exported sequence contains more channels (or tracks) than the sequence that you are importing to, new channels or tracks will automatically be created in the latter sequence during the import (or, if the channels in a track of the configuration file are copies of channels in earlier tracks of the configuration file, copies of the corresponding channels from the earlier tracks of the sequence will be put into the later tracks of the sequence). On the other hand, if the exported sequence contains less channels (or tracks), the extras in the sequence that you are importing to will simply remain unchanged.

When exporting and importing from and to sequences with more than one track, there are two
potential minor side effects:

First, if a track in the sequence contains only channels that are copies of channels in earlier tracks of the sequence, and the channel configuration does not contain a track at the corresponding position, then the track will be removed from the sequence. Note that the channels from the track are not removed from the sequence - they are only removed from the track (and, since the track then contains no channels, the track is removed from the sequence). The channels will still be present in earlier tracks of the sequence.

Second, if a track in the sequence contains a channel which is not a copy of a channel of an earlier track in the sequence, and the channel configuration file does not contain a channel at the corresponding position (other than copies of channels from earlier tracks), then the channel will be “pushed down” towards the bottom of the track.

Preferences

The Preferences submenu of the Edit menu allows you to open various preference dialogs that affect how the Sequence Editor will behave:

- Display Preferences
- DMX Preferences
- Holiday Lights Designer Preferences
- Network Preferences
- New Animation Preferences
- New Musical Sequence Preferences
- Play Preferences
- Video Preferences
- Zoom Preferences

For detailed help on each, please refer to their individual help file pages.

5.3.4.2.1 The New Track Dialog

The Sequence Editor's New Track dialog is used to create a new track in a sequence. You can open the New Track dialog in a few ways:

- Via "Add New Track" on the Edit menu. This will create a new track with all new channels.
- Via "Copy to New Track" on a channel button's popup menu. This will create a new track that shares the selected channel with the old track, and optionally includes new channels as well.
- Via "Move to New Track" on a channel button's popup menu. This will create a new track, move the selected channel from the old track to the new, and optionally add new channels to the new track as well.

Important Note: If you want a single channel shared by multiple tracks, do not simply set up different channels in the different tracks to have the same unit ID, circuit ID, et cetera. Doing so will likely cause unexpected and undesired results, as the different channels vie for control over the same physical string of lights. Instead, copy the channel from one track to another, or duplicate a track (which shares all channels in it with the new duplicate track).

For detailed help on the New Track dialog, please see the following sections:

- What is this track's name?
• How long should this track be?
• What timings should be used?
• How much time should be in between timings?
• Move the display to show the newly created track

The New Track dialog

What is this track’s name?

If you want the track to have a name, enter it here. The track’s name will show up on its track bar, and in various other places where tracks are listed.

If you do not wish to have a track name, you can simply leave this field blank. If you change your mind later, you can always go back and add a name (or change an existing one) by using "Change Track Name" on the Edit menu.

How long should this track be?

For animation sequences, this allows you to specify the duration of the track. You can choose to use the duration of an existing track, or manually enter a time. For the format used for entering
times, please see Time Format.

For musical sequences, this question is greyed out. All tracks in a musical sequence must have the same duration, and so the duration of the new track will automatically be set to the duration of the other tracks in the sequence.

**How many channels should this track use?**

Use this box to specify the number of new channels that this track should have.

If you have opened the New Track dialog by copying or moving a channel to a new track, this question will ask you how many channels this track should have in addition to the one that you are copying or moving. So, for example, if you want the track only to contain the copied channel, enter "0" in this box.

**What timings should be used?**

This allows you to instruct the Sequence Editor to automatically insert timings into the new track, or else to use an existing timing grid. You can choose from among various preset durations (such as half a second between timings), to manually enter a duration (see Time Format for how to specify an amount of time), not to insert timings at all, or, for musical sequences, to use various wizards to insert timings or effects based upon the song itself - the MIDI Wizard, the Tapper Wizard, the Beat Wizard, and the VU Wizard. Not all of these wizards will be available for any given sequence - which is available depends upon the type of media file being used.

Note that you can always go back later and add, delete or move timings, in a number of different ways.

**Move the display to show the newly created track**

If this box is checked, then when the new track is created, the display will automatically move to show the new track. To get back to the other tracks in your sequence, scroll up.

---

**5.3.4.2.2 Preference Dialogs**

The Preferences submenu of the Edit menu of the Sequence Editor gives access to various preference dialogs which can be used to control the behavior of the Sequence Editor and other parts of the Light-O-Rama software package:

- Display Preferences
- DMX Preferences
- Holiday Lights Designer Preferences
- Network Preferences
- New Animation Preferences
- New Musical Sequence Preferences
- Play Preferences
- Video Preferences
- Zoom Preferences
The Preferences submenu of the Sequence Editor's Edit menu

5.3.4.2.2.1 Display Preferences

The Sequence Editor's Display Preferences dialog (which can be opened from the Preferences submenu of the Edit menu) gives control over some aspects of how the Sequence Editor looks:

- **General Preferences**
  - View Channel Buttons by Default
  - View Fades as Ramps by Default
  - View Time Scale by Default
  - View Wave Form by Default

- **Tooltip Preferences**
  - Enable tooltips
  - Seconds before opening
  - Seconds before closing automatically
  - Manually close tooltips on mouseover
  - Manually close tooltips on click

- **Animation Redraw Throttling**
- **Advanced OpenGL Settings**
The Display Preferences dialog

General Preferences

- View Channel Buttons by Default
- View Fades as Ramps by Default
- View Time Scale by Default
- View Wave Form by Default

**View Channel Buttons by Default**

If this box is checked, the channel buttons for each channel in a sequence will be displayed whenever a sequence is created or opened.

If you don't want to change this default, but want to temporarily change whether or not channel buttons are displayed, you can use "Channel Buttons" from the View menu, or "View Channel buttons" from the Standard toolbar, or click on the thick grey vertical bar to the left of the sequence's grid (and, if channel buttons are currently visible, to the right of them).
**View Fades as Ramps by Default**

If this box is checked, fades and intensities will be displayed as ramps by default, whenever a sequence is opened or created. This means that a cell with a fade or an intensity will be displayed as partially filled in, based upon how bright the fade or intensity is, rather than as shades of the channel's color.

If you don't want to change this default, but want to temporarily change whether fades are displayed as ramps or as colors, you can use the Fades submenu of the View menu, or "View Fades as Ramps" from the Standard toolbar.

**View Time Scale by Default**

If this box is checked, then whenever a sequence is created or opened, a time scale will be displayed at the top of the sequence.

If you don't want to change this default, but want to temporarily change whether a time scale is
displayed or not, you can use "Time Scale" from the View menu, or "View Time Scale" from the Standard toolbar.

![A sequence, with a time scale displayed](image1)

The same sequence, with no time scale displayed

**View Wave Form by Default**

If this box is checked, then whenever a musical sequence is created or opened, a wave form of the song will be displayed near the top of the sequence (except for sequences using certain types of media files, such as MIDI files and video files). This setting has no effect on the display of musical sequences using those types of media files, or of animation sequences.

If you do not want to change this default, but want to temporarily change whether wave form is displayed or not, you can use "Wave Form" from the View menu, or "View Wave Form" from the Standard toolbar.
A sequence, with a waveform displayed

The same sequence, with no waveform displayed

Tooltip Preferences

- **Enable tooltips**
- **Seconds before opening**
- **Seconds before closing automatically**
- **Manually close tooltips on mouseover**
- **Manually close tooltips on click**

**Enable tooltips**

If this box is checked, when the mouse is over a sequence grid, a tooltip displaying information about the cell being pointed to can be displayed. You can control more specific behaviors of the tooltip via other tooltip preferences.

**Seconds before opening**

If tooltips are enabled, this text box controls how many seconds it will take before the tooltip pops up, when the mouse is kept still over a sequence grid.
You do not have to specify a whole number; for example, you can set it to three-quarters of a second by entering "0.75".

**Seconds before closing automatically**

If tooltips are enabled, this checkbox and text box control whether or not they will automatically close themselves a certain amount of time after being opened. If the checkbox is checked, they will automatically close after the number of seconds specified in the text box.

You do not have to specify a whole number; for example, you can set it to three-quarters of a second by entering "0.75".

**Manually close tooltips on mouseover**

If tooltips are enabled, selecting this option will make them close when you roll your mouse over them. The other option is to make them close when you click on them.

**Manually close tooltips on click**

If tooltips are enabled, selecting this option will make them close when you click on them. The other option is to make them close when you roll your mouse over them.

**Animation Redraw Throttling**

During play, the Animator will only redraw the animation every so often, suppressing more frequent redraw requests. This is done to try to ensure that it does not take up too much of the computer's CPU time. However, it means that very fast events may not get displayed by the Animator (although they will still affect your actual lights).

The amount of throttling that the Animator will do is configurable. By default, it is set to "Low", which means that it doesn't throttle very much, and therefore the animation should be as smooth as possible. The cost of this smoothness is that the Animator will use more of your computer's CPU time.

So, if you notice that the Animator is having a hard time keeping up with your sequence, making the animation and perhaps even the sequence itself choppy or sluggish, it may be because the Animator is using too much CPU time for your computer. In this case, you may want to try changing this setting to "Medium", which will cause the Animator to allow redrawings less frequently, thereby decreasing the amount of CPU time it uses. "High" will decrease CPU utilization even further.

**Advanced OpenGL Settings**

This button opens up the Advanced OpenGL Settings dialog, which can be used experimentally to try to resolve various strange graphics issues. However, this is not recommended, and often other steps (such as updating your graphics card's driver) will resolve graphics issues in a better manner.

The Advanced OpenGL Settings dialog (which can be accessed from the Display Preferences dialog) can be used, experimentally, to try to resolve various strange graphics issues, such as a blank area appearing where the grid of a sequence should be, or the grid appearing offset from where it should be (e.g. the rows of the grid do not properly line up with the channel buttons).
However, this is not recommended. Typically, such issues can be better resolved in other ways, such as updating your computer's graphics card's drivers. Some people have also had luck resolving such issues by doing things such as disabling advanced Windows themes (such as "Aero"), by disabling "hardware acceleration" in their graphics card's settings, or by changing their Windows display settings from 32 bit color to 16 bit color.

The Advanced OpenGL Settings dialog can be used as another option to these methods, but, again, it is not suggested. Changing the settings using this dialog could conceivably cause other strange graphics issues, or cause the Sequence Editor to run slowly.

The dialog allows you to choose between two options: "Use the default Windows pixel format" (which is recommended), and "Use a specific pixel format". If you chose to use a specific pixel format, then you can choose it from the dropdown list immediately below that option.

The list of pixel formats does not include all possible pixel formats that are available on your computer; instead, it only includes those that seem to meet the requirements of the Light-O-Rama Sequence Editor. It also includes brief descriptions of each of them; the meanings of these descriptions are beyond the scope of this help file. If you would like to know what they mean, please consult OpenGL documentation.

In either case, whether you choose to use the default Windows pixel format or a specific pixel format, a preview picture will be displayed at the bottom of the dialog, drawn using that pixel format. If the picture does not look as its description says it should, then the chosen pixel format will probably not work correctly on your computer.

Some pixel formats may be more efficient than others, so even if a pixel format seems to work, it may cause the Sequence Editor to run more slowly than normal. So, if you choose to change the pixel format in use, and the Sequence Editor then seems choppy or slow, you may want to try another pixel format.

After you choose a pixel format and exit the dialog, you may have to close the Sequence Editor and restart it before your changes will fully take effect.
5.3.4.2.2 DMX Preferences

By default, the DMX intensity tool is not available for use in the Sequence Editor. This means that no toolbar icon will be shown for it on the Tools toolbar, nor a menu item in the Tools menu, nor will a keyboard shortcut be available for it. To enable these things, turn on “Allow DMX Editing” in the DMX Preferences submenu of the Preferences menu of the Edit menu:

5.3.4.2.3 Holiday Lights Designer Preferences

Holiday Lights Designer™ is a third-party application, by Holidaysoft®, that can be used to virtually place lights and decorations on images of your home or business. Light-O-Rama can send Holiday Lights Designer™ commands during play to make those virtual lights behave as your real lights would during a show. The Holiday Lights Designer™ Preferences dialog (in the Preferences submenu of the Sequence Editor’s Edit menu) is used to set up how Light-O-Rama interacts with Holiday Lights
To use this dialog, enter the IP address and port that Holiday Lights Designer™ listens to in the "HLD Host" and "HLD Port" fields, and the port that Light-O-Rama should listen to in the "Local Port" field. If Holiday Lights Designer™ is running on the same machine as Light-O-Rama, setting the HLD Host to 127.0.0.1 will likely work.

Similar settings may need to be made in the configuration of Holiday Lights Designer™ itself.

Some older versions of Holiday Lights Designer™ support shimmers and twinkles only as full intensity shimmers and twinkles; custom shimmers and twinkles (such as faded shimmers) are not supported. If your sequence contains such an effect, and it is sent to a version of Holiday Lights Designer™ without support for it, Holiday Lights Designer™ will simply ignore the effect. However, you could uncheck the "HLD supports faded shimmers and twinkles" box; this causes Light-O-Rama to send Holiday Lights Designer™ all shimmers and twinkles as if they were full intensity shimmers and twinkles, allowing these older versions of Holiday Lights Designer™ to at least partially display these effects. Note that this does not affect the behavior of your actual lights; it only affects what is displayed in Holiday Lights Designer™.

Additionally, commands will only be sent from Light-O-Rama to Holiday Lights Designer™ if "Control Holiday Lights Designer" is turned on in the Sequence Editor's Play menu, or if "Holiday Lights Designer On" is enabled in the Light-O-Rama Control Panel.

All of these settings will be used not only when sequences are played using the Sequence Editor, but also when shows are played using the Show Player.

5.3.4.2.2.4 Network Preferences

Light-O-Rama software running on a computer can control several types of hardware controllers. To do so, most of these types must be hooked up to the computer using a serial port (adapters such as the USB-RS485 are available from Light-O-Rama if your computer does not have a serial port). The Sequence Editor's Network Preferences dialog, available from the Preferences submenu of the Edit menu, can be used to configure the serial ports on your computer to support different types of hardware controllers.

Light-O-Rama controllers can be controlled on up to four different networks, each using a different serial port (referred to as the "regular network" and three auxiliary networks, "Aux A", "Aux B", and "Aux C").

If you have any Dasher controllers, they must be on their own serial port (referred to as the "Dasher port"). Similarly, X10 controllers must be on their own serial port as well (the "X10 port").
Light-O-Rama can control hardware on all of these ports (as well as on Digital IO cards and BSOFT Digital IO cards, which do not use serial ports) simultaneously.

For details on how to use the Network Preferences dialog, please refer to the following individual sections:

- Light-O-Rama Networks
  - The Serial Ports
  - Connection Speed
  - List Networks in Channel Configuration
  - Compatibility
- Dasher Port
- X10 Port

The Network Preferences Dialog

![Network Preferences Dialog](image)

Light-O-Rama Networks

Up to four different networks for Light-O-Rama controllers can be specified here, each with a different serial port. The communications speed of each can be set independently. If you only want
to use a single Light-O-Rama network (which is perfectly sufficient for many users’ needs), you can choose to simplify the behavior of the Sequence Editor in various ways by turning off "List networks in channel configuration". Finally, if you own certain old Light-O-Rama controllers, you should use the "Compatibility" section to let Light-O-Rama know so that it can support them correctly.

**The Serial Ports**

In the dropdown box for each Light-O-Rama network, choose the serial port that you wish to use for that network. Make sure that they do not conflict with each other, or with the Dasher port or the X10 port.

If you don't want to use all four possible networks, you can simply set some of them to "(None)". Using only a single Light-O-Rama network is perfectly sufficient for the needs of many users.

**Connection Speed**

Light-O-Rama can communicate with Light-O-Rama controllers using various communication speeds. These speeds can be set independently for each Light-O-Rama network.

If you do not have extraordinary needs, "Average Recommended Setting" is suggested.

If your controllers are hooked to your computer using a very long or poor quality communications cable, you may need to set the speed to "Long Range Medium Speed".

If you have many circuits with very fast action you may need to set the speed to "Short Range Fastest Speed". This setting is not supported if you are using Light-O-Rama Easy Light Linkers for wireless communications.

**List Networks in Channel Configuration**

Although Light-O-Rama supports up to four separate networks of Light-O-Rama controllers, the needs of many users will be met adequately with a single network. If this is the case for you, you may wish to turn off this checkbox. Doing so will simplify using the Sequence Editor a little, by disabling the dropdown boxes which let you assign a network to a channel (for example, on the Channel Property Grid or the Channel Settings dialog). Instead, the "Regular" network will automatically be used.

**Compatibility**

If you are using Light-O-Rama MC-P controllers purchased prior to November 15, 2003, then you should enable Old MC-P Compatibility mode by checking its compatibility box. If you do not check this box, then you will see odd behavior on circuits 9 through 16 of such controllers.

**Dasher Port**

If you are using any Dasher controllers, they must be hooked to your computer on their own serial port. Set the serial port used for Dasher controllers here. Make sure that it does not conflict with any of the ports used for Light-O-Rama networks, or with the X10 port.

If you are not going to use any Dasher controllers, simply set the Dasher port to "(None)".

**X10 Port**
If you are using any X10 controllers, they must be hooked up to your computer on their own serial port. Set the serial port used for X10 controllers here. Make sure that it does not conflict with any of the ports used for Light-O-Rama networks, or with the Dasher port.

If you are not going to use any X10 controllers, simply set the X10 port to "(None)".

5.3.4.2.2.5 New Animation Preferences

The Sequence Editor's New Animation dialog is used to create new animation sequences. When a new animation sequence is created, it allows you to specify things like the name of the author of the sequence and how many channels the sequence will use.

You can change the default answers to most of these questions, so that you don't have to type them in every time, by selecting "New Animation Preferences" from the Preferences submenu of the Edit menu.

For more detailed help, please refer to the help page for the New Animation dialog.
5.3.4.2.2.6 New Musical Sequence Preferences

The Sequence Editor’s New Musical Sequence dialog is used to create new musical sequences. When a new musical sequence is created, it allows you to specify things like the name of the author of the sequence and how many channels the sequence will use.

You can change the default answers to most of these questions, so that you don’t have to type them in every time, by selecting “New Musical Sequence Preferences” from the Preferences submenu of the Edit menu.

For more detailed help, please refer to the help page for the New Musical Sequences dialog.

5.3.4.2.2.7 Play Preferences

The Sequence Editor can be used not only to create and edit sequences, but also to test them by playing them. The Play Preferences dialog of the Preferences submenu of the Edit menu allows control over certain aspects of how it plays them.

**Note:** These settings only affect play in the Sequence Editor. They do not affect play of Shows, via the Show Player.
The following options can be set in the Play Preferences dialog:

- **Vary the Color of Channel Buttons during Play by Default**
- **Loop at the End of a Sequence by Default**
- **Highlight Current Event during Play by Default**
- **Highlight Current Time during Play by Default**

![Play Preferences dialog](image)

**Vary the Color of Channel Buttons during Play by Default**

Channels can be assigned colors. When a lighting effect is shown by the Sequence Editor in a sequence's grid, that color (or one based on it) will be used. This doesn't affect your actual lights, but it might be helpful to set the channels in your sequence to have the same colors as the real lights that will be hooked up to them.

When the Sequence Editor plays a sequence, it can vary the colors of the channel buttons to show the lighting effect taking place on that channel at that instant. For example, during a fade up, the color of the channel button will gradually fade from the default light grey up to the color assigned to that channel.

If you prefer not to see the channel buttons' colors vary this way during play, you can uncheck "Vary the color of channel buttons during play by default", and the channel buttons will simply remain light grey during play, regardless of what lighting effects occur.

If you do not want to change this preference as a default, but do want to temporarily change it, you can do so via "Vary Color of Channel Buttons" on the Play menu, or by the "View Channel Button Colors" button on the Standard toolbar.

**Loop at the End of a Sequence by Default**

Normally, when the Sequence Editor plays a sequence, play stops automatically when the end of the sequence is reached (or the end of the selection, or of the currently visible screen; please see "Play Range" on the Play menu for details). However, if "Loop at End" is selected from the Play menu, then play will instead automatically loop back to the beginning of the play range whenever the end of the play range is reached. To stop playing a sequence when it is looping like this, you must manually stop it, for example via the Stop button on the Standard toolbar.
On the **Play Preferences menu**, you can set whether or not "Play at End" is enabled by default whenever the Sequence Editor starts up by choosing a value for "Loop at the end of a sequence by default".

Note that this does not affect the play of your sequences during a show (via the **Show Player**), nor should it be confused with loops within a sequence.

### Highlight Current Event during Play by Default

If the "Highlight Current Event" option on the **Play menu** is enabled, then when the Sequence Editor plays a sequence, it will highlight the timings that are closest to the current time with thick black lines, moving them across the sequence's grid as play progresses. For example, if a sequence has timings every half a second, and the current time is 37 and 37/100 seconds, then a thick black border will be made on the timings at 37 seconds and at 37.5 seconds.

On the **Play Preferences menu**, you can set whether or not "Highlight Current Event" is enabled by default whenever the Sequence Editor starts up by choosing a value for "Highlight current event during play by default".

### Highlight Current Time during Play by Default

If the "Highlight Current Time" option on the **Play menu** is enabled, then when the Sequence Editor plays a sequence, it will draw a dashed vertical line at the current time, which will move across the sequence's grid as play progresses.

On the **Play Preferences menu**, you can set whether or not "Highlight Current Time" is enabled by default whenever the Sequence Editor starts up by choosing a value for "Highlight current time during play by default".

### Video Preferences

Musical sequences are associated with a song or other sound effect, from either an audio file (such as an MP3) or a video file (such as a WMV file). If a musical sequence is associated with a video file, Light-O-Rama can display the video during play. Or, for an audio file, Light-O-Rama can display a visualization.

The Video Preferences dialog, of the **Preferences submenu** of the **Sequence Editor's Edit menu**, can be used to control whether and how video is displayed during play.

**Note:** These settings affect not only play of sequences in the Sequence Editor, but also play of shows by the **Show Player**.

The following options can be set via the Video Preferences dialog:

- Display Videos
- Display Audio Visualizations
- Use Full Screen Mode
- Select Monitor
Display Videos

If "Show Videos" is enabled on the Video submenu of the View menu, and a musical sequence based on a video file is played by the Sequence Editor, Light-O-Rama will display the video during play.

You can control whether "Show Videos" is enabled by default via this setting on the Video Preferences menu. This also affects play during shows, by the Show Player.

Display Audio Visualizations

If "Show Audio Visualizations" is enabled on the Video submenu of the View menu, and a musical sequence based on an audio file is played by the Sequence Editor, Light-O-Rama will display a visualization of the audio during play.

You can control whether "Show Audio Visualizations" is enabled by default via this setting on the Video Preferences menu. This also affects play during shows, by the Show Player.

Use Full Screen Mode

If "Full Screen" is enabled on the Video submenu of the View menu, and a video or audio visualization is displayed for a musical sequence being played by the Sequence Editor, Light-O-Rama will display the video or visualization during play.

You can control whether "Full Screen" is enabled by default via this setting on the Video Preferences menu. This also affects play during shows, by the Show Player.

Select Monitor

If you have more than one monitor hooked up to your computer, you can use this button to select which monitor Light-O-Rama will use when it displays videos or audio visualizations. This also affects play during shows, by the Show Player.
5.3.4.2.9 Zoom Preferences

When a sequence is displayed in the Sequence Editor, it is represented as a grid. Columns represent time, and rows represent channels. You can zoom the display of either or both of these dimensions in or out for any particular sequence, in a variety of ways (such as by using the keyboard, or various buttons on the Standard toolbar).

However, whenever the Sequence Editor opens or creates a sequence, it will use some default zoom level settings. If you prefer some other zoom level, you probably do not want to zoom in or out every time that you open a sequence. So, the Zoom Preferences submenu (of the Preferences submenu of the Edit menu) allows you to save your current zoom level settings, by selecting "Save Zoom Preferences".

Later, when the Sequence Editor opens or creates a new sequence, it will default to the zoom level settings that you had saved.

If you change the zoom level on a sequence, and want to get back to your saved zoom level settings, the Zoom Preferences submenu also provides a way to do this, by selecting "Restore Zoom Preferences".

The Zoom Preferences submenu

5.3.4.3 The View Menu

The Light-O-Rama Sequence Editor's View menu contains items that enable you to customize how the Sequence Editor appears and how it displays sequences, as well as to view certain information about sequences.

The following items appear on the Sequence Editor's View menu:

- Channel Buttons
- Time Scale
- Wave Form
- Animation
- Video
  - Show Videos
  - Show Audio Visualizations
  - Full Screen
- Fades
- Sequence Info
- Track Info
- Cell Info
- Zoom Rows
- Zoom Columns
- Tool Bars
- Refresh
The View menu

Channel Buttons

If this option is enabled, the channel buttons of the active sequence will be displayed. Multiple sequences can be open in the Sequence Editor at the same time, and this option can be set independently for each of them.

You can also control this using the “View Channel Buttons” button on the Standard toolbar, or by clicking on the thick grey vertical bar between the sequence’s grid and the channel buttons.

You can control whether or not this option is enabled by default via “View Channel Buttons by Default” on the Display Preferences dialog.

A sequence, with channel buttons displayed
The same sequence, without channel buttons displayed

**Time Scale**

If this option is enabled, a time scale will be displayed at the top of each sequence. Multiple sequences can be open in the Sequence Editor at the same time, and this option can be set independently for each of them.

Clicking and dragging on the time scale will set the freeform play range; clicking without dragging will clear the freeform play range (if one had been set).

You can also control this using the "View Time Scale" button on the Standard toolbar.

You can control whether or not this option is enabled by default via "View Time Scale" on the Display Preferences dialog.
Wave Form

This submenu of the View menu can be used to display a waveform of the audio of a musical sequence (although this is not supported for all types of media files). Three modes can be selected: full height, half height, and off.

Changing between full height and half height will cause all waveforms in all open sequences to be displayed in the new manner, and Light-O-Rama will remember the choice for future waveforms. Changing between either of those and "off" will only update the currently active sequence. To control whether waveforms are off or not by default, use View Wave Form by Default of the Display Preferences dialog.

You can also toggle between "off" and whichever of "half height" and "full height" was last selected by using the View Wave Form button on the Standard Toolbar.
The same sequence, with the wave form displayed at half height

The same sequence, with no wave form displayed

**Animation**

If this option is enabled, the animation of the current sequence will be displayed. Multiple sequences can be open in the Sequence Editor at the same time, and this option can be set independently for each of them.
The animation for a sequence

Video

This submenu of the View menu enables you to specify if and how the Sequence Editor will display videos during play:

- **Show Videos**
- **Show Audio Visualizations**
- **Full Screen**

Show Videos

If this option is enabled, then whenever the Sequence Editor plays a musical sequence based on a video file, the video will be displayed during play.

You can control whether or not this option is on by default via "Display Videos" on the Video Preferences dialog. That also controls whether videos will be displayed during shows by the Show Player.

Show Audio Visualizations

If this option is enabled, then whenever the Sequence Editor plays a musical sequence based on an audio file, a visualization of the audio will be displayed during play.

You can control whether or not this option is on by default via "Display Audio Visualizations" on the
Video Preferences dialog. That also controls whether visualizations will be displayed during shows by the Show Player.

**Full Screen**

If this option is enabled, then whenever the Sequence Editor displays a video or an audio visualization, it will do so in full screen mode.

You can control whether or not this option is on by default via "Use Full Screen Mode" on the Video Preferences dialog. That also controls whether full screen mode will be used during shows by the Show Player.

**Fades**

When fade or intensity lighting effects are displayed in the Sequence Editor, they are displayed in one of two ways: "as ramps" or "as colors". You can use the Fades submenu of the View menu to control which is used.

When viewed "as colors", fades and intensities will be displayed as gradually varying shades between light grey (which indicates that the channel is off, i.e. the intensity is zero) and the color assigned to the channel (which indicates an intensity of 100%, i.e. full brightness).

When viewed "as ramps", they are instead displayed as partially filling in their cells with the color of the channel, to a degree based upon the intensity.

Neither of these settings have any effect on the behavior of your actual lights; they only affect how the Sequence Editor displays these lighting effects in a sequence’s grid.

You can control which is used by default via "View Fades as Ramps by Default" on the Display Preferences menu.

![A sequence with fades viewed using colors](image)
Sequence Info

Selecting "Sequence Info" from the View menu will cause various information about the active sequence to be displayed:

Track Info

Selecting "Track Info" from the View menu will cause various information about the active track in the active sequence to be displayed:
Cell Info

Selecting "Cell Info" from the View menu will cause various information about the currently selected cell to be displayed.

To use "Cell Info", there must be only a single cell currently selected. However, if the cell contains multiple lighting effects, all of them will be displayed, and if any of them fall partially outside of the cell, their entire lengths will be indicated, not just the portions that coincide with the cell:

```
Cell Info

Cell Info
Channel: Channel 2
Time: 0:02:12-0:02:40

Effects:
0:01.84-0:02.21: Fade up from 0% to 19% intensity
0:02.21-0:02.30: Twinkle
0:02.30-0:02.68: Fade up from 24% to 43% intensity
```

Zoom Rows

When the Sequence Editor displays a sequence, it is represented as a grid. Rows in the grid represent channels. You can zoom in and out on the channels by using the Zoom Rows submenu of the View menu.

You can also accomplish this using the zoom buttons on the Standard toolbar.

If you have a zoom level that you like, you may want to save it using the Zoom Preferences menu. Doing so will cause the Sequence Editor to use that zoom level by default whenever you open or create a sequence.

See also "Zoom Columns", to zoom time in and out.

Zoom Columns

When the Sequence Editor displays a sequence, it is represented as a grid. Columns in the grid represent time, bound by timings. You can zoom time in and out by using the Zoom Columns submenu of the View menu.

You can also accomplish this using the zoom buttons on the Standard toolbar.

If you have a zoom level that you like, you may want to save it using the Zoom Preferences menu. Doing so will cause the Sequence Editor to use that zoom level by default whenever you open or
create a sequence.

See also "Zoom Rows", to zoom channels in and out.

Tool Bars

The Light-O-Rama Sequence Editor has two toolbars: the Standard toolbar and the Tools toolbar. You can control whether each of these is displayed using the Tool Bars submenu of the View menu.

Refresh

Occasionally during play, the display of a sequence's grid may seem to blank out. This is typically caused when your computer happens to do something unrelated to Light-O-Rama, and temporarily takes the focus away from the Sequence Editor. The sequence itself is not affected, nor are the actual lights - only the Sequence Editor's display of the sequence is - and the display is typically returned to normal when play reaches the next screen (or stops). However, if you do not wish to wait for that, you can select "Refresh" from the View menu, or simply hit the F5 key, to manually refresh the display.

5.3.4.4 The Tools Menu

The Light-O-Rama Sequence Editor's Tools menu contains items enabling you to choose which lighting effects will be applied when you edit sequences (via the mouse or the keyboard), settings for those effects, and several wizards that can be used to change sequences in various ways.

The following options are available on the Tools menu:

- **Effect Tools**
  - Select
  - Toggle
  - Twinkle
  - Shimmer
  - On
  - Off
  - Set Intensity
  - Fade Up
  - Fade Down
  - Intelligent Fade
  - Fill
  - Chase
  - Color Fade
  - DMX Intensity
  - Custom

- **Effect Tool Settings**
  - Custom Settings
  - Background Effects
  - Foreground Effects
  - Intensity Tool Settings
  - Intensity Tool Options
  - Fade Tool Settings
  - Fade Tool Options
  - Load Intensities and Fades from Current Sequence

- **Channel Property Grid**
Effect Tools

The first group of items on the Tools menu enables you to choose the tool that will be used.
whenever you select a cell or cells using the mouse, or hit the enter key on the keyboard. The selected tool will generally apply a lighting effect to the selected cell or cells (an exception to this is the Fill tool, which applies a fill to the cell that you click on, and any cell that you then drag to, rather than to the selected cell or cells).

Only one of these tools can be enabled at any given time; enabling one will automatically disable the others.

You can also choose the current effect tool using the Tools toolbar.

The following effect tools can be enabled:

- **Select**
- **Toggle**
- **Twinkle**
- **Shimmer**
- **On**
- **Off**
- **Set Intensity**
- **Fade Up**
- **Fade Down**
- **Intelligent Fade**
- **Fill**
- **Chase**
- **Color Fade**
- **DMX Intensity**
- **Custom**

**Select**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid will simply select those cells. No lighting effect will be applied, nor will any be applied by hitting the enter key.

**Toggle**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will turn individual parts of the selection on or off. Each portion of the selection that had been on will be turned off, and every other portion will be turned on. Note that the latter includes not just portions of the selection that had been off, but also those that had been twinkles, fades, shimmers, and intensities.

**Twinkle**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the twinkle effect to the selected cells, making the selected channels blink on and off randomly during the selected time.

**Shimmer**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the shimmer effect to the selected cells, making the selected
channels rapidly blink on and off in unison during the selected time.

**On**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the on effect to the selected cells, making the selected channels turn on at full brightness during the selected time.

**Off**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the off effect to the selected cells, making the selected channels turn completely off during the selected time.

**Set Intensity**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the set intensity effect to the selected cells, making the selected channels turn on at a specified percentage of their full brightness during the selected time.

The exact percentage of brightness used can be chosen via the Intensity Tool Settings dialog.

**Fade Up**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the fade up effect to the selected cells, making the selected channels gradually increase in brightness during the selected time.

The exact levels of brightness that the fade will start and end at can be chosen via the Fade Tool Settings dialog.

**Fade Down**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the fade down effect to the selected cells, making the selected channels gradually decrease in brightness during the selected time.

The exact levels of brightness that the fade will start and end at can be chosen via the Fade Tool Settings dialog.

**Intelligent Fade**

The Intelligent Fade tool is similar to the Fade Up and Fade Down tools, but it can create either a fade up effect or a fade down effect, as well as applying a fill. It will create a fade up when you use it by clicking and dragging left-to-right, or a fade down when clicking or dragging right-to-left (or, if you are using the keyboard, fade up or fade down depends upon whether you expanded the selection left-to-right or right-to-left).

If you click without dragging, it will apply a fill. That is, if you click on an empty area of the grid, it will change that area to be a fade from the preceding intensity to the following intensity. For example, if a fade up from 10% to 40% is followed by the lights being off, which is followed by a fade
up from 20% to 80%, then clicking on the area where the lights are off will make it into a fade down from 40% to 20%.

**Fill**

The Fill tool can be used to create smooth fades from one effect to another. For example, if a fade up from 10% to 40% is followed by the lights being off, which is followed by a fade up from 20% to 80%, then applying the Fill tool on the area where the lights are off will make it into a fade down from 40% to 20%:

Before a fill... ... and after a fill

It can also be used in a similar manner on RGB channels to smoothly fade from one color to another.

Before a fill... ... and after a fill

The Fill tool does not do anything when used on cells that are not completely off.

When used with the mouse, the Fill tool works slightly differently than other effect tools. With most tools, clicking a cell will change the selected area of the sequence grid to be that cell, and dragging (with the mouse still clicked) will expand the selection. Only after the mouse button is let up will the tool be applied to the selection.

The Fill tool, on the other hand, is applied to the effect that you click on, immediately when you click down, and to any effect that you subsequently drag to (with the mouse still clicked down). It does not change the selected area of the sequence grid in any way. This fact, plus the fact that the Fill tool does not affect effects other than off effects, hopefully makes it easy to apply a wide range of fills quickly, simply by clicking and dragging to the appropriate spots.

The Intelligent Fade tool and the Color Fade tool can also be used to apply fills in certain situations.

**Chase**

The Chase tool can be used to take a pattern and “chase” it through several channels over a time range. For example:
Exactly what is chased, and where it is chased to, depends upon how you click-and-drag (or, if using the keyboard, how you expanded the selection). The lighting effects in the corner that you started dragging from will be chased to the corner that you finished dragging to so that, for example, you could chase effects “up” or “down” through channels.

The effects that are chased will include everything up to and including the last non-off lighting effect in the channel that you start dragging from (or, if dragging backwards, everything from the first non-off lighting effect).

The Chase tool can also be used on RGB channels:

The Chase tool pays attention to the Paste from Foreground clipboard option, so that you can chase a pattern without overwriting existing effects with “off” effects. For example, consider the following sequence, and imagine that you want to chase the second fade up in the first channel:
Before chasing the second fade

If you did not have "Paste from Foreground" turned on, the chase would overwrite the ends of the existing fades in some of the other channels:

After chasing the second fade, without "Paste from Foreground"

But with "Paste from Foreground" turned on, the existing effects would be kept in place:

After chasing the second fade, with "Paste from Foreground"

**Color Fade**

Color Fade tool can be used to apply colors to RGB channels. Selecting the Color Fade tool opens the Color Fade tool window, which enables you to specify the colors to be used (note, however, that the colors as displayed on your screen will not necessarily match those shown by your actual lights; you may have to experiment to determine colors that wind up looking the way you want, and different RGB devices may show different colors when sent the same intensities):
The Color Fade tool window

With the Color Fade tool selected, clicking and dragging an area of an RGB channel or multiple RGB channels will cause that area to become those colors:

![Applying a color fade to an RGB channel](image)

If you drag backwards, however, the colors will be applied in reverse order (this also happens if you are using the keyboard, and expand the selection from right to left instead of left to right):

![Applying a color fade to an RGB channel by dragging backwards](image)

Clicking (as opposed to clicking-and-dragging) on an empty area will cause the Color Fade tool to perform a fill, smoothly fading from the preceding color to the following color:

![Before clicking the empty area...](image) ![... and after clicking the empty area](image)

The Color Fade tool window gives several ways to select the colors to be used:

- The "Choose" buttons on either side will open a color picker dialog to specify the color for that side
- The "Copy" button on either side will copy the color from the opposite side
- The "Swap" button will move the two colors to their opposite sides
- The "Random" buttons on either side will choose a random color for that side
- The "Random button in the middle will choose random colors for both sides

The Color Fade tool window also enables you to choose what kind of effect should be applied. For example, here is a twinkling color fade:

![A twinkling color fade](image)

A note regarding DMX color effects: The Color Fade tool allows you to specify that DMX effects should be used. However, as of the time of this writing, LOR hardware does not support DMX effects which change intensity (for example, a fade up), and so unless the underlying DMX effects caused by using the Color Fade tool stay at a constant intensity, they will be automatically converted to regular fades when they are sent to the controllers. That is, for example, a DMX fade from 0 to 255 will be converted to a regular fade from 0% to 100%. So, the Color Fade tool will not give as fine-grained control over DMX as you may think.

However, if you make your sequence using DMX fades now, and in the future LOR hardware is updated to support them, then your sequence will take already be set up to advantage of this.

**DMX Intensity**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence’s grid,
or hitting the enter key, will apply the DMX intensity effect to the selected cells, allowing for 256 possible intensities (between 0 and 255), rather than 101 (between 0 and 100).

This tool is only available if DMX editing has been enabled.

**Custom**

If this effect tool is enabled on the Tools menu, then clicking on a cell or cells in a sequence's grid, or hitting the enter key, will apply the current custom tool effect to the selected cells, for example making the selected channels twinkle while gradually decreasing in brightness during the selected time.

**Effect Tool Settings**

The Tools menu contains several settings that affect the behavior of the currently selected effect tool:

- Custom Settings
- Background Effects
- Foreground Effects
- Intensity Tool Settings
- Intensity Tool Options
- Fade Tool Settings
- Fade Tool Options
- Load Intensities and Fades from Current Sequence

**Custom Settings**

This submenu of the Tools menu allows you to select the behavior of the current custom tool. For example, to make the current custom tool into a twinkling fading down tool, check "Twinkle" and "Fade Down" from this submenu.

**Background Effects**

Enabling this item on the Tools menu will turn on background effects mode, which causes the current effect tool to apply only to those portions of the selection which are currently off.

Background effects mode can also be turned on via the Tools toolbar, or by hitting Shift-A on the keyboard.

At most one of background effects mode and foreground effects mode can be enabled at the same time. Enabling one will automatically disable the other. However, using the keyboard, you can temporarily turn on either of them (and also regular effects mode) for the next keystroke only, using the A, O, and E keys, respectively.

**Foreground Effects**

Enabling this item on the Tools menu will turn on foreground effects mode, which causes the current effect tool to apply only to those portions of the selection which are not currently off.

Foreground effects mode can also be turned on via the Tools toolbar, or by hitting Shift-O on the keyboard.
At most one of background effects mode and foreground effects mode can be enabled at the same
time. Enabling one will automatically disable the other. However, using the keyboard, you can
temporarily turn on either of them (and also regular effects mode) for the next keystroke only, using
the A, O, and E keys, respectively.

**Intensity Tool Settings**

This item on the Tools menu opens or closes the Intensity Tool Settings dialog, which allows you to
choose what percentage of full brightness will be used when you apply the set intensity tool to cells
in a sequence.

The dialog has ten preset values that you can select from. If you want to use a value that is not
among these ten, use the Intensity Tool Options dialog to change the available preset values (by
choosing it from the Tools menu, or by pressing the "Edit" button on the Intensity Tool Settings
dialog). The values of the presets can also be set using Load Intensities and Fades from Current
Sequence on the Tools menu.

![Intensity Tool Settings dialog, with 70% intensity selected]

**Intensity Tool Options**

This item on the Tools menu opens the Intensity Tool Options dialog, which allows you to set the
values of the available presets on the Intensity Tool Settings dialog.

The Intensity Tool Options dialog can also be opened by clicking the "Edit" button on the Intensity
Tool Settings dialog.
The Intensity Tool Options dialog

**Fade Tool Settings**

This item on the Tools menu opens or closes the Fade Tool Settings dialog, which allows you to choose what percentages of full brightness will be used when you apply the fade up tool or fade down tool to cells in a sequence.

The dialog has ten preset values that you can select from, and the values for fade up and fade down can be selected independently. If you want to use a value that is not among these ten, use the Fade Tool Options dialog to change the available preset values (by choosing it from the Tools menu, or by pressing the "Edit" button on the Fade Tool Settings dialog). The values of the presets can also be set using Load Intensities and Fades from Current Sequence on the Tools menu.

**Fade Tool Options**

This item on the Tools menu opens the Fade Tool Options dialog, which allows you to set the values of the available presets on the Fade Tool Settings dialog.
The Fade Tool Options dialog can also be opened by clicking the “Edit” button on the Fade Tool Settings dialog.

![Fade Options dialog]

**Load Intensities and Fades from Current Sequence**

This item on the Tools menu can be used to automatically set the preset values available in the Intensity Tool Settings dialog and the Fade Tool Settings dialog, based upon the most commonly used values in the current sequence.

**Channel Property Grid**

This item on the Tools menu opens the Channel Property Grid, which enables you to modify the settings of all of the channels in the current sequence (such as their names, colors, unit IDs, and circuit IDs).
The Channel Property Grid

Note that only channels, and not RGB channels, are displayed in the Channel Property Grid. However, the three constituent channels of an RGB channel (that is, the red, green, and blue channels of that RGB channel) are displayed in the Channel Property Grid.

Wizards

The Tools menu can be used to launch several wizards that enable you to make changes to sequences in various ways:

- **Beat Wizard**
- **MIDI Wizard**
- **Tapper Wizard**
- **VU Wizard**

**Beat Wizard**

This item on the Tools menu opens the Beat Wizard, which can be used to try to determine the tempo of a song, and insert timings and effects based upon it into the current sequence.

The Beat Wizard is only available for musical sequences, and not all types of media files are supported. Notably, video files and MIDI files are not supported.
This item on the Tools menu opens the MIDI Wizard, which can be used to insert timings and effects into a sequence based upon the tempo of a MIDI file, or upon the individual notes played by instruments in that MIDI file.

The MIDI Wizard is only supported for musical sequences based upon MIDI files.
The MIDI Wizard

**Tapper Wizard**

This item on the **Tools menu** opens the **Tapper Wizard**, which can play the sequence's song and record you as you tap along with it, and insert **timings** and **effects** based upon your taps into the current **sequence**.

The Tapper Wizard is only supported for **musical sequences**.
The Tapper Wizard

**VU Wizard**

This item on the Tools menu opens the VU Wizard, which can be used to insert timings and effects based upon it into the current sequence based upon audio peaks in the song, much like a VU meter.

The VU Wizard is only available for musical sequences, and not all types of media files are supported. Notably, video files and MIDI files are not supported.
The Play Menu

The Light-O-Rama Sequence Editor's Play menu contains menu items enabling you to play open sequences and to affect the behavior of the Sequence Editor during play.

The following items are available on the Play menu:

- Start This Sequence
- Start All Sequences
- Stop
- Lights Off Now
- Play Again
- Play Range
  - Full Sequence
  - Selection

© 2010 Light-O-Rama, Inc.
• From Selection
• To Selection
• Visible Screen
• Loop at End
• Lights Off at End
• Control Lights
• Control Holiday Lights Designer
• Move Grid with Play
• Vary Color of Channel Buttons
• Highlight Current Event
• Highlight Current Time
• Speed

The Play menu

Start This Sequence

Selecting this item from the Play menu will cause the currently active sequence to start playing.

You can also start play by using the Play button on the Standard toolbar.

Start All Sequences

Selecting this item from the Play menu will cause all open sequences to start playing. However, only one musical sequence can be playing at a time, so if you have more than one musical sequence open, you will instead be told that you have to close all but one if you want to play all open sequences.

You can also start play by using the Play button on the Standard toolbar.
Stop

Selecting this item from the Play menu will stop all playing sequences.

You can also stop play by using the Stop button on the Standard toolbar, or by simply waiting until the sequences naturally complete (unless "Loop at End" is enabled).

Lights Off Now

This item from the Play menu will turn off any lights that had previously been turned on during play. It is only available when "Lights Off at End" is turned off, and play is stopped, and lights had been sent commands since the last time it was used.

Play Again

Selecting this item from the Play menu will play the same thing that you last asked it to play. An example of how this could be useful:

If you are working on some particular section of a sequence, you might set the play range to "Selection", and select the cells in the time range that you are currently interested in. When you start play, only that time range will be played. You might then notice something that you want to change about the lighting effects in that portion of the sequence. Doing so would change what time range was selected, so if you simply started play a second time, the portion of the sequence played would be different than your original selection.

You could re-select the original selection before starting play, but it would be easier to simply use "play again". It would play the same time range as you had originally selected, even though a different time range is now selected.

The Play Again button on the Standard toolbar also does this same thing.

Play Range

When playing a sequence in the Sequence Editor, you can choose what portion of the sequence will be played by setting the play range in the Play menu. The following play range modes are supported:

- Full Sequence
- Selection
- From Selection
- To Selection
- Visible Screen

Additionally, freeform play mode can be used to play any time range that you specify. Freeform play mode is not available on the Play Range menu; instead, please refer to its help page for details on how to use it.

**Full Sequence**

If you set the Sequence Editor's play range to "Full Sequence", then whenever it plays a sequence, it will start at the beginning of the sequence, and stop at the end of the sequence.
Selection

If you set the Sequence Editor's play range to "Selection", then whenever it plays a sequence, it will play only that time range of the sequence which is currently selected (i.e. the cells that are currently surrounded by a thick black border).

Note that all channels in the sequence will be played, even those outside of the current selection. Only the time range is set by this option.

From Selection

If you set the Sequence Editor's play range to "From Selection", then whenever it plays a sequence, it will play the time range from the start of the current selection (i.e. the cells that are currently surrounded by a thick black border) to the end of the sequence.

Note that all channels in the sequence will be played, even those outside of the current selection. Only the time range is set by this option.

To Selection

If you set the Sequence Editor's play range to "To Selection", then whenever it plays a sequence, it will play the time range from the start of the sequence to the end of the current selection (i.e. the cells that are currently surrounded by a thick black border).

Note that all channels in the sequence will be played, even those outside of the current selection. Only the time range is set by this option.

Visible Screen

If you set the Sequence Editor's play range to "Visible Screen", then whenever it plays a sequence, it will play only that time range of the sequence that is currently displayed.

Note that all channels in the sequence will be played, even those currently above or below the visible portion of the sequence. Only the time range is set by this option.

Loop at End

If "Loop at End" is enabled in the Play menu of the Sequence Editor, then whenever it plays a sequence and reaches the end of the play range, instead of stopping, it will automatically loop back to the beginning of the play range and continue playing. The sequence can still be stopped manually, via "Stop" on the Play menu or the Stop button of the Standard toolbar.

You can control whether or not "Loop at End" is enabled by default via "Loop at the End of a Sequence by Default" on the Play Preferences dialog.

Note that this should not be confused with loops within a sequence.

Lights Off at End

If "Lights Off at End" is enabled in the Play menu of the Sequence Editor, then whenever it plays a sequence and reaches the end of play, it will automatically turn off all lights in that sequence. If it is
disabled, then any lights that happen to be on at the very end of the sequence will remain on.

Control Lights

If "Control Lights" is enabled in the Play menu of the Sequence Editor, then whenever it plays a sequence, the Sequence Editor will send lighting effect commands to your controllers, causing your actual lights to be used.

Note that you will additionally need to have the channels in your sequence set up appropriately with information such as the unit IDs and circuit IDs of the controllers that are hooked up to your computer.

Control Holiday Lights Designer

If "Control Holiday Lights Designer" is enabled in the Play menu of the Sequence Editor, then whenever it plays a sequence, the Sequence Editor will send lighting effect commands to Holiday Lights Designer™, a third party add-on by Holidaysoft® which can be used to virtually place lights and decorations on images of your home or business.

Please also see the Holiday Lights Designer Preferences dialog.

Move Grid with Play

If "Move Grid with Play" is enabled in the Play menu of the Sequence Editor, then whenever a sequence is played, the portion of the sequence's grid that is currently displayed will change as play progresses so that the current time is always displayed. Otherwise, the grid's display will simply remain static.

Vary Color of Channel Buttons

If "Vary Color of Channel Buttons" is enabled in the Play menu of the Sequence Editor, then whenever it plays a sequence, the color of a channel button will vary based upon the lighting effect taking place on that channel at that moment during the sequence.

You can control whether or not "Vary Color of Channel Buttons" is enabled by default via "Vary the Color of Channel Buttons during Play by Default" on the Play Preferences dialog.

Highlight Current Event

If "Highlight Current Event" is enabled in the Play menu of the Sequence Editor, then whenever it plays a sequence, the timings closest to the current time will be highlighted with thick black lines, moving as play progresses.

You can control whether or not "Highlight Current Event" is enabled by default via "Highlight Current Event during Play by Default" on the Play Preferences dialog.

Highlight Current Time

If "Highlight Current Time" is enabled in the Play menu of the Sequence Editor, then whenever it plays a sequence, the current time will be highlighted with a dashed vertical line, moving as play progresses.
You can control whether or not "Highlight Current Time" is enabled by default via "Highlight Current Time during Play by Default" on the Play Preferences dialog.

Speed

The Speed submenu of the Play menu can be used to instruct the Sequence Editor to play sequences at different speeds - quarter speed, half speed, normal speed, double speed, or quadruple speed.

Slower speeds may be useful, for example, when you are trying to precisely adjust the time at which a lighting effect takes place; faster speeds may be useful to get a quick overview of how the sequence looks.

5.3.4.6 The Window Menu

The Window menu of the Light-O-Rama Sequence Editor enables you to control how the windows for the open sequences are arranged on your screen. It also shows a list of the open sequences, which can be used to select which one is currently active.

The following menu items are available:

- Tile Horizontally
- Tile Vertically
- Cascade
- Arrange Icons
- Minimize All Windows
- The Open Sequence List

Tile Horizontally

When the Sequence Editor has multiple sequences open at once, this option from the Window menu will cause their windows to take up all available space, not overlapping with each other, and to be placed next to each other horizontally.

Tile Vertically

When the Sequence Editor has multiple sequences open at once, this option from the Window
menu will cause their windows to take up all available space, not overlapping with each other, and to be placed above and below each other.

Cascade

When the Sequence Editor has multiple sequences open at once, this option from the Window menu will cause their windows to overlap with each other in an organized way.

Arrange Icons

If the Sequence Editor has any sequences open with their windows minimized, this option from the Window menu will order their icons neatly.

Minimize All Windows

Selecting this option from the Window menu of the Sequence Editor will cause the windows for all open sequences to become minimized.

The Open Sequence List

At the bottom of the Window menu of the Sequence Editor is a list of all of the sequences that are currently open. Clicking on one, or hitting the key of the number displayed next to it, will cause it to become the active sequence.

5.3.4.7 The Help Menu

The Help menu of the Light-O-Rama Sequence Editor brings up help and other information about Light-O-Rama.

The following options are available on the Help menu:

- Contents
- Index
- Search
- Visit Light-O-Rama on the Web
- About the Light-O-Rama Editor
- Register (or Upgrade) Light-O-Rama

<table>
<thead>
<tr>
<th>Contents</th>
<th>F1</th>
</tr>
</thead>
<tbody>
<tr>
<td>Index</td>
<td></td>
</tr>
<tr>
<td>Search</td>
<td></td>
</tr>
<tr>
<td>Visit Light-O-Rama on the Web</td>
<td></td>
</tr>
<tr>
<td>About The Light-O-Rama Editor</td>
<td></td>
</tr>
<tr>
<td>Register Light-O-Rama</td>
<td></td>
</tr>
</tbody>
</table>

The Help menu

Contents

This option on the Help menu opens up the table of contents of the Light-O-Rama help files.
Index

This option on the Help menu opens up the index of the Light-O-Rama help files.

Search

This option on the Help menu opens up the search menu of the Light-O-Rama help files.

Visit Light-O-Rama on the Web

This option on the Help menu opens the Light-O-Rama website in your browser window.

About the Light-O-Rama Editor

This option on the Help menu brings up an "About" box displaying some information about the Light-O-Rama Sequence Editor.

Register (or Upgrade) Light-O-Rama

Use this item on the Help menu to register your Light-O-Rama software, or to upgrade to a higher level license, unlocking various features.

This item will show up as "Register Light-O-Rama" if you are using the unlicensed Demo version of the software, or "Upgrade" if you are using a license, but it is not the highest possible license level. If you are using the highest possible license level, this item will not be displayed at all.

5.3.5 Toolbars

The Light-O-Rama Sequence Editor has three toolbars: the Standard toolbar, the Tools toolbar, and the Tracks and Timings toolbar.

The Standard toolbar has buttons for a variety of different functions, such as creating, opening, and saving sequences, setting various display options, and playing sequences.

The Tools toolbar enables you to choose which lighting effect tool is currently in use, and set certain options regarding them.

The Tracks and Timings toolbar has dropdown boxes to allow you to quickly choose which track is displayed, and which timing grid it is displayed with, and it additionally has buttons with popup menus, with various track and timing grid-related menu items.

If desired, these toolbars can be hidden (and later unhidden) by using the "Tool Bars" item on the View menu.
The Tools toolbar

The Tracks and Timings Toolbar

5.3.5.1 The Standard Toolbar

The Light-O-Rama Sequence Editor's Standard toolbar contains buttons for several functions and options. From left to right, they are:

- New Sequence
- Open Sequence
- Close Sequence
- Save Sequence
- Cut
- Copy
- Paste
- Repeat
- Undo
- Redo
- View Animation
- View Fades as Ramps
- View Channel Buttons
- Vary Channel Button Colors
- View Time Scale
- View Waveform
- Zoom Channels Out
- Zoom Channels In
- Zoom Time Out
- Zoom Time In
- Play
- Play Again
- Stop
- Lights Off Now

If desired, the toolbar can be hidden (or unhidden) via "Tool Bars" on the View menu.
This button on the **Standard toolbar** can be used to create a new **sequence**. Clicking on it opens the **New and Open dialog**, on its "**New Sequence**" tab.

### Open Sequence

This button on the **Standard toolbar** can be used to open a **sequence**. Clicking on it opens the **New and Open dialog**, on whichever of its "**Existing Sequence**" tab or its "**Recent Sequence**" tab was most recently used.

### Close Sequence

This button on the **Standard toolbar** can be used to close an open **sequence**. Please see "**Close**" on the **File menu** for details.

### Save Sequence

This button on the **Standard toolbar** can be used to save changes to an open **sequence**. Please see "**Save**" on the **File menu** for details.

### Cut

This button on the **Standard toolbar** can be used to cut **effects** from a **sequence**. Please see "**Cut, Copy, Paste, and Paste Multiple**" on the **Edit menu** for details.

### Copy

This button on the **Standard toolbar** can be used to copy **effects** from a **sequence**. Please see "**Cut, Copy, Paste, and Paste Multiple**" on the **Edit menu** for details.

### Paste

This button on the **Standard toolbar** can be used to paste **effects** into a **sequence**. Please see "**Cut, Copy, Paste, and Paste Multiple**" on the **Edit menu** for details.

### Repeat

The Repeat tool can be used to automatically place a copy of the selected area immediately after the selected area. For example, consider the following:

![Before repeating](image)

Then pressing the Repeat button will make the following:
And you can repeat as many times as you like thereafter; for example, pressing Repeat three more times will make the following:

The Repeat tool pays attention to your current "Paste from Foreground" setting. For example, before repeating:

And after repeating, with "Paste from Foreground" enabled:

Undo

This button on the Standard toolbar can be used to undo changes to a sequence. Please see "Undo and Redo" on the Edit menu for details.

Redo

This button on the Standard toolbar can be used to redo previously undone changes to a sequence. Please see "Undo and Redo" on the Edit menu for details.

View Animation

This button on the Standard toolbar can be used to control whether the animation for a sequence is displayed. This can be set independently for different open sequences. Please see "View Animation" on the View menu for details.
View Fades as Ramps

This button on the Standard toolbar can be used to control whether fades are displayed as gradual changes in color or as ramps. Please see "Fades" on the View menu for details.

View Channel Buttons

This button on the Standard toolbar can be used to control whether the channel buttons for a sequence are displayed. This can be set independently for different open sequences. Please see "View Channel Buttons" on the View menu for details.

Vary Channel Button Colors

This button on the Standard toolbar can be used to control whether the channel buttons for a sequence will change color during play, based upon the lighting effects happening on those channels. Please see "Vary Color of Channel Buttons" on the Play menu for details.

View Time Scale

This button on the Standard toolbar can be used to control whether a time scale is displayed at the top of an open sequence. This can be set independently for different open sequences. Please see "View Time Scale" on the View menu for details.

View Waveform

This button on the Standard toolbar can be used to control whether the audio waveform is displayed at the top of an open musical sequence. This can be set independently for different open musical sequences. Please see "View Waveform" on the View menu for details.

Zoom Channels Out

This button on the Standard toolbar can be used to zoom a sequence's rows (representing its channels) out, making them shorter. Please see "Zoom Rows" on the View menu for details.

Zoom Channels In

This button on the Standard toolbar can be used to zoom a sequence's rows (representing its channels) in, making them taller. Please see "Zoom Rows" on the View menu for details.

Zoom Time Out

This button on the Standard toolbar can be used to zoom a sequence's columns (representing the duration from one timing to the next) out, making them thinner. Please see "Zoom Columns" on the View menu for details.

Zoom Time In

This button on the Standard toolbar can be used to zoom a sequence's columns (representing the
duration from one \textit{timing} to the next) in, making them wider. Please see "Zoom Columns" on the View menu for details.

Play \begin{figure}[h]
\centering
\includegraphics[width=0.1\textwidth]{play_button}
\caption{Play button on the Standard toolbar can be used to start play of an open sequence or sequences. If only a single sequence is open, it will be played; if more than one sequence is open, a popup menu will open, asking if you want to play all of the sequences or just the currently active sequence. Please see "Start This Sequence" and "Start All Sequences" on the Play menu for details.}
\end{figure}

Play Again \begin{figure}[h]
\centering
\includegraphics[width=0.1\textwidth]{play_again_button}
\caption{Play Again button on the Standard toolbar can be used to start play in the same way as it was last started. Please see "Play Again" on the Play menu for details.}
\end{figure}

Stop \begin{figure}[h]
\centering
\includegraphics[width=0.1\textwidth]{stop_button}
\caption{Stop button on the Standard toolbar can be used to stop a playing sequence. Please see "Stop" on the Play menu for details.}
\end{figure}

Lights Off Now \begin{figure}[h]
\centering
\includegraphics[width=0.1\textwidth]{lights_off_button}
\caption{Lights Off Now button on the Standard toolbar can be used to manually turn off lights. Please see "Lights Off Now" on the Play menu for details.}
\end{figure}

5.3.5.2 The Tools Toolbar

The Light-O-Rama Sequence Editor’s Tools toolbar contains buttons which enable you to choose which effect tool is currently selected, as well as buttons to modify the behavior of those tools. From left to right, they are:

- Select
- Toggle
- Twinkle
- Shimmer
- On
- Off
- Set Intensity
- Fade Up
- Fade Down
- Intelligent Fade
- Fill
- Chase
If desired, the Tools toolbar can be hidden (or unhidden) via "Tool Bars" on the View menu.

Select

This button on the Tools toolbar chooses the Select tool as the currently active effect tool. It is equivalent to "Select" from the Tools menu. Please refer to that help page for details.

Toggle

This button on the Tools toolbar chooses the Toggle tool as the currently active effect tool. It is equivalent to "Toggle" from the Tools menu. Please refer to that help page for details.

Twinkle

This button on the Tools toolbar chooses the Twinkle tool as the currently active effect tool. It is equivalent to "Twinkle" from the Tools menu. Please refer to that help page for details.

Shimmer

This button on the Tools toolbar chooses the Shimmer tool as the currently active effect tool. It is equivalent to "Shimmer" from the Tools menu. Please refer to that help page for details.

On

This button on the Tools toolbar chooses the On tool as the currently active effect tool. It is equivalent to "On" from the Tools menu. Please refer to that help page for details.

Off
This button on the **Tools toolbar** chooses the Off tool as the currently active **effect tool**. It is equivalent to "**Off**" from the **Tools menu**. Please refer to that help page for details.

### Set Intensity

This button on the **Tools toolbar** chooses the Set Intensity tool as the currently active **effect tool**. It is equivalent to "**Set Intensity**" from the **Tools menu**. Please refer to that help page for details.

### Fade Up

This button on the **Tools toolbar** chooses the Fade Up tool as the currently active **effect tool**. It is equivalent to "**Fade Up**" from the **Tools menu**. Please refer to that help page for details.

### Fade Down

This button on the **Tools toolbar** chooses the Fade Down tool as the currently active **effect tool**. It is equivalent to "**Fade Down**" from the **Tools menu**. Please refer to that help page for details.

### Intelligent Fade

This button on the **Tools toolbar** chooses the Intelligent Fade tool as the currently active **effect tool**. It is equivalent to "**Intelligent Fade**" from the **Tools menu**. Please refer to that help page for details.

### Fill

This button on the **Tools toolbar** chooses the Fill tool as the currently active **effect tool**. It is equivalent to "**Fill**" from the **Tools menu**. Please refer to that help page for details.

### Chase

This button on the **Tools toolbar** chooses the Chase tool as the currently active **effect tool**. It is equivalent to "**Chase**" from the **Tools menu**. Please refer to that help page for details.

### Color Fade

This button on the **Tools toolbar** chooses the Color Fade tool as the currently active **effect tool**. It is equivalent to "**Color Fade**" from the **Tools menu**. Please refer to that help page for details.

### DMX Intensity

This button on the **Tools toolbar** chooses the DMX Intensity tool as the currently active **effect tool**. It is equivalent to "**DMX Intensity**" from the **Tools menu**. Please refer to that help page for details.

Note: The DMX Intensity button is only present if **DMX editing** has been enabled.
This button on the Tools toolbar chooses the current custom tool as the currently active effect tool. When this button is selected, the exact meaning of the current custom tool can be selected via the five buttons to its right - Custom Twinkle, Custom Shimmer, Custom Set Intensity, Custom Fade Up, and Custom Fade Down.

For example, to use a tool that will shimmer the lights while fading them down, select this button, Custom Shimmer, and Custom Fade Down.

**Custom Twinkle**

When the Custom button is selected, this button on the Tools toolbar makes the current custom tool some sort of twinkle tool.

For example, to use a tool that will twinkle the lights while fading them down, select the Custom button, this button, and Custom Fade Down.

**Custom Shimmer**

When the Custom button is selected, this button on the Tools toolbar makes the current custom tool some sort of shimmer tool.

For example, to use a tool that will shimmer the lights while fading them down, select the Custom button, this button, and Custom Fade Down.

**Custom Set Intensity**

When the Custom button is selected, this button on the Tools toolbar makes the current custom tool some sort of set intensity tool.

For example, to use a tool that will twinkle the lights at some intensity other than full intensity, select the Custom button, Custom Twinkle, and this button.

**Custom Fade Up**

When the Custom button is selected, this button on the Tools toolbar makes the current custom tool some sort of fade up tool.

For example, to use a tool that will twinkle the lights while fading them up, select the Custom button, Custom Twinkle, and this button.

**Custom Fade Down**

When the Custom button is selected, this button on the Tools toolbar makes the current custom tool some sort of fade down tool.

For example, to use a tool that will twinkle the lights while fading them down, select the Custom button, Custom Twinkle, and this button.

**Background Effects**
This button on the Tools toolbar can be used to enable background effects mode. It is equivalent to "Background Effects" from the Tools menu. Please refer to that help page for details.

Foreground Effects

This button on the Tools toolbar can be used to enable foreground effects mode. It is equivalent to "Foreground Effects" from the Tools menu. Please refer to that help page for details.

Intensity Settings

This button on the Tools toolbar can be used to open or close the Intensity Tool Settings dialog. It is equivalent to "Intensity Tool Settings" from the Tools menu. Please refer to that help page for details.

Fade Settings

This button on the Tools toolbar can be used to open or close the Fade Tool Settings dialog. It is equivalent to "Fade Tool Settings" from the Tools menu. Please refer to that help page for details.

5.3.5.3 The Track and Timings Toolbar

The Tracks and Timings toolbar consists of four controls, two related to tracks and two related to timings:

- The track button
- The track dropdown
- The timings button
- The timings dropdown

The Tracks and Timings toolbar

The Track Button

Clicking on the Track and Timings toolbar's track button brings up a popup menu with various track-related items:

- Change Track Name
- Add new Track
- Duplicate Track
- Delete Track

The track button's popup menu
**Change Track Name**

This menu item on the track button's popup menu can be used to change the name of the current track. For details, please see the Change Track Name menu item on the Edit menu.

**Add New Track**

This menu item on the track button's popup menu can be used to add a new track to the sequence. For details, please see the Add New Track menu item on the Edit menu.

**Duplicate Track**

This menu item on the track button's popup menu can be used to add a new track with all the same channels as the current track. For details, please see the Duplicate Track menu item on the Edit menu.

**Delete Track**

This menu item on the track button's popup menu can be used to delete the current track from the sequence. There must be at least one track in a sequence, so this menu item will be unavailable if there is only one track.

**The Track Dropdown**

The Tracks and Timings toolbar's track dropdown gives a list of the tracks in the sequence. It displays the currently active track; selecting another track from the dropdown makes that track active, and updates the display to show that track if it is not already being shown.

**The Timings Button**

Clicking on the Tracks and Timings toolbar's timings button brings up a popup menu with various timings-related items:

- Change Timing Grid Name
- Add New Fixed Grid
- Add New Freeform Grid
- Duplicate to New Freeform Grid
- Delete Timing Grid

<table>
<thead>
<tr>
<th>Change Timing Grid Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Add New Fixed Grid</td>
</tr>
<tr>
<td>Add New Freeform Grid</td>
</tr>
<tr>
<td>Duplicate to New Freeform Grid</td>
</tr>
<tr>
<td>Delete Timing Grid</td>
</tr>
</tbody>
</table>

**Change Timing Grid Name**

This menu item on the timings button's popup menu can be used to change the name of the current timing grid. The main purpose of giving a timing grid a name is to make it easier to distinguish
timing grids when they are listed in places such as the Tracks and Timings toolbar's timings dropdown.

**Add New Fixed Grid**

This menu item on the timings button's popup menu can be used to add a new fixed timing grid to the sequence. After you select this item, you will be asked to specify the length of time between timings - for example, to make the timings a quarter second apart, enter "0.25".

**Add New Freeform Grid**

This menu item on the timings button's popup menu can be used to add a new freeform timing grid to the sequence. After you select this item, you will be prompted to enter a name for the new timing grid.

**Duplicate to New Freeform Grid**

This menu item on the timings button's popup menu can be used to create a new freeform timing grid, initially populating it with the same timings as are in the current timing grid.

Note that this can be done regardless of whether the current timing grid is a freeform grid or a fixed grid.

**Delete Timing Grid**

This menu item on the timings button's popup menu can be used to delete the current timing grid from the sequence. Any tracks in the sequence that use this timing grid will automatically be switched to use some other timing grid from the sequence.

There must be at least one timing grid in a sequence, so this menu item will be unavailable if there is only one timing grid.

**The Timings Dropdown**

The Tracks and Timings toolbar's timings dropdown gives a list of the timing grids in the sequence. It displays the timing grid currently in use on the active track; selecting another timing grid from the dropdown changes the track to use that timing grid instead.

### 5.3.6 The Tools Panel

On the left-hand side of the Light-O-Rama Sequence Editor is a Tools panel, with three subpanels ("Saved Tools", "Recent Tools", and "Clipboards"): 
You can hide or show any individual subpanel by clicking on the arrows at its top right. For example, with the "Recent Tools" subpanel hidden:
The entire Tools Panel can be hidden by clicking on the pin in its top right. This will cause the Tools Panel to collapse down to a narrow bar on the left, with a wrench icon on a tab:

Moving your mouse over that tab will cause the panel to be shown again, at which time you can use its various items. After you are done with it, and move your mouse away from the panel, it will collapse back down to be hidden again. If you instead want it to remain open, you can click on its pin icon again.
Whether the panel is collapsed or open, and whether its individual subpanels are, is remembered in between runs of the Sequence Editor - that is, they will start up in the same states that they were in when you last used the Sequence Editor.

For details on the subpanels, please see their individual sections of the help file:

- Saved Tools
- Recent Tools
- Clipboards

### 5.3.6.1 Saved Tools

The Saved Tools list of the Sequence Editor's left-hand side Tools Panel is a list of effect tools that you have saved for future use. Once on the Saved Tools list, a tool will remain there, even when you use the Sequence Editor again in the future, unless and until you remove it from the list.

Clicking on a tool listed in the Saved Tools list makes that tool active.

![Saved Tools list](image)

The Saved Tools list, with four saved color fades and five other saved tools

To put a tool on the Saved Tools list, right-click on its entry in the Recent Tools list, and select "Save Tool" from the popup menu that will open.

To remove a tool from the Saved Tools list, right-click on its entry in the Saved Tools list, and select "Remove Tool" from the popup menu that will open.

### 5.3.6.2 Recent Tools

The Recent Tools list of the Sequence Editor's left-hand side Tools Panel is a list of the effect tools that you have used most recently (with some exceptions, noted below). Clicking on a tool listed in the Saved Tools list makes that tool active.
The Recent Tools list, with several color fades interspersed with several other tools

Not all tools that you use will be added to the Recent Tools list; a tool is only added to the list if you cannot get back to that tool in a single click via the Tools toolbar. For example, if you use the Toggle tool or the Twinkle tool, they will not be added to the list, because you could get back to them in a single click, by clicking the Toggle button or the Twinkle button, respectively. But if you use the Fade Up tool or a custom tool such as a twinkling intensity, it will be added, because it would take more than one mouse click to get back to it - a click to change to the "base" form of the tool itself, and one or more additional clicks to select the proper intensity values.

If you find a tool that you want to keep for future use, you can add it to the Saved Tools list by right-clicking on its entry in the Recent Tools list, and selecting "Save Tool" from the popup menu that will open.

5.3.6.3 Clipboards

Clipboards are used to copy (or cut) and paste lighting effects from some channels (or RGB channels) to others. In the Light-O-Rama Sequence Editor, you can have multiple different clipboards at once, allowing you to keep several different copied sets of effects pastable simultaneously. You can also save clipboards so that their contents will still be available to you even when you use the Sequence Editor again in the future, lock clipboards so that they cannot be copied to (thus preventing accidental overwriting of their contents), and set various options on how pasting behaves (paste by cell, paste by time, and paste from foreground).

Clipboards can be managed through the Clipboards subpanel of the left-hand Tools Panel:
Adding New Clipboards

By default, the Sequence Editor has a single clipboard, as in the picture above. However, the "Add New Clipboard" button can be used to quickly create multiple clipboards:

The Clipboards subpanel, with three clipboards

When multiple clipboards exist, you can select which one is currently in use simply by selecting the radio button to the left of its name.

Locking and Unlocking Clipboards

A clipboard can be locked or unlocked; a locked clipboard cannot be copied to (though it can still be pasted from). This is so as to prevent accidentally overwriting copied effects that you want to keep available.

You can lock an unlocked clipboard by pressing the "unlocked" button to the right of its name; the button will then change to "locked":

A locked clipboard

To unlock a locked clipboard, press the "locked" button, which will then change to "unlocked".

Saving Clipboards

Clipboards can be saved for later use, so that their contents will be available to you whenever you use the Sequence Editor in the future; any saved clipboards will be automatically loaded for you when you start up the Sequence Editor. To save a clipboard, right-click on its name, which will open up a popup menu:
The clipboard popup menu

Select "Save Clipboard" from the popup menu; you will be prompted to give the clipboard a name (unless you have done so before), and the clipboard will then be moved to a different section in the top of the list of clipboards, in a different color, indicating that it is a saved clipboard:

A clipboard will be automatically locked upon being saved; you can, of course, unlock it if you wish, and if you do so, then any changes you make to it will automatically be saved.

Renaming Clipboards, and Other Uses of the Popup Menu

The clipboard popup menu (for a clipboard that has not been saved) also gives you the ability to rename the clipboard, and to lock or unlock the clipboard:

For a saved clipboard, the popup menu gives you the option to "unsave" the clipboard, thus moving it back into the "Other Clipboards" section (and making it so that the clipboard will not be automatically loaded the next time that you start the Sequence Editor), and to lock or unlock the clipboard.

Loading Clipboards

Any saved clipboard will be automatically loaded whenever you start the Sequence Editor. However, if you had previously saved a clipboard, but had removed it from the saved list, you can later manually open it up again via the Clipboards subpanel's "Load Clipboard" button.
Paste Mode

Towards the bottom of the Clipboards subpanel are controls that let you choose between two different paste modes: "Paste by Cell" and "Paste by Time". "Paste by cell" pastes the effects based upon the relative durations of the copied cells and the cells where they will be pasted, while "paste by time" pastes them based only upon the duration of the copied effects.

**Paste by Cell**

Paste by Cell pastes effects based upon the relative durations of the copied cells and the cells where they will be pasted. For example, consider timings at 0 seconds, 1 second, and 2 seconds. Between 0 and 1 is a fade up, and between 1 and 2 is a fade down:

![Paste by Cell diagram](image1)

These events will be copied, and pasted to the time starting at 5 seconds. There are timings at 5 seconds, 7 seconds, and 7.5 seconds:

![Paste by Cell diagram](image2)

If "Paste by Cell" is selected, then there will be a fade up from 5 to 7, and a fade down from 7 to 7.5:

![Paste by Cell diagram](image3)

**Paste by Time**

Paste by Time pastes effects based upon their durations as they were copied. For example,

For example, consider timings at 0 seconds, 1 second, and 2 seconds. Between 0 and 1 is a fade up, and between 1 and 2 is a fade down:
These events will be copied, and pasted to the time starting at 5 seconds. There are timings at 5 seconds, 7 seconds, and 7.5 seconds:

If "Paste by Time" is selected, then there will be a fade up from 5 to 6, and a fade down from 6 to 7. The timings at 7 and 7.5 are ignored; only the original lengths of the events are used:

Paste from Foreground

At the bottom of the Clipboards subpanel is a checkbox labeled "Paste from Foreground". This checkbox controls whether or not copied "off" effects will overwrite existing effects when pasted. For example, consider the following portion of a sequence, and imagine that the simple chase on the left will be copied and pasted on top of the twinkling on the right:

If "Paste from Foreground" is turned off, then the entire copied area - including the off effects - will be pasted:
But if "Paste from Foreground" is turned on, then the off effects are not pasted, leaving some of the cells twinkling:

![Image](image.png)

After pasting, with "Paste from Foreground"

"Paste from Foreground" also affects the behavior of the Chase tool and the Repeat tool, in similar fashion.

### 5.3.7 The Right-Click Context Menu

In the Light-O-Rama Sequence Editor, sequences are represented using a grid. Rows in the grid represent channels, and columns in the grid represent the duration between timings. Cells in the grid are used to display what lighting effects are set in the sequence for that point in time on those channels.

Right-clicking on the grid brings up a popup menu. This menu contains several items which allow you to modify the currently selected cells, in a variety of ways. For example, you can insert lighting effects, cut, copy, and paste (both effects and timings), and delete or resize timings.

The following items are available on this right-click context menu:

- Fade Down
- Fade Up
- On
- Off
- Set Intensity
- Shimmer
- Toggle
- Twinkle
- Fill
- Background Effects
- Foreground Effects
- Cut
- Copy
- Paste
- Paste Multiple
- Copy Timing
- Paste Timing at...
- Paste Timing at (centisecond)
- Paste Timing Multiple
- Insert Timing at...
- Insert Timing at (centisecond)
- Insert Multiple Timings
- Subdivide Timings
- Delete Timing at (centisecond)
- Delete Selected Timings
- Resize Timings to...
- Resize Timings to Equal Times
- Clear Freeform Play Range
Fade Down

This item on the right-click context menu will insert a fade down effect into the currently selected cell or cells.

Fade Up

This item on the right-click context menu will insert a fade up effect into the currently selected cell or cells.
On

This item on the right-click context menu will insert an on effect into the currently selected cell or cells.

Off

This item on the right-click context menu will insert an off effect into the currently selected cell or cells.

Set Intensity

This item on the right-click context menu will insert a set intensity effect into the currently selected cell or cells.

Shimmer

This item on the right-click context menu will insert a shimmer effect into the currently selected cell or cells.

Toggle

This item on the right-click context menu will toggle the effects in the currently selected cell or cells between on and off. Any that had been off will be turned on; all others will be turned off (note that this includes not just those that had been on, but also, for example, those that had been shimmers or fades).

Twinkle

This item on the right-click context menu will insert a twinkle effect into the currently selected cell or cells.

Fill

This item on the right-click context menu will apply a fill to every off event in the currently selected cell or cells.

Background Effects

This submenu of the right-click context menu can be used to insert various effects (such as fades and shimmers) into the currently selected cell or cells, using background effects mode.

Note that this does not turn on background effects mode permanently; it merely enables it for this one insertion.

Foreground Effects

This submenu of the right-click context menu can be used to insert various effects (such as fades and shimmers) into the currently selected cell or cells, using foreground effects mode.
Note that this does not turn on foreground effects mode permanently; it merely enables it for this one insertion.

**Cut**

This item on the right-click context menu will cut the effects from the currently selected cell or cells. Please see "Cut, Copy, Paste, and Paste Multiple" on the Edit menu for details.

**Copy**

This item on the right-click context menu will copy the effects from the currently selected cell or cells. Please see "Cut, Copy, Paste, and Paste Multiple" on the Edit menu for details.

**Paste**

This item on the right-click context menu will paste effects into the sequence, starting at the start of the currently selected cell or cells. Please see "Cut, Copy, Paste, and Paste Multiple" on the Edit menu for details.

**Paste Multiple**

This item on the right-click context menu opens a dialog that can be used to paste several copies of effects into the sequence, starting from the currently selected cell or cells. For example, you can choose to paste the effects three times in a row horizontally, and two times in a row vertically. Please see "Cut, Copy, Paste, and Paste Multiple" on the Edit menu for details.

**Copy Timing**

This item on the right-click context menu will copy the timings from the currently selected cell or cells. Please see "Copy and Paste Timings" on the Edit menu for details.

**Paste Timing at ...**

This item on the right-click context menu can be used to paste copied timings into the sequence. It opens a dialog asking you for the time that you want to paste the timings to (defaulting to the time that you right-clicked when opening the context menu). Please see "Copy and Paste Timings" on the Edit menu for details, and Time Format for details on how to enter times.

**Paste Timing at (centisecond)**

This item on the right-click context menu can be used to paste copied timings into the sequence, starting at the time that you right-clicked when opening the context menu. Please see "Copy and Paste Timings" on the Edit menu for details.

**Paste Timing Multiple**

This item on the right-click context menu can be used to paste copied timings into the sequence, multiple times in a row. Please see "Copy and Paste Timings" on the Edit menu for details.
Insert Timing at ...

This item on the right-click context menu can be used to insert a timing into the sequence. It opens a dialog asking you for the time that you want to insert a timing at (defaulting to the time that you right-clicked when opening the context menu). Please see Time Format for details on how to enter times.

Insert Timing at (centisecond)

This item on the right-click context menu can be used to insert a timing into the sequence at the time that you right-clicked when opening the context menu.

Insert Multiple Timings

This item on the right-click context menu can be used to insert multiple evenly-spaced timings into the selected cell or cells, based on the length of the entire selection. See "Insert Multiple Timings" on the Timings submenu of the Edit menu for details.

Also see "Subdivide Timings" for similar, but different, functionality.

Subdivide Timings

This item on the right-click context menu can be used to insert multiple evenly-spaced timings into each selected cell, based on the length of the cell. See "Subdivide Timings" on the Timings submenu of the Edit menu for details.

Also see "Insert Multiple Timings" for similar, but different, functionality.

Delete Timing at (centisecond)

This item on the right-click context menu can be used to delete the timing closest on the left to the time that you right-clicked when opening the context menu.

Delete Selected Timings

This item on the right-click context menu can be used to delete the timings inside the currently selected cells. Note that the two timings on the edges of the currently selected cells are not deleted.

Resize Timings to ...

This item on the right-click context menu can be used to change the duration of time between the selected timings. It will not allow any of the timings to be pushed beyond the next timing in the sequence. Please see Time Format for details on how to enter times.

Note that the length of the sequence will not be affected, nor the positions of the timings past the selected range. So, if you choose to resize some timings such that their total length decreases, this will cause the cell just past them to increase in size (since the last selected timing is moved earlier, while the next timing remains the same).
Resize Timings to Equal Times

This item on the right-click context menu can be used to change the duration of time between the selected timings so that all such durations are equal (or as close to equal as possible). For example, if you select two cells with durations of 0.2 seconds and 0.8 seconds, and use “Resize Timings to Equal Times”, they will both change to 0.5 seconds.

Clear Freeform Play Range

If a track has a freeform play range selected, this item on the right-click context menu can be used to remove it.

5.3.8 Channel and RGB Channel Buttons

In the Light-O-Rama Sequence Editor, sequences are represented using a grid. Rows in the grid represent channels and RGB channels, and columns in the grid represent the duration between timings. Cells in the grid are used to display what lighting effects are set in the sequence for that point in time on those channels and RGB channels.

In each row, to the left of the grid, there is a button associated with the channel or RGB channel for that row. The button is labeled with the name of the channel or RGB channel:

Buttons for regular channels are shown in grey, as in the above picture. Those for RGB channels are shown in black, as in the first row of the following:

Left-clicking on such a button brings up the Channel Settings dialog if for a channel, and the RGB
Channel Settings dialog if for an RGB channel, from which you can modify various settings such as a channel's name, color, unit ID, and circuit ID.

Right-clicking brings up the channel button's popup menu, giving access to various channel-related functionality.

Left-clicking on the small button to the left of an RGB channel's button (with the red, green, and blue stripes) expands the view so that the constituent channels of that RGB channel can be seen (and clicking it again collapses the view by hiding them):

Channels or RGB channels can be moved up or down in a sequence by clicking and dragging their buttons.

Between the channel/RGB channel buttons and the grid is a thick grey vertical bar. Dragging the bar left or right changes the width of the channel/RGB channel buttons; clicking on it (without dragging) hides them, and clicking it again unhides them. This latter can also be done via "Channel Buttons" on the View menu.

During play, the color of a channel or RGB channel button will vary along with the lighting effects happening on that channel or RGB channel. For example, during a fade, the button will gradually change in color, and during a twinkle, the button will blink between its usual light grey and the channel's color. If you do not wish to see this, you can turn this behavior off permanently via "Vary the color of channel buttons during play by default" on the Play Preferences dialog, or temporarily via either "Vary Color of Channel Buttons" on the Play menu or the Vary Channel Button Colors button of the Standard toolbar.

5.3.8.1 Channel Settings

The Sequence Editor's Channel Settings dialog allows you to set various properties of a channel in your sequence, such as its name, color, unit ID and circuit ID.

You can access the Channel Settings dialog by clicking on the channel's button, or right-clicking and selecting "Change Channel Settings" from the popup menu.

Not all settings are available for all channel types; for example, X10 controllers do not use circuit IDs, and only channels representing subsequences can specify the name of a sequence file. The controls for
The **Channel Property Grid** allows you to do the same sort of things as the Channel Settings dialog, but can be used on all of the channels in your sequence at the same time.

### 5.3.8.2 RGB Channel Settings

The **Sequence Editor**'s RGB Channel Settings dialog allows you to set various properties of an RGB channel in your sequence, such as its name and the unit and circuit IDs of its constituent channels.

You can access the RGB Channel Settings dialog by clicking on the RGB channel's button, or right-clicking and selecting "Change RGB Channel Settings" from the popup menu.
In the above picture, notice that the settings for the green and blue channels are greyed out, so that their settings cannot be modified (directly). This is because the "Automatically link channel settings" checkbox is checked. When it is checked, any change to the red channel's settings will be automatically reflected in the green and blue channels. For example, setting the red channel's unit ID to 02 will cause both the green and blue channels to automatically change to unit ID 02, and setting the red channel's circuit ID to 4 will cause the green channel's circuit ID to become 5, and the blue's to become 6.

To modify the green and blue channels' settings independently of those of the red channel, uncheck the "Automatically link channel settings" checkbox.

The "Use LOR legacy mode" checkbox, if checked, will limit the available circuit IDs from 1 to 16 (as opposed to the standard 1 to 512). This is to support older controllers, which might each have several different unit IDs, each of which have circuit IDs from 1 to 16, instead of having a single unit ID with many circuit IDs.

5.3.8.3 Channel and RGB Channel Buttons' Popup Menus

In the Sequence Editor, right-clicking on a channel or RGB channel button brings up a popup menu of items regarding that channel or RGB channel. These include:

- **Change Name**
- **Change Color**
- **Change Channel Settings / Change RGB Channel Settings**
- **Insert Device**
  - Insert Device Above
  - Insert Device Below
- **Insert Channels**
  - Insert Channel Above
  - Insert Channel Below
  - Insert Multiple Channels Above
  - Insert Multiple Channels Below
- **Insert RGB Channels**
  - Insert RGB Channel Above
  - Insert RGB Channel Below
  - Insert Multiple RGB Channels Above
  - Insert Multiple RGB Channels Below
- **Convert to RGB Channel**
- **Delete Channel / Delete RGB Channel**
- **Remove Channel from Track / Remove RGB Channel from Track**
- **Copy to Other Track**
  - Copy to New Track
  - Copy to Track Number...
- **Move**
  - Move Up
  - Move Down
  - Move to New Track
  - Move to Track Number...
Change Name

This option from the channel/RGB channel button popup menu can be used to change the name of the channel or RGB channel. The name will be displayed in various places, including on the channel or RGB channel's button.

Change Color

This option from the channel button popup menu can be used to change the color assigned to the channel (it is unavailable for RGB channels). Note that this has no effect on your actual lights, and that it is not necessary to set the color of the channel to match the color of the actual lights hooked up to the channel. However, doing so may be convenient. For example, the Sequence Editor will use the assigned color to display lighting effects in the sequence’s grid.

Change Channel Settings / Change RGB Channel Settings

This option from the channel/RGB channel button popup menu opens the Channel Settings dialog or the RGB Channel Settings dialog, which can be used to modify various properties of the channel or RGB channel, such as a channel's name, color, unit ID and circuit ID.

Insert Device

This submenu of the channel/RGB channel button popup menu can be used to insert channels and/or RGB channels representing a particular device (such as a Cosmic Color Device or an LOR/CTB device) above or below the selected channel or RGB channel.

- Insert Device Above
- Insert Device Below

Insert Device Above
This option from the channel/RGB channel button popup menu opens up the Insert Device dialog, allowing you to specify settings of a new device (such as a Cosmic Color Device or an LOR/CTB device) to be inserted into the sequence above the selected channel or RGB channel.

Insert Device Below

This option from the channel/RGB channel button popup menu opens up the Insert Device dialog, allowing you to specify settings of a new device (such as a Cosmic Color Device or an LOR/CTB device) to be inserted into the sequence above the selected channel or RGB channel.

Insert Channels

This submenu of the channel/RGB channel button popup menu can be used to insert a channel, or multiple channels, above or below the selected channel or RGB channel.

- Insert Channel Above
- Insert Channel Below
- Insert Multiple Channels Above
- Insert Multiple Channels Below

Insert Channel Above

This option from the channel/RGB channel button popup menu creates a new channel and inserts it into the sequence above the selected channel or RGB channel.

Insert Channel Below

This option from the channel/RGB channel button popup menu creates a new channel and inserts it into the sequence below the selected channel or RGB channel.

Insert Multiple Channels Above

This option from the channel/RGB channel button popup menu can be used to create multiple new channels at once, and insert them into the sequence above the selected channel or RGB channel. You will be prompted for how many channels you want to create.

Insert Multiple Channels Below

This option from the channel/RGB channel button popup menu can be used to create multiple new channels at once, and insert them into the sequence below the selected channel or RGB channel. You will be prompted for how many channels you want to create.

Insert RGB Channels

This submenu of the channel/RGB channel button popup menu can be used to insert an RGB channel, or multiple RGB channels, above or below the selected channel or RGB channel.

- Insert RGB Channel Above
- Insert RGB Channel Below
- Insert Multiple RGB Channels Above
- Insert Multiple RGB Channels Below
Insert RGB Channel Above

This option from the channel/RGB channel button popup menu creates a new RGB channel and inserts it into the sequence above the selected channel or RGB channel.

Insert Channel Below

This option from the channel/RGB channel button popup menu creates a new RGB channel and inserts it into the sequence below the selected channel or RGB channel.

Insert Multiple Channels Above

This option from the channel/RGB channel button popup menu can be used to create multiple new RGB channels at once, and insert them into the sequence above the selected channel or RGB channel. You will be prompted for how many RGB channels you want to create.

Insert Multiple Channels Below

This option from the channel/RGB channel button popup menu can be used to create multiple new RGB channels at once, and insert them into the sequence below the selected channel or RGB channel. You will be prompted for how many RGB channels you want to create.

Convert to RGB Channel

This option from the channel button popup menu opens the Convert to RGB Channel dialog, which allows you to convert existing channels into RGB channels. It is not available from the popup menus for RGB channel buttons.

Delete Channel / Delete RGB Channel

This option from the channel/RGB channel button popup menu deletes the selected channel or RGB channel. Note that this will completely delete the channel or RGB channel from the sequence, not just from the current track. If you want to remove the channel or RGB channel from the current track but still keep it in other tracks, use “Remove Channel from Track / Remove RGB Channel from Track” instead.

Remove Channel from Track / Remove RGB Channel from Track

This option from the channel/RGB channel button popup menu removes the selected channel or RGB channel from the track. If the channel or RGB channel is shared with other tracks, it will remain in those other tracks. If you instead want to delete a channel or RGB channel from the sequence completely, removing it from all tracks, use “Delete Channel / Delete RGB Channel” instead.

Copy to Other Track

This submenu of the channel/RGB channel button popup menu can be used to share the selected channel or RGB channel either to a new track or to an existing track:
Copy to New Track

This item on the "Copy to Other Track" submenu of the channel/RGB channel button popup menu will create a new track (via the New Track dialog) and share the selected channel or RGB channel with that track.

Copy to Track Number...

This item on the "Copy to Other Track" submenu of the channel/RGB channel button popup menu will share the selected channel or RGB channel with another existing track in the sequence. You will be prompted to select which track.

Move

This submenu of the channel/RGB channel button popup menu can be used to move the selected channel or RGB channel up or down within its track, or to another track. Note that a channel or RGB channel can also be moved up or down within its track by clicking and dragging its channel button.

Move Up

This item on the "Move" submenu of the channel/RGB channel button popup menu will move the selected channel or RGB channel one slot up in its track.

Move Down

This item on the "Move" submenu of the channel/RGB channel button popup menu will move the selected channel or RGB channel one slot down in its track.

Move to New Track

This item on the "Move" submenu of the channel/RGB channel button popup menu will create a new track (via the New Track dialog) and move the selected channel or RGB channel to that track.

Move to Track Number...

This item on the "Move" submenu of the channel/RGB channel button popup menu will move the selected channel or RGB channel to another existing track in the sequence. You will be prompted to select which track.

5.3.8.3.1 Insert Device

The Insert Device dialog can be used to add several channels and/or RGB channels to a sequence, automatically populated with various settings such as their unit IDs and circuit IDs. The dialog can be opened by right-clicking on a channel or RGB channel's button, and selecting either "Insert Device Above
" or "Insert Device Below" from the popup menu (which will cause the new device’s channels to be inserted above or below the clicked channel, respectively).

At the top of the Insert Device dialog is a dropdown list of the available devices:

- CMB16D
- Cosmic Color Device
- DIO32
- iDMX1000
- LOR/CTB (8 Channel)
- LOR/CTB (16 Channel)
- LOR/CTB (32 Channel)
- RGB Device (Non-CCD)
- Servo Dog

CMB16D

The CMB16D choice for the Insert Device dialog will add sixteen channels, with device type Light-O-Rama, a network and unit ID that you specify, and circuit numbers from 1 to 16. The name of a channel will be “CMB” followed by an indication of the unit and circuit (such as “CMB 03.7” for unit 03 and circuit 7).

Cosmic Color Device

The Cosmic Color Device choice for the Insert Device dialog has both a basic and an advanced mode. In basic mode, it will add fifty RGB channels followed by seven regular channels. All will have device type Light-O-Rama, and a specified network and unit ID.

The circuit numbers of the first RGB channel will be red = 1, green = 2, blue = 3, the next RGB Channel will have red = 4, green = 5, blue = 6, and so on, up to the fiftieth RGB channel, which will have red = 148, green = 149, blue = 150. The seven regular channels, which represent the macro channels of the Cosmic Color Device, start at circuit 151 and go through 157.

The names of the RGB channels will be "CCD" followed by an indication of the unit ID and the pixel number (such as "CCD 03 p7" for unit ID 03 pixel 7). The names of the macro channels will indicate which macro channels they represent, instead of having a pixel number, such as "CCD 03 LR", meaning "Cosmic Color Device, unit 03, Logical Resolution". The full list of abbreviations such as "LR" for "Logical Resolution" is:

- LR: Logical Resolution
- MM: Macro Mode
Light-O-Rama v2.8.12

- MS: Macro Submode
- ME: Macro Effect
- CM: Color Mode
- CS: Color Speed
- CI: Color Intensity

**MS: Macro Submode**

**ME: Macro Effect**

**CM: Color Mode**

**CS: Color Speed**

**CI: Color Intensity**

To use advanced mode, click on the "Show Advanced Options" button:

The "Resolution" dropdown controls the number of pixels - i.e. the number of RGB channels - that will be created. Also, macro channels will only be created if the resolution is set to 50 pixels.

When "Unit ID Mode" is set to "Native Mode", all channels and RGB channels on the Cosmic Color Device use a single unit ID (as described above, in basic mode). If it is set to "Legacy Mode", however, circuit IDs will be limited from 1 to 16, and multiple unit IDs will be used. For example, if the selected unit ID is 01, and 50 pixels are chosen, then instead of having unit 01 circuits 1 through 157, the channels and RGB channels to be created will have unit 01 circuits 1 through 16, unit 02 circuits 1 through 16, ..., unit 09 circuits 1 through 16, and unit 0A circuits 1 through 13. The names of all channels and RGB channels will still indicate the base unit ID, though - for example, the fiftieth
A pixel will be labelled "CCD 01 p50" despite its constituent channels actually using unit ID 09 rather than 01.

When "Channel Mode" is set to "Triples", the circuit IDs are as described above in the "basic mode" section - i.e. the first pixel will have circuit IDs 1, 2, and 3 for red, green, and blue, respectively, the second will have 4, 5, and 6, and so on. If it is set to "Sequential", the circuit IDs will instead be assigned to all of the red channels first, then all of the green channels, then all of the blue channels. For example, with 50 pixels and native unit ID mode, the first pixel will have circuit IDs 1, 51, and 101 for red, green, and blue, respectively, the second will have 2, 52, and 102, and so on.

**DIO32**

The DIO32 choice for the Insert Device dialog will add 32 channels, with device type Light-O-Rama and a specified network. If "Unit ID Mode" is set to "Native Mode", then the specified unit ID will be used for all 32 channels, which will have circuits 1 through 32. If it is instead set to "Legacy Mode", then the first sixteen channels will have the specified unit ID and circuits 1 through 16, and the last sixteen channels will have the next unit ID and circuits 1 through 16.

The names of the channels will be "DIO" followed by an indication of the unit and circuit, such as "DIO 03.7" for unit ID 03, circuit 7.

**iDMX1000**

The iDMX1000 choice for the Insert Device dialog will add anywhere from 16 to 512 channels, in multiples of 16, with device type Light-O-Rama and a specified network. If "Unit ID Mode" is set to "Native Mode", then a single (specified) unit ID will be used for all channels, with circuit IDs ranging from 1 to the number of channels. If it is set to "Legacy Mode", then circuit IDs will be limited from 1 to 16, and multiple unit IDs will be used (assuming more than 16 channels are selected), starting at the specified unit ID.

The names of the channels will be "iDMX" followed by an indication of the unit and circuit, such as "iDMX 03.7" for unit ID 03 circuit 7.
The LOR/CTB (8 Channel) choice for the Insert Device dialog will add eight channels, with device type Light-O-Rama and a specified network and unit ID, and circuit IDs ranging from 1 to 8.

The names of the channels will be "Unit" followed by an indication of the unit and circuit, such as "Unit 03.7" for unit 03 circuit 7.

The LOR/CTB (16 Channel) choice for the Insert Device dialog will add sixteen channels, with device type Light-O-Rama and a specified network and unit ID, and circuit IDs ranging from 1 to 16.

The names of the channels will be "Unit" followed by an indication of the unit and circuit, such as "Unit 03.7" for unit 03 circuit 7.
The LOR/CTB (32 Channel) choice for the Insert Device dialog will add thirty-two channels, with device type Light-O-Rama and a specified network and unit ID, and circuit IDs ranging from 1 to 32.

The names of the channels will be "Unit" followed by an indication of the unit and circuit, such as "Unit 03.7" for unit 03 circuit 7.

The RGB Device (Non-CCD) choice for the Insert Device dialog will add anywhere from 1 to 16 RGB channels, with device type Light-O-Rama and a specified network and base unit ID. Note, though, that you do not specify the number of RGB channels; instead, you specify the number of underlying channels, with three channels corresponding to a single RGB channel. For example, to add 16 RGB channels, select 48 channels.

The reason for specifying the number of channels instead of the number of RGB channels is because the number of channels per unit ID can also be specified (so that, for example, 48 channels with 16 channels per unit ID will cause three unit IDs to be used, starting from the specified base).

If the "Channel Mode" option is set to "Triples", then the circuit IDs will be 1 for the red channel of the first RGB channel, 2 for the green channel of the first RGB channel, 3 for the blue channel of the first RGB channel, 4 for the red channel of the second RGB channel, and so on. If it is instead set to "Sequential", then they will instead be 1 for the red channel of the first RGB channel, 2 for the red channel of the second RGB channel, 3 for the red channel of the third RGB channel, and so on through all of the red channels, then through the green channels, then the blue channels.

The RGB channel names will be “RGB” followed by an indication of the base unit ID plus the pixel number; for example, "RGB 03 p7" for the seventh pixel of the RGB device whose base unit ID is 03.
Insert Device: RGB Device (non-CCD)

Servo Dog

The Servo Dog choice for the Insert Device dialog will add eight channels, with device type Light-O-Rama and a specified network and unit. The circuit IDs will range from 1 to 8.

The names of the channels will be "SD" followed by an indication of the unit and circuit, such as "SD 03.7" for unit 03 circuit 7.

5.3.8.3.2 Convert to RGB Channel

The Convert to RGB Channel dialog enables you to convert existing channels into RGB channels. You can open the Convert to RGB Channel dialog by right-clicking on a channel's button, and selecting "Convert to RGB Channel" from the popup menu. The RGB channel that is created by the dialog will be placed at the erstwhile location of the channel that you click on, and (by default) will use that channel as its red constituent channel, and the immediately following channels (if any) as its green and blue constituent channels.
The Light-O-Rama Software Package

The Convert to RGB Channel dialog

RGB Channel Name

The RGB Channel Name field allows you to specify the name of the RGB channel to be created; by default, it will be the same as the name of the channel that you clicked on. The names of the constituent channels will be changed to reflect the name of the RGB channel; for example, if you name the RGB channel “My RGB”, then its red, green, and blue constituent channels will be renamed “My RGB (R)”, “My RGB (G)”, and “My RGB (B)”, respectively.

Component Channels

The three component channel dropdown lists allow you to specify the existing channels to use as the component channels. Also, the top entry in each list, “Add a new channel”, allows you to say that an entirely new channel should be created and used as that component channel, rather than using an existing channel. By default, the red channel will be the channel that you clicked on, the green channel will be the channel following that, and the blue will be the channel following that.

Also Do This for Following Channels

If the “Also do this for following channels” box is checked, you can specify a number of RGB channels to create (otherwise, only one will be created). The dialog will try to create as many as you specify, using succeeding channels from the track. Exactly which channels are used depends upon the relationship between the three channels that you specify in the “Component Channels” section:

The first mode is intended to support sequences whose channels are currently set up in the order R, G, B, R, G, B, R, G, B, and so on. So, if the specified green channel immediately follows the specified red channel, and the specified blue channel immediately follows the specified green channel, then the next RGB channel will be created from the three channels following those (as R, G, and B, respectively), and the RGB channel after that from the three channels following those, and so on. If this causes the dialog to run out of channels before creating the number of RGB channels that you requested (either due to reaching the end of the track or due to reaching an existing RGB channel instead of a channel), it will stop, and warn you that it was only able to create less RGB channels than you had requested.
The other mode is intended to support sequences whose channels are currently set up in the order R, R, R, ..., G, G, G, ..., B, B, B, .... So, if the specified green channel does not immediately follow the specified red channel, or the specified blue channel does not immediately follow the specified green channel, then the next RGB channel will consist of the channel following the specified red channel as its red channel, the channel following the specified green channel as its green channel, and the channel following the specified blue channel as its blue channel. Again, if this causes it to run out of channels before creating the requested number of RGB channels (either due to the conditions listed previously or else due to reaching a channel that has already been used), it will stop, and warn you that it created less than you asked for.

5.3.9 Track Bars

If a sequence contains more than one track, the Sequence Editor displays each track with a track bar at its top. This bar is labelled with up to three parts:

- "Track <number>“, such as “Track 2“, with the topmost track being “Track 1“, the next being “Track 2“, and so on;
- If the track has been assigned a name, the name is displayed after the track number;
- If the track’s grid has been hidden, the label will additionally say “(hidden)”.

The track bar of the currently active track is colored green, so as to make that track easily distinguishable from the other tracks.

Clicking on a track bar brings up a the track bar’s popup menu, which allows access to various functionality related to the track. For example, you can move the track up or down in the sequence, hide or unhide the track, or duplicate the track to another track.

5.3.9.1 Track Bars’ Popup Menus

If a sequence has more than one track, the Sequence Editor displays a track bar at the top of each. Clicking on a track bar opens up a popup menu containing various functions related to the track. These include:
• **Change Track Name**
• **Move Track Up**
• **Move Track Down**
• **Insert Track Above**
• **Insert Track Below**
• **Duplicate Track**
• **Change Total Time**
• **Delete Track**
• **Hide or Show Track**

The track bar popup menu

**Change Track Name**

This item on the track bar popup menu can be used to change the name of the track, or assign a name if the track does not already have one. If a track is given a name, it will be displayed on that track's track bar (among other places).

This is equivalent to "Change Track Name" on the Edit menu.

**Move Track Up**

This item on the track bar popup menu will move the track up a single slot in the sequence.

Note that this will cause the label on the track's track bar to change - for example, if track 3 is moved up, it will become track 2, and what had been track 2 will become track 3. However, if either of the tracks have names, their names will remain the same. For example, if "Track 3: Funky Bass Line" is moved up, its track bar will be relabelled "Track 2: Funky Bass Line", and if the previous track 2 had been named "Awesome Guitar Solo", its track bar will be changed from "Track 2: Awesome Guitar Solo" to "Track 3: Awesome Guitar Solo".

**Move Track Down**

This item on the track bar popup menu will move the track down a single slot in the sequence.

Note that this will cause the label on the track's track bar to change - for example, if track 2 is moved down, it will become track 3, and what had been track 3 will become track 2. However, if
either of the tracks have names, their names will remain the same. For example, if "Track 2: Funky Bass Line" is moved down, its track bar will be relabelled "Track 3: Funky Bass Line", and if the previous track 3 had been named "Awesome Guitar Solo", its track bar will be changed from "Track 3: Awesome Guitar Solo" to "Track 2: Awesome Guitar Solo".

Insert Track Above

This item on the track bar popup menu can be used to create a new track, via the New Track dialog, and insert that new track into the sequence just above the selected track.

Insert Track Below

This item on the track bar popup menu can be used to create a new track, via the New Track dialog, and insert that new track into the sequence just above the selected track.

Duplicate Track

This item on the track bar popup menu can be used to duplicate the selected track to a new track, which will be inserted at the bottom of the sequence.

This is equivalent to "Duplicate Track" on the Edit menu.

Change Total Time

This item on the track bar popup menu can be used to change the duration of the selected track. Note that all tracks in a musical sequence (as opposed to an animation sequence) must have the same duration, so changing the duration of one track in a musical sequence will automatically change the duration of all others.

This is equivalent to "Change Total Time" on the Edit menu.

Delete Track

This item on the track bar popup menu can be used to delete the selected track from the sequence.

Hide or Show Track

This item on the track bar popup menu can be used to hide or unhide the track's grid. When a track's grid is hidden, only the track bar will remain visible, and it will be relabelled to indicate that the track has been hidden. To unhide a track that has been hidden, simply click on the track bar to open the popup menu again, and select "Show Track".
5.3.10 Loop Menus

The Light-O-Rama Sequence Editor has two popup menus for dealing with loops:

First, clicking on the grid in a loop level opens the Loop Context menu (loop levels can be recognized as the rows with white background and buttons, as opposed to the light grey of channels' rows; they are located above the channels, but below the time scale). This can be used, for example, to add, delete, change, or view information about loops, as well as to add or delete loop levels.

Second, clicking on a loop level's button will bring up a menu that contains a subset of the items of the Loop Context menu. Specifically, it includes those items that deal with the loop level, as opposed to loops on that loop level.

If your sequence does not contain any loop levels, but you want to add loops to it, first use "Turn On Loops" from the Edit menu. This will insert a loop level into the sequence. Note that loops can only be used in animation sequences, not in musical sequences.

5.3.10.1 The Loop Context Menu

The Sequence Editor's Loop Context menu gives access to various loop-related functionality. It can be accessed by clicking on the grid in a loop level's row (which can be recognized by its white background,
as opposed to the light grey of channels; loop levels' rows are located above the channels' rows but below the time scale).

Different menu items are available depending upon whether a loop already exists at the spot clicked; for example, if one does, there is a menu item to delete it; if none does, there is instead a menu item to insert one.

Those portions of the menu that deal with loop levels (as opposed to loops) can also be accessed by clicking on a loop level button.

The items on the menu include:

- Insert Loop
- Change Loop
- Loop Info
- Remove Loop
- Add Loop Level Above
- Add Loop Level Below
- Remove Loop Level
- Remove All Loops on Level

Insert Loop

This item on the Loop Context menu inserts a loop in the selected cell or cells on the selected loop level. After clicking it, you will first be asked how many times the loop should loop back (for example, to play through a loop twice, it should loop back once):

Looping back five times will cause six passes through the loop

After that, you will be prompted to say whether (and by how much) it should speed up, slow down, or remain at the same speed with each successive pass through the loop:
This loop will speed up by 37% with each successive pass

This menu item is available only if no loop exists in any of the selected cells on the selected loop level.

Change Loop

This item on the Loop Context menu can be used to change the settings of the selected loop - i.e. the number of times that it will loop back, and the speed change (if any) with each successive pass. Using it is very similar to using "Insert Loop"; please see that help file entry for details.

This menu item is available only if the popup menu is opened by clicking on an existing loop.

Loop Info

This item on the Loop Context menu displays information about the selected loop, such as how many times it loops back, and the speed change (if any) with each successive pass.

This menu item is available only if the popup menu is opened by clicking on an existing loop.
Remove Loop

This item on the Loop Context menu can be used to delete an existing loop.

This menu item is available only if the popup menu is opened by clicking on an existing loop.

Add Loop Level Above

This item on the Loop Context menu can be used to add another loop level to the sequence, above the selected loop level. Loops on the new (higher) level can contain loops within the preexisting (lower) level.

Add Loop Level Below

This item on the Loop Context menu can be used to add another loop level to the sequence, below the selected loop level. Loops on the preexisting (higher) level can contain loops within the new (lower) level.

Remove Loop Level

This item on the Loop Context menu can be used to delete the entire selected loop level, including all loops on it.

If you wish to delete all of the loops on a level, but to keep the level itself, use "Remove All Loops on Level" instead.

If you have removed all of the loop levels from a sequence, but later decide that you want to use loops, use "Turn On Loops" from the Edit menu. Doing so will add a loop level to the sequence.

Remove All Loops on Level

This item on the Loop Context menu can be used to delete all of the loops on the selected loop level, but to keep the loop level itself.

If you wish to additionally delete the loop level itself, use "Remove Loop Level" instead.

5.3.10.2 Loop Level Buttons

Loops in a sequence can be grouped into loop levels. Loops on a higher level can contain loops on lower levels.

In the Sequence Editor, loop levels are displayed as white rows, above the channels' rows and below the time scale. On the left of each loop level's row is that loop level's button:

![Loop level buttons](image)

The bottom loop level in a sequence is always labelled "Loop 1"; the one immediately higher than that is
labelled "Loop 2", and so on.

Clicking on a loop level's button will bring up a portion of the Loop Context menu (specifically, those menu items dealing with loop levels, as opposed to loops). You can use this, for example, to delete the loop level, remove all of the loops from it, or add a new loop level above or below the selected level.

If you wish to add loops to a sequence but it does not currently have any loop levels, use "Turn On Loops" from the Edit menu. Doing so will add a loop level to the sequence. Note that this is only possible in animation sequences, since musical sequences cannot contain loops.

5.3.11 The Waveform

For certain types of musical sequences (those based on WAV, MP3, or WMA audio files), the Sequence Editor can display a waveform of the audio at the top of each track. This can be useful for visually matching up timings and events to the sound.

In addition to the waveform itself, a vertical highlight bar is displayed at the current time that your mouse is pointing at.

- Viewing the waveform
- Scaling up and down
- Changing the display type
- Changing the colors

Viewing the Waveform

Waveforms can only be displayed for certain types of musical sequences - those based on WAV, MP3, or WMA audio files. To view the waveform for such a file, make sure that "Wave Form" on the View menu is set to either "Full Height" or "Half Height". To hide the waveform, set it to "Off".

"Full Height" or "Half Height" determines the size of the whole display. This should not be confused with scaling up and down, which will keep the size of the display the same, but vary the size of the graph within the display.

The View Wave Form button on the Standard Toolbar can be used to toggle between "Off" and whichever of "Full Height" and "Half Height" was last selected.
Additionally, "View Wave Form by Default" in the Display Preferences dialog can be used to control whether or not a waveform will automatically be displayed whenever a musical sequence (of an appropriate type) is opened or created.

**Scaling Up and Down**

When displaying a waveform, the Sequence Editor tries to automatically scale the graph's vertical size so that a lot of the wave is displayed. There may be occasional spots where the wave goes past the top of the display - corresponding to very loud spots in the audio - but these should be infrequent.

However, you may want to zoom in or out. To do this, click on the "Scale Up" or "Scale Down" buttons to the left of the waveform display. Note that these buttons are visible if and only if the channel buttons are visible.

If you do zoom in or out, and save the sequence, the Sequence Editor will remember your zoom settings for this particular sequence for whenever you open it in the future.

This should not be confused with the "Full Height" and "Half Height" options, which change the size of the entire display, rather than the size of the graph on the display.

**Changing the Display Type**

By default, the waveform display is centered about a line corresponding to zero volume. Loud portions of the song will extend both far above and far below the center. This is known as "full mode".

Two other modes are also supported: "fold mode" and "top mode".

"Fold mode" shows zero volume at the bottom of the display, and above it shows whichever half of full mode would be larger, as if the two halves were folded at the center and lain on top of each other. It is then stretched vertically so that the full size of the display is used.
"Top mode" is similar to fold mode, except that only those portions of the display which would have been above the center in full mode are shown.

To change between the modes, right-click on the waveform, and choose the desired mode from the popup menu.

When you choose a mode, the Sequence Editor automatically saves it, and uses it as the default mode in the future.

Changing the Colors

The colors used to display the waveform can be changed via the Wave Colors dialog, which can be opened by right-clicking on the waveform and selecting "Change Colors" from the popup menu:

Three different colors can be set: "Foreground" is the color of the wave itself; "background" is the field that it is drawn upon; "highlight" is the vertical bar showing the position of the mouse.
The colored buttons on the left can be used to set each of these three colors, and the display on the right shows how a sample waveform would look using these colors.

The Sequence Editor will remember the colors that you chose, so that other waveforms will automatically be displayed using those colors.

5.3.12 The Animator

Each sequence can have an animation associated with it. This is a simple drawing indicating how your lights will be laid out, optionally with a background picture (such as a photograph of your house). When the Sequence Editor plays a sequence, you can display its animation, and the lights drawn on it will turn on and off, fade, shimmer, and twinkle, as your real lights will.

To view the animation for a sequence, click on the "View Animation" button in the standard toolbar, or "Animation" under the View menu. Note that the animations for multiple sequences can be viewed simultaneously, and you can control whether or not each sequence's animation is displayed independently.

During play, the Animator only redraws the animation every so often, rather than every time that something changes. This is to try to ensure that it does not use too much CPU time. You can modify the time between redraws in the Display Preferences dialog, to try to strike an appropriate balance between CPU usage and smoothness of display for your individual computer.

- Sizing the Animation
- Drawing in the Animator
- Background Images
- Showing and Hiding Controls
- Playing the Sequence
Sizing the Animation

If your animation does not contain a background image, you can change the number of rows and columns in it by using the controls in the "Size" section of the Animator (if it does contain a background image, you will have chosen the number of rows and columns when choosing the image).

You can also zoom in and out on the animation. This does not affect the number of rows and columns; it only affects their displayed size.

Drawing in the Animator

To draw in the Animator, select "Draw" from the "Drawing" section, choose which channel or RGB channel you want to draw for (first choosing the track it is in if you have more than one), and simply click on spots in the animation that you want associated with that channel or RGB channel. You can also click and drag, to draw as if you were holding a pen down to paper.

Only a single channel or RGB channel can be assigned to a cell in the animation, so if you draw over a cell that had had another channel assigned to it, only the new channel will thereafter be assigned to that cell.

The drawing will be done in the color that you chose for the channel, or, in the case of an RGB channel, white (which will vary during play). To choose a color for a channel, see the Channel Settings dialog, the Channel Property Grid, or "Change Color" in the channel button's right-click
There are two ways to erase channels from a cell: First, using "Erase" from the "Drawing" section, you can erase cells in much the same way as you drew them, by clicking or clicking and dragging. Second, while "Draw" is active, you can erase by right-clicking or right-clicking and dragging.

You can also erase all cells in the sequence at once, using the "Clear All" button.

Background Images

If you wish, you can give each animation a background image. For example, using a photo of your house might make it easier to visualize how your lights will actually look when they are put on your house.

To add a background image to an animation, click on the "Select" button in the "Background Image" section of the Animator. You will be prompted to select how many rows and columns should be in the animation.

To remove an existing background image, click the "Remove" button.

The "Simulate night time" checkbox will cause the background image to appear a bit darker than it normally does, while keeping your drawing (representing your lights) at full brightness.

Showing and Hiding Controls

The various controls on the Animator, such as the "Size", "Draw", and "Background Image" sections, can be hidden by clicking on the toolbar button in the upper left corner, showing two green arrows pointing to the left. This leaves more room for the actual animation.

When the Animator has its controls hidden, two additional buttons appear on the toolbar, allowing the drawing to be resized larger or smaller.

When the controls are hidden, that button will change to show the arrows pointing to the right instead. Simply click on it again to unhide them.

Playing the Sequence

You can play a sequence (or stop play) directly from the Animator, by clicking the play and stop toolbar buttons at its top. You can also play (or stop) from outside the Animator - for example, via the Play button on the Sequence Editor's Standard toolbar.

5.3.13 The Beat Wizard

The Light-O-Rama Sequence Editor's Beat Wizard can analyze the song associated with a musical sequence to try to determine its tempo, and can insert timings and lighting effects into the sequence based upon it. These are not necessarily inserted exactly the same distance apart from each other; rather, the Beat Wizard attempts to match them up with peaks in the audio that are near the tempo. This is to allow for subtle variation in the speed of the song.

The Beat Wizard is available as an option when creating a musical sequence or a new track, and can
Not all types of media files are supported. For example, the Beat Wizard cannot be used with video files or MIDI files. If the Beat Wizard cannot be used with the media file for the sequence, it will simply be unavailable from this menu and these dialogs. Also, the Beat Wizard may not be able to be used with very large files.

- **Selecting the Time Range**
- **Selecting the Tempo**
- **Previewing**
- **What To Do with Beats**

### Selecting the Time Range

The Beat Wizard can try to determine the tempo of a song as a whole, or of just a portion of the song. Use the "Time Range" settings to tell it which to try. If you select a portion of the song, be
sure to click the "Update" button after changing the "From" or "To" times.

Choosing a portion of the song is useful if the song's tempo changes; the Beat Wizard will be more accurate if it only is asked to operate on a section with a near-constant tempo throughout. It may also be useful if the Beat Wizard has a problem with a certain portion of a song; if the beats seem off in a particular spot, you may want to try running the Beat Wizard on that spot individually.

Selecting the Tempo

The Beat Wizard shows its best guess as to the tempo of the selected portion of the song. You can choose to use that tempo, or faster or slower related tempos - for example, three times as fast, or twice as slow. Depending upon the song, one of the related tempos may seem more natural when you preview it.

Another use of related tempos is to simply insert more timings, allowing for faster lighting effects to be used that are still synchronized to the beat of the song. For example, it is unlikely that a "10x Faster" tempo will seem "more natural" in any sense, because it will probably be too quick to count along with. However, selecting it will, for example, let you set up a lighting effect with ten different channels that looks like the lights are quickly chasing each other to the beat of the music.

If a slower related tempo is chosen, you must also choose a "beat offset" to determine which beats of the "best guess" tempo will be selected: You might feel that the best guess tempo is actually twice as fast as it should be - that you would count along to it as "one - and - two - and" instead of "one - two - three - four", for example. If you therefore choose a "2x Slower" tempo, the Beat Wizard will use only every other beat from its "best guess" tempo, but it doesn't know whether to use every first beat or every second beat. So, you can let it know which to use by selecting the "beat offset".

Previewing

After you choose a tempo to use in the Beat Wizard, you can get an idea of what it will make your lights look like by using the controls in the "Preview" section. Simply click "Start" to start the preview.

The boxes to the right of the button will light up sequentially, in time with the tempo. Only the white boxes will be used; the greyed out boxes will not. However, you can choose how many white boxes there are by selecting the radio button under one of the boxes.

This allows you to make the preview section look more natural - for example, the boxes lighting up sequentially in a song that you count along with as "one, two, three, one, two, three" will look most natural if you select three boxes - doing so will make the same box light up every time you count the same number.

Clicking directly in one of the boxes will reset it so that that box lights up at that moment (and the other boxes follow sequentially from there). This is also useful for making the preview seem more natural - for example, the third box might be lighting up every time that you count "one", and if so, it might look more natural if you reset it so that the first box lights up at that time instead.

None of this has any effect on the timings or lighting effects that will be inserted into the sequence when you decide what to do with beats - it is merely to help you see how the selected tempo looks in relation to the song.

Finally, if you are unsatisfied with the selected tempo, simply choose another tempo, or choose a
different portion of the song to analyze.

What To Do with Beats

When you have selected a time range and a tempo for the Beat Wizard to use, and are satisfied with it after previewing it, you can use the controls in the "What To Do with Beats" section to insert timings, lighting effects, or both, based upon the selected tempo into the sequence.

If you choose "Turn on a channel every so many beats", you will also have to specify the channel, the number of beats, and a "beat offset". For example, to make a set of four channels chase each other in time with the beat, you could:

- Select the first channel, four beats, and a beat offset of zero;
- Click "Apply";
- Select the second channel, four beats, and a beat offset of one;
- Click "Apply";
- Select the third channel, four beats, and a beat offset of two;
- Click "Apply";
- Select the fourth channel, four beats, and a beat offset of three;
- Click "Apply and Exit".

Note that you can apply multiple effects to different channels, all in the same use of the Beat Wizard, by using "Apply" multiple times. You can even apply effects based on different portions of the song or different tempos, all without leaving the Beat Wizard.

5.3.14 The Channel Property Grid

The Sequence Editor's Channel Property Grid shows a list of the channels in a sequence, along with their properties such as their name, color, unit ID, and circuit ID. It can also be used to modify all of those properties, and it includes ways to add or delete channels (including all channels for a controller) and to print out a list of the channels and their properties:

- Selecting a Track
- The Channel List
- Print
- Add Controller
- Delete Controller
- Add Channels

RGB channels are not listed in the Channel Property Grid, but their constituent channels (i.e. the red, green and blue channels which comprise them) are.

The Channel Property Grid can be opened via "Channel Property Grid" on the Tools menu.
The Channel Property Grid

Selecting a Track

At the top of the Channel Property Grid is a dropdown box listing the tracks in the sequence. Only the channels in the selected track will be displayed at any given time. To view the channels in another track, simply choose that track in the dropdown box.

When the Channel Property Grid is opened, this defaults to the currently active track.

The Channel List

The Channel Property Grid displays each channel in the selected track on its own row, along with its various properties such as its name, color, and device type, allowing changes to be made to these properties. Note that not all properties will be available for all channels - for example, X10 controllers do not have circuit IDs, and only channels representing subsequences will allow a sequence file to be specified.

On the left of each channel's row is a red X button. Clicking this will remove that channel from the selected track. If the channel had been shared with other tracks, it will not be removed from those tracks.

Print

This button on the Channel Property Grid will print out the channel list, including the channels' properties (such as name, unit ID, and circuit ID).

Add Controller
This button on the Channel Property Grid can be used to add several channels to the selected track at once, all for a single controller. You can specify the type of controller, as well as its unit ID and its number of channels. The newly created channels will automatically have their device type, unit ID, and circuit ID set appropriately.

![Add Controller dialog](image)

Delete Controller

This button on the Channel Property Grid brings up a list of the controllers used in the selected track. Choosing one from the list will delete all of its channels from the track. If any of the channels had been shared with other tracks, it will not be removed from those other tracks.

![Delete Controller dialog](image)

Add Channels

This button on the Channel Property Grid can be used to add many channels to the selected track all at once. You will be prompted for how many channels should be added.

The newly created channels will not have any of their properties (such as device type, unit ID and
circuit ID) set. If you know in advance what these properties are to be, it would probably be easier to use "Add Controller" instead of "Add Channels".

5.3.15 The MIDI Wizard

The Light-O-Rama Sequence Editor's MIDI Wizard can be used to automatically populate a musical sequence that is based on a MIDI file with timings and lighting effects based on the MIDI file itself. For example, lights can be set up to chase each other in time to the music, or to turn on and off when certain notes are played.

The MIDI Wizard is available (for musical sequences based on MIDI files) as an option when creating a new musical sequence or a new track, and can later be accessed via "MIDI Wizard" on the Tools menu.

The MIDI Wizard has three main screens, each on a different tab:

The Effects Summary tab can be used to visualize the song while it is playing - for example, to see which instruments are playing what notes at what time, and to show the overall beat of the song. It can also be used to listen to only certain instruments in the song, by muting others. This tab cannot be used to insert timings or lighting effects into a sequence - instead, it is used to get an idea of how the other tabs might be used for the song.

The Various Effects tab can record timings and lighting effects based upon the beat of the song. The lights can be made to behave in a variety of ways, such as chasing each other or rotating around a tree, in various patterns.

The Individual Notes tab can be used to record timings and lighting effects based upon the notes played by individual instruments in the song. For example, a channel can be set up to turn on whenever a tenor saxophone plays a C note.

For more detailed help, please consult the help file pages for the individual tabs:

- The Effects Summary tab
- The Various Effects tab
- The Individual Notes tab
The Effects Summary tab can be used to get an overall idea of a MIDI song. It displays, for example, which instrument is playing what note when, and the beat of the song. It can also mute instruments, so that you can listen more specifically to certain other instruments.

The Effects Summary tab cannot be used to insert timings or lighting effects into the sequence. To do that, use the other tabs of the MIDI Wizard - the Various Effects tab and the Individual Notes tab.

To use the Effects Summary tab, simply hit "Play". The song will begin playing, and the controls on the tab will start lighting up to represent what's happening in the song. The boxes in the "Various Effects" section will light up to represent the beat of the song; the "General Instruments" section will show which instruments are playing which notes when; the "Percussion Instruments" section will show which percussion instruments are playing at what times.

You can choose to mute certain instruments, by selecting the "Mute" radio button next to each, so as to listen more closely to other instruments.

You can also superimpose clicking beat sounds over the song, to more clearly hear where the beat is falling, by checking the "Beat Sound" checkbox in the "Beat Adjuster" section.
5.3.15.2 The Various Effects Tab

The MIDI Wizard's Various Effects tab can be used to populate a sequence with timings and lighting effects based upon the beat of a MIDI file's song. For example, lights can be made to chase each other, in a variety of patterns, to the beat of the song.
There are three main types of effect patterns that can be made here:

- Canned Chase Sequences
- Custom Chase Sequences
- Rotating Tree Effect

There are two ways to use the tab - while recording effects and while not recording effects. By default, hitting “Play” will play the song, and let you choose patterns for the lights, but no effects will be recorded to be inserted into the sequence. This allows you to adjust the patterns to your liking before actually recording effects.

Adjustments can also be made while recording, but the main type of effect must be chosen before recording begins.

To play without recording, simply hit the “Play” button.

To record, first select the type of behavior you want to record (such as a canned chase sequence or a rotating tree effect). Choose the specific details of the behavior as well (for example, if you choose a canned chase sequence, also choose how many channels to use and how many of them should be on at any given time).

Next, select which channels from the sequence the effects will be recorded into, using the “Channel Selection” section (which is on the right). Each type of effect has a different number of channels required; you will not be allowed to record effects until the full number of required channels has been
assigned. You can select a channel from the dropdown list, and add it to the selected channels by pressing "Add One", or you can add several channels at once (starting with the selected channel) by pressing "Add a Group". At the bottom of the "Channel Selection" section are buttons enabling you to remove a channel from the selected channel list, or to clear the entire list.

Next, click the "Record" button. If you have not assigned the required number of channels, you will be told that you cannot record until you do so. If, however, you have, the "RECORDING" label (near the top) will turn red, and you can then hit "Play" to actually play the sequence and record effects.

During recording, you can make adjustments to the pattern, such as doubling its speed or reversing its direction, using the controls in the "Adjustments" section. These adjustments are done in real time, so, for example, you can record some of the pattern at normal speed, and then a minute into the song, switch the pattern to double speed; the events recorded in the first minute will still be at normal speed.

After play ends (either at the natural end of the song or by hitting "Stop"), hit "Record" again (at which point the red "RECORDING" label will turn off), and "Save" to save the recorded effects to the sequence. Or, if you were not satisfied with the recorded events, you can hit "Clear" to get rid of them.

Canned Chase Sequences

The Canned Chase Sequences section of the MIDI Wizard's Various Effects tab can be used to set up several channels of lights to chase each other - e.g. one turning on, then the next turning on while the first turns off, then another turning on while the second turns off, and so on.

Using the dropdown box in this section, you can choose how many channels will be involved in the chase, and how many of them will be on at any given time.

You can adjust the behavior of the chase - for example reversing its direction or speeding it up - using the controls in the Adjustments section. This can be done both before and during play, and before and during recording.

For more control over the behavior of a chase sequence - for example, to use more channels, or to use a different pattern for which channels are on at any given time - use Custom Chase Sequences instead.

Custom Chase Sequences

The Custom Chase Sequences section of the MIDI Wizard's Various Effects tab can be used to set up several channels of lights to chase each other - e.g. one turning on, then the next turning on while the first turns off, then another turning on while the second turns off, and so on. This is similar to the Canned Chase Sequences section, except that it is more flexible whereas the Canned Chase Sequences section is simpler to use.

In this section, you can select the number of channels involved in the chase, and, in the "Pattern Selector" section, choose how many channels will be on at any given time, and how far apart channels that are simultaneously on will be from each other.

You can adjust the behavior of the chase - for example reversing its direction or speeding it up - using the controls in the Adjustments section. This can be done both before and during play, and before and during recording.

Rotating Tree Effect
The Canned Chase Sequences section of the MIDI Wizard's Various Effects tab can be used to set up several channels of lights set up as vertical sections of a tree to rotate around the tree.

You can select how many channels to use, and then use the "Pattern Selector" section to define how many of them will be on at any given time, and how far apart simultaneously on channels will be.

The "Opposite Sides Connected" checkbox can be used to see how the lights will look if each single channel of lights is actually draped over the tree from one side to the opposite side, rather than each running down only one side of the tree.

You can adjust the behavior of the chase - for example reversing its direction or speeding it up - using the controls in the Adjustments section. This can be done both before and during play, and before and during recording.

Adjustments

The Adjustments section of the MIDI Wizard's Various Effects tab can be used to adjust the behavior of the selected effects pattern in various ways. This can be done both before and during play, and before and during recording.

Checking the "Double Speed" checkbox will cause the pattern to start going twice as fast as the beat of the song; unchecking it will bring the pattern back to its normal speed.

"Reverse" will make the pattern go in the opposite direction.

"Back & Forth" will cause the pattern to periodically reverse directions. Exactly how often it does so can be set using the "Back & Forth Counts" section.

5.3.15.3 The Individual Notes Tab

The MIDI Wizard's Individual Notes tab can be used to populate a sequence with timings and lighting effects based upon the notes that are played in a MIDI file's song. For example, lights can be made to flash whenever a trombone plays a G note.
There are two ways to use the tab - while recording effects and while not recording effects. By default, hitting "Play" will play the song, and let you choose patterns for the lights, but no effects will be recorded to be inserted into the sequence. This allows you to adjust the patterns to your liking before actually recording effects.

To play without recording, simply hit the "Play" button.

To record, first select the instrument that you wish to record. The notes that that instrument uses in this song will be displayed as black boxes in the "Notes To Record" section, with white X marks in them.

Next, select the number of channels that you wish to use for the recording. If you choose a number less than the full number of notes that the instrument uses in the song, some of the white X marks will go away; the same number will be left as the number of channels that you selected. Those white X marks indicate the notes that will actually be recorded - one note per channel. They are decided based upon how often each note is played by the instrument in the song; the most frequently used notes will be recorded.

Next, a couple of options can be selected, if you wish:

- Selecting "Minimum On Centiseconds" will force any channel that turns on to stay on for at least the specified duration. This prevents very fast notes from causing your lights to blink very quickly.

- "Map Unselected Notes by Octave" can be used to record notes of the same pitch class into a single channel. For example, if an instrument uses two or more different F-sharp notes (in different octaves)
during the song, and you have not specified enough channels to record them individually, then if a F-sharp that is not directly mapped to a channel is played, but another F-sharp is mapped to some channel, then that note will be recorded into the channel assigned to the closest F-sharp having a channel.

Next, select which channels from the sequence the notes will be recorded into, using the "Channel Selection" section (which is on the right). You will not be allowed to record effects until the full number of required channels (which you chose in the previous step) has been assigned. You can select a channel from the dropdown list, and add it to the selected channels by pressing "Add One", or you can add several channels at once (starting with the selected channel) by pressing "Add a Group". At the bottom of the "Channel Selection" section are buttons enabling you to remove a channel from the selected channel list, or to clear the entire list.

Next, click the "Record" button. If you have not assigned the required number of channels, you will be told that you cannot record until you do so. If, however, you have, the "RECORDING" label (near the top) will turn red, and you can then hit "Play" to actually play the sequence and record effects.

After play ends (either at the natural end of the song or by hitting "Stop"), hit "Record" again (at which point the red "RECORDING" label will turn off), and "Save" to save the recorded effects to the sequence. Or, if you were not satisfied with the recorded events, you can hit "Clear" to get rid of them.

5.3.16 The Tapper Wizard

The Light-O-Rama Sequence Editor’s Tapper Wizard is a tool that lets you populate a musical sequence with timings and lighting effects simply by tapping along with the song, on your keyboard or your mouse. The Tapper Wizard will remember the moments in the song that you tapped at, and will insert timings and effects into the sequence at those times.

The Tapper Wizard is available as an option when creating a new musical sequence or a new track, and can later be accessed via "Tapper Wizard" on the Tools menu.

The Tapper Wizard has the following sections and controls:

- Play Options
- What to Do with Taps
- Input Options
- Start and Stop
- Play Back
- Tap
- Apply
- Undo and Redo
- Apply and Exit
- Exit
The Tapper Wizard

Play Options

This section of the Tapper Wizard lets you control how the song will be played while you are tapping. You can select to play the entire song, or just a certain time range of the song; you can also choose the speed at which the song will be played - half speed, normal speed, or double speed.

When the Tapper Wizard is opened, the time range to be played will default to the freeform play range of the active track, if one exists. If not, it will default to the normally selected play range (such as play full sequence, play visible screen, et cetera).

What to Do with Taps

This section lets you tell the Tapper Wizard what you want it to do with your taps. You can choose the track and the timing grid to apply the taps to (or create a new timing grid to use), and then choose to insert timings into the timing grid, or to insert lighting effects into a channel of the track, or both.

If you choose to insert lighting effects into a channel, you can either have the channel briefly turn on for each tap, or you can choose to have it toggle on with one tap, off with the next, on with the third, and so forth. If you choose to have it turn briefly on for each tap, you can additionally choose to have it fade off after the tap (otherwise it will simply turn off).

You also have the option to "snap to existing events". If you select this option, and you tap at a point in time that is near an existing timing (with "near" meaning within the number of hundredths of a second that you specify here), instead of using the exact time that you tapped, the Tapper Wizard uses the time of that timing. This makes it easier to cleanly use the Tapper Wizard multiple times.
on the same sequence (for different channels), without introducing minor timing errors based upon your reaction time.

After you have done your tapping, and used this section to tell the Tapper Wizard what to do with your taps, click "Apply", or "Apply and Exit" to apply them to the sequence. If you clicked "Apply" rather than "Apply and Exit", then the Tapper Wizard will remain open. At this point, you could change your settings in this section to apply your existing taps in a different way (such as to a different channel, or with different types of effects), or you could tap again (by hitting "Start" again) to collect new taps. You could also undo and redo any changes that the Tapper Wizard made to your sequence.

Input Options

This section of the Tapper Wizard allows you to control how you will tap.

You can use the mouse, or the keyboard, or both.

If you use the mouse, you have two options: pushing the mouse button down and then letting it up count as two separate taps, or as a single tap. To use the mouse, you must click on the Tap button.

If you use the keyboard, you can tap with practically any key, or even multiple keys.

You can also choose whether to use a countdown or not; if you do, then when you start the song (by clicking Start), a countdown will be displayed before the song begins, rather than starting immediately. This may give you time to get ready after clicking "Start".

Start and Stop

Use these buttons to start playing the song (or to start the countdown before play), and to stop the song. When the song begins, the Tap button will become enabled. When the song ends, you do not have to use the Stop button; the Stop button is for stopping the song in the middle, for example if you are unhappy with the taps that you made.

After the song ends (or after you hit Stop), you can click Start again in order to redo your taps. This will wipe out any previously recorded taps. You will be warned that they will be wiped out, and will be given an option to cancel.

You can also redo your taps after having applied them to the sequence. This lets you use different sets of taps for different purposes, all without closing the Tapper Wizard.

Tap

While a song is playing, the Tap button is enabled. Every time that you tap (whether by mouse or by keyboard), it will provide feedback by briefly flashing.

Play Back

After you have recorded taps, you can click "Play Back" to play the song over again. The Tap button will flash at the points in time that you tapped. You can use this to double check that you are satisfied with your taps before entering them into the sequence (by clicking the Apply button); if
you are not satisfied with them, you can wipe them out and try again by hitting the Start button again.

Apply

After you have tapped, and have told the Tapper Wizard what to do with the taps, click the Apply button to apply those taps to your sequence.

Note that you can then change the settings in the "What To Do with Taps" section, and click Apply again; this will apply the new settings, using the same taps, to the sequence.

Or, you could click Start again, to collect new taps. Your old taps will be deleted when you do this, but any timings or effects that you inserted into the sequence based on them will remain. In this way, you can use different sets of taps to do different things, all without closing the Tapper Wizard.

Undo and Redo

After applying your taps to the sequence, you can use these buttons to undo and redo any such applications, without exiting from the Tapper Wizard.

Apply and Exit

Clicking the Tapper Wizard's Apply and Exit button will apply your taps to the sequence, in the manner that you specify in the "What To Do with Taps" section, and then exit from the Tapper Wizard.

If you want to apply your taps without exiting the Tapper Wizard, so that you can apply them again using new settings, or so that you can collect different taps, use the Apply button instead.

Exit

This button simply exits from the Tapper Wizard, without applying your taps to the sequence. Note, though, that if you have already applied your taps (using the Apply button), they will remain in your sequence; using this button (instead of Apply and Exit) will prevent your taps from being applied again.

For example, if you apply your taps, then change the settings in the What To Do with Taps section, and then click Exit, your applied taps, based on your original settings, will remain in the sequence, but your taps will not be reapplied based on the changed settings.

5.3.17 The VU Wizard

The Light-O-Rama Sequence Editor's VU Wizard can analyze the song associated with a musical sequence to try to find peaks in the audio - much like a VU meter - and can insert timings and lighting effects into the sequence based upon them.

The VU Wizard is available as an option when creating a musical sequence or a new track, and can later be accessed via "VU Wizard" on the Tools menu.

Not all types of media files are supported. For example, the VU Wizard cannot be used with video files or MIDI files. If the VU Wizard cannot be used with the media file for the sequence, it will simply be unavailable from this menu and these dialogs.
Selecting a Time Range

You can choose to let the VU Wizard look for audio peaks throughout the entire song, or limit it to a specific portion of the song. If you choose to use only a portion of the song, be sure to hit the "Update" button after setting the "From" and "To" times.
Attack and Decay Settings

These two values determine how quickly the VU Wizard will react to changes in the audio volume. "Attack" is how quickly it reacts to increased volume, and "Decay" is how quickly it reacts to decreased volume. The higher the number, the more slowly it reacts to changes.

You can enter specific numbers (make sure to hit "Update" if you do), or you can use one of the "Preset" buttons to simulate common types of audio meters:

- "VU Meter" simulates a standard VU meter, as often found on home stereo systems.
- A "Peak Program Meter" reacts very quickly to increased volume, but very slowly to decreased volume. This causes peaks to last longer.
- A "Peak Meter" reacts instantaneously to changes in volume.

Peak Threshold

Using the Peak Threshold section, you can tell the VU Wizard to look for audio peaks on either the left stereo channel or the right stereo channel, or on the sum of the two.

The selected stereo channel (or channels) has a thick black bar in its row. This bar represents the threshold for what will be considered a peak. Above the bar is a peak; below the bar is not. The bar can be slid left and right to increase and decrease the threshold.

When you play the song (using the "Preview" section), the rows will pulse along with the audio volume, showing blue starting at the left and continuing rightwards based upon how loud the audio is at any given point in time. When the selected stereo channel (or channels) is above the threshold, it will turn red instead of blue.

Note that this is strongly affected by the attack and decay settings - lower values will cause the pulsing to react more slowly to the music, and higher values more quickly. Try playing with the various "Preset" buttons to see this.

Preview

Clicking the Start button in the VU Wizard's Preview section plays the song, and pulses the rows in the Peak Threshold section along with the audio. It also flashes the box in the Preview section whenever the pulse is above the selected threshold.

You can change both threshold settings and the attack and decay settings during preview, and the VU Wizard will react instantly to such changes. However, only the final settings will be used when you apply the peaks to the sequence (using the "What To Do with Peaks" section).

What To Do with Peaks

Once you are satisfied with the peaks found using your chosen attack and decay settings and peak threshold settings, you can apply the peaks to the sequence using the "What To Do with Peaks" section of the VU Wizard. You can insert a timing every time the threshold is crossed (no matter whether from below or from above), or turn a selected channel on whenever above the threshold, and off whenever below, or both.

You can reuse the VU Wizard for multiple channels (and multiple settings) without closing it by
5.3.18 Freeform Play Mode

In addition to the various play ranges available on the play menu, the Sequence Editor also supports another way of playing a sequence, using the space bar on the keyboard.

When the space bar is pressed, the current sequence will start playing, starting at the start of the current selection and ending at the end of the sequence (this is equivalent to "From Selection" play mode). Pressing space again will stop play, and the selection will be changed to the spot where play stopped. So pressing it a third time will start the sequence again, approximately where you had stopped it. This can be used to effectively pause and unpause play.

However, the space bar may have a different meaning, allowing play in another way:

During play, pressing the keyboard's down arrow will mark the current time as the start of a "freeform play range". Later pressing the up arrow will mark the current time as the end of the freeform play range. The freeform play range is displayed with a slightly darker grey background color for its cells:

![Image of a sequence with a freeform play range starting at about 37 seconds]

A sequence with a freeform play range starting at about 37 seconds

If the space bar is used to start play while a freeform play range has been selected, then instead of playing in "From Selection" mode (as described above), it will play from the start of the freeform play range to the end of it.

Using "shift-space" instead of "space" to start play will first get rid of any freeform play range that may be selected. The freeform play range can also be removed (without starting play) by selecting "Clear Freeform Play Range" from the right-click context menu.

The freeform play range can also be selected (while not playing) by clicking and dragging the mouse on the time scale, or cleared by clicking (and not dragging).

Note that using the space bar to play does not affect the currently selected play mode from the play menu, so playing in any other way (such as using the Play button on the Standard toolbar) will still use...
the last-selected play mode.

## 5.4 Show Editor

The Light-O-Rama Show Editor is used to create shows. Shows are groups of sequences to be played as a group. They can be scheduled to play at certain times using the Schedule Editor, and will then be played using the Show Player.

To start the Show Editor, you can run it from your computer's Start Menu by selecting "All Programs" -> "Light-O-Rama" -> "Light-O-Rama Show Editor". Alternatively, if the Light-O-Rama Control Panel is already running, you can right-click its icon in your computer's system tray, and select "Show Editor" from the popup menu that will open.

Shows consist of several sections. Each section serves a different purpose - for example, the "startup section" is a list of sequences that will be played when the show begins, while the "animation section" is a list of animation sequences that will be played throughout most of the show's duration (after startup and before shutdown). All sections are optional.

For details on each of the sections, please refer to the following:

- The Background Section
- The Startup Section
- The Animation Section
- The Musical Section
- The Interactive Section
- The Shutdown Section

The Show Editor consists of six main tabs, and a toolbar at their top. Each of the tabs is associated with one of the six sections of the show (such as "background" and "animation"), while the toolbar has buttons to create, open, and save shows.

To add a sequence to a section, click on that section's tab, and then on the large "+" button. This will prompt you for the name of the sequence that you want to add. Similarly, to remove one, select the sequence from the section's list by clicking on its name, and then click the large "-" button.

A sequence can be moved up or down in a section's list by clicking on its name and then on the large up arrow or down arrow buttons. This generally affects the order that the sequences will be played in, but not always: For example, in the musical section, you can select that the sequences will be played in the order listed, or in a random shuffle; if you choose the latter, it doesn't matter what order they are listed in. Similarly, in the animation section, you can select that the sequences be played simultaneously (as opposed to sequentially); if you do, their listed order does not matter.
5.5 Schedule Editor

The Light-O-Rama Schedule Editor is used to schedule shows to be played at certain times. Shows are created using the Light-O-Rama Show Editor, and consist of sequences, which are created using the Light-O-Rama Sequence Editor. Scheduled shows are then played by the Light-O-Rama Show Player.

To start the Schedule Editor, you can run it from your computer's Start Menu by selecting "All Programs" -> "Light-O-Rama" -> "Light-O-Rama Schedule Editor". Alternatively, if the Light-O-Rama Control Panel is already running, you can right-click its icon in your computer's system tray, and select "Schedule Editor" from the popup menu that will open.

For an overview of schedules, please refer to:

- Schedules
  - The Weekly Schedule
  - The Calendar Schedule

For help on the Schedule Editor, please refer to:

- Opening, Saving, and Reverting
- Switching between the Weekly and Calendar Schedules
• Adding a Show to the Weekly Schedule
• Adding a Show to the Calendar Schedule
• Editing a Scheduled Show
• Deleting a Scheduled Show

Opening, Saving, and Reverting

Light-O-Rama maintains just a single schedule (with two parts - the weekly schedule and the calendar schedule), so when the Schedule Editor starts, it automatically opens and displays the current schedule. Once you start editing it, however, the displayed schedule may differ from the saved schedule. So, after you have edited the schedule and are satisfied with the changes you
made, click the toolbar's Save button to save your changes.

On the other hand, if you wish to discard your changes without saving them, click the toolbar's Revert button instead. Only the changes made since the last time that you saved will be discarded.

In order for the changes that you have made to the schedule to take effect, you must first save the schedule.

Switching between the Weekly and Calendar Schedules

The schedule consists of two parts - the weekly schedule and the calendar schedule. The Schedule Editor only displays one of these two at a time, although both are always in effect.

When the Schedule Editor starts, it displays the weekly schedule. You can switch to the calendar schedule by pressing the toolbar's Calendar button, and you can switch back to the weekly schedule by pressing its Week button.

Adding a Show to the Weekly Schedule

With the weekly schedule displayed, there are two ways to add a show to it:

- Click the toolbar's Add button.
- Click on an unscheduled area of the schedule and select "Add" from the popup menu.

Adding a new show to the weekly schedule

In either case, the Add Show dialog will open:
Opening the Add Show dialog by clicking on an unscheduled area, rather than by using the Add button, has a couple advantages: First, it will automatically be populated with a start time and an end time based on where you had clicked. In the above example, the click was made at approximately 6:30 AM, and so the start and end times were automatically set to 6:00 AM and 7:00 AM.

Second, it automatically takes into account conflicts between the new show and any existing shows. For example, if there were already a show scheduled starting at 6:45, the end time of the new show would have automatically been set to 6:45 rather than 7:00. Similarly, if a show had already been scheduled at this time on Sunday, the "Sun" checkbox for the new show would have automatically been unchecked.

To add a new show using this dialog, first select the name of the show file; it is easiest to do this using the "..." button next to the File box, which will open up a dialog allowing you to choose among the existing show files.

Next, choose the start and end time for the show, and then select the day or days of the week that you wish this show to run.

Close the dialog by pressing "Add" (or "Cancel" if you no longer wish to add the new show), and save your changes by pressing the toolbar's "Save" button (or "Revert" if you wish to get rid of your changes).

Adding a Show to the Calendar Schedule

With the calendar schedule displayed, there are two ways to add a new show. In either case, first select the day that you want to schedule the show for (by clicking that day in the calendar), and then either:

- Click the toolbar's Add button, or
- Click on an unscheduled area of the schedule and select "Add" from the popup menu.
Adding a show to the calendar schedule for March 15, 2008

In either case, the Add Show dialog will open:

Opening the Add Show dialog by clicking on an unscheduled area, rather than by using the Add button, has a couple advantages: First, it will automatically be populated with a start time and an end time based on where you had clicked. In the above example, the right-click was made at approximately 3:30 PM, and so the start and end times were automatically set to 3:00 PM and 4:00 PM.

Second, it automatically takes into account conflicts between the new show and any existing shows. For example, if a show had already been scheduled to start at 3:45 PM, the end time in the
above dialog would have automatically been set to 3:45 rather than 4:00. Note that this conflict checking is only done for other shows in the calendar schedule, not for shows in the weekly schedule; this is because the purpose of the calendar schedule is to easily override the weekly schedule for specific dates and times.

To add a new show using this dialog, simply select the show's filename (this is easiest using the "..." button, which will let you choose from the list of existing shows), select the start and end times, and "Add" (or "Cancel" if you wish to discard the new show).

Finally, remember to save your changes using the toolbar's "Save" button (or, if you wish to discard your changes, "Revert" instead).

Editing a Scheduled Show

No matter whether the weekly schedule or the calendar schedule is currently displayed, you can edit a scheduled show by clicking on that show in the schedule, and selecting "Edit" from the popup menu:

Editing an existing show

This will open a dialog very similar to the one you originally used to add the show. It will allow you to modify the name of the show file to be used, the start and end time, and, in the weekly schedule, the days of the week that the show will run on.

Finally, remember to save your changes using the toolbar's "Save" button (or, if you wish to discard your changes, "Revert" instead).

You cannot edit the contents of a show - such as the sequences it uses - from the Schedule Editor. In order to do that, you need to use the Show Editor.

Deleting a Scheduled Show

No matter whether the weekly schedule or the calendar schedule is currently displayed, you can delete a scheduled show by clicking on that show in the schedule, and selecting "Delete" from the popup menu:

Deleting an existing show
Note that this does not actually delete the show - it only deletes it from the schedule. The show will still be available for editing with the Show Editor, or for scheduling at some other time.

Finally, remember to save your changes using the toolbar's "Save" button (or, if you wish to discard your changes, "Revert" instead).

5.6 Simple Show Builder

The Light-O-Rama Simple Show Builder is an alternative to the Show Editor and the Schedule Editor, allowing you to create shows and to schedule them to be played at certain times. While the Simple Show Builder is easier to use, the Show Editor and the Schedule Editor are more flexible and powerful.

The Simple Show Builder progresses, step by step, through a few screens:

First, a "Welcome" screen is displayed, giving some brief instructions on what you will need to have ready in order to use the Simple Show Builder.

Next, you are given a choice of what type of device type you want to use for your show.

Then, you can select the sequences that you want to use for the show.

Next, you can pick the time or times that the show should run at.

If you chose to use an MP3 device, you will then be asked to insert your SD card into your SD card reader/writer, and to tell the Simple Show Builder when you have done so. Your show will then be downloaded to your SD card.

Otherwise, you will be presented with a final screen, showing some directions on how to enable the Show Player to run the show that you have just scheduled.

Welcome

The first screen in the Simple Show Builder shows a list of things that it would help to have ready before you use it. After you have these things ready, simply click "Next".
Choose the Device Type

The next screen in the Simple Show Builder allows you to select the type of device that you want to control your show. You can run it from your PC (using the Light-O-Rama Show Player), or any of a few types of Light-O-Rama MP3 devices. Choose the device you wish to use, and click "Next".
Select the device type that will control your show

Select Sequences

The Simple Show Builder will next ask you which sequences you wish to use in the show. On the left is a list of your existing musical sequences (either those with 16 channels, those with 32 channels, or all of your musical sequences, based on your choice of the radio buttons at the bottom).

Add a sequence to the show by highlighting it and then clicking the "Add" button; this will move the show from the left pane to the right pane, which is the list of sequences in your show. Similarly, remove one from your show by highlighting it and clicking "Remove".

The sequences will be played in the order that you list them, but you can change the order simply by clicking on the "Up" or "Down" arrow (on the right-hand side).

When you are satisfied with the sequences in your show and their order, continue by pressing the "Next" button.

Note that only musical sequences can be scheduled using the Simple Show Builder. If you wish your show to have animation sequences, you must instead use the Show Editor and the Schedule Editor.
Choose the Times

The **Simple Show Builder** will then ask you to select the times at which you want your **show** to run. You can have different times for up to two different sets of days of the week. You can select any days you want to be in either set, but typically this is used to have your show played during different times on weekdays and weekends. Note that "weekends" here might mean "Friday and Saturday", rather than "Saturday and Sunday", since your show will probably be playing while it's dark out, and so "weekend" is really "the night before a weekend day". In fact, this is how the Simple Show Builder operates by default, but again, you can change this however you want.

After selecting the days of the week, select the start and end times for each.

Next, choose whether you want the show to run continuously, or once every hour or every half hour. If you select "continuously", then after all of its **sequences** have been played, the show will automatically start over with the first sequence; this will continue until the end time is reached. If, instead, you select "once every hour" or "once every half hour", the show will stop after its last sequence, and start again once every hour (or half hour), until its end time is reached.

When you are satisfied with the scheduled times, click "Next".
Select the times that you want the show to run at

Download to the SD Card

If you had asked the Simple Show Builder to control your show via a Light-O-Rama MP3 device, rather than via the Show Player on your computer, you will then be prompted to insert your SD card in your SD reader/writer. When you have done so, click the large “CLICK HERE to write the SD card” button, and wait for confirmation that your show has been written to the SD card.

The Simple Show Builder is then complete; simply move your SD card to the Light-O-Rama MP3 device, and the sequences that you selected will play at the times that you selected.
Finished

If you had asked the Simple Show Builder to control your show via the Show Player on your computer, rather than via a Light-O-Rama MP3 device, you will be presented with a final screen giving directions on how to enable the Show Player. After you have read and understood them, simply click "Finish", and your show will be scheduled.
5.7 Show Player

The Light-O-Rama Show Player is a program that runs behind the scenes, monitoring your schedule to see if a show should be playing at the current time, and if so, playing it.

To make sure that the Show Player is running, and therefore that your scheduled shows will be played, you first must ensure that the Light-O-Rama Control Panel is running. Next, right-click on the Light-O-Rama Control Panel's icon in your computer's system tray, and select "Enable Schedule" from the popup menu. If "Enable Shows" is greyed out, that means that it is already selected.
If the Light-O-Rama Control Panel is not running, or if “Disable Shows” is greyed out, your scheduled shows will not be played.

Note that only one source can control your lights at any time - either the Show Player, the Sequence Editor, or the Hardware Utility. So, if you try to enable the Show Player with one of the others running, you may be shown a message saying that you need to shut down the others before “Enable Shows” will work.

5.8 Hardware Utility

The Light-O-Rama Hardware Utility is used to manage the hardware that you use to control your lights. This includes several types of controllers as well as other devices such as Light-O-Rama MP3 Directors and Light-O-Rama wireless devices.

Each of these types has a different tab in the Hardware Utility. When you start the Hardware Utility, the tab for Light-O-Rama controllers is displayed; to access one of the others, simply click its tab.

For details on each, please refer to the following sections:

- Light-O-Rama Controllers
  - Selecting a Comm Port
  - Setting Unit IDs
  - Configuring Units
  - Testing Units
  - Downloading Sequences
  - Firmware Update
- Light-O-Rama MP3 Directors
- Light-O-Rama Wireless Devices
- Digital IO Boards
- X10 Controllers
- Test Console
To run the Hardware Utility, select it from your computer's Start menu (Start / Light-O-Rama / Hardware Utility) or, if the Light-O-Rama Control Panel is currently running, right-click on its icon in your computer's system tray and select "Hardware Utility" from the popup menu.

![The Hardware Utility's tab for Light-O-Rama controllers](image)

### 5.8.1 Light-O-Rama Controllers

The Light-O-Rama Hardware Utility can be used to configure and test Light-O-Rama controllers in several ways:

- Selecting a Comm Port
- Setting Unit IDs
- Configuring Units
- Testing Units
- Downloading Sequences
- Firmware Updates

To use these, select the Hardware Utility's tab labeled "LOR Control" (it is already selected by default when the Hardware Utility is started).
5.8.1.1 Selecting a Comm Port

The "Setup Comm Port" section of the LOR Control tab of the Light-O-Rama Hardware Utility is used to set which RS-232 comm port the Hardware Utility will use for Light-O-Rama controllers.

While the Sequence Editor and Show Player can use up to four different comm ports simultaneously for Light-O-Rama controllers, the Hardware Utility only uses one at a time. By default, it will be set to use the port you have configured to be your "Regular" port (if you have done so); see "Network Preferences" in the Sequence Editor for details on how to set your Light-O-Rama ports.

Only comm ports 1 through 16 are supported in the Hardware Utility.

If you know the comm port that it should be using, you can simply select it from the "Manual Select" dropdown box. If you select a port other than your "Regular" port, the Hardware Utility will offer to automatically change your "Regular" port to be the one that you selected.

If you do not know the comm port to be used, you can ask the Hardware Utility can automatically detect it:

- Connect a Light-O-Rama controller to your PC, for example using an SC485 connector or a USB-RS485 adapter.
• Connect the controller to AC power, and turn it on.
• Click on the "Auto Configure" button.

The Hardware Utility should then automatically detect the comm port that you have hooked the controller up to. If it does not:

• Check the physical connection (such as cables and the SC485 connector).
• Check that the controller's power is on.
• Ensure that switches or jumpers on the controller are correct.
• Ensure that the correct type of cable is used.
• Retry the "Auto Configure" button.

If all of the above fails to find the port, then watch the controller's blinking LED light while manually selecting different comm ports from the list. Once a comm port is selected, wait about five seconds. If the LED stops blinking, then that is the correct port. If it does not stop blinking, try the next comm port in the list.

If this still does not determine the correct comm port, there may be a problem with the connector or the controller.

If "Auto Configure" does not work, but you were able to determine the comm port by manual selection, there may be a problem with the connector. Or, if your computer is an older PC or laptop, there may be a compatibility issue with the computer's communications drivers.

In any case, if you can get the unit's LED to stop blinking, then that controller will most likely work on your PC.

5.8.1.2 Setting Unit IDs

Each Light-O-Rama controller must have a unique assigned unit ID, identifying this particular controller. The reason for this is that every Light-O-Rama controller in a network can see every lighting command message that is sent over the network, not only the lighting commands sent for that controller. So, all of the commands contain a unit ID, and a controller only acts upon a command if the unit ID of the controller matches the unit ID of the message.

A unit ID is a two-character field. Each character can have any of the values 0, 1, 2, 3, 4, 5, 6, 7, 8, 9, A, B, C, D, E, and F. For example, a unit ID might be "03", "07", "25", "37", "6B", "C8", or "DA". However, certain values are reserved, and so not allowed (specifically, "00", and "F1" through "FF").

Some Light-O-Rama controllers have selector switches that allow you to directly set their unit IDs. In that case, simply use a small screwdriver (making sure that the unit is not attached to power) to dial the switches to the desired unit ID.

Other controllers do not have selector switches. To set the unit IDs of these controllers, you can use the LOR Control tab of the Light-O-Rama Hardware Utility:
Connect the Unit to the Computer

The first step in setting a Light-O-Rama controller's unit ID using the Hardware Utility is to connect the unit to the computer, for example using an SC485 adaptor or a USB-RS485 adaptor. Make sure that the selector switches are correctly set for the type of cable used (units are shipped ready to use data cables). Plug the unit into an AC outlet, and turn the unit on.

Select the Comm Port

After you have connected the unit to the computer, select the comm port that the Hardware Utility should use to communicate with the controller.

Set the ID of a New Unit

If this is a new unit that has not previously been assigned a unit ID, use the "Set New Unit ID" section of the LOR Control tab of the Hardware Utility. Simply select the unit ID you want to assign, and click the "Set Unit ID" button.

Change the ID of an Existing Unit

If you have previously assigned a unit ID to this unit, but want to change it, use the "Change Existing ID" section of the LOR Control tab of the Hardware Utility. Select the unit's current ID in the "Old Unit ID" list, and the unit ID that you want to change it to in the "New Unit ID" list. Finally, click the "Set Unit ID" button.

If you do not remember the unit's current unit ID, or if the controller doesn't seem to be reacting to its current ID, you can change it to a new unit ID by selecting "Any Unit" in the "Old Unit ID" list. However, **be very careful**. If you select "Any Unit", then all units that are connected to the PC will have their unit IDs changed. So, make sure that you have only the one controller (whose unit ID you wish to change) connected.
Troubleshooting

If, while setting a Light-O-Rama controller's unit ID, you receive an error saying that the unit cannot be located, the first thing to do is to check all connections and to make sure that the correct comm port is selected. If the Hardware Utility still cannot locate the unit, check the Communication LED on the unit. When the unit is disconnected from the data cable the LED should blink; when it is connected and the Hardware Utility is running with the correct comm port selected, the LED should stop blinking, turning on steady.

If the Communications LED continues to blink regardless of the steps taken, then there may be a problem with the cable, the adaptor, the controller, or the PC's comm port.

If the LED stops blinking but you still get an error when attempting to set the unit ID, then there may be a problem with the adaptor or the controller, or the PC may have a communications driver that is not completely compatible with Light-O-Rama. However, you may still be able to set the unit ID by checking the "Ignore Errors" box and then trying to set the unit ID again. If you do check the "Ignore Errors" box, make sure that the unit ID has been set correctly by running some tests on the controller.

5.8.1.3 Configuring Units

Some Light-O-Rama controllers, such as the MC-Px and CTBxxD units, have special options that can be configured. You can use the LOR Control tab of the Hardware Utility to do so, using the following steps:

- Connect The Unit to the PC
- Select the Comm Port
- Select the Unit
- Choose "Configuration"
- Set the Minimum and Maximum Intensities
- Set the Input Channel Types
- Set the Port Type
- Configuring DIO32 Servos
- Configuring Cosmic Color Ribbons
- Update

Connect the Unit to the PC

The first step is to connect the unit to the computer, for example using an SC485 adaptor or a USB-RS485 adaptor. Make sure that the selector switches are correctly set for the type of cable used (units are shipped ready to use data cables). Plug the unit into an AC outlet, and turn the unit on.

Select the Comm Port
After you have connected the unit to the computer, select the comm port that the Hardware Utility should use to communicate with the controller.

Select the Unit

After you have connected the unit to the PC and selected the comm port, select the unit ID of the controller that you wish to configure: Hit the "Refresh" button, and the Hardware Utility will scan your network for connected units. You can then select the unit ID from the dropdown list. Alternatively, if you already know the unit ID, you could simply type it into the dropdown box, without hitting "Refresh" first; this is quicker, but has some drawbacks:

Depending upon the type of controller and the level of firmware, hitting "Refresh" may allow the Hardware Utility to automatically populate the configuration settings screen with the actual current configuration of the controller. Typing in the unit ID, without first hitting "Refresh", will not do this, and so the configuration settings screen will simply show default values, which may or may not be how the controller is currently configured.

Also, "Refresh" allows the Hardware Utility to figure out the type of the controller, which lets it know various things about how to interact with this controller specifically; for example, the maximum number of bytes in a standalone sequence varies with the type of controller. If you hit "Refresh", the Hardware Utility will know how many bytes this controller can handle, and so won't allow a larger sequence to be sent to the controller. Simply typing in the unit ID, without first hitting "Refresh", will not do this, and so the Hardware Utility may try to send a standalone sequence that is larger than the controller can deal with.

NOTE: Scanning the network may take some time. If you have set the unit IDs of your controllers to low values, you can use the "Max Unit ID" section to speed up this scan drastically. It is therefore a good habit to assign your controllers unit IDs starting at 01, and increasing sequentially through 02, 03, and so on.

Choose "Configuration"

Next, click the "Configuration" button (near the bottom of the LOR Control tab of the Hardware Utility). This brings up configuration settings:
The configuration section of the LOR Control tab

**Set the Minimum and Maximum Intensities**

While active, the controller will not set its lights\' intensities below the specified minimum. If, however, it loses communications with its director, it will turn them off (i.e. 0% intensity). The lights are not turned up to the minimum until the unit receives its first lighting command.

Setting a maximum intensity below 100% may be used to help prolong the life of bulbs, although there is an important exception: Retro LED C7 and C9 bulbs (also known as replacement LEDs) can be harmed by using them at any intensity other than 100% or 0%.

The initial values displayed in this section are read from the controller itself (although this is supported only for certain versions of firmware - your controller may need a firmware update in order to read the values from the controller).

These settings only take effect for ports that are configured as "Triac Board".

**Set the Port Type**

The port type can be set to Triac Board, SSR, or Servo Motor. When set to Triac Board, dimming and fading are possible. When set to SSR, the unit will support SSRs with zero cross detectors. For the CTB08D controller, the two servo pins can be activated by setting Port B to Servo.
### Setting the Port Type

#### Set the Input Channel Types

Circuits that are used for interactive triggers can be either normally open ("N/O") or normally closed ("N/C"). The current value for each circuit is read from the controller itself, and the value can be updated in the "Input Channels" section.

Not all versions of firmware support this feature; if your controller has not yet been updated with firmware that supports it, the circuit will be treated as normally open (which is also the default for versions of firmware that can support both).

### Configuring DIO32 Servos

DIO32 devices can be set up to control servos; the Hardware Utility can be used to configure them by clicking the "DIO32-Servo Screen" button in the Configuration section. Doing so brings up the following:
The Light-O-Rama Software Package

For each circuit, you can select the appropriate pulse width to be used for the servo attached to that circuit. There are at least two reasons why you might want to do this: First, some servos support different pulse widths than others; second, you might want to use this to limit the range of the servo.

The minimum value in the selected pulse width will be used whenever a 0% intensity is set on that circuit's channel; the maximum value will be used whenever a 100% intensity is set. Regardless of the pulse width, 50% intensity always corresponds to 1.5 milliseconds.

Note that only sixteen circuits are displayed, though the DIO32 has 32 circuits. This is because its 32 circuits are spread among two unit IDs. For example, the first sixteen circuits might be for unit ID 01, in which case the next sixteen would be for unit ID 02. Both sets of sixteen can be configured independently, by selecting the appropriate unit ID. However, if you want to configure both, make sure to update the controller with your changes for one before proceeding to the other.

Configuring Cosmic Color Ribbons

The Cosmic Color Ribbon has its own configuration options, unique to it. You can use the Hardware Utility to configure these options by clicking the "CCR-Config Screen" button in the Configuration section (note, though, that this button will be greyed out unless you have selected a Cosmic Color Ribbon unit; you may have to use the Refresh button in order to let the Hardware Utility know about your Cosmic Color Ribbon). Doing so will bring up the following screen:

![Cosmic Color Ribbon Configuration Screen]

For details on these options, please refer to your Cosmic Color Ribbon manual (a PDF of the manual is available online at http://lightorama.com/Documents/CR150D_Man_Web.pdf). Here is a brief overview of each:

- **Unit ID Mode**: In "Normal" mode, the Cosmic Color Ribbon will be a single unit ID, with 157 circuit IDs. In "Legacy" mode, the Cosmic Color Ribbon will use up to ten sequential unit IDs (depending upon the configured resolution), with up to 16 circuit IDs for each unit ID.

- **Channel Mode**: In "Triples" mode, channels will be arranged red, green, blue, red, green, blue, and so forth. For example, circuit 1 is red for the first pixel; circuit 2 green for the first pixel; circuit 3 blue for the first pixel; circuit 4 red for the second pixel; and so on. In "Sequential" mode,
all red pixels will come first, then all green pixels, then all blue pixels.

- **Standalone Speed:** The speed at which a standalone sequence will run. A value of 8 is normal speed; higher values are faster, and lower values are slower.

- **Resolution:** The number of logical pixels that the Cosmic Color Ribbon will be. For example, setting it to 50 will give individual control over each of the 50 physical pixels, using 150 channels (one red, one green, and one blue for each pixel), while setting it to 1 will make all of the lights on the Cosmic Color Ribbon act as a single pixel, using three channels (red, green and blue).

- **Strips:** The number of end-to-end connected ribbons.

- **DMX Mode:** Selects how the Cosmic Color Ribbon will appear in a DMX universe: just the RGB channels, just the Macro channels, or both.

After choosing the configuration options, make sure to update the unit with the new settings.

**Update**

When you have set the configuration settings to the value you want, click the "Update Unit" button to send the new configuration information to the controller. Note: Doing so will update both the settings from the main screen and the settings from the DIO32 servo screen.

After updating, hit "Refresh" again to reload the new settings from the controller into the Hardware Utility.

**5.8.1.4 Testing Units**

You can test the operation of Light-O-Rama controllers using the LOR Control tab of the Hardware Utility, sending commands to turn lights on and off and to do other effects, or generate interactive triggers, by taking the following steps:

- Connect the Unit to the Computer
- Select the Comm Port
- Select the Unit
- Test the Unit

**Connect the Unit to the Computer**

The first step is to connect the unit to the computer, for example using an SC485 adaptor or a USB-RS485 adaptor. Make sure that the selector switches are correctly set for the type of cable used (units are shipped ready to use data cables). Plug the unit into an AC outlet, and turn the unit on.

**Select the Comm Port**

After you have connected the unit to the computer, select the comm port that the Hardware Utility should use to communicate with the controller.

**Select the Unit**

After you have connected the unit to the PC and selected the comm port, select the unit ID of the controller that you wish to use. If you know the controller's unit ID, you can simply type it into the dropdown box labelled “Select Unit”. If not, use the "Refresh" button, and the Hardware Utility will scan your network for connected units. You can then select it from the dropdown list.
NOTE: Scanning the network may take some time. If you have set the unit IDs of your controllers to low values, you can use the "Max Unit ID" section to speed up this scan drastically. It is therefore a good habit to assign your controllers unit IDs starting at 01, and increasing sequentially through 02, 03, and so on.

Selecting the unit to use

Test the Unit

The "Test Unit's Operation" screen of the LOR Control tab of the Hardware Utility is the screen displayed by default when the Hardware Utility is opened. If it is not currently open, make sure you have selected the LOR Control tab, and then hit the "Test" button near the bottom of the Hardware Utility:

By setting the "Test Mode" appropriately, you can either test output to the controllers - that is, test that they can control your lights - or test input from your controllers - that is, test that they can generate interactive triggers.

Test Outputs (test lights)

To test that your controllers can control your lights, select "Test Outputs (test lights)" as your "Test Mode".
After selecting the circuits that you wish to test (by checking their boxes in the "Select Circuits to Test" section), you can send a lighting effect command to those circuits by choosing the "Light Mode", "Start Intensity", "End Intensity", and "Fade Duration", and clicking on either the "ON", "OFF", or "Fade" buttons. **Note:** If "ON" is used, the intensity is specified via "End Intensity", not "Start Intensity".

Alternatively, the "Chase Sequence" section can be used to turn the selected circuits on and off in sequence.

**Test Inputs (for interactive)**

To test that your controllers can generate interactive triggers, select "Test Inputs (for interactive)" as your "Test Mode".

Select the circuits that you want to test. When you trip a trigger for one of those circuits, it should show up as red in this screen.

The input testing section of the LOR Control tab, with no circuits tripped.
5.8.1.5 Downloading Sequences

The Standalone Sequence Downloader section of the LOR Control tab of the Light-O-Rama Hardware Utility can be used to send an animation sequence to a Light-O-Rama controller, which can later run that sequence independently, in "standalone" mode, without being hooked up to a computer running Light-O-Rama software.

When a unit runs a sequence in standalone mode, it not only executes the lighting commands in the sequence that are for that controller itself, but also, if the sequence contains any commands for other units, it will transmit them to the other units that it is connected to. In this way, a single controller can be downloaded with a sequence, and act as a "director" for several linked controllers.

It is important that only one controller in any mutually connected group act as a director. Downloading sequences to two separate controllers that are hooked up in a mutually connected group will have undesired results, as the commands transmitted by the two will interfere with each other. Similarly, it is important not to also control sequences from your computer while you have a controller hooked up to it acting in standalone mode, for the same reason.

Normally, the controller will execute the standalone sequence any time that it is powered on. However, some controllers have internal clocks that allow the standalone sequence to be scheduled to run during a particular timeframe.

Note: The CTB08 controller does not have transmit capability in standalone mode.

To download a sequence to a controller to be used in standalone mode, take the following steps:
Create the Sequence

Connect the Controller to the PC
Select the Comm Port
Select the Unit
Download the Sequence

You can also use this section of the Hardware Utility to choose when the sequence will run (for controllers that support this), to remove the standalone sequence from a controller, and to test a standalone sequence.

To get to the Standalone Sequence Downloader screen, make sure that you are in the LOR Control tab of the Hardware Utility, and then click on the “Standalone” button.

Create the Sequence

Using the Sequence Editor, create an animation sequence. Only animation sequences - not musical sequences - can be downloaded for standalone mode. When you create the sequence, you must assign unit IDs and circuit IDs to the channels, as normal.

Some controllers have very little storage space for sequences. Because size is a limiting factor, you should consider the following tips to keep your sequence’s size at a minimum:

- **Fade** commands take up the most space.
- The least space is used when all lights on a controller are at either 100% or 0% intensity.
- When possible, place similar commands at the same time. For example, if you turn one circuit of a controller off and then, a tenth of a second later, turn another circuit on the same controller off, that will take about twice as much space as would turning both of them off at the same time.
- Use **loops** whenever possible.
• Different types of controllers have different maximum sequence sizes; controllers such as the CTB08 have little space and can handle only very simple animations.

Also, sequences to be used in standalone mode have some limitations:

• The sequence must contain only one track.
• The sequence should only contain commands for controllers on a single network; unexpected results may occur if you have more than one network listed in the sequence.
• Timings are only supported on tenth-of-a-second boundaries (for example, 1 second, 1.1 seconds, 1.2 seconds). If any timings in the sequence are at some centisecond other than a tenth-of-a-second boundary (for example, 1.15 seconds), they will be considered to be at the next tenth-of-a-second boundary.
• Depending on the device type, between 1 and 10 loop levels may be supported.
• Loop speed modification is not supported, and will be ignored.

Connect the Controller to the PC

Connect the unit to the computer, for example using an SC485 adaptor or a USB-RS485 adaptor. Make sure that the selector switches are correctly set for the type of cable used (units are shipped ready to use data cables). Plug the unit into an AC outlet, and turn the unit on.

Select the Comm Port

After you have connected the unit to the computer, select the comm port that the Hardware Utility should use to communicate with the controller.

Select the Unit

After you have connected the unit to the PC and selected the comm port, select the unit ID of the controller that you wish to use. If you know the controller's unit ID, you can simply type it into the dropdown box labelled "Select Unit". If not, use the "Refresh" button, and the Hardware Utility will scan your network for connected units. You can then select it from the dropdown list.

NOTE: Scanning the network may take some time. If you have set the unit IDs of your controllers to low values, you can use the "Max Unit ID" section to speed up this scan drastically. It is therefore a good habit to assign your controllers unit IDs starting at 01, and increasing sequentially through 02, 03, and so on.

Download the Sequence

Choose the animation sequence you wish to download using the "Open" button in the "Select Sequence" section, and then download it using the "DownLoad" button in the "Download Selected Sequence" section:
Selecting and downloading the sequence

If you do not see this in the Hardware Utility, make sure that you are on the LOR Control tab, and click on the "Standalone" button near the bottom.

Scheduling the Sequence

Some Light-O-Rama controllers can schedule the downloaded sequence to run at certain times or in certain conditions (those that cannot will run the sequence continually whenever powered on). To schedule when it will run, use the "Trigger Condition" section:

Selecting the condition you want to start the sequence, and click "Send Trigger info to Unit".

If you do not see this in the Hardware Utility, make sure that you are on the LOR Control tab, and click on the "Standalone" button near the bottom.

Note: If you choose to use specific scheduled times, the clock on the controller is set to the current time according to your computer. Make sure that the time on your computer is correct.

Removing the Sequence

To remove a downloaded sequence from a standalone controller, use the "Delete" button in the "Remove Sequence" section:
Removing a sequence

Note: This does not actually remove the sequence from the controller; rather, it makes it so that the controller will no longer play the sequence. So, if you later decide to use the sequence again, you can simply reschedule the sequence to run, rather than downloading the sequence again.

If you do not see this in the Hardware Utility, make sure that you are on the LOR Control tab, and click on the "Standalone" button near the bottom.

Testing the Sequence

After downloading a sequence to a controller to be used in standalone mode, it is recommended that you test the sequence, using the buttons in the "Test Sequence" section. To start the sequence, click "Sequence ON"; to stop it, click "Sequence OFF".

Note that the "Sequence OFF" button will stop the sequence even if it was started automatically (by powering on or by schedule, as opposed to via the "Sequence ON" button).

Testing the sequence

If you do not see this in the Hardware Utility, make sure that you are on the LOR Control tab, and click on the "Standalone" button near the bottom.

5.8.1.6 Firmware Updates

The Firmware Update section of the LOR Control tab of the Hardware Utility can be used to send new firmware to Light-O-Rama controllers. A controller's firmware has a similar purpose to the operating system on your computer (such as Windows XP or Windows Vista): The operating system on your computer is used to run other programs that you load on the computer, such as Light-O-Rama. The firmware on a Light-O-Rama controller is used to execute the commands to control the lights and run standalone sequences.

From time to time, new versions of firmware will become available. In general, unless the new version of firmware has a new feature that you need to use, you should not update the firmware.

If you do wish to update the firmware of a controller, do so using the following steps:

- Select the Unit
- Select the Firmware File
- Download the Firmware

If any problems are encountered, please see "Troubleshooting".

To get to the Firmware Update section of the Hardware Utility, make sure that you are in the LOR Control tab, and click the "Firmware" button (near the bottom).
Select the Unit

It is recommended that only one controller be connected to the computer when updating firmware. Units can have firmware updated when more than one is attached to the computer, but if you choose to do this, make sure that "Selected unit listed above" is selected, and make sure that the proper unit is selected in the "Select Unit to Configure.. Download.. Test" section (above the "Firmware" section).

If you instead use the recommended method of having only a single controller attached to the PC during a firmware update, choose "Only one unit is connected".

To update the firmware of a Light-O-Rama MP3 Player or a Light-O-Rama Wireless Unit, select the matching entry in the "Select Unit" section.

Select the Firmware File

Use the "Open" button to select the firmware file that you wish to send to the controller. The "Open" button starts in your Light-O-Rama base directory; the firmware files are typically located in the "Firmware" subdirectory.

Select the latest version of firmware for the unit being updated. The names of the firmware files correspond with the names of the controllers.
Download the Firmware

Finally, start the download by pressing the “Download” button. The progress bar will provide you with an update.

If you encounter any problems, please see "Troubleshooting".

Troubleshooting

If the download does not start within 15 seconds of hitting the "Download" button, check that the unit is powered and properly connected to the PC. If all else fails, power the unit on and off after you click the download button and the PC is attempting to start the download.

5.8.2 Light-O-Rama MP3 Directors

The LOR MP3 tab of the Light-O-Rama Hardware Utility can be used to download musical sequences to a Light-O-Rama MP3 director (such as an "LOR1602W with Show Director and MP3 Player"), and schedule when those sequences should be played.

Up to nine separate shows can be downloaded to an MP3 director.

For details, please refer to the following sections:

- Scheduling/Show Options
  - Old Firmware
  - Select When Show Plays
  - Select How Show Plays
- MP3 Player Showlist
- Download the Show
- Set the Time
Scheduling/Show Options

This section allows you to select various options about the show:

- **Old Firmware**
- **Select When Show Plays**
- **Select How Show Plays**

**Old Firmware**

If your MP3 unit has the original firmware (Version 1.0) then you must check this box. To determine if the unit has this old version of firmware, watch the LEDs when you apply power. Newer versions of firmware will chase the LEDs briefly when power is first applied. The Old version of firmware will not perform the chasing of the LEDs.

New versions of firmware will provide you with many new scheduling features. It is recommended that if you want these additional features, update your firmware.

**Select When Show Plays**

This section gives three main options for when the show will play: "plays anytime powered", "plays during scheduled time", and "plays when triggered". Additionally, you can specify that the show cannot be interrupted by input triggers, even if other shows are set up to start on those triggers.

Selecting "plays anytime powered" will cause the show to run whenever the MP3 director is powered
Selecting "plays during scheduled time" allows you to specify a time or times when the show should play. Up to nine shows can be downloaded to a controller, and each will be assigned a number between 1 and 9. If two shows are scheduled for the same time, the lower numbered show will be played.

Selecting "plays when triggered" will cause the show to start whenever some external trigger happens (such as a circuit being closed or a motion detector being tripped). If you choose this option, you will be prompted to select the trigger’s switch number (up to six switches are supported), and whether the switch is normally open or normally closed.

A normally open switch has its contacts open until you activate it, at which point they close; a normally closed switch has its contacts closed until you activate it, at which point they open. Most switches are normally open; motion detectors, however, are typically normally closed. This is because they are often used in security systems, where it is important to notice that a wire has been cut.

**Select How Show Plays**

In this section, you can choose whether the show should loop continuously (that is, when it finishes playing the last sequence in its list, it will start over at the first), or only one time, or every so often (every hour, half hour, fifteen minutes or ten minutes).

If you choose to play the show every so often, you will also be prompted for what the lights should do in between. You can choose to have all your lights on, or off, or else use an animation sequence as a "filler" that will play continuously during the time in between.

**MP3 Player Showlist**

You can add musical sequences to the show by clicking the “Add Sequence” button. To remove one, click on it to highlight it, and then click the “Remove Sequence” button.

The sequences will be played in the order listed. You can change the order by clicking on a sequence to highlight it, and then clicking “Move Up” or “Move Down”.

Sequences with subsequences cannot be added to the showlist.

Optionally, you can also specify a "start sequence", which will be played once and only once every time the show starts up, before the other sequences. This is most useful if you selected that the show should loop continuously. For example, a show with a start sequence and three sequences in the showlist will, when "loop continuously" is turned on, first play the start sequence, then the first sequence of the showlist, then the second, then the third, and then back to the first in the showlist - not back to the start sequence.

Both musical sequences and animation sequences can be used as start sequences.

**Download the Show**

When you have selected the show's options and the sequences to be played, you can download the show to an SD card (which can later be placed into the MP3 director). Make sure that you have your SD card reader/writer hooked up to your PC, and click on the "Create Show" button.
brings up a final options screen:

![Setup MP3/Director Memory Card](image)

The final options for downloading a show to the SD card

On this screen, first select the show number that you want to use for this show. Each show on a card must have a unique number assigned. If multiple shows are scheduled at the same time, the lowest numbered show will take priority.

If you have a very large display, selecting "lock step" may help the different controllers used in the display react with a higher degree of synchronization. This is not supported on all controller types, and the level of firmware in the controllers must be 3.0 or higher.

If you wish to add a file to the SD card to set the MP3 director's internal clock, check the box that says so. Note that there are also other ways to set the director's clock.

Select the communications speed that will be used to broadcast lighting commands. The recommended setting (57.6) will suffice for many users' displays. If you have many controllers that are far distances apart, a slower speed may help; if your sequences use many rapid lighting commands, a faster speed may help.

Next, select the drive that contains your SD card, and click "Place Show on the SD Card". After this completes, you can move the SD card to your MP3 director.

Set the Time

If any of your shows are set up to run on schedules, it is important to set the MP3 director's clock appropriately. There are several ways to do this:
First, you can directly hook your MP3 director up to your PC, and click on the "Set to PC's time" 
button (in the lower right-hand corner of the LOR MP3 tab).

If you cannot (or do not wish to) hook the MP3 director up to your PC, you can instead create a 
"time file" to be placed on an SD card. The first time that SD card is placed in the MP3 director, the 
director's clock will be set to the time specified in the time file (which you can choose, so that you 
have enough time to move the card from your PC to your MP3 director).

There are two ways to build a time file: First, you can click on the "Only place SET TIME file on the 
SD card"; this will create a time file and download it, without downloading a show as well. Second, 
when you create a show, during the final options dialog, you can request that a time file be created 
and downloaded along with the show.

Finally, you can manually set the time on an MP3 director. See the director's user's guide for 
details.

5.8.3 Light-O-Rama Wireless Devices

The LOR RF tab of the Light-O-Rama Hardware Utility can be used to configure Light-O-Rama wireless 
devices (such as the Easy Light Linker).

When using this tab, make sure that only a single wireless device is in the daisy-chained network 
hooked up to the PC.

For details, please see the following sections:

- Frequency
- Speed
- Power Level
- Stream Data
- Get Current Configuration
- Set Defaults
- Update Configuration
The LOR RF tab of the Hardware Utility

**Frequency**

Use this section to control the frequency used by the wireless device. Note that the transmitter and any receivers for it must be set to use the same frequency.

You can also use this to set the frequencies of two different transmitters to different values, so that they will not interfere with each other; these different transmitters can then be placed far apart from each other, effectively increasing the range of your wireless network.

Finally, some other wireless source in your area may interfere with Light-O-Rama's wireless communications at certain frequencies, so if you notice problems with the controllers hooked up to your wireless devices, try changing the frequency that is used.

If you change this setting, make sure to click the **Update Configuration button** so that the change will be sent to the wireless device currently hooked up to the PC.

**Speed**

Use this section to control the communications speed used by the devices. The faster speed is typically the better, allowing more frequent lighting effects, unless your controllers are separated over large distances. In that case, if you notice problems with the higher speed, try changing to the lower speed.

Note that a transmitter and its receivers must use the same speed.

If you change this setting, make sure to click the **Update Configuration button** so that the change will be sent to the wireless device currently hooked up to the PC.
Power Level

If your transmitter and receivers are physically close to each other, using too much power might cause unintended effects. If you notice this, try setting a lower power level.

If you change this setting, make sure to click the Update Configuration button so that the change will be sent to the wireless device currently hooked up to the PC.

Stream Data

This section continuously streams data. This is mostly for internal testing purposes, and it is unlikely that you will need to use this.

Get Current Configuration

Clicking this button will retrieve the settings (such as frequency) from the wireless device currently hooked up to the PC, and display them in the "Current Device Parameters" section.

Set Defaults

Clicking this button will reset the settings (such as frequency) of the wireless device currently hooked up to the PC back to their factory defaults.

Update Configuration

After you have changed the frequency, speed, or power level, click this button to send the changes to the wireless device currently hooked up to the PC.

5.8.4 Digital IO Boards

The Digital IO Boards tab on the Light-O-Rama Hardware Utility can be used to determine if Light-O-Rama can properly communicate with digital IO boards (including BSOFT digital IO boards) installed on your computer. In order to use these boards with Light-O-Rama, your computer must have the Universal Library and InstaCal installed.

To get a list of the boards that Light-O-Rama can find installed on the PC, click the "Refresh List" button. Once a list of boards appears, you can select a board to test. If the board is a BSOFT digital IO board, make sure that you check the appropriate checkbox.

After a board has been selected, you can test either individual pins on the board, or chase through all pins.

If you cannot control the board using the Hardware Utility, then you will not be able to control the board using any Light-O-Rama software, including the Sequence Editor or the Show Player.
5.8.5 X10 Controllers

Light-O-Rama can control industry standard X10 modules using CM11A X10 controllers (available for purchase at a variety of online stores). The X10 CM11A tab of the Light-O-Rama Hardware Utility can be used to test the connection and functionality of such controllers.

To do so, first connect the controller to a serial port, using the cable supplied with the CM11A.

Select the port that you believe the CM11A to be on in the "Select CM11A Port" dropdown list, and click on the "Init Unit" button. In the status window above the port selection dropdown list, you will see if the unit has been located on the selected port. **Note:** Occasionally there will be a false report of a CM11A being located on comm ports that are actually internal modems. This is generally Comm 3.

Select the house code and unit number of the controller, and test the unit using any of the "On", "Off", "Fade Down" and "Fade Up" buttons.
5.8.6 Test Console

Clicking on the "Console" button of the Light-O-Rama Hardware Utility opens the Test Console. The Test Console can be used to test standard Light-O-Rama controllers, or to configure and test Light-O-Rama iDMX-1000 DMX interface.
Controller Type

Use this section (in the lower left) to choose whether to use a test a standard Light-O-Rama controller or to configure and test a Light-O-Rama DMX interface. In the latter case, you can choose between the ability to send any of 101 different intensities, from 0 to 100 ("LOR %" mode), or the ability to send any of 256 different intensities ("DMX" mode).

DMX Channel Mode

This section (in the lower right) is available only if the controller type is set to "iDMX-1000 - LOR %" or "iDMX-1000 - DMX". It allows you to choose how to map Light-O-Rama channels to DMX channels.

NOTE: Only "Virtual Controllers" is currently supported. "Extended Circuit IDs" will be supported in a future release.

In "Virtual Controllers" mode, the DMX interface is treated as sixteen separate Light-O-Rama controllers each having its own unit ID and each with sixteen circuits, for a total of 256 channels. These 256 channels are each mapped to an individual DMX channel.

In "Extended Circuit IDs" mode (which is not currently supported), the DMX interface will be treated as a single Light-O-Rama unit ID, but can individually address all 256 circuits (whereas currently a single Light-O-Rama unit ID supports up to 16 circuits).

Select Unit ID
Use this section to select the unit ID.

If the **controller type** is set to "Standard Controller", or if the **DMX channel mode** is set to "Extended Circuit IDs", both dropdown lists are enabled, with 0 through F available as the choices in each. So, for example, to use unit ID C7, select "C" from the first dropdown list, and "7" from the second.

If the DMX channel mode is set to "Virtual Controllers", only the first dropdown list is enabled. The DMX interface will use all sixteen unit IDs starting with the value selected there. For example, to use unit IDs 30 through 3F, select "3" in the first dropdown box.

### Select Channel Group

A Light-O-Rama DMX interface can support up to 256 DMX channels simultaneously. However, the **intensity sliders** at the top of the Test Console only show sixteen of them at once (plus the master slider). To select which sixteen are currently displayed, use the "Select Channel Group" slider with the **controller type** set to iDMX-1000.

### Set Intensities

The top portion of the Test Console shows sixteen sliders for the intensities of sixteen channels, plus a master slider (on the left) which can be used to slide them all simultaneously.

Above each slider are the Light-O-Rama **unit ID** and **circuit ID** associated with that slider. Also, if the controller type is set to iDMX-1000, then above those is the corresponding DMX address. These values depend upon the selections made for the controller type, DMX channel mode, unit ID, and channel group.

A common use of this is to determine the Light-O-Rama intensities to be used to produce various effects on a DMX controller. For example, a DMX controller may be able to turn on red, green, or blue lights; each of these is done by sending the same circuit a different command value. In Light-O-Rama, these are represented as intensities. The Light-O-Rama intensities and the corresponding DMX values are displayed below each slider.

So, for example, you could use this portion of the Test Console to determine that your controller turns on a blue light when sent a value of 94, which corresponds to a Light-O-Rama intensity of 37%. So, when building a sequence in the Sequence Editor, you can tell this DMX controller to turn on a blue light by applying a Set Intensity effect for 37%.

### Test Buttons

You can use the various buttons at the bottom of the Test Console to send lighting effect commands to the controller.

### 5.9 ServoDog Utility

The Light-O-Rama ServoDog Utility can be used to configure the Light-O-Rama ServoDog, which is a fourteen channel digital controller that can perform digital input, digital output, servo control and PWM ("Pulse Width Modulation") dimming.

For details on how to use the ServoDog Utility, please refer to your ServoDog manual. This can be downloaded from [the Light-O-Rama Support page](https://www.light-orama.com/support/).
5.10 Verifier

The Light-O-Rama Verifier can be used to check for certain types of problems with the way that Light-O-Rama is configured on your machine, and with your schedule, shows, and sequences.

To use the Verifier, simply click its "Verify" button. As it is checking for issues, it will display what it is doing in its "Output Log" tab; when it is complete, it will switch to its "Results" tab, showing a list of the issues that it has found:
The Light-O-Rama Software Package

The Verifier has found one error and seven warnings.

Each result has a description, severity, and message number, and may have additional details. There are several "Details" columns, each of which may contain a piece of information specific to the detected problem. For example, in the above screenshot, several warning messages appear, all with message number 28, meaning "Channel is completely off". This message number's first "Details" column shows the name of the sequence in which the problem was found and its second "Details" column shows the track containing the channel which is completely off. Its third "Details" column (which cannot be seen in the screenshot above, but which could be seen by scrolling to the right) displays the name of the channel.

If you right-click on a particular result, a popup menu will appear:

The right-click popup menu for a result

Clicking "Help on this result" simply opens the help file to the page for the result number in question.

The two "ignore" options let you tell the Verifier that you are not interested in seeing this result in the future - either it specifically ("Ignore this result") or all results with the same message number ("Ignore all results with message number 28").

© 2010 Light-O-Rama, Inc.
If you ignore a result (or all results with a certain message number), then whenever such results are
detected in the future, they will not count towards the number of errors or warnings which the Verifier
says it detected, and they will be displayed on the Verifier's "Ignored Results" tab instead of the
"Results" tab. You can later decide to stop ignoring such results by going to that tab, right-clicking on a
result, and unchecking the ignore option that you had previously selected.

You can also save the list of results to a text file, by clicking the Verifier's "Save" button. Only results
on the "Results" tab will be saved to the file; those on the "Ignored Results" will not be.

Please see the list of Verifier messages for details on the types of problems that the Verifier checks for.

5.10.1 List of Verifier Messages

The following messages can be generated by the Light-O-Rama Verifier. For details on any given one,
please refer to its individual help page.

- **Message 1** (Info): No errors or warnings found
- **Message 2** (Warning): Verification cancelled
- **Message 3** (Error): Light-O-Rama is not fully installed
- **Message 4** (Error): No registry entry for application path
- **Message 5** (Error): Application directory does not exist
- **Message 6** (Warning): Verifier not running from LOR application path
- **Message 7** (Error): Application file does not exist
- **Message 8** (Error): Unlicensed LOR demo version used
- **Message 9** (Warning): Unsupported version of Windows Media Player
- **Message 10** (Error): No registry entry for user data path
- **Message 11** (Error): User data directory does not exist
- **Message 12** (Warning): No registry entry for non-media data path
- **Message 13** (Warning): Non-media data directory does not exist
- **Message 14** (Warning): No registry entry for media data path
- **Message 15** (Warning): Media data directory does not exist
- **Message 16** (Error): Application file has unexpected version number
- **Message 17** (Warning): Weekly schedule file does not exist
- **Message 18** (Warning): Yearly schedule file does not exist
- **Message 19** (Warning): Calendar scheduling not supported
- **Message 20** (Warning): No shows are scheduled
- **Message 21** (Error): Show file does not exist
- **Message 22** (Error): Error reading show file
- **Message 23** (Error): Sequence file does not exist
- **Message 24** (Error): Sequence file cannot be loaded
- **Message 25** (Warning): Show has no sequences
- **Message 26** (Error): Media file does not exist
- **Message 27** (Warning): Conflicting channel settings in sequence
- **Message 28** (Warning): Channel is completely off
- **Message 29** (Warning): Sequence is completely off
- **Message 30** (Warning): Channel is missing settings
- **Message 31** (Warning): Channel uses undefined comm network
- **Message 32** (Warning): Channel in tracks of conflicting length
- **Message 33** (Warning): Musical file used in non-audio section of show
- **Message 34** (Warning): Subsequences not supported
- **Message 35** (Warning): Background sequences unsupported
- **Message 36** (Warning): Startup sequences unsupported
• **Message 37** (Warning): Shutdown sequences unsupported
• **Message 38** (Warning): Interactive triggers unsupported
• **Message 39** (Warning): Unsupported number of tracks
• **Message 40** (Warning): Shell commands unsupported
• **Message 41** (Warning): Shell command map file does not exist
• **Message 42** (Warning): Shell command not set
• **Message 43** (Warning): Channel conflict

### 5.10.1.1 Verifier Messages 1-10

The following are some messages can be generated by the Light-O-Rama Verifier. For details on any given one, please refer to its individual help page. To see all possible messages, please refer to the List of Verifier Messages.

• **Message 1** (Info): No errors or warnings found
• **Message 2** (Warning): Verification cancelled
• **Message 3** (Error): Light-O-Rama is not fully installed
• **Message 4** (Error): No registry entry for application path
• **Message 5** (Error): Application directory does not exist
• **Message 6** (Warning): Verifier not running from LOR application path
• **Message 7** (Error): Application file does not exist
• **Message 8** (Error): Unlicensed LOR demo version used
• **Message 9** (Warning): Unsupported version of Windows Media Player
• **Message 10** (Error): No registry entry for user data path

#### 5.10.1.1.1: No errors or warnings found

**Message Number:** 1  
**Severity:** Info  
**Summary:** No errors or warnings found

If the Light-O-Rama Verifier does not find any errors or warnings (other than those you have told it to ignore), it will output this message.

---

**The LOR Verifier**  
**List of Verifier Messages**

#### 5.10.1.1.2: Verification cancelled

**Message Number:** 2  
**Severity:** Warning  
**Summary:** Verification cancelled

If you hit the cancel button while the LOR Verifier is checking for problems, it will stop checking, display any issues that it has found to that point, and additionally display this message to warn you that there may be other issues that it would have found had it not been cancelled.

Note that it may not stop immediately when you hit the cancel button; it may finish its current check first.

---

**The LOR Verifier**

© 2010 Light-O-Rama, Inc.
List of Verifier Messages

5.10.1.1.3  3: Light-O-Rama is not installed

Message Number: 3
Severity: Error
Summary: Light-O-Rama is not fully installed

The installation of Light-O-Rama is not complete. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry.

If the problem is that the registry entries have been deleted, you can solve it by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a "Sequences" directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.

The LOR Verifier
List of Verifier Messages

5.10.1.1.4  4: No registry entry for application path

Message Number: 4
Severity: Error
Summary: No registry entry for application path

A required Light-O-Rama entry in the Windows registry cannot be found. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry. You will not be able to use Light-O-Rama until this problem is resolved.

If the problem is that the registry entries have been deleted, you can solve it by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a "Sequences" directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.
5.10.1.1.5 5: Application directory does not exist

**Message Number:** 5  
**Severity:** Error  
**Summary:** Application directory does not exist  
**Details:** The name of the directory that is missing

The Windows registry says that the Light-O-Rama program files, such as the Sequence Editor and the Hardware Utility, can be found in a certain directory, but that directory does not actually exist. You will not be able to use Light-O-Rama until this problem is resolved.

It is suggested to uninstall and reinstall Light-O-Rama.

---

5.10.1.1.6 6: Verifier not running from LOR application path

**Message Number:** 6  
**Severity:** Warning  
**Summary:** Verifier not running from LOR application path  
**Details #1:** The name of the directory that LOR program files should be contained in  
**Details #2:** The name of the directory that the Verifier is running from

The various Light-O-Rama program files, such as the Sequence Editor and the Hardware Utility, are expected to be found in a certain Windows directory. The Verifier itself is one such program. However, the copy of the Verifier that you are running is actually contained in a different directory.

This may not be a problem, for example if you intentionally copied the Verifier to a different directory and ran it from there.

However, it might indicate that you are using an old version of the Verifier from a previous installation, and that old Verifier may not be completely compatible with the current installation. Or, it might be indicative of a deeper problem with the installation of Light-O-Rama.

It is suggested that you run the Verifier from the same directory where the Light-O-Rama program files are installed. If you are doing so, and still get this error, consider uninstalling and reinstalling Light-O-Rama.

---

5.10.1.1.7 7: Application file does not exist

**Message Number:** 7  
**Severity:** Error  
**Summary:** Application file does not exist  
**Details:** The expected directory and filename of the missing application file

One of the Light-O-Rama program files, such as the Sequence Editor or the Hardware Utility, cannot be found.

Depending upon exactly what is missing, your shows may still be able to play. However, they may not,
and in any case, something is definitely wrong.

It is suggested that you uninstall and reinstall Light-O-Rama.

The LOR Verifier
List of Verifier Messages

5.10.1.1.8  8: Unlicensed LOR demo version used

Message Number: 8
Severity: Error
Summary: Unlicensed LOR demo version used

Your Light-O-Rama software has not been registered. Until you register it, it will not actually control your lights (and will have other limitations as well).

This may have occurred for various reasons - for example, it simply may be that you have not yet purchased a Light-O-Rama license. If you do have a license, though, you may not have entered it on this computer, or perhaps you have recently installed a new version of Light-O-Rama (in which case your license may or may not be valid for this new version). Or, perhaps your licensing information has been deleted from the Windows registry, perhaps by a registry cleanup tool.

If you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

The LOR Verifier
List of Verifier Messages

5.10.1.1.9  9: Unsupported version of Windows Media Player

Message Number: 9
Severity: Warning
Summary: Unsupported version of Windows Media Player

The version of Windows Media Player installed on this computer is older than the minimum version required by Light-O-Rama, or, perhaps, Windows Media Player is not correctly installed.

You may still be able to use Light-O-Rama, but it will (at the very least) be severely limited - for example, musical sequences will not play. It is suggested that you install the latest version of Windows Media Player.

The LOR Verifier
List of Verifier Messages

5.10.1.1.10 10: No registry entry for user data path

Message Number: 10
Severity: Error
Summary: No registry entry for user data path
A required Light-O-Rama entry in the Windows registry cannot be found. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry.

Your shows will not run successfully until this problem is resolved.

If the problem is that the registry entries have been deleted, you can solve it by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a "Sequences" directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.

The LOR Verifier
List of Verifier Messages

5.10.1.2 Verifier Messages 11-20

The following are some messages can be generated by the Light-O-Rama Verifier. For details on any given one, please refer to its individual help page. To see all possible messages, please refer to the List of Verifier Messages.

- **Message 11** (Error): User data directory does not exist
- **Message 12** (Warning): No registry entry for non-media data path
- **Message 13** (Warning): Non-media data directory does not exist
- **Message 14** (Warning): No registry entry for media data path
- **Message 15** (Warning): Media data directory does not exist
- **Message 16** (Error): Application file has unexpected version number
- **Message 17** (Warning): Weekly schedule file does not exist
- **Message 18** (Warning): Yearly schedule file does not exist
- **Message 19** (Warning): Calendar scheduling not supported
- **Message 20** (Warning): No shows are scheduled

5.10.1.2.1 11: User data directory does not exist

**Message Number:** 11  
**Severity:** Error  
**Summary:** User data directory does not exist  
**Details:** The name of the missing directory

The directory that Light-O-Rama expects to find Light-O-Rama data files in does not exist. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry, or if the directory was deleted or renamed.

Your shows will not run successfully until this problem is resolved.

You may be able to solve this problem by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama
program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a "Sequences" directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.

The LOR Verifier
List of Verifier Messages

5.10.1.2.2  12: No registry entry for non-media data path

Message Number: 12
Severity: Warning
Summary: No registry entry for non-media data path

A required Light-O-Rama entry in the Windows registry cannot be found. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry.

Until this problem is resolved, it is possible that your shows will run successfully, but it is likely that they will not. Even if the shows themselves do run, certain sequences in them may not.

If the problem is that the registry entries have been deleted, you can solve it by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a "Sequences" directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.

The LOR Verifier
List of Verifier Messages

5.10.1.2.3  13: Non-media data directory does not exist

Message Number: 13
Severity: Warning
Summary: Non-media data directory does not exist
Details: The name of the missing directory

The directory that Light-O-Rama expects to find Light-O-Rama sequence files in does not exist. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry, or if the directory was deleted or renamed.

Until this problem is resolved, it is possible that your shows will run successfully, but it is likely that they will not. Even if the shows themselves do run, certain sequences in them may not.
You may be able to solve this problem by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a "Sequences" directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.

---

**The LOR Verifier**

**List of Verifier Messages**

5.10.1.2.4 14: No registry entry for media data path

**Message Number:** 14  
**Severity:** Warning  
**Summary:** No registry entry for media data path

A required Light-O-Rama entry in the Windows registry cannot be found. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry.

Until this problem is resolved, it is possible that your shows will run successfully, but it is likely that they will not. Even if the shows themselves do run, certain sequences in them may not.

If the problem is that the registry entries have been deleted, you can solve it by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a "Sequences" directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.

---

**The LOR Verifier**

**List of Verifier Messages**

5.10.1.2.5 15: Media data directory does not exist

**Message Number:** 15  
**Severity:** Warning  
**Summary:** Media data directory does not exist

The directory that Light-O-Rama expects to find audio and video files in does not exist. This could occur, for example, if the installation was interrupted, or if a registry cleanup utility deleted certain Light-O-Rama entries from your computer's Windows registry, or if the directory was deleted or renamed.
Until this problem is resolved, it is possible that your shows will run successfully, but it is likely that they will not. Even if the shows themselves do run, certain sequences in them may not.

You may be able to solve this problem by running the LORPost utility, which is typically automatically run after installation. This utility can be found in the directory where you installed your Light-O-Rama program files, which is typically (but not always) C:\Program Files\Light-O-Rama.

Note that the LORPost utility will ask where your Light-O-Rama data files should be stored. If you already have a “Sequences” directory, and would like to keep your sequences there by default, tell it the directory one level above that directory. For example, if your sequences are stored in C:\LOR\Sequences, tell the LORPost utility to store your Light-O-Rama data files in C:\LOR.

Otherwise, try reinstalling Light-O-Rama, or uninstalling and then reinstalling.

5.10.1.2.6 16: Application file has unexpected version number

Message Number: 16
Severity: Error
Summary: Application file has unexpected version number
Details #1: The name of the application file
Details #2: The expected version number of the application file
Details #3: The actual version number of the application file

A certain Light-O-Rama program file, such as the Sequence Editor or the Hardware Utility, has a version number other than the one that the Verifier was expecting.

This may be because you are using an old version of the Verifier from a previous installation, and that old Verifier may not be completely compatible with the current installation. Or, it might be indicative of a deeper problem with the installation of Light-O-Rama.

Make sure that you are running the copy of the Verifier that is in the same directory where your current version of Light-O-Rama is installed. If you are doing so, it is suggested that you uninstall and reinstall Light-O-Rama.

5.10.1.2.7 17: Weekly schedule file does not exist

Message Number: 17
Severity: Warning
Summary: Weekly schedule file does not exist
Details: The name of the missing file

The file which is supposed to contain your weekly schedule does not exist.

If you do not intend to have any shows scheduled via the weekly schedule, this is not an issue; any shows that you have scheduled via the calendar schedule should play as scheduled. But if you do intend to have shows scheduled via the weekly schedule, they will not be played until this problem is
resolved.

Perhaps the file was renamed out of the way, in which case you can rename it back to the expected name. Or, perhaps it was deleted; check your computer's Recycle Bin. If neither of these is the problem, then you will have to recreate your weekly schedule via the Schedule Editor or the Simple Show Builder.

The LOR Verifier
List of Verifier Messages

5.10.1.2.8 18: Yearly schedule file does not exist

Message Number: 18
Severity: Warning
Summary: Yearly schedule file does not exist
Details: The name of the missing file

The file which is supposed to contain your calendar schedule does not exist.

If you do not intend to have any shows scheduled via the calendar schedule, this is not an issue; any shows that you have scheduled via the weekly schedule should play as scheduled. But if you do intend to have shows scheduled via the calendar schedule, they will not be played until this problem is resolved.

Perhaps the file was renamed out of the way, in which case you can rename it back to the expected name. Or, perhaps it was deleted; check your computer's Recycle Bin. If neither of these is the problem, then you will have to recreate your weekly schedule via the Schedule Editor or the Simple Show Builder.

The LOR Verifier
List of Verifier Messages

5.10.1.2.9 19: Calendar scheduling not supported

Message Number: 19
Severity: Warning
Summary: Calendar scheduling not supported
Details #1: The date on which a show is scheduled via the calendar
Details #2: The name of the show

A show is scheduled via the calendar schedule, but your license does not support calendar scheduling (or you are using the unlicensed demo version of the software). The show will not play at the scheduled time.

If you already have a license, and have registered Light-O-Rama on this computer, then to get the show to play, you can either upgrade to a higher level license which does support calendar scheduling, or else remove the show from your calendar schedule and schedule it in your weekly schedule instead.

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers
covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

The LOR Verifier
List of Verifier Messages

5.10.1.2.10 20: No shows are scheduled

**Message Number:** 20  
**Severity:** Warning  
**Summary:** No shows are scheduled

You have no shows scheduled. None of your shows will play until you schedule them, via the Schedule Editor or the Simple Show Builder.

The LOR Verifier
List of Verifier Messages

5.10.1.3 Verifier Messages 21-30

The following are some messages can be generated by the Light-O-Rama Verifier. For details on any given one, please refer to its individual help page. To see all possible messages, please refer to the List of Verifier Messages.

- **Message 21** (Error): Show file does not exist
- **Message 22** (Error): Error reading show file
- **Message 23** (Error): Sequence file does not exist
- **Message 24** (Error): Sequence file cannot be loaded
- **Message 25** (Warning): Show has no sequences
- **Message 26** (Error): Media file does not exist
- **Message 27** (Warning): Conflicting channel settings in sequence
- **Message 28** (Warning): Channel is completely off
- **Message 29** (Warning): Sequence is completely off
- **Message 30** (Warning): Channel is missing settings

5.10.1.3.1 21: Show file does not exist

**Message Number:** 21
**Severity:** Error
**Summary:** Show file does not exist
**Details:** The name of the missing show file

You have a show scheduled, but the file that is supposed to contain that show does not exist. The show will not play until this problem is resolved.

If you do not want the show to play, this is not a problem, but you may want to remove it from your schedule (using the Schedule Editor) so that this error message does not appear in the future.

If you do want the show to play, perhaps its file was renamed, or deleted. If it was renamed, either rename it back, or else use the Schedule Editor to point to the new name of the show file instead of the old name. If it was deleted, check your computer's Recycle Bin.

If these suggestions do not resolve the situation, you may have to recreate the show, using the Show Editor.
5.10.1.3.2 22: Error reading show file

**Message Number:** 22  
**Severity:** Error  
**Summary:** Error reading show file  
**Details:** The name of the show file

You have a show scheduled, but the show cannot be loaded. For example, perhaps the show's file has become corrupted. The show will not play until this problem is resolved.

If you have any backups of the show file, check to see if they work. Otherwise, you may have to recreate the show, using the Show Editor.

5.10.1.3.3 23: Sequence file does not exist

**Message Number:** 23  
**Severity:** Error  
**Summary:** Sequence file does not exist  
**Details #1:** The name of the missing sequence file  
**Details #2:** The name of the show file that this sequence is referenced in

One of your scheduled shows refers to a sequence file that does not exist. The sequence will not play in the show until this problem is resolved.

If you do not want the sequence to play, this is not a problem, but you may want to remove it from the show (using the Show Editor) so that this message does not appear in the future.

If you do want the sequence to play, perhaps its file was renamed (or placed in a different directory), or deleted.

If it was renamed (or placed in a different directory), you can either rename it back, or else use the Show Editor to point to the new name instead of the old one.

If it was deleted, check your computers Recycle Bin, or any backups that you may have. Note that whenever you change a sequence and save it (using the Sequence Editor), Light-O-Rama automatically saves a backup copy of the file as it was before your changes, so you may be able to use that backup copy. It will be saved to the same directory as the original, with the file extension ".bak" appended to its name. For example, if your sequence is named "MySequence.las", the automatic backup will be named "MySequence.las.bak".

If none of these suggestions help, you may have to recreate the sequence, using the Sequence Editor.
Message Number: 24  
Severity: Error  
Summary: Sequence file cannot be loaded  
Details: The name of the file

One of your scheduled shows refers to a sequence file that cannot be loaded. For example, perhaps the sequence file has become corrupted. The sequence will not play in the show until this problem is resolved.

If you have any backups of the sequence file, check to see if they work. Note that whenever you change a sequence and save it (using the Sequence Editor), Light-O-Rama automatically saves a backup copy of the file as it was before your changes, so you may be able to use that backup copy. It will be saved to the same directory as the original, with the file extension ".bak" appended to its name. For example, if your sequence is named "MySequence.las", the automatic backup will be named "MySequence.las.bak".

Otherwise, you may have to recreate the sequence, using the Sequence Editor.

Message Number: 25  
Severity: Warning  
Summary: Show has no sequences  
Details: The name of the show file

One of your scheduled shows has no sequences in it. This will not cause any problems - your other scheduled shows should play fine - but there isn't much point to scheduling a show without sequences, so this probably indicates a mistake.

If you want sequences to play in the scheduled show, use the Show Editor to add the sequences to the show.

If you do not want any sequences to play in the scheduled show, consider removing the show from your schedule, using the Schedule Editor, so that this message does not appear in the future.

Message Number: 26  
Severity: Error  
Summary: Media file does not exist  
Details #1: The name of the missing media file  
Details #2: The name of the sequence file that refers to the missing media file

One of your scheduled musical sequences refers to an audio file or video file that does not exist. The sequence will not play until this problem is resolved.
It is possible that the file has been renamed, placed in a different directory, or deleted.

If it has been renamed or placed in a different directory, you can either move it back to its original location, or else use the Sequence Editor to modify the sequence so that it points to its new location.

If it has been deleted, check your computer's Recycle Bin, or for any backups that you may have of the file.

The LOR Verifier
List of Verifier Messages

5.10.1.3.7 27: Conflicting channel settings in sequence

Message Number: 27
Severity: Warning
Summary: Conflicting channel settings in sequence
Details #1: The name of the sequence having the conflict
Details #2: The track containing the first conflicting channel
Details #3: The name of the first conflicting channel
Details #4: The track containing the second conflicting channel
Details #5: The name of the second conflicting channel

One of your scheduled sequences contains two different channels that both are set up to control the same physical string of lights - for example, they are both set up to control circuit 3 of Light-O-Rama unit 7 on the regular Light-O-Rama network.

Your sequence will play, but these two channels will fight for control over the lights hooked up to the circuit, which may have make the lights behave in ways that you weren't expecting.

The cause of this may simply be that one of the two channels is set up with the wrong unit ID, circuit number, network, or device type. In this case, use the Sequence Editor to change the channel's settings appropriately.

If you do intend both channels to control the same string of lights, the lights may or may not behave as you expect. The suggested way to do what you probably want is not to have two different channels with the same settings, but to have a single channel that is contained in two different tracks:

Let's say that you have "Channel A" in the first track, and "Channel B" in the second track. These channels have the same physical settings as each other, but different effect events. Then to change this situation to the suggested way, use the Sequence Editor as follows:

First, copy Channel A from the first track to the second track.

Next, merge the effect events from Channel B into Channel A, so that Channel A contains the effect events from both channels.

Finally, delete Channel B.

This will leave you with a single channel - Channel A - which is contained in both tracks, and which contains all of the effect events that you wanted for its string of lights. Having this single channel in two tracks, instead of two different channels in the two tracks, will make the lights behave as you probably expect.
The LOR Verifier
List of Verifier Messages

5.10.1.3.8 28: Channel is completely off

**Message Number:** 28  
**Severity:** Warning  
**Summary:** Channel is completely off  
**Details #1:** The sequence containing the channel  
**Details #2:** The track containing the channel  
**Details #3:** The name of the channel

One of your scheduled sequences contains a channel which is completely off for its entire duration.

Consider removing the channel from the sequence, using the Sequence Editor.

---

The LOR Verifier
List of Verifier Messages

5.10.1.3.9 29: Sequence is completely off

**Message Number:** 29  
**Severity:** Warning  
**Summary:** Sequence is completely off  
**Details:** The name of the sequence file

One of your scheduled sequences has no lighting effects for any of its channels, except for having each of them off for the sequence's entire duration.

This may be intentional - for example, you may have scheduled a musical sequence so that a song plays while your lights are off. Otherwise, consider adding effects to the sequence, or removing the sequence from the show.

---

The LOR Verifier
List of Verifier Messages

5.10.1.3.10 30: Channel is missing settings

**Message Number:** 30  
**Severity:** Warning  
**Summary:** Channel is missing settings  
**Details #1:** The name of the sequence file containing the channel  
**Details #2:** The track containing the channel  
**Details #3:** The name of the channel

One of your scheduled sequences has a channel which is missing a required part of its physical settings - for example, perhaps it does not have a unit ID set.

This may be intentional - for example, perhaps you have a channel that shows the beat of a song, which you intend to use to help build other channels rather than to actually control lights when your show plays. If not, though, use the Sequence Editor to set the channel's settings appropriately.
5.10.1.4 Verifier Messages 31-40

The following are some messages that can be generated by the Light-O-Rama Verifier. For details on any given one, please refer to its individual help page. To see all possible messages, please refer to the List of Verifier Messages.

- **Message 31** (Warning): Channel uses undefined comm network
- **Message 32** (Warning): Channel in tracks of conflicting length
- **Message 33** (Warning): Musical file used in non-audio section of show
- **Message 34** (Warning): Subsequences not supported
- **Message 35** (Warning): Background sequences unsupported
- **Message 36** (Warning): Startup sequences unsupported
- **Message 37** (Warning): Shutdown sequences unsupported
- **Message 38** (Warning): Interactive triggers unsupported
- **Message 39** (Warning): Unsupported number of tracks
- **Message 40** (Warning): Shell commands unsupported

5.10.1.4.1 31: Channel uses undefined comm network

**Message Number:** 31  
**Severity:** Warning  
**Summary:** Channel uses undefined comm network  
**Details #1:** The sequence that the channel is in  
**Details #2:** The track that the channel is in  
**Details #3:** The name of the channel

One of your scheduled sequences contains a channel which is set up to use a network which does not have a comm port defined for it. The channel will not control lights until this issue is resolved.

The channel could be for a Light-O-Rama controller, which can be set up to use one of four different networks, or a Dasher or X10 controller, each of which can only have one network defined for all controllers of their type.

It is possible that the channel's network (or device type) is simply set incorrectly. For example, perhaps a channel for a Light-O-Rama controller was accidentally set to use the Aux A network, whereas you only have a comm port assigned to the Regular network. Or perhaps a channel was accidentally set to control a Dasher controller, whereas it was intended to control a Light-O-Rama controller. In cases like these, use the Sequence Editor to change the channel's settings, via the channel's Channel Settings dialog, or via the Channel Property Grid.

Another possibility is that you do intend to use the network that the channel has assigned to it, but that network is not set up to use any comm port on your computer. In this case, use the Sequence Editor's Network Preferences dialog to specify a comm port for the network to use.
Summary: Channel in tracks of conflicting length
Details #1: The sequence that the channel is in
Details #2: The name of the channel
Details #3: A track that the channel is in
Details #4: Another track that the channel is in

One of your scheduled sequences contains a channel which is in two different tracks, but those tracks are of different lengths. For example, one track is a minute long, while the other is two minutes long.

This will likely cause the lights hooked up to that channel to behave in a way that you don't expect, as different lighting effects from different parts of the same channel could be sent to the lights in an order that you were not expecting.

Unless you have done this intentionally, and understand the way that your lights will behave because of this, consider using the Sequence Editor to either remove the channel from one of the tracks or to change the tracks to be of the same length.

The LOR Verifier
List of Verifier Messages

5.10.1.4.3 33: Musical file used in non-audio section of show

Message Number: 33
Severity: Warning
Summary: Musical file used in non-audio section of show
Details #1: The sequence file
Details #2: The show file that refers to the sequence
Details #3: The section of the show that refers to the sequence

One of your musical sequences is scheduled in a section of a show that does not support audio or video. For example, perhaps a musical sequence is contained in the Background section of the show. The sequence will play at its scheduled time, but will only control lights; it will not play audio or display video.

Make sure that the sequence is in the section of the show that you intend it to be in. If it is not, use the Show Editor to move it to the appropriate section.

If it is in the section that you intended, consider using an animation sequence instead, to avoid possible confusion in the future.

The LOR Verifier
List of Verifier Messages

5.10.1.4.4 34: Subsequences not supported

Message Number: 34
Severity: Warning
Summary: Subsequences not supported
Details #1: The name of the subsequence
Details #2: The name of the parent sequence containing the subsequence
Details #3: The name of the channel in the parent sequence referencing the subsequence

One of your scheduled sequences contains a channel set up to be a subsequence, but your license
does not support subsequences (or you are using the unlicensed demo version of the software). The parent sequence will play at its scheduled time, but the subsequence will not.

If you already have a license, and have registered Light-O-Rama on this computer, then to get the subsequence to play, you would have to upgrade to a higher license level which supports subsequences.

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

---

The LOR Verifier
List of Verifier Messages

5.10.1.4.5  35: Background sequences unsupported

**Message Number:** 35  
**Severity:** Warning  
**Summary:** Background sequences unsupported  
**Details:** The name of the show file containing sequences in its Background section

One of your scheduled shows contains sequences in its Background section, but your license does not support sequences in this section. The show will play at its scheduled time, but sequences in this section will not.

If you already have a license, and have registered Light-O-Rama on this computer, then to get these sequences to play, you would have to either move them to a different section of the show, or else upgrade to a higher license level which supports this feature.

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

---

The LOR Verifier
List of Verifier Messages

5.10.1.4.6  36: Startup sequences unsupported

**Message Number:** 36  
**Severity:** Warning  
**Summary:** Startup sequences unsupported  
**Details:** The name of the show file containing sequences in its Startup section

One of your scheduled shows contains sequences in its Startup section, but your license does not support sequences in this section. The show will play at its scheduled time, but sequences in this section will not.
If you already have a license, and have registered Light-O-Rama on this computer, then to get these sequences to play, you would have to either move them to a different section of the show, or else upgrade to a higher license level which supports this feature.

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

---

**The LOR Verifier**

**List of Verifier Messages**

5.10.1.4.7 37: Shutdown sequences unsupported

**Message Number**: 37  
**Severity**: Warning  
**Summary**: Shutdown sequences unsupported  
**Details**: The name of the show file containing sequences in its Shutdown section

One of your scheduled shows contains sequences in its Shutdown section, but your license does not support sequences in this section. The show will play at its scheduled time, but sequences in this section will not.

If you already have a license, and have registered Light-O-Rama on this computer, then to get these sequences to play, you would have to either move them to a different section of the show, or else upgrade to a higher license level which supports this feature.

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

---

**The LOR Verifier**

**List of Verifier Messages**

5.10.1.4.8 38: Interactive triggers unsupported

**Message Number**: 38  
**Severity**: Warning  
**Summary**: Interactive triggers unsupported  
**Details**: The name of the show file using interactive triggers

One of your scheduled shows uses interactive triggers, either in an interactive group or as part of its startup options, but your license does not support interactive triggers. The show will play at its scheduled time, but its interactive triggers will not.
If you already have a license, and have registered Light-O-Rama on this computer, then to get these triggers to work, you would have to upgrade to a higher license level which supports subsequences. If your triggers are used for interactive groups, you could also move the sequences in them to a different section of the show (but if so, they will play immediately, not upon being triggered).

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

---

**The LOR Verifier**

**List of Verifier Messages**

5.10.1.4.9 39: Unsupported number of tracks

**Message Number:** 39  
**Severity:** Warning  
**Summary:** Unsupported number of tracks  
**Details #1:** The name of the sequence using too many tracks  
**Details #2:** The number of tracks the sequence uses  
**Details #3:** The allowed number of tracks

One of your scheduled sequences uses more tracks than your license supports. The sequence will play at its scheduled time, but its excess tracks will not.

If you already have a license, and have registered Light-O-Rama on this computer, then to get these tracks to play, you would have to upgrade to a higher license level which supports more tracks.

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

---

**The LOR Verifier**

**List of Verifier Messages**

5.10.1.4.10 40: Shell commands unsupported

**Message Number:** 40  
**Severity:** Warning  
**Summary:** Shell commands unsupported  
**Details:** The name of the sequence using a shell command

One of your scheduled sequences is set up to use a Windows shell command, but your license does not support such commands. The sequence will play at its scheduled time, but the command will not be executed.
If you already have a license, and have registered Light-O-Rama on this computer, then to get the command to execute, you would have to upgrade to a higher license level which supports this feature.

If you are using the unlicensed demo version, and you have not yet purchased a license, you can do so from the Light-O-Rama website.

If you have already purchased one, try using it to register Light-O-Rama on this computer. If this does not work, perhaps you have already installed Light-O-Rama on the maximum number of computers covered by your license, or perhaps your license is for an older version of Light-O-Rama than the one that you are trying to run.

The LOR Verifier
List of Verifier Messages

5.10.1.5 Verifier Messages 41-50

The following are some messages can be generated by the Light-O-Rama Verifier. For details on any given one, please refer to its individual help page. To see all possible messages, please refer to the List of Verifier Messages.

- **Message 41** (Warning): **Shell command map file does not exist**
  
  One of your scheduled sequences is set up to use a Windows shell command, but the command map file that defines the commands to execute does not exist. The sequence will play at its scheduled time, but the command will not be executed.

  This could be because you created the sequence on one computer, and moved it to another computer to play in your show, but did not move the command map file. Light-O-Rama keeps these commands in the command map file, rather than in the sequences themselves, due to security concerns. Please see Sharing Sequences between Computers, and Security for details.

- **Message 42** (Warning): **Shell command not set**
  
  One of your scheduled sequences is set up to use a Windows shell command, but the command map file does not list a command to be executed by that sequence. The sequence will play at its scheduled time, but no command will be executed.
This could be because you created the sequence on one computer, and moved it to another computer to play in your show, but did not move the command map file. Light-O-Rama keeps these commands in the command map file, rather than in the sequences themselves, due to security concerns. Please see Sharing Sequences between Computers, and Security for details.

The LOR Verifier
List of Verifier Messages

5.10.1.5.3  43: Channel conflict

Message Number: 43
Severity: Warning
Summary: Channel conflict
Details #1: The name of the show containing the channel conflict
Details #2: One of the sections of the show containing a sequence with the conflicting channel
Details #3: The sequence file in that section containing the conflicting channel
Details #4: The track in that sequence containing the conflicting channel
Details #5: The name of the conflicting channel in that track
Details #6: Another section of the show containing a sequence with the conflicting channel
Details #7: The sequence file in that section containing the conflicting channel
Details #8: The track in that sequence containing the conflicting channel
Details #9: The name of the conflicting channel in that track

One of your scheduled shows contains sequences which could possibly play at the same time, but which each contain a channel representing the same physical string of lights. For example, perhaps the show contains one sequence in its Background section, and another in its Musical section, which each contain a channel for Light-O-Rama unit 3 circuit 7 on the regular network. Since sequences in the Background section can play at the same time as those in the Musical section, this is a conflict.

The show, and its sequences, will play at the appropriate times, but the two channels may fight for control over the single string of lights that they are set up to use. This may lead to those lights behaving in a manner that you are not expecting.

It is suggested that you use the Sequence Editor to check whether the channels are set up properly - for example, perhaps the unit ID of one of the channels was mistakenly set to an incorrect value. Otherwise, consider removing the conflicting channel from one of the sequences, or moving one of the sequences to a different section of the show, where it could not be played at the same time as the other sequence.

The LOR Verifier
List of Verifier Messages

5.11 Diagnostic

The Light-O-Rama Diagnostic tool can be used in troubleshooting. It shows a snapshot of your Light-O-Rama configuration, such as registry settings and the version numbers of the various Light-O-Rama programs.
5.12 Offline Registration Utility

The Offline Registration Utility is a program that you can use to help register the Light-O-Rama Software Package on a computer which is not connected to the internet. It must be run on another computer, which is connected to the internet. If you do not have another computer which is connected to the internet, you can still register an offline computer by calling Light-O-Rama.

Please see the help file page "Registering Offline" for details.
In addition to the standard programs that come with the Light-O-Rama software package, there are several add-on programs available. These include both official Light-O-Rama products and third-party applications:

- Light-O-Rama Add-Ons
The Light-O-Rama Registry Wiper tool

Third Party Add-Ons

- Holiday Lights Designer™, by Holidaysoft®
- Universal Library and InstaCal

5.13.1 Registry Wiper

The Light-O-Rama Registry Wiper tool deletes your Light-O-Rama configuration from your computer's registry. This is for use in troubleshooting severe cases.

**IMPORTANT:** After running the Light-O-Rama Registry Wiper tool, your Light-O-Rama software will not run. You will need to reinstall Light-O-Rama. Also, even after having reinstalled, you will have lost certain preferences settings that you may have previously set.

The Registry Wiper tool is not a standard part of the Light-O-Rama software package. It is available from Light-O-Rama, for troubleshooting severe cases.

The Registry Wiper tool should not be used except in extreme situations.

If you have previously registered your copy of Light-O-Rama, after selecting "Wipe", you may be presented with a choice of whether to keep your licensing information (such as your license name and license key) in the registry or not. If you choose not to, your copy of Light-O-Rama will run in Demo mode afterwards, until you re-register. Note, though, that you will still be able to re-register using your exact same licensing information.

5.13.2 Holiday Lights Designer

Holiday Lights Designer™ is a third-party application by Holidaysoft® which can be used to virtually place lights and decorations on images of your home or business. Light-O-Rama can now send Holiday Lights Designer™ commands during play to make those virtual lights behave as your real lights would during a show.

To send commands to Holiday Lights Designer™, first set the Holiday Lights Designer Preferences in the Sequence Editor under the Edit menu. After this is done, commands can be sent from the Sequence Editor by turning on "Control Holiday Lights Designer" in the Play menu, or from the Show Player by selecting "Holiday Lights Designer On" in the Light-O-Rama Control Panel.

Version 4.0 or above of Holiday Lights Designer™ is required to take advantage of Light-O-Rama
interaction.

For more information about Holiday Lights Designer™, please see the Holidaysoft website.

5.13.3 Universal Library and InstaCal

The Universal Library and InstaCal are software allowing access to digital IO boards and BSOFT digital IO boards. In order to use these boards with Light-O-Rama, you must have these installed.

The Universal Library and InstaCal are available from Measurement Computing.
Index

- A -
Add-Ons 369
  Holiday Lights Designer 370
  InstaCal 371
  Registry Wipe Utility 370
  Universal Library 371
Advanced OpenGL Settings (Sequence Editor) 185
Animation 97
  Animation Redraw Throttling 185
Animation Section (Show) 103
Animation Sequence 72
  New Animation Dialog 159
  New Animation Preferences 191
Animator 278
  Animation Redraw Throttling 185
Background Images 280
Drawing 279
  Sizing and Zooming 279
Audio Visualizations 195

- B -
Background Effects Mode 90
Background Section (Show) 101
Beat Wizard 280
BSOFT Digital IO Cards 127
  Circuit IDs 128
  Hardware Utility 339
  InstaCal 371
  Limitations 127
  Requirements 127
  Unit IDs 127
  Universal Library 371

- C -
Cable
  Data 7
  Phone 7
Calendar Schedule 116
Channel 74, 253, 266, 283
  Channel Settings 254
  Subsequence 98
  Channel and RGB Channel Buttons (Sequence Editor)
    Channel and RGB Channel Buttons (Sequence Editor) 253
    Convert to RGB Channel 266
    Convert to RGB Channel (Sequence Editor) 266
    Insert Device 260
    Popup Menu 256
  Channel Buttons (Sequence Editor)
    Vary Color by Default 193
    View by Default 181
Channel Property Grid
  Channel Property Grid 283
Channel Settings 254
Circuit IDs
  BSOFT Digital IO Cards 128
  Dasher Controllers 124
  Digital IO Cards 126
  Light-O-Rama Controllers 120
Clipboards (Sequence Editor) 243
Companion Unit 6
Control Panel 134
  Disable Shows Gracefully 140
  Disable Shows Immediately 141
  Enable Schedule 140
  Hardware Utility Quicklaunch 140
  Holiday Lights Designer 142
  Launch at Startup 142
  Popup Menu 137
  Schedule Editor Quicklaunch 140
  Sequence Editor Quicklaunch 139
  Show Editor Quicklaunch 139
  Show On Demand 141
  Shut Down Show On Demand 142
  Simple Show Builder Quicklaunch 139
  Status Window 135
  Unload Light-O-Rama 143
Controllers 118
  BSOFT Digital IO 127
  Dasher 123
  Digital IO 126
  Light-O-Rama 119
  X10 128
Convert to RGB Channel (Sequence Editor) 266

- D -
Daisy Chain 6
Dashers
  Circuit IDs 124
  Controllers 123
  Dasher Port 123
  Importing Dasher Files 124
  Unit IDs 123
Data Cable 7
Diagnostic Utility 367
Digital IO Boards Tab (Hardware Utility) 339
Digital IO Cards 126
  Circuit IDs 126
  Hardware Utility 339
  InstaCal 371
  Limitations 126
  Requirements 126
  Unit IDs 126
  Universal Library 371
Director Unit 7
Disable Shows Gracefully (Control Panel) 140
Disable Shows Immediately (Control Panel) 141
Display Preferences (Sequence Editor) 180
  Animation Redraw Throttling 185
  Channel Buttons 181
  Fades as Ramps 182
  Time Scale 182
  Tooltip Preferences 184
  Wave Form 183
DMX 341
DMX Intensity Effect 89
DMX Preferences (Sequence Editor) 187

-E-
Edit Menu (Sequence Editor) 165
Editing Sequences
  Keyboard 145
  Mouse 151
Effect 83
  Background Effects Mode 90
  Custom Tool 88
  DMX Intensity 89
  Fade Down 86
  Fade Up 86
  Faded Twinkles and Shimmers 88
  Foreground Effects Mode 90
  Normal Effects Mode 90
  Off 84
  On 84
Set Intensity 84
  Shimmer 86
  Twinkle 85
Effect Tools (Sequence Editor) 206
  Custom 213
  DMX Intensity 212
  Fade Down 208
  Fade Up 208
  Off 208
  On 208
  Select 207
  Set Intensity 208
  Settings 213
  Shimmer 207
  Toggle 207
  Tools Toolbar 233
  Twinkle 207
Enable Schedule (Control Panel) 140

-F-
Fade Down Effect 86
Fade Up Effect 86
Fades 86
  Faded Twinkles and Shimmers 88
  View Menu 202
File Menu (Sequence Editor) 153
  Close 154
  Close All Files 155
  Close All Files Except This 155
  Exit 155
  New 154
  Open 154
  Open Recent 154
  Revert to Save 155
  Save 155
  Save As 155
Firmware Updates 331
Fixed Timing Grids 81
Foreground Effects Mode 90
Freeform Play Mode 299
Freeform Timing Grids 81

-G-
Getting Help 6
Getting Started 6
Musical Sequence 73
  New Musical Sequence Dialog 162
  New Musical Sequence Preferences 192

- N -

Network 120
  Connection Speed 190
  Preferences (Sequence Editor) 188
  Serial Port 190
Network Preferences (Sequence Editor) 188
New and Open Dialog 155
New Animation Dialog 159
New Animation Preferences (Sequence Editor) 191
New Musical Sequence Dialog 162
New Musical Sequence Preferences (Sequence Editor) 192
New Track Dialog 177
Normal Effects Mode 90

- O -

Off Effect 84
On Effect 84

- P -

Phone Cable 7
Play Menu (Sequence Editor) 221
  Control Holiday Lights Designer 225
  Control Lights 225
  Highlight Current Time 225
  Loop at End 224
  Move Grid with Play 225
  Play Again 223
  Play Range 223
  Speed 226
  Start All Sequences 222
  Start This Sequence 222
  Stop 223
  Vary Color of Channel Buttons 225
Play Preferences (Sequence Editor) 192
  Highlight Current Event 194
  Highlight Current Time 194
  Loop at End 193
  Vary Channel Button Colors 193
  Play Range 223

- R -

Registry Wipe Utility 370
RGB Channel 77, 255
  Channel and RGB Channel Buttons (Sequence Editor) 253
  Convert to RGB Channel (Sequence Editor) 266
RGB Channel Settings
  RGB Channel Settings 255
Right-Click Context Menu (Sequence Editor) 248
  Background Effects 250
  Copy 251
  Copy Timing 251
  Cut 251
  Delete Selected Timings 252
  Delete Timing at (centisecond) 252
  Fade Down 249
  Fade Up 249
  Foreground Effects 250
  Insert Multiple Timings 252
  Insert Timing at (centisecond) 252
  Insert Timing at ... 252
  Off 250
  On 250
  Paste 251
  Paste Multiple 251
  Paste Timing at (centisecond) 251
  Paste Timing at ... 251
  Paste Timing Multiple 251
  Resize Timings to ... 252
  Resize Timings to Equal Times 253
  Set Intensity 250
  Shimmer 250
  Toggle 250
  Twinkle 250

© 2010 Light-O-Rama, Inc.
Index 377

Software 131
  InstaCal 371
  Registry Wipe Utility 370
  Schedule Editor 301
  Sequence Editor 143
  ServoDog Utility 343
  Show Editor 300
  Show Player 313
  Simple Show Builder 307
  Universal Library 371
  Verifier 344

Soundboard 112

Stand-alone Mode 327

Standard Toolbar (Sequence Editor) 229
  Close Sequence 230
  Copy 230
  Cut 230
  New Sequence 229
  Open Sequence 230
  Paste 230
  Play 233
  Play Again 233
  Redo 231
  Save Sequence 230
  Stop 233
  Undo 231
  Vary Channel Button Colors 232
  View Animation 231
  View Fades as Ramps 232
  View Time Scale 232
  View Waveform 232
  Zoom Channels In 232
  Zoom Channels Out 232
  Zoom Time In 232
  Zoom Time Out 232

Startup Section (Show) 102

Status Window (Control Panel) 135

Subsequence 98

- T -

Tapper Wizard 293

Time Format 152

Timing 80

Timing Grids 81
  Fixed 81
  Freeform 81

Toolbars (Sequence Editor) 228

Standard Toolbar 229

Tools Toolbar 233

Tracks and Timings Toolbar 237

Tools Menu (Sequence Editor) 205

  Background Effects 213
  Beat Wizard 217
  Channel Property Grid 216
  Custom 213
  Custom Settings 213
  DMX Intensity 212
  Effect Tool Settings 213
  Effect Tools 206
  Fade Down 208
  Fade Tool Options 215
  Fade Tool Settings 215
  Fade Up 208
  Foreground Effects 213
  Intensity Tool Options 214
  Intensity Tool Settings 214
  Load Intensities and Fades 216
  MIDI Wizard 218
  Off 208
  On 208
  Select 207
  Set Intensity 208
  Shimmer 207
  Tapper Wizard 219
  Toggle 207
  Twinkle 207
  VU Wizard 220

Tools Toolbar (Sequence Editor) 233

  Background Effects 236
  Custom 235
  Custom Fade Down 236
  Custom Fade Up 236
  Custom Set Intensity 236
  Custom Shimmer 236
  Custom Twinkle 236
  DMX Intensity 235
  Fade Down 235
  Fade Settings 237
  Fade Up 235
  Foreground Effects 237
  Intensity Settings 237
  Off 234
  On 234
  Select 234
  Set Intensity 235

© 2010 Light-O-Rama, Inc.
Tools Toolbar (Sequence Editor) 233
   Shimmer 234
   Toggle 234
   Twinkle 234
Track 95
   New Track Dialog 177
   Track Bars 268
   Track Info 203
Track Bars (Sequence Editor) 268
   Popup Menus 268
Track Info 203
Tracks and Timings Toolbar (Sequence Editor) 237
   Twinkle Effect 85

- U -

Unit 8
Unit IDs
   BSOFT Digital IO Cards 127
   Dasher Controllers 123
   Digital IO Cards 126
   Light-O-Rama Controllers 119
   Setting Unit IDs (Hardware Utility) 317
   X10 Controllers 130
Universal Library 371
Unload Light-O-Rama (Control Panel) 143

- V -

Vary Channel Button Colors by Default (Sequence Editor) 193
Verifier 344
   List of Verifier Messages 346
Video
   Display Audio Visualizations 195
   Display Video 195
   Full Screen Mode 195
   Monitor 195
   Preferences 194
View Menu (Sequence Editor) 196
   Animation 200
   Cell Info 204
   Channel Buttons 197
   Fades 202
   Refresh 205
   Sequence Info 203
   Time Scale 198

- W -

Waveform 275
Weekly Schedule 115
What's New 11
Window Menu (Sequence Editor) 226
   Arrange Icons 227
   Cascade 227
   Minimize All Windows 227
   Open Sequence List 227
   Tile Horizontally 226
   Tile Vertically 226
Windows Shell Commands 99
Wireless Devices
   Hardware Utility 337

- X -

X10
   Controllers 128
   Hardware Utility 340
   Limitations 128
   Unit IDs 130
   X10 Port 129
   X10 CM11A Tab (Hardware Utility) 340

- Z -

Zoom Preferences (Sequence Editor) 196